[PATCH v3] drm: drm_fourcc: add NV15, Q410, Q401 YUV formats

2020-06-01 Thread Ben Davis
ecific modifier name NV15: Tested-by: Jonas Karlman Reviewed-by: Brian Starkey Signed-off-by: Ben Davis --- drivers/gpu/drm/drm_fourcc.c | 12 include/uapi/drm/drm_fourcc.h | 24 2 files changed, 36 insertions(+) diff --git a/drivers/gpu/drm/drm_fourcc

[PATCH v2] drm: drm_fourcc: add NV15, Q410, Q401 YUV formats

2020-05-29 Thread Ben Davis
, but only 10 bits are used and 6 are padded. 'Q' is chosen as the first letter to denote 3 plane YUV444, (and is the next letter along from P which is usually 2 plane). V2: Updated block_w of NV15 to {4, 2, 0} NV15: Tested-by: Jonas Karlman Reviewed-by: Brian Starkey Signed-off-by: Ben

Re: [PATCH] drm: drm_fourcc: add NV15, Q410, Q401 YUV formats

2020-05-06 Thread Ben Davis
Hi all, any feedback on this patch? Thanks, Ben On Wed, Apr 22, 2020 at 12:13:49PM +0100, Ben Davis wrote: > DRM_FORMAT_NV15 is a 2 plane format suitable for linear and 16x16 > block-linear memory layouts. The format is similar to P010 with 4:2:0 > sub-sampling but has no paddin

[PATCH v2] drm: drm_fourcc: Add uncompressed AFBC modifier

2020-04-30 Thread Ben Davis
AFBC has a mode that guarantees use of AFBC with an uncompressed payloads, we add a new modifier to support this mode. V2: updated modifier comment Signed-off-by: Ben Davis --- include/uapi/drm/drm_fourcc.h | 12 1 file changed, 12 insertions(+) diff --git a/include/uapi/drm

[PATCH] drm: drm_fourcc: Add uncompressed AFBC modifier

2020-04-22 Thread Ben Davis
AFBC has a mode that allows use of AFBC with an uncompressed buffer, we add a new modifier to support this mode. Signed-off-by: Ben Davis --- include/uapi/drm/drm_fourcc.h | 6 ++ 1 file changed, 6 insertions(+) diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h

[PATCH] drm: drm_fourcc: add NV15, Q410, Q401 YUV formats

2020-04-22 Thread Ben Davis
, but only 10 bits are used and 6 are padded. 'Q' is chosen as the first letter to denote 3 plane YUV444, (and is the next letter along from P which is usually 2 plane). Signed-off-by: Ben Davis --- drivers/gpu/drm/drm_fourcc.c | 12 include/uapi/d

[PATCH v4 1/2] drm: Add writeback_dest_x,y,w,h properties

2019-05-02 Thread Ben Davis
Add new properties to specify x,y coordinates and width and height for writeback. These are reset to 0 on duplicating state to provide robustness against accidental scaling. Signed-off-by: Ben Davis --- drivers/gpu/drm/drm_atomic_state_helper.c | 6 +++ drivers/gpu/drm/drm_atomic_uapi.c

[PATCH v4 0/2] Add writeback scaling

2019-05-02 Thread Ben Davis
values from the properties are passed to enable_memwrite as intended in v3 and some other clean up. Ben Davis (2): drm: Add writeback_dest_x,y,w,h properties drm/malidp: Enable writeback scaling drivers/gpu/drm/arm/malidp_crtc.c | 47 ++-- drivers/gpu/drm/arm/malidp_drv.c

[PATCH v4 2/2] drm/malidp: Enable writeback scaling

2019-05-02 Thread Ben Davis
The phase setting part of malidp_crtc_atomic_check_scaling is refactored to allow use in writeback scaling. Also the enable_memwrite function prototype is simplified by directly passing mw_state. Signed-off-by: Ben Davis --- drivers/gpu/drm/arm/malidp_crtc.c | 47 --- drivers/gpu

[PATCH v3 2/2] drm/malidp: Enable writeback scaling

2019-04-23 Thread Ben Davis
The phase setting part of malidp_crtc_atomic_check_scaling is refactored to allow use in writeback scaling. Also the enable_memwrite function prototype is simplified by directly passing mw_state. Signed-off-by: Ben Davis --- drivers/gpu/drm/arm/malidp_crtc.c | 49 +++- drivers

[PATCH v3 1/2] drm: Add writeback_dest_w,h properties

2019-04-23 Thread Ben Davis
Add new properties to specify width and height for writeback. Signed-off-by: Ben Davis --- drivers/gpu/drm/drm_atomic_uapi.c | 8 drivers/gpu/drm/drm_writeback.c | 30 ++ include/drm/drm_connector.h | 4 include/drm/drm_mode_config.h | 10

[PATCH v3 0/2] Add writeback scaling

2019-04-23 Thread Ben Davis
). v2: Use 0 as default for writeback_w,h and so update range to use 1 as minimum. v3: Rename properties to specify they are destination width/height. Make sure the values from the properties are passed to enable_memwrite rather than the framebuffer dimensions Ben Davis (2): drm: Add

[PATCH v2 2/2] drm/malidp: Enable writeback scaling

2019-04-12 Thread Ben Davis
The phase setting part of malidp_crtc_atomic_check_scaling is refactored to allow use in writeback scaling. Also the enable_memwrite function prototype is simplified by directly passing mw_state. Signed-off-by: Ben Davis --- drivers/gpu/drm/arm/malidp_crtc.c | 49

[PATCH v2 1/2] drm: Add writeback_w,h properties

2019-04-12 Thread Ben Davis
Add new properties to specify width and height for writeback. Signed-off-by: Ben Davis --- drivers/gpu/drm/drm_atomic_uapi.c | 8 drivers/gpu/drm/drm_writeback.c | 28 include/drm/drm_connector.h | 4 include/drm/drm_mode_config.h | 10

[PATCH v2 0/2] Add writeback scaling

2019-04-12 Thread Ben Davis
as default for writeback_w,h and so update range to use 1 as minimum. Ben Davis (2): drm: Add writeback_w,h properties drm/malidp: Enable writeback scaling drivers/gpu/drm/arm/malidp_crtc.c | 49 -- drivers/gpu/drm/arm/malidp_crtc.h | 12 ++ drivers/gpu/drm/arm

Re: [PATCH 1/2] drm: Add writeback_w,h properties

2019-04-10 Thread Ben Davis
On Wed, Apr 10, 2019 at 01:48:51PM +0200, Maarten Lankhorst wrote: > Op 10-04-2019 om 13:11 schreef Ben Davis: > > Add new properties to specify width and height for writeback. > > > > Signed-off-by: Ben Davis > > --- > > drivers/gpu/drm/drm_atomic_uapi.c |

[PATCH 0/2] Add writeback scaling

2019-04-10 Thread Ben Davis
Add support for scaling on writeback. To do this add writeback_w and writeback_h as writeback connector properties to specify the desired output dimensions. Then implement downscaling on writeback for Malidp-550 and Malidp-650 (upscaling on writeback is not supported on these devices). Ben Davis

[PATCH 1/2] drm: Add writeback_w,h properties

2019-04-10 Thread Ben Davis
Add new properties to specify width and height for writeback. Signed-off-by: Ben Davis --- drivers/gpu/drm/drm_atomic_uapi.c | 8 drivers/gpu/drm/drm_writeback.c | 28 include/drm/drm_connector.h | 4 include/drm/drm_mode_config.h | 10

[PATCH 2/2] drm/malidp: Enable writeback scaling

2019-04-10 Thread Ben Davis
The phase setting part of malidp_crtc_atomic_check_scaling is refactored to allow use in writeback scaling. Also the enable_memwrite function prototype is simplified by directely passing mw_state. Signed-off-by: Ben Davis --- drivers/gpu/drm/arm/malidp_crtc.c | 49