Re: [PATCH 1/3] drm/etnaviv: Track GPU VA size separately

2024-10-26 Thread Sui Jingfeng
Hi, On 10/7/24 18:12, Lucas Stach wrote: Am Samstag, dem 05.10.2024 um 03:42 +0800 schrieb Sui Jingfeng: Etnaviv assumes that GPU page size is 4KiB, yet on some systems, the CPU page size is 16KiB. The size of etnaviv buffer objects will be aligned to CPU page size on kernel side, however, user

Re: drm/etnaviv: always allocate 4K for kernel ringbuffers

2024-10-26 Thread Sui Jingfeng
Hi, On 10/25/24 23:14, Lucas Stach wrote: Since the kernel ringbuffers are allocated from a larger suballocated area, same as the user commandbufs, they don't need to be CPU page sized. Allocate 4KB for the kernel ring buffers, as we never use more than that. Signed-off-by: Lucas Stach Review

Re: [PATCH 1/3] drm/msm: Avoid NULL dereference in msm_disp_state_print_regs()

2024-10-26 Thread Dmitry Baryshkov
On Mon, 14 Oct 2024 09:36:08 -0700, Douglas Anderson wrote: > If the allocation in msm_disp_state_dump_regs() failed then > `block->state` can be NULL. The msm_disp_state_print_regs() function > _does_ have code to try to handle it with: > > if (*reg) > dump_addr = *reg; > > [...] Applie

[PATCH] fbdev: omapfb: Remove some deadcode

2024-10-26 Thread linux
From: "Dr. David Alan Gilbert" commit f76ee892a99e ("omapfb: copy omapdss & displays for omapfb") took a copy of the omapdrm code into omapfb, however at that point a couple of functions were already unused at that point. Remove dispc_mgr_get_clock_div() and dispc_enable_fifomerge() from the oma

[PATCH] drm/omap: Clean up deadcode functions

2024-10-26 Thread linux
From: "Dr. David Alan Gilbert" dispc_enable_fifomerge() last use was removed by 2012's commit 85099f11bd03 ("Revert "OMAPDSS: APPLY: add fifo merge support funcs"") dispc_has_writeback(), dispc_wb_get_framedone_irq(), dispc_wb_go(), dispc_wb_go_busy() and dispc_wb_setup() were changed from stati

Re: [PATCH v6] rockchip/drm: vop2: add support for gamma LUT

2024-10-26 Thread Piotr Zalewski
Hi all, any comments on this? On Thursday, October 17th, 2024 at 12:36 AM, Piotr Zalewski wrote: > Add support for gamma LUT in VOP2 driver. The implementation was inspired > by one found in VOP1 driver. Blue and red channels in gamma LUT register > write were swapped with respect to how gamma

Re: [PATCH v4 0/5] drm/vkms: Switch all vkms object to DRM managed objects

2024-10-26 Thread Maíra Canal
Hi Louis, How do you feel about adding the patch [1] to this series? This will avoid issues when reviewing and pushing the series? [1] https://lore.kernel.org/all/20241010-vkms-remove-index-v2-1-6b8d6cfd5...@bootlin.com/ Best Regards, - Maíra On 10/10/24 14:39, Louis Chauvet wrote: To simpl

Re: [PATCH] drm/msm/gpu: Fix missing error check for dev_pm_qos_add_request()

2024-10-26 Thread Dmitry Baryshkov
On Sat, Oct 26, 2024 at 05:37:38PM +0800, Jinjie Ruan wrote: > dev_pm_qos_add_request() can fail, and it returns -EINVAL in case of > wrong parameters, return -ENOMEM if there's not enough memory to allocate > for data structures, and return -ENODEV if the device has just been > removed from the sy

Re: [PATCH v8 1/4] drm: Introduce device wedged event

2024-10-26 Thread Raag Jadav
On Fri, Oct 25, 2024 at 05:45:59PM +0300, Andy Shevchenko wrote: > On Fri, Oct 25, 2024 at 12:08:50PM +0300, Jani Nikula wrote: > > On Fri, 25 Oct 2024, Raag Jadav wrote: > > ... > > > > +/* > > > + * Available recovery methods for wedged device. To be sent along with > > > device > > > + * wed

Re: [PATCH v4 1/5] drm/vkms: Switch to managed for connector

2024-10-26 Thread Maíra Canal
Hi Louis, On 10/10/24 14:39, Louis Chauvet wrote: The current VKMS driver uses non-managed function to create connectors. It is not an issue yet, but in order to support multiple devices easily, convert this code to use drm and device managed helpers. Signed-off-by: Louis Chauvet --- drivers

Re: [PATCH v2] drm/vkms: Remove index parameter from init_vkms_output

2024-10-26 Thread Maíra Canal
Hi Louis, On 10/10/24 14:27, Louis Chauvet wrote: VKMS currently supports only one CRTC, so it make no sense to have this index configurable. To avoid issues, replace this hardcoded index by drm_crtc_mask when applicable. There is no need to manually set a crtc mask on primary and cursor plane

Re: [PATCH RESEND v2 1/8] drm/vkms: Create helpers macro to avoid code duplication in format callbacks

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:46, Louis Chauvet wrote: The callback functions for line conversion are almost identical for some format. The generic READ_LINE macro generate all the required boilerplate to process a line. Two overrides of this macro have been added to avoid duplication of the same ar

Re: [PATCH v2 2/3] drm/vkms: Add a macro for write_line functions

2024-10-26 Thread Maíra Canal
Hi Louis, On 14/08/24 05:42, Louis Chauvet wrote: As stated in [2], the write_line functions are very similar and force code Where is [2]? duplication. This patch add a macro to avoid code repetition. Signed-off-by: Louis Chauvet --- drivers/gpu/drm/vkms/vkms_formats.c | 107 ++--

Re: [PATCH v2 1/3] drm/vkms: Re-introduce line-by-line algorithm for writeback

2024-10-26 Thread Maíra Canal
Hi Louis, On 14/08/24 05:42, Louis Chauvet wrote: Re-introduce a line-by-line writeback algorithm for each pixel format. This allows more performance by not requiring an indirection per pixel write. Line-by-line writeback was introduced by [1] but rewritten back to pixel-by-pixel algorithm in [

Re: [PATCH RESEND v2 1/8] drm/vkms: Create helpers macro to avoid code duplication in format callbacks

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:46, Louis Chauvet wrote: The callback functions for line conversion are almost identical for some format. The generic READ_LINE macro generate all the required boilerplate to process a line. Two overrides of this macro have been added to avoid duplication of the same ar

Re: [PATCH v12 13/15] drm/vkms: Create KUnit tests for YUV conversions

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:10, Louis Chauvet wrote: From: Arthur Grillo Create KUnit tests to test the conversion between YUV and RGB. Test each conversion and range combination with some common colors. The code used to compute the expected result can be found in comment. [Louis Chauvet: - fix

Re: [PATCH RESEND v2 5/8] drm/vkms: Add support for RGB888 formats

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:46, Louis Chauvet wrote: Add the support for: - RGB888 - BGR888 Signed-off-by: Louis Chauvet --- drivers/gpu/drm/vkms/vkms_formats.c | 7 +++ drivers/gpu/drm/vkms/vkms_plane.c | 2 ++ 2 files changed, 9 insertions(+) diff --git a/drivers/gpu/drm/vkms/vkms_fo

Re: [PATCH v12 08/15] drm/vkms: Re-introduce line-per-line composition algorithm

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:10, Louis Chauvet wrote: Re-introduce a line-by-line composition algorithm for each pixel format. This allows more performance by not requiring an indirection per pixel read. This patch is focused on readability of the code. Line-by-line composition was introduced by [1

Re: [PATCH v1 2/5] arm64: dts: qcom: Add support for configuring channel TRE size

2024-10-26 Thread Jyothi Kumar Seerapu
On 10/17/2024 12:40 PM, Krzysztof Kozlowski wrote: On 16/10/2024 16:35, Bjorn Andersson wrote: @@ -1064,7 +1064,7 @@ }; gpi_dma0: dma-controller@90 { - #dma-cells = <3>; + #dma-cells = <4>; compatibl

[PATCH] drm/nouveau/gr/gf100: Fix missing unlock in gf100_gr_chan_new()

2024-10-26 Thread Li Huafei
When the call to gf100_grctx_generate() fails, unlock gr->fecs.mutex before returning the error. Fixes smatch warning: drivers/gpu/drm/nouveau/nvkm/engine/gr/gf100.c:480 gf100_gr_chan_new() warn: inconsistent returns '&gr->fecs.mutex'. Fixes: ca081fff6ecc ("drm/nouveau/gr/gf100-: generate golde

Re: [PATCH RESEND v2 4/8] drm/vkms: Add support for RGB565 formats

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:46, Louis Chauvet wrote: The format RGB565 was already supported. Add the support for: - BGR565 Signed-off-by: Louis Chauvet --- drivers/gpu/drm/vkms/vkms_formats.c | 25 - drivers/gpu/drm/vkms/vkms_plane.c | 1 + 2 files changed, 25 inse

Re: [PATCH RESEND v2 3/8] drm/vkms: Add support for ARGB16161616 formats

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:46, Louis Chauvet wrote: The formats XRGB16161616 and ARGB16161616 were already supported. Add the support for: - ABGR16161616 - XBGR16161616 Signed-off-by: Louis Chauvet --- drivers/gpu/drm/vkms/vkms_formats.c | 11 --- drivers/gpu/drm/vkms/vkms_plane.c |

Re: [PATCH RESEND v2 2/8] drm/vkms: Add support for ARGB8888 formats

2024-10-26 Thread Maíra Canal
Hi Louis, On 07/10/24 13:46, Louis Chauvet wrote: The formats XRGB and ARGB were already supported. Add the support for: - XBGR - RGBX - BGRX - ABGR - RGBA - BGRA Signed-off-by: Louis Chauvet --- drivers/gpu/drm/vkms/vkms_formats.c | 18 ++ dr

[drm:vc4_hvs_irq_handler [vc4]] *ERROR* HVS underrun

2024-10-26 Thread Stefan Wahren
Hi, during the investigations of the recent VC4 HDMI Sink issue [1], I was able to reproduce another issue with vc4 after s2idle resume. Sometimes ( probability ~ 1 : 30 cases ) I'm able to trigger a HVS underrun and it's impact is that the HDMI display stays black and unusable: [ 1790.139465] PM

Re: [PATCH v2 2/3] dt-bindings: display: panel: add YAML schema for LXD M9189A

2024-10-26 Thread Krzysztof Kozlowski
On Fri, Oct 25, 2024 at 04:11:28PM +0200, Rouven Czerwinski wrote: A nit, subject: drop second/last, redundant "YAML schema for". The "dt-bindings" prefix is already stating that these are bindings in schema and YAML. See also: https://elixir.bootlin.com/linux/v6.7-rc8/source/Documentation/devicet

Re: [PATCH v12 09/15] drm/vkms: Remove useless drm_rotation_simplify

2024-10-26 Thread Maíra Canal
Hi Louis, On 14/10/24 05:39, Louis Chauvet wrote: On 11/10/24 - 10:53, Maira Canal wrote: Hi Louis, On 10/11/24 06:36, Louis Chauvet wrote: Hi all, Until this point, this series has not received any major comments since v9. I will commit patches 1-9 next week if there are no further comment

Re: [PATCH v3 5/5] drm/panel: samsung-s6e88a0-ams427ap24: Add flip option

2024-10-26 Thread Jakob Hauser
Hi Linus, On 25.10.24 21:32, Linus Walleij wrote: ... On Thu, Oct 24, 2024 at 5:18 AM Jakob Hauser wrote: The way of implementing a flip option follows the existing panel-samsung-s6e8aa0.c [1][2][3]. That driver is notoriously hard to read because it uses so much magic numbers so please don

Re: [PATCH v3 4/5] drm/panel: samsung-s6e88a0-ams427ap24: Add brightness control

2024-10-26 Thread Jakob Hauser
Hi Linus, On 25.10.24 21:27, Linus Walleij wrote: ... On Thu, Oct 24, 2024 at 5:18 AM Jakob Hauser wrote: +static const int s6e88a0_ams427ap24_br_to_cd[NUM_STEPS_CANDELA] = { (...) + /* brightness till, candela */ Brightness to candela conversion table? Edit comment? In the downst

Re: [PATCH v8 1/4] drm: Introduce device wedged event

2024-10-26 Thread kernel test robot
e: https://gitlab.freedesktop.org/drm/xe/kernel.git drm-xe-next patch link: https://lore.kernel.org/r/20241025084817.144621-2-raag.jadav%40intel.com patch subject: [PATCH v8 1/4] drm: Introduce device wedged event config: arm-randconfig-002-20241026 (https://download.01.org/0day-ci/archive/20241026/20

[PATCH] drm/msm/gpu: Fix missing error check for dev_pm_qos_add_request()

2024-10-26 Thread Jinjie Ruan
dev_pm_qos_add_request() can fail, and it returns -EINVAL in case of wrong parameters, return -ENOMEM if there's not enough memory to allocate for data structures, and return -ENODEV if the device has just been removed from the system. If it fails in msm_devfreq_init(), there is no point in going o

Re: [PATCH v3 3/5] drm/panel: samsung-s6e88a0-ams427ap24: Add initial driver

2024-10-26 Thread Jakob Hauser
Hi Linus, On 25.10.24 18:36, Linus Walleij wrote: ... On Thu, Oct 24, 2024 at 5:18 AM Jakob Hauser wrote: ... +#include +#include +#include +#include Why do you need this include? .of_match_table is part of You're right, I'll remove it. +static int s6e88a0_ams427ap24_on(struct s6

[PATCH v2] drm/bridge: tc358767: Improve DPI output pixel clock accuracy

2024-10-26 Thread Marek Vasut
The Pixel PLL is not very capable and may come up with wildly inaccurate clock. Since DPI panels are often tolerant to slightly higher pixel clock without being operated outside of specification, calculate two Pixel PLL settings for DPI output, one for desired output pixel clock and one for output

Re: [PATCH] drm/etnaviv: always allocate 4K for kernel ringbuffers

2024-10-26 Thread Christian Gmeiner
Am Fr., 25. Okt. 2024 um 17:14 Uhr schrieb Lucas Stach : > > Since the kernel ringbuffers are allocated from a larger suballocated > area, same as the user commandbufs, they don't need to be CPU page > sized. Allocate 4KB for the kernel ring buffers, as we never use more > than that. > > Signed-off