Hightest is a typo. It should be highest.Please ensure
the consistency of variable naming.
Signed-off-by: Yang Ruibin <11162...@vivo.com>
---
Changes v5:
-Updated the ignored misspellings
---
.../drm/amd/pm/powerplay/smumgr/fiji_smumgr.c| 16
.../amd/pm/powerplay/smumgr/polar
Adding the per-frame lp function of mt8188, which can keep HFP in HS and
reduce the time required for each line to enter and exit low power.
Per Frame LP:
|<--One Active Frame>|
--_____
^HSA+HBP^^RGB^^HFP^^HSA+HBP^^RGB^^HFP
Hi Krzysztof
> > + prev = of_get_child_by_name(parent, "ports");
(snip)
> > + if (!prev) {
> > + prev = of_node_get(parent);
> > +
> > + /* check wether it has port node */
> > + struct device_node *port __free(device_node
On Mon, Aug 26, 2024 at 02:43:23AM +, Kuninori Morimoto wrote:
> We have endpoint base functions
> - of_graph_get_next_device_endpoint()
> - of_graph_get_device_endpoint_count()
> - for_each_of_graph_device_endpoint()
> + if (!prev) {
> + /*
> + *
Hi Krzysztof,
Thank you for the reviewing the patches.
On 7/21/24 21:06, Krzysztof Kozlowski wrote:
> On 16/07/2024 10:42, Aradhya Bhatia wrote:
>> The OLDI (transmitters) TXes do not have registers of their own, and are
>> dependent on the source video-ports from the DSS to provide
>> configura
The return value of drm_atomic_get_crtc_state() needs to be
checked. To avoid use of error pointer 'crtc_state' in case
of the failure.
Cc: sta...@vger.kernel.org
Fixes: dec92020671c ("drm: Use the state pointer directly in planes
atomic_check")
Signed-off-by: Ma Ke
---
drivers/gpu/drm/sti/sti
Sorry, please ignore this patch for now. As the wrong subject line.
This patch will be updated later.
在 2024/8/26 10:55, Yang Ruibin 写道:
Hightest is a typo. It should be highest.Please ensure
the consistency of variable naming.
Signed-off-by: Yang Ruibin <11162...@vivo.com>
---
Changes V3:
-
Sorry, please ignore this patch for now. As the wrong subject line.
This patch will be updated later.
在 2024/8/26 11:47, Yang Ruibin 写道:
Hightest is a typo. It should be highest.Please ensure
the consistency of variable naming.
Signed-off-by: Yang Ruibin <11162...@vivo.com>
---
Changes V4:
-
Hightest is a typo. It should be highest.Please ensure
the consistency of variable naming.
Signed-off-by: Yang Ruibin <11162...@vivo.com>
---
Changes V4:
-Adds some information in the subject
-Updated the ignored misspellings
---
.../drm/amd/pm/powerplay/smumgr/fiji_smumgr.c| 16 -
Hightest is a typo. It should be highest.Please ensure
the consistency of variable naming.
Signed-off-by: Yang Ruibin <11162...@vivo.com>
---
Changes V3:
-Updated the ignored misspellings
---
.../drm/amd/pm/powerplay/smumgr/fiji_smumgr.c| 16
.../amd/pm/powerplay/smumgr/polar
We use komeda_crtc_normalize_zpos to normalize zpos of affected planes
to their blending zorder in CU. If there's only one slave plane in
affected planes and its layer_split property is enabled, order++ for
its split layer, so that when calculating the normalized_zpos
of master planes, the split la
Now we can use new port related functions for port parsing. Use it.
Signed-off-by: Kuninori Morimoto
Reviewed-by: Tomi Valkeinen
---
drivers/media/platform/xilinx/xilinx-tpg.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/media/platform/xilinx/xilinx-tpg.c
b/dri
Now we can use new port related functions for port parsing. Use it.
Signed-off-by: Kuninori Morimoto
---
drivers/video/fbdev/omap2/omapfb/dss/dpi.c| 3 +-
drivers/video/fbdev/omap2/omapfb/dss/dss-of.c | 66 ---
drivers/video/fbdev/omap2/omapfb/dss/dss.c| 9 +--
drivers/
Now we can use new port related functions for port parsing. Use it.
Signed-off-by: Kuninori Morimoto
Reviewed-by: Tomi Valkeinen
---
drivers/gpu/drm/omapdrm/dss/dpi.c | 3 ++-
drivers/gpu/drm/omapdrm/dss/sdi.c | 3 ++-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/d
Now we can use new port related functions for port parsing. Use it.
Signed-off-by: Kuninori Morimoto
Acked-by: Mark Brown
---
sound/soc/generic/audio-graph-card2.c | 111 --
1 file changed, 49 insertions(+), 62 deletions(-)
diff --git a/sound/soc/generic/audio-graph-car
Now we can use new port related functions for port parsing. Use it.
Signed-off-by: Kuninori Morimoto
Acked-by: Mark Brown
---
sound/soc/generic/audio-graph-card.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/sound/soc/generic/audio-graph-card.c
b/sound/soc/generic/au
Now we can use new port related functions for port parsing. Use it.
Signed-off-by: Kuninori Morimoto
Acked-by: Mark Brown
---
sound/soc/sh/rcar/core.c | 12 +++-
1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/sound/soc/sh/rcar/core.c b/sound/soc/sh/rcar/core.c
index 15cb5
Current test-component.c is using for_each_endpoint_of_node()
for parsing "port", because there was no "port" base loop before.
It has been assuming 1 port has 1 endpoint here.
But now we can use "port" base loop (= for_each_of_graph_port()).
Let's replace for_each function from "endpoint" base to
We already have of_graph_get_next_endpoint(), but it is not
intuitive to use in some case.
(X) node {
(Y) ports {
(P0)port@0 { endpoint { remote-endpoint = ...; };};
(P10) port@1 { endpoint { remote-endpoint = ...; };
(P11)
We have endpoint base functions
- of_graph_get_next_device_endpoint()
- of_graph_get_device_endpoint_count()
- for_each_of_graph_device_endpoint()
Here, for_each_of_graph_device_endpoint() loop finds each endpoints
ports {
port@0 {
(1)
Hi Rob, Saravana, Tomi, Laurent, Sakari
This is v3 patch-set
I have been posting to add new port base for loop function
as below steps.
[o] done
[@] this patch set
[o] tidyup of_graph_get_endpoint_count()
[o] replace endpoint func - use endpoint_by_regs()
[o] replace end
Hi, Liviu,
I'll initialize 'slave_zpos' to zero and resend the [patch v2] soon,
thanks!
Best Regards,
Hongchi Peng
-邮件原件-
发件人: Liviu Dudau
发送时间: 2024年8月24日 20:33
收件人: Peng Hongchi/彭洪驰
抄送: maarten.lankho...@linux.intel.com; mrip...@kernel.org; tzimmerm...@suse.de;
airl...@gma
On Sat, Aug 17, 2024 at 10:56 AM Yafang Shao wrote:
>
> Using {memcpy,strncpy,strcpy,kstrdup} to copy the task comm relies on the
> length of task comm. Changes in the task comm could result in a destination
> string that is overflow. Therefore, we should explicitly ensure the
> destination string
在 2024/8/24 7:32, Andi Shyti 写道:
> [Some people who received this message don't often get email from
> andi.sh...@linux.intel.com. Learn why this is important at
> https://aka.ms/LearnAboutSenderIdentification ]
>
> Hi Yu,
>
> On Wed, Aug 21, 2024 at 10:41:27AM +0800, Yu Jiaoliang wrote:
>> Let t
>From DT point of view, in general, drivers should be asking for a
specific port number because their function is fixed in the binding.
of_graph_get_next_endpoint() doesn't match to this concept.
Simply replace
- of_graph_get_next_endpoint(xxx, NULL);
+ of_graph_get_endpoint_by_r
Hi all,
Today's linux-next merge of the amdgpu tree got a conflict in:
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
between commits:
537ef0f88897 ("drm/amd/display: use new vblank enable policy for DCN35+")
e45b6716de4b ("drm/amd/display: use a more lax vblank enable policy for
DCN3
It will be called by drm_gem_print_info() if have implemented, and this can
provide more information about the framebuffer objects. In order to make
the newly implemented etnaviv_gem_object_funcs::print_info() get in use,
we make the drm_gem_print_info() exported, then we re-implement the
etnaviv_g
This will make the newly implemented etnaviv_gem_object_funcs::print_info
get in use, which improves code sharing and simplifies debugfs. Achieve
better humen readability for debug log.
Signed-off-by: Sui Jingfeng
---
drivers/gpu/drm/drm_gem.c | 1 +
drivers/gpu/drm/etnaviv/etnaviv_
It will be called by drm_gem_print_info() if have implemented, and this can
provide more information about the framebuffer objects.
Signed-off-by: Sui Jingfeng
---
drivers/gpu/drm/etnaviv/etnaviv_gem.c | 32 +++
drivers/gpu/drm/etnaviv/etnaviv_gem.h | 2 +-
2 files chang
Hi,
CEC features are useful to e.g. control HDMI monitor standby.
But I wonder what happened to this series?
I could find some reviewed-by: and acked-by: in [1] but it wasn't merged
upstream
for unidentifiable reasons.
We apparently had merged this series some years ago into our LetuxOS distro
Hi Raag,
kernel test robot noticed the following build errors:
[auto build test ERROR on groeck-staging/hwmon-next]
[also build test ERROR on linus/master v6.11-rc5 next-20240823]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use
> On 25 Aug 2024, at 18:10, Chukun Pan wrote:
>
> Hi,
>
>> --- /dev/null
>> +++ b/arch/arm64/boot/dts/rockchip/rk3576.dtsi
>> ...
>> +opp-141600 {
>> +opp-hz = /bits/ 64 <141600>;
>> +opp-microvolt = <725000 725000 95>;
>> +opp-microvolt
The unpin_user_pages() function takes an unsigned long argument to store
length of the number of user space pages, and struct drm_gem_object::size
is a size_t type. The number of pages can not be negative, hence, use an
unsigned variable to store the number of pages.
Signed-off-by: Sui Jingfeng
-
Hi,
> --- /dev/null
> +++ b/arch/arm64/boot/dts/rockchip/rk3576.dtsi
> ...
> + opp-141600 {
> + opp-hz = /bits/ 64 <141600>;
> + opp-microvolt = <725000 725000 95>;
> + opp-microvolt-L1 = <712500 712500 95>;
>
Hi,
> --- /dev/null
> +++ b/arch/arm64/boot/dts/rockchip/rk3576-armsom-sige5.dts
> ...
> + leds: leds {
> + compatible = "gpio-leds";
Maybe there should be a blank line.
> + work_led: work-led {
> + gpios = <&gpio0 RK_PB4 GPIO_ACTIVE_HIGH>;
> +
The drm_prime_pages_to_sg() function takes unsigned int argument to store
length of the page vector, and the type of struct drm_gem_object::size is
a size_t. The size of the object in CPU pages can not be negative, hence,
use unsigned variable to store the number of pages, instead of the signed
typ
Currently, the etnaviv_gem_submit.c isn't call any runtime power management
functions. So drop it, we can re-include it when the header really get used
though.
Signed-off-by: Sui Jingfeng
---
drivers/gpu/drm/etnaviv/etnaviv_gem_submit.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/
There are 2G and 4G RAM versions of the Lenovo Yoga Tab 3 X90F and it
turns out that the 2G version has a DMI product name of
"CHERRYVIEW D1 PLATFORM" where as the 4G version has
"CHERRYVIEW C0 PLATFORM". The sys-vendor + product-version check are
unique enough that the product-name check is not ne
Currently, the calling of mutex_destroy() is ignored on error handling
code path. It is safe for now, since mutex_destroy() actually does
nothing in non-debug builds. But the mutex_destroy() is used to mark
the mutex uninitialized on debug builds, and any subsequent use of the
mutex is forbidden.
drm_WARN_ON() acts like WARN_ON(), but with the key difference of
using device specific information so that we know from which device
warning is originating from.
Signed-off-by: Sui Jingfeng
---
drivers/gpu/drm/etnaviv/etnaviv_gem.c | 9 +
drivers/gpu/drm/etnaviv/etnaviv_gem_prime.
Hello,
We found the following issue using syzkaller on Linux v6.10.
In `fast_imageblit`, there is an out-of-bounds memory access when
executing `*dst++ = colortab[(*src >> 7) & bit_mask];`
Although Syzbot has found a similar bug
(https://syzkaller.appspot.com/bug?extid=3d3864c27a5e770e7654), the
b
With last TXT binding converted to DT schema, all Samsung Exynos display
bindings are in "samsung" directory, already present in maintainers
entry. Drop old "exynos" directory to fix get_maintainers.pl self-test
warning:
./MAINTAINERS:7539: warning: no file matches F:
Documentation/devic
42 matches
Mail list logo