Re: [PATCH 7/7] drm/i915/pmu: Do not set event_init to NULL

2024-08-04 Thread kernel test robot
Hello, kernel test robot noticed "INFO:trying_to_register_non-static_key" on: commit: a236f4d92e214998f7606430282249580f709423 ("[PATCH 7/7] drm/i915/pmu: Do not set event_init to NULL") url: https://github.com/intel-lab-lkp/linux/commits/Lucas-De-Marchi/perf-core-Add-pmu-get-put/20240723-05

Re: [PATCH 11/11] arm64: defconfig: build CONFIG_REGULATOR_QCOM_REFGEN as module

2024-08-04 Thread Krzysztof Kozlowski
On 04/08/2024 07:40, Dmitry Baryshkov wrote: > Enable CONFIG_REGULATOR_QCOM_REFGEN and build it as a module. It is an > internal supply used by the DSI on SM8350-based platforms (e.g. on the > SM8350 HDK device). > > Signed-off-by: Dmitry Baryshkov Reviewed-by: Krzysztof Kozlowski Best regards

Re: [PATCH 07/11] dt-bindings: interconnect: qcom,sm8450: drop DISP nodes

2024-08-04 Thread Krzysztof Kozlowski
On 04/08/2024 07:40, Dmitry Baryshkov wrote: > Vendor msm-5.x kernels declared duplicate indices for some of display > nodes to be used by separate display RSC and BCM voters. As it is not > clear how this separate BCM should be modelled upstream and the device > trees do not use these indices, dro

Re: [PATCH 06/11] dt-bindings: interconnect: qcom,sm8350: drop DISP nodes

2024-08-04 Thread Krzysztof Kozlowski
On 04/08/2024 07:40, Dmitry Baryshkov wrote: > Vendor msm-5.x kernels declared duplicate indices for some of display > nodes to be used by separate display RSC and BCM voters. As it is not > clear how this separate BCM should be modelled upstream and the device > trees do not use these indices, dro

Re: [PATCH v2 09/16] drm/imx: Add i.MX8qxp Display Controller KMS

2024-08-04 Thread Liu Ying
On 07/31/2024, Dmitry Baryshkov wrote: > On Tue, Jul 30, 2024 at 04:31:35PM GMT, Liu Ying wrote: >> On 07/28/2024, Dmitry Baryshkov wrote: >>> On Fri, Jul 12, 2024 at 05:32:36PM GMT, Liu Ying wrote: i.MX8qxp Display Controller(DC) is comprised of three main components that include a blit

[PATCH v2 4/4] udmabuf: remove folio unpin list

2024-08-04 Thread Huan Yang
Currently, udmabuf handles folio by creating an unpin list to record each folio obtained from the list and unpinning them when released. To maintain this approach, many data structures have been established. However, maintaining this type of data structure requires a significant amount of memory a

[PATCH v2 1/4] udmabuf: cancel mmap page fault, direct map it

2024-08-04 Thread Huan Yang
The current udmabuf mmap uses a page fault mechanism to populate the vma. However, the current udmabuf has already obtained and pinned the folio upon completion of the creation.This means that the physical memory has already been acquired, rather than being accessed dynamically. The current page f

[PATCH v2 2/4] udmabuf: change folios array from kmalloc to kvmalloc

2024-08-04 Thread Huan Yang
When PAGE_SIZE 4096, MAX_PAGE_ORDER 10, 64bit machine, page_alloc only support 4MB. If above this, trigger this warn and return NULL. udmabuf can change size limit, if change it to 3072(3GB), and then alloc 3GB udmabuf, will fail create. [ 4080.876581] [ cut here ] [ 4080.

[PATCH v2 3/4] fix vmap_udmabuf error page set

2024-08-04 Thread Huan Yang
Currently vmap_udmabuf set page's array by each folio. But, ubuf->folios is only contain's the folio's head page. That mean we repeatedly mapped the folio head page to the vmalloc area. This patch fix it, set each folio's page correct, so that pages array contains right page, and then map into vm

[PATCH v2 0/4] udmbuf bug fix and some improvements

2024-08-04 Thread Huan Yang
This patchset attempts to fix some errors in udmabuf and remove the upin_list structure. Some of this fix just gather the patches which I upload before. Patch1,2,4 has passed the udmabuf self-test suite's tests. Suggested by Kasireddy, Vivek Test item 6 maybe requires running the command: echo

Re: [PATCH v2 06/16] drm/imx: Add i.MX8qxp Display Controller display engine

2024-08-04 Thread Liu Ying
On 07/31/2024, Dmitry Baryshkov wrote: > On Tue, Jul 30, 2024 at 02:25:41PM GMT, Liu Ying wrote: >> On 07/28/2024, Dmitry Baryshkov wrote: >>> On Fri, Jul 12, 2024 at 05:32:33PM GMT, Liu Ying wrote: i.MX8qxp Display Controller display engine consists of all processing units that operate i

Re: [PATCH v1 1/2] drm/panel: jd9365da: Move the sending location of the 11/29 command

2024-08-04 Thread zhaoxiong lv
Hi all Do you have any other suggestions for this patch? Looking forward to your reply, thank you BR On Tue, Jul 30, 2024 at 4:09 AM Dmitry Baryshkov wrote: > > On Mon, 29 Jul 2024 at 06:10, zhaoxiong lv > wrote: > > > > On Sun, Jul 28, 2024 at 12:59 AM Dmitry Baryshkov > > wrote: > > > > > >

Re: [PATCH v2 1/2] drm/msm/dpu1: don't choke on disabling the writeback connector

2024-08-04 Thread Leonard Lausen
Dear Dmitry, Thank you for the patch. Unfortunately, the patch triggers a regression with respect to DRM CRTC state handling. With the patch applied, suspending and resuming a lazor sc7180 with external display connected, looses CRTC state on resume and prevents applying a new CRTC state. Without

Re: [PATCH] drm/amdgpu: add dce6 drm_panic support

2024-08-04 Thread yaolu
在 2024/8/2 17:39, Christian König 写道: Am 02.08.24 um 09:17 schrieb Lu Yao: Add support for the drm_panic module, which displays a pretty user friendly message on the screen when a Linux kernel panic occurs. Signed-off-by: Lu Yao --- The patch can work properly on the TTY, but after start X,

Re: [RFC PATCH v4 00/42] Color Pipeline API w/ VKMS

2024-08-04 Thread Melissa Wen
On 06/11, Harry Wentland wrote: > > > On 2024-06-05 06:04, Melissa Wen wrote: > > On 02/26, Harry Wentland wrote: > >> This is an RFC set for a color pipeline API, along with a sample > >> implementation in VKMS. All the key API bits are here. VKMS now > >> supports two named transfer function co

Re: [PATCH v3] drm/vkms: Fix cpu_to_le16()/le16_to_cpu() warnings

2024-08-04 Thread Maíra Canal
Hi José, On 8/4/24 14:14, José Expósito wrote: On Tue, Jul 16, 2024 at 06:17:26PM +0200, José Expósito wrote: Building with Sparse enabled prints this warning for cpu_to_le16() calls: warning: incorrect type in assignment (different base types) expected unsigned short [usertype]

Re: [PATCH v3] drm/vkms: Fix cpu_to_le16()/le16_to_cpu() warnings

2024-08-04 Thread José Expósito
On Tue, Jul 16, 2024 at 06:17:26PM +0200, José Expósito wrote: > Building with Sparse enabled prints this warning for cpu_to_le16() > calls: > > warning: incorrect type in assignment (different base types) > expected unsigned short [usertype] > got restricted __le16 [usertype]

[PATCH] drm/connector: Document destroy hook in drmm init functions

2024-08-04 Thread José Expósito
Document that the drm_connector_funcs.destroy hook must be NULL in drmm_connector_init() and drmm_connector_hdmi_init(). Signed-off-by: José Expósito --- drivers/gpu/drm/drm_connector.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/gpu/drm/drm_connector.c b/drivers/gpu/drm/drm_

[PATCH] i2c: Add error handling for drm_hdmi_avi_infoframe_from_display_mode in tda998x_write_avi

2024-08-04 Thread Mikhail Lobanov
This patch adds error handling for the return value of the drm_hdmi_avi_infoframe_from_display_mode function within the tda998x_write_avi function. The function's return value is checked to ensure that any errors encountered during the generation of the AVI infoframe are properly handled. If th

[PATCH 0/3] drm/amd: some trivial fixes

2024-08-04 Thread tjakobi
From: Tobias Jakobi Nothing serious here, just some bits I noticed when reading code. Tobias Jakobi (3): drm/amd: Make amd_ip_funcs static for SDMA v5.0 drm/amd: Make amd_ip_funcs static for SDMA v5.2 drm/amdgpu/swsmu: fix SMU11 typos (memlk -> memclk) drivers/gpu/drm/amd/amdgpu/sdma_v5_

[PATCH 3/3] drm/amdgpu/swsmu: fix SMU11 typos (memlk -> memclk)

2024-08-04 Thread tjakobi
From: Tobias Jakobi No functional changes. Signed-off-by: Tobias Jakobi --- drivers/gpu/drm/amd/pm/swsmu/smu11/navi10_ppt.c | 4 ++-- drivers/gpu/drm/amd/pm/swsmu/smu11/sienna_cichlid_ppt.c | 4 ++-- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/amd/pm/

[PATCH 1/3] drm/amd: Make amd_ip_funcs static for SDMA v5.0

2024-08-04 Thread tjakobi
From: Tobias Jakobi The struct can be static, as it is only used in this translation unit. Signed-off-by: Tobias Jakobi --- drivers/gpu/drm/amd/amdgpu/sdma_v5_0.c | 2 +- drivers/gpu/drm/amd/amdgpu/sdma_v5_0.h | 1 - 2 files changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/gpu/drm

[PATCH 2/3] drm/amd: Make amd_ip_funcs static for SDMA v5.2

2024-08-04 Thread tjakobi
From: Tobias Jakobi The struct can be static, as it is only used in this translation unit. Signed-off-by: Tobias Jakobi --- drivers/gpu/drm/amd/amdgpu/sdma_v5_2.c | 2 +- drivers/gpu/drm/amd/amdgpu/sdma_v5_2.h | 1 - 2 files changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/gpu/drm

Re: [PATCH 03/14] drm/dp_mst: Simplify the condition when to enumerate path resources

2024-08-04 Thread Manasi Navare
On Mon, Jul 22, 2024 at 9:55 AM Imre Deak wrote: > > In the > if (old_ddps != port->ddps || !created) > if (port->ddps && !port->input) > ret = drm_dp_send_enum_path_resources(); > > sequence the first if's condition is true if the port exists alread

[PATCH 0/2] drm/i915: Fix ttm small BAR placement handling

2024-08-04 Thread David Gow
From: David Gow As described in [1], there have been a couple of regressions in the TTM placement handling for i915, which adversely affect DG2 systems with small BAR. In particular, performance become very poor when eviction from the mappable BAR memory is required, as suboptimal placements can

[PATCH 1/2] drm/i915: Allow evicting to use the requested placement

2024-08-04 Thread David Gow
In commit a78a8da51b36 ("drm/ttm: replace busy placement with flags v6"), the old system of having a separate placement list (for placements which should be used without eviction) and a 'busy' placement list (for placements which should be attempted if eviction is required) was replaced with a new

[PATCH 2/2] drm/i915: Attempt to get pages without eviction first

2024-08-04 Thread David Gow
In commit a78a8da51b36 ("drm/ttm: replace busy placement with flags v6"), __i915_ttm_get_pages was updated to use flags instead of the separate 'busy' placement list. However, the behaviour was subtly changed. Originally, the function would attempt to use the preferred placement without eviction, a

Re: [PATCH 0/2] Add MSM8996/MSM8953 dpu catalog

2024-08-04 Thread barnabas . czeman
On 2024-08-01 21:25, Dmitry Baryshkov wrote: On Fri, Jun 28, 2024 at 04:39:38PM GMT, Barnabás Czémán wrote: This patch series add dpu support for MSM8996/MSM8953 devices. Note, by default these platforms are still handled by the MDP5 driver unless the `msm.prefer_mdp5=false' parameter is provid

Re: [PATCH 07/11] dt-bindings: interconnect: qcom, sm8450: drop DISP nodes

2024-08-04 Thread Dmitry Baryshkov
y-Baryshkov/clk-qcom-dispcc-sm8250-use-CLK_SET_RATE_PARENT-for-branch-clocks/20240804-134328 > base: 668d33c9ff922c4590c58754ab064aaf53c387dd > patch link: > https://lore.kernel.org/r/20240804-sm8350-fixes-v1-7-1149dd8399fe%40linaro.org > patch subject: [PATCH 07/11] dt-bindings:

Re: [PATCH 07/11] dt-bindings: interconnect: qcom,sm8450: drop DISP nodes

2024-08-04 Thread kernel test robot
Hi Dmitry, kernel test robot noticed the following build errors: [auto build test ERROR on 668d33c9ff922c4590c58754ab064aaf53c387dd] url: https://github.com/intel-lab-lkp/linux/commits/Dmitry-Baryshkov/clk-qcom-dispcc-sm8250-use-CLK_SET_RATE_PARENT-for-branch-clocks/20240804-134328 base

[PATCH v5 9/9] drm: Replace strcpy() with __get_task_comm()

2024-08-04 Thread Yafang Shao
To prevent erros from occurring when the src string is longer than the dst string in strcpy(), we should use __get_task_comm() instead. This approach also facilitates future extensions to the task comm. Signed-off-by: Yafang Shao Acked-by: Daniel Vetter Cc: Maarten Lankhorst Cc: Maxime Ripard

[PATCH v5 8/9] net: Replace strcpy() with __get_task_comm()

2024-08-04 Thread Yafang Shao
To prevent errors from occurring when the src string is longer than the dst string in strcpy(), we should use __get_task_comm() instead. This approach also facilitates future extensions to the task comm. Signed-off-by: Yafang Shao Cc: "David S. Miller" Cc: David Ahern Cc: Eric Dumazet Cc: Jaku

[PATCH v5 7/9] tracing: Replace strncpy() with __get_task_comm()

2024-08-04 Thread Yafang Shao
Using __get_task_comm() to read the task comm ensures that the name is always NUL-terminated, regardless of the source string. This approach also facilitates future extensions to the task comm. Signed-off-by: Yafang Shao Acked-by: Masami Hiramatsu (Google) Cc: Steven Rostedt Cc: Mathieu Desnoye

[PATCH v5 6/9] mm/util: Deduplicate code in {kstrdup, kstrndup, kmemdup_nul}

2024-08-04 Thread Yafang Shao
These three functions follow the same pattern. To deduplicate the code, let's introduce a common helper __kmemdup_nul(). Suggested-by: Andrew Morton Signed-off-by: Yafang Shao Cc: Simon Horman Cc: Matthew Wilcox --- mm/util.c | 67 +-- 1 fil

[PATCH v5 5/9] mm/util: Fix possible race condition in kstrdup()

2024-08-04 Thread Yafang Shao
In kstrdup(), it is critical to ensure that the dest string is always NUL-terminated. However, potential race condidtion can occur between a writer and a reader. Consider the following scenario involving task->comm: readerwriter len = strlen(s) + 1;

[PATCH v5 4/9] bpftool: Ensure task comm is always NUL-terminated

2024-08-04 Thread Yafang Shao
Let's explicitly ensure the destination string is NUL-terminated. This way, it won't be affected by changes to the source string. Signed-off-by: Yafang Shao Reviewed-by: Quentin Monnet --- tools/bpf/bpftool/pids.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/tools/bpf/bpftool/pids.c b/

[PATCH v5 3/9] security: Replace memcpy() with __get_task_comm()

2024-08-04 Thread Yafang Shao
Quoted from Linus [0]: selinux never wanted a lock, and never wanted any kind of *consistent* result, it just wanted a *stable* result. Using __get_task_comm() to read the task comm ensures that the name is always NUL-terminated, regardless of the source string. This approach also facilitates

[PATCH v5 2/9] auditsc: Replace memcpy() with __get_task_comm()

2024-08-04 Thread Yafang Shao
Using __get_task_comm() to read the task comm ensures that the name is always NUL-terminated, regardless of the source string. This approach also facilitates future extensions to the task comm. Signed-off-by: Yafang Shao Acked-by: Paul Moore Cc: Eric Paris --- kernel/auditsc.c | 6 +++--- 1 fi

[PATCH v5 1/9] fs/exec: Drop task_lock() inside __get_task_comm()

2024-08-04 Thread Yafang Shao
Quoted from Linus [0]: Since user space can randomly change their names anyway, using locking was always wrong for readers (for writers it probably does make sense to have some lock - although practically speaking nobody cares there either, but at least for a writer some kind of race could

[PATCH v5 0/9] Improve the copy of task comm

2024-08-04 Thread Yafang Shao
Using {memcpy,strncpy,strcpy,kstrdup} to copy the task comm relies on the length of task comm. Changes in the task comm could result in a destination string that is overflow. Therefore, we should explicitly ensure the destination string is always NUL-terminated, regardless of the task comm. This ap