Am 04.08.23 um 08:56 schrieb Ma Jun:
[1] Change pages to blocks to avoid confusion.
[2] Fix output format to align the output info.
Signed-off-by: Ma Jun
Of hand looks good to me, but Arun should probably judge.
Christian.
---
drivers/gpu/drm/drm_buddy.c | 8
1 file changed, 4
On Fri, Aug 04, 2023 at 02:06:13PM -0700, Douglas Anderson wrote:
> Now that most panels have been updated not to track/double-check their
> prepared/enabled state update the TODO with next steps.
>
> Signed-off-by: Douglas Anderson
> ---
>
> Documentation/gpu/todo.rst | 33 +---
Hi Doug,
Thanks for working on this :)
On Fri, Aug 04, 2023 at 02:06:07PM -0700, Douglas Anderson wrote:
> The goal of this file is to contain helper functions for panel drivers
> to use. To start off with, let's add drm_panel_helper_shutdown() for
> use by panels that want to make sure they're p
Add the device link when panel bridge is attached and delete the link
when panel bridge is detached. The drm device is the consumer while
the panel device is the supplier. This makes sure that the drm device
suspends eariler and resumes later than the panel device, hence resolves
problems where t
Freescale i.MX93 SoC embeds a Synopsys Designware MIPI DSI host
controller and a Synopsys Designware MIPI DPHY. Some configurations
and extensions to them are controlled by i.MX93 media blk-ctrl.
Add a DRM bridge for i.MX93 MIPI DSI by using existing DW MIPI DSI
bridge helpers and implementing i.
Freescale i.MX93 SoC embeds a Synopsys Designware MIPI DSI host
controller and a Synopsys Designware MIPI DPHY. Some configurations
and extensions to them are controlled by i.MX93 media blk-ctrl.
Signed-off-by: Liu Ying
Reviewed-by: Rob Herring
---
v2->v3:
* No change.
v1->v2:
* Add Rob's R-b
According to Synopsys support channel, each region of HSA, HBP and HFP must
have minimum number of 10 bytes where constant 4 bytes are for HSS or HSE
and 6 bytes are for blanking packet(header + CRC). Hence, the below table
comes in.
++--+---+
| data lanes | min lbcc | byt
According to Synopsys DW MIPI DSI host databook, HSTX and LPRX timeout
contention detections are measured in TO_CLK_DIVISION cycles. However,
the current driver programs magic values to TO_CLK_DIVISION, HSTX_TO_CNT
and LPRX_TO_CNT register fields, which makes timeout error event wrongly
happen for
Vendor drivers may need to fixup mode due to pixel clock tree limitation,
so introduce the ->mode_fixup() callcack to struct dw_mipi_dsi_plat_data
and call it at atomic check stage if available.
Signed-off-by: Liu Ying
---
v1->v3:
* No change.
drivers/gpu/drm/bridge/synopsys/dw-mipi-dsi.c | 14
To get better accuration, use pixel clock rate to calculate lbcc instead of
lane_mbps since the pixel clock rate is in KHz while lane_mbps is in MHz.
Without this, distorted image can be seen on a HDMI monitor connected with
i.MX93 11x11 EVK through ADV7535 DSI to HDMI bridge in 1920x1080p@60 video
The DATAEN_ACTIVE_LOW bit in DSI_DPI_CFG_POL register is set to zero,
so set the DRM_BUS_FLAG_DE_HIGH flag in input_bus_cfg.flags. It appears
that the DRM_BUS_FLAG_PIXDATA_SAMPLE_NEGEDGE flag also makes sense, so
set it in input_bus_cfg.flags too. With this patch, the flags set by
drm_atomic_brid
Introduce ->get_input_bus_fmts() callback to struct dw_mipi_dsi_plat_data
so that vendor drivers can implement specific methods to get input bus
formats for Synopsys DW MIPI DSI.
While at it, implement a generic callback for ->atomic_get_input_bus_fmts(),
where we try to get the input bus formats
Add dw_mipi_dsi_get_bridge() helper so that it can be used by vendor
drivers which implement vendor specific extensions to Synopsys DW MIPI DSI.
Signed-off-by: Liu Ying
---
v1->v3:
* No change.
drivers/gpu/drm/bridge/synopsys/dw-mipi-dsi.c | 6 ++
include/drm/bridge/dw_mipi_dsi.h
Hi,
This series aims to add MIPI DSI support for Freescale i.MX93 SoC.
There is a Synopsys DesignWare MIPI DSI host controller and a Synopsys
Designware MIPI DPHY embedded in i.MX93. Some configurations and
extensions to them are controlled by i.MX93 media blk-ctrl.
Add a DRM bridge for i.MX93
[Why]
Today, the allocation/deallocation steps and status is a bit unclear.
For instance, payload->vc_start_slot = -1 stands for "the failure of
updating DPCD payload ID table" and can also represent as "payload is not
allocated yet". These two cases should be handled differently and hence
better
[Why]
Now in drm_dp_remove_payload_part2(), it utilizes the time slot number
of the payload in old state to represent the one in the payload table
at the moment.
It would be better to clarify the idea by using the latest allocated
time slot number for the port at the moment instead and which info
[Why]
There is no need to consider payload->delete case since we won't call
drm_dp_add_payload_part2() to create a payload when we're about to
remove it.
[How]
Delete unnecessary case to simplify the code.
Signed-off-by: Wayne Lin
---
drivers/gpu/drm/display/drm_dp_mst_topology.c | 8 ++--
This patch set is mainly trying to organize the mst code today a bit.
Like to clarify and organize the sequence of mst payload allocation and
removement.And also clean up some redundant codes today.
The main refactor one is the patch
"drm/mst: Refactor the flow for payload allocation/removement"
w
[AMD Official Use Only - General]
> -Original Message-
> From: Imre Deak
> Sent: Friday, August 4, 2023 11:32 PM
> To: Lin, Wayne
> Cc: dri-devel@lists.freedesktop.org; amd-...@lists.freedesktop.org;
> ly...@redhat.com; jani.nik...@intel.com; ville.syrj...@linux.intel.com;
> Wentland, Ha
According to the comment in drm_atomic_helper_async_commit(),
we should make sure FBs have been swapped, so that cleanups in the
new_state performs a cleanup in the old FB.
So we should move swapping FBs after calling mtk_plane_update_new_state(),
to avoid using the old FB which could be freed.
F
Fix some IGT tests fail at iommu fault in OVL cursor plane.
Change in RESEND v4 :
1. Remove redundant plane_state assigning.
Change in v4:
1. Change disable all layer method to update mtk_plane_state stored
in mtk_crtc by drm_atomic_state from mtk_drm_crtc_atomic_enable().
Change in v3:
1. Ad
The plane_state of drm_atomic_state is not sync to the mtk_plane_state
stored in mtk_crtc during crtc enabling.
So we need to update the mtk_plane_state stored in mtk_crtc by the
drm_atomic_state carried from mtk_drm_crtc_atomic_enable().
While updating mtk_plane_state, OVL layer should be disabl
Hi all,
After merging the drm-misc tree, today's linux-next build (x86_64
allmodconfig) failed like this:
drivers/gpu/drm/nouveau/nouveau_dmem.c: In function
'nouveau_dmem_migrate_chunk':
drivers/gpu/drm/nouveau/nouveau_dmem.c:681:43: error: 'chunk' undeclared (first
use in this function)
681
Hi all,
After merging the drm-misc tree, today's linux-next build (arm
multi_v7_defconfig) produced this warning:
In file included from drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmm.h:4,
from drivers/gpu/drm/nouveau/nvkm/subdev/mmu/uvmm.h:5,
from drivers/gpu/drm/no
drivers/gpu/drm/bridge/synopsys/dw-hdmi-cec.c:332 dw_hdmi_cec_suspend() warn:
inconsistent indenting
Reported-by: Abaci Robot
Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=6101
Signed-off-by: Yang Li
---
drivers/gpu/drm/bridge/synopsys/dw-hdmi-cec.c | 6 +++---
1 file changed, 3 inser
Panfrost IRQ handler may stuck for a long time, for example this happens
when there is a bad HDMI connection and HDMI handler takes a long time to
finish processing, holding Panfrost. Make Panfrost's job timeout handler
to sync IRQ before checking fence signal status in order to prevent
spurious jo
Hi GUO,
kernel test robot noticed the following build warnings:
[auto build test WARNING on next-20230804]
url:
https://github.com/intel-lab-lkp/linux/commits/GUO-Zihua/drm-kmb-Make-layer_irqs-static/20230807-054559
base: next-20230804
patch link:
https://lore.kernel.org/r/202308040850
Hi GUO,
kernel test robot noticed the following build warnings:
[auto build test WARNING on next-20230804]
url:
https://github.com/intel-lab-lkp/linux/commits/GUO-Zihua/drm-kmb-Make-layer_irqs-static/20230807-054559
base: next-20230804
patch link:
https://lore.kernel.org/r/202308040850
On Fri, 4 Aug 2023 at 14:15, Karol Herbst wrote:
mind retrying with only fb725beca62d and 62aecf23f3d1 reverted?
I will do this later this day (takes some time, it is a slow machine).
Would be weird if the other two commits are causing it. If that's the
case, it's a bit worrying that reverti
Hi Laurent,
Thank you for the review.
On 2023/08/03 20:06, Laurent Pinchart wrote:
On Fri, Aug 04, 2023 at 02:53:17AM +0300, Laurent Pinchart wrote:
On Fri, Aug 04, 2023 at 02:47:04AM +0300, Laurent Pinchart wrote:
Hi Damian,
Thank you for the patch.
On Fri, Jul 28, 2023 at 04:07:13PM -0400
Dear all,
On Fri, 4 Aug 2023 at 14:15, Karol Herbst wrote:
62aecf23f3d1 drm/nouveau: add nv_encoder pointer check for NULL
fb725beca62d drm/nouveau/dp: check for NULL nv_connector->native_mode
90748be0f4f3 drm/nouveau: don't detect DSM for non-NVIDIA device
5a144bad3e75 nouveau: fix client work
-邮件原件-
发件人: Liu Lucas/刘保柱
发送时间: 2023年8月4日 15:47
收件人: 'Liviu Dudau'
抄送: Huang Menghui/黄梦辉 ; airl...@gmail.com;
dan...@ffwll.ch
主题: 回复: 回复: 回复: 回复: [PATCH] drm/komeda: drop all currently held locks if
deadlock happens
Hi Liviu,
I have resend that patch and cc to the dri-devel
layer_irqs is not referred elsewhere, so makt it static.
This resolves the following sparse warning:
warning: symbol 'layer_irqs' was not declared. Should it be static?
Signed-off-by: GUO Zihua
---
drivers/gpu/drm/kmb/kmb_plane.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --g
-邮件原件-
发件人: Liu Lucas/刘保柱
发送时间: 2023年8月1日 16:59
收件人: 'Liviu Dudau'
抄送: airl...@gmail.com; dan...@ffwll.ch; Huang Menghui/黄梦辉
主题: 回复: 回复: [PATCH] drm/komeda: drop all currently held locks if deadlock
happens
Ok , later, I will send a new patch.
-邮件原件-
发件人: Liviu Dudau
发送时间:
Hi,
this should probably also go to the maintainers of the "HID CORE LAYER"
for review:
HID CORE LAYER
M: Jiri Kosina
M: Benjamin Tissoires
L: linux-in...@vger.kernel.org
And maybe it would better fit to be in drivers/hid/ ?
(Something for the maintainers to figure out)
Some t
Mark fbcon_registered_fb, and fbcon_num_registered_fb static
to fix the following sparse warnings:
drivers/video/fbdev/core/fbcon.c:105:16: sparse: warning: symbol
'fbcon_registered_fb' was not declared. Should it be static?
drivers/video/fbdev/core/fbcon.c:106:5: sparse: warning: symbol
'fbcon_
On Fri, 4 Aug 2023 at 14:51, Karol Herbst wrote:
How are you building the kernel? Because normally from git reverting
one of those shouldn't take long, because it doesn't recompile the
entire kernel. But yeah, you can potentially just revert one of one
for now and it should be fine.
I am usi
On Sat, 5 Aug 2023 at 01:09, Karol Herbst wrote:
Mind checking if instead of reverting the entire commit that this is
enough to fix it as well?
https://gitlab.freedesktop.org/karolherbst/nouveau/-/commit/f99ae069876f7ffeb6368da0381485e8c3adda43.patch
This patch does fix the problem as well: S
Hi folks,
the patch in $Subject breaks booting here on one of my test boxes, see
below.
Reverting it ontop of -rc4 fixes the issue.
Thx.
[3.580535] ACPI: \_PR_.CP04: Found 4 idle states
[3.585694] ACPI: \_PR_.CP05: Found 4 idle states
[3.590852] ACPI: \_PR_.CP06: Found 4 idle states
On 2023-08-02 13:04:24, Dmitry Baryshkov wrote:
> In preparation to reworking IRQ indcies, stop using raw IRQ indices in
> kernel output (both printk and debugfs). Instead use a pair of register
> index and bit. This corresponds closer to the values in HW catalog.
>
> Signed-off-by: Dmitry Baryshk
On 2023-08-02 13:04:19, Dmitry Baryshkov wrote:
> Since commit 1e7ac595fa46 ("drm/msm/dpu: pass irq to
> dpu_encoder_helper_wait_for_irq()") the
> dpu_encoder_phys_wb_wait_for_commit_done expects the IRQ index rather
> than the IRQ index in phys_enc->intr table, however writeback got the
> older in
Hi Chris,
hi Guido,
On 2023-06-06 at 08:12:36 +0200, Frank Oltmanns wrote:
> Hi Chris,
> hi Guido,
>
> On 2023-04-26 at 16:54:46 +0200, Guido Günther wrote:
>> Hi Chris,
>> could you check if these two modifications by Frank of the init sequence
>>
>>
>> https://lore.kernel.org/dri-devel/202
nfig: i386-randconfig-r072-20230806
(https://download.01.org/0day-ci/archive/20230806/202308062017.iku92hml-...@intel.com/config)
compiler: gcc-12 (Debian 12.2.0-14) 12.2.0
reproduce:
(https://download.01.org/0day-ci/archive/20230806/202308062017.iku92hml-...@intel.com/reproduce)
If you fix the
Initialize struct fb_ops to the correct default values with the
internal __FB_DEFAULT_SBUS_OPS_*() macros. Rename the ioctl and
mmap callbacks to use the infix _sbusfb_. This makes them fit the
SBUS helpers' naming pattern.
It is not possible to use set all defaults via FB_DEAFULT_SBUS_OPS(),
as c
Initialize struct fb_ops to the correct default values with the
macro FB_DEFAULT_SBUS_OPS(). Rename the ioctl and mmap callbacks
to use the infix _sbusfb_. This makes them fit the SBUS helpers'
naming pattern. Also make the driver depend on FB_SBUS_HELPERS,
which selects the correct modules.
Signe
Add macros to initialize struct fb_ops for drivers that support
framebuffers on Sparc's SBUS. Also add a Kconfig token that selects
the necessary helpers.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/Kconfig | 6 ++
drivers/video/fbdev/sbuslib.h | 31 ++
Initialize struct fb_ops to the correct default values with the
macro FB_DEFAULT_SBUS_OPS(). Rename the ioctl and mmap callbacks
to use the infix _sbusfb_. This makes them fit the SBUS helpers'
naming pattern. Also make the driver depend on FB_SBUS_HELPERS,
which selects the correct modules.
Signe
In sbuslib.h, declare all of the header file's structs at the
top. No functional changes.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/sbuslib.h | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/video/fbdev/sbuslib.h b/drivers/video/fbdev/sbuslib.h
inde
Initialize struct fb_ops to the correct default values with the
macro FB_DEFAULT_SBUS_OPS(). Rename the ioctl and mmap callbacks
to use the infix _sbusfb_. This makes them fit the SBUS helpers'
naming pattern. Also make the driver depend on FB_SBUS_HELPERS,
which selects the correct modules.
Signe
Initialize struct fb_ops to the correct default values with the
internal __FB_DEFAULT_SBUS_OPS_*() macros. Rename the ioctl and
mmap callbacks to use the infix _sbusfb_. This makes them fit the
SBUS helpers' naming pattern.
It is not possible to use set all defaults via FB_DEAFULT_SBUS_OPS(),
as f
Initialize struct fb_ops to the correct default values with the
macro FB_DEFAULT_SBUS_OPS(). Rename the ioctl and mmap callbacks
to use the infix _sbusfb_. This makes them fit the SBUS helpers'
naming pattern. Also make the driver depend on FB_SBUS_HELPERS,
which selects the correct modules.
Signe
Initialize struct fb_ops to the correct default values with the
macro FB_DEFAULT_SBUS_OPS(). Rename the ioctl and mmap callbacks
to use the infix _sbusfb_. This makes them fit the SBUS helpers'
naming pattern. Also make the driver depend on FB_SBUS_HELPERS,
which selects the correct modules.
Signe
Avoid duplicate listings of sbuslib.o in the Makefile by building
it if CONFIG_FB_SBUS has been selected. Remove the object file from
the various drivers' build rules.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/Makefile | 17 +
1 file changed, 9 insertions(+), 8 del
Initialize struct fb_ops to the correct default values with the
macro FB_DEFAULT_SBUS_OPS(). Rename the ioctl and mmap callbacks
to use the infix _sbusfb_. This makes them fit the SBUS helpers'
naming pattern. Also make the driver depend on FB_SBUS_HELPERS,
which selects the correct modules.
Signe
Add initializer macros for struct fb_ops of drivers that operate
on SBUS-based framebuffers. Also add a Kconfig token to select the
correct dependencies.
All drivers for SBUS-based framebuffers use the regular helpers
for framebuffers in I/O memory (fb_io_*() and cfb_*()). Each driver
provides its
The HID spec defines the following Usage IDs (p. 345 ff):
- Monitor Page (0x80) -> Monitor Control (0x01)
- VESA Virtual Controls Page (0x82) -> Brightness (0x10)
Apple made use of them in their Apple Studio Display and most likely on
other external displays (LG UltraFine 5k, Pro Display XDR).
T
Complete rewrite of [1]. Instead of a USB driver it`s now a HID driver
and will work without being part of the early boot environment.
The driver is no longer heavily tied to the Apple Studio Display, but
should work with all HID devices, that expose a report containing fields
with the Monitor - B
57 matches
Mail list logo