The backlight_bl driver required initialization using
struct generic_bl_info. As there are no more references
to this struct there is no users left.
So it is safe to delete the driver.
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
--
Add overview chapter to backlight.c.
Update existing kernel-doc to follow a more consistent
style and drop kernel-doc for deprecated functions.
v2:
- Sevaral editorial corrections that makes reading
much easier (Daniel)
- Spelling fixes (Daniel)
- updated intro chapter with a little more
Include backlight so the documentation is now generated
with make htmldocs and friends.
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Maarten Lankhorst
Cc: Maxime Ripard
Cc: Thomas Zimmermann
Cc: David Airlie
Cc: Daniel Vetter
Cc: Jonathan Corbet
---
Documentation/gpu/backl
No need to put "extern" in front of prototypes.
While touching the prototypes adjust indent to follow
the kernel style.
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
---
include/linux/backlight.h | 35 +++
v3:
- Dropped video patch that was reviewd and thus applied
- Updated kernel-doc so all fields now have a short intro
- Improved readability in a lot of places, thanks to review
feedback from Daniel - thanks!
- Added better intro to backlight
- Added acks
Several other smaller changes d
Improve the documentation for backlight_device and
adapt it to kernel-doc style.
v2:
- Add short intro to all fields (Daniel)
- Updated description of update_lock (Daniel)
Signed-off-by: Sam Ravnborg
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
---
include/linux/backlight.h | 72
Improve the documentation for backlight_ops and
adapt it to kernel-doc style.
v2:
- Add intro for each field (Daniel)
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
---
include/linux/backlight.h | 59 ++
Add documentation for the inline functions in backlight.h
v2:
- Fix spelling (Daniel)
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
---
include/linux/backlight.h | 16
1 file changed, 16 insertions(+)
diff --git
Increase readability of fb_notifier_callback() by removing
a few indent levels.
No functional change.
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
---
drivers/video/backlight/backlight.c | 43 +++--
1 file c
Replaces the open-coded checks of the state etc.,
with the backlight_is_blank() helper.
This increases readability of the code and align
the functionality across the drivers.
v3:
- Dropped as3711_bl, it will be modified in another patch
v2:
- Fixed so changelog is readable
Signed-off-by: Sam
The backlight support has two properties that express the state:
- power
- state
It is un-documented and easy to get wrong.
Add backlight_is_blank() helper to make it simpler
for drivers to get the check of the state correct.
A lot of drivers also includes checks for fb_blank.
This check is redun
Replaces the open-coded checks of the state, with the
backlight_is_blank() helper. This increases readability
of the code and aling the functionality across the drivers.
Futhermore drop the debug prints in update_status().
If we need debug printing then we can add it to the backlight core.
Signed
Add kernel-doc documentation for the backlight enums
v2:
- Add intro to each enum member (Daniel)
Except backlight type as line lenght was too long.
The generated HTML is the same.
Signed-off-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo
Improve the documentation for backlight_properties and
adapt it to kernel-doc style.
v2:
- Added into for each field (Daniel)
- Re-written some parts to explain what to do, rather
than what not to do.
Partly based on suggestions from the review (Daniel)
Signed-off-by: Sam Ravnborg
Cc
From: Sandor Yu
Document the bindings used for the Cadence MHDP HDMI/DP bridge.
Signed-off-by: Sandor Yu
---
.../bindings/display/bridge/cdns,mhdp.yaml| 46 +++
.../devicetree/bindings/display/imx/mhdp.yaml | 59 +++
2 files changed, 105 insertions(+)
create mo
From: Sandor Yu
Initial support for i.MX8MQ MHDP Displayport.
Add MHDP DP PHY configutation.
The features are same as MHDP DP bridge driver.
Signed-off-by: Sandor Yu
---
drivers/gpu/drm/imx/Kconfig | 1 +
drivers/gpu/drm/imx/Makefile| 1 +
drivers/gpu/drm/im
From: Sandor Yu
The patch set initial support for Cadence MHDP(HDMI/DP) drm bridge
driver and iMX8MQ HDMI/DP.
The first patch drm/rockchip: prepare common code for cdns and rk dpi/dp driver
is from the link https://patchwork.kernel.org/patch/10788309/
that still in reviewing.
Files in drm/bridg
From: Sandor Yu
This adds initial support for MHDP DP bridge driver.
Basic DP functions are supported, that include:
-Video mode set on-the-fly
-Cable hotplug detect
-MAX support resolution to 3096x2160@60fps
-Support DP audio
-EDID read via AUX
Signed-off-by: Sandor Yu
---
drivers/gpu/dr
From: Sandor Yu
Create new directory drm/bridge/cadence.
Cadence MHDP DP and HDMI bridge dirver will added later.
drm/rockchip/cdn-dp-reg.c will separate to three files.
- cdns-mhdp-common.c: Provide basic MHDP register read/write via mailbox.
public firmware load, event, edid and HPD functi
From: Sandor Yu
Add initial support for i.MX8MQ MHDP HDMI.
Add MHDP HDMI PHY configuration.
The features are same as mhdp hdmi bridge driver.
Signed-off-by: Sandor Yu
---
drivers/gpu/drm/imx/mhdp/Kconfig | 5 +-
drivers/gpu/drm/imx/mhdp/Makefile | 2 +-
drivers/gpu
From: Sandor Yu
This adds initial support for cadence MHDP HDMI bridge driver.
Basic HDMI functions are supported, that include:
-Video mode set on-the-fly
-Cable hotplug detect
-MAX support resolution to 3096x2160@60fps
-HDMI audio
-AV infoframe
-EDID read
-SCDC read
Signed-off-by: Sando
From: Sandor Yu
- Extracted common fields from cdn_dp_device to a new cdns_mhdp_device
structure which will be used by two separate drivers later on.
- Moved some datatypes (audio_format, audio_info, vic_pxl_encoding_format,
video_info) from cdn-dp-core.c to cdn-dp-reg.h.
- Changed prefixes f
Hi,
For letting DRM clients to select output encoding:
Sink can support certain display timings with high output bit-depths using
multiple output encodings, e.g. sink can support a particular timing with
RGB 10-bit, YCbCr422 10-bit and YCbCr420 10-bit. So DRM client may want to
select YCbCr422 10-
On Mon, 1 Jun 2020 at 13:37, Ben Skeggs wrote:
>
> On Mon, 1 Jun 2020 at 13:27, wrote:
> >
> >
> > Hi Ben,
> >
> > > > When gk20a_clk_ctor() returns an error code, pointer "clk"
> > > > should be released. It's the same when gm20b_clk_new()
> > > > returns from elsewhere following this call.
> >
On Mon, 1 Jun 2020 at 13:27, wrote:
>
>
> Hi Ben,
>
> > > When gk20a_clk_ctor() returns an error code, pointer "clk"
> > > should be released. It's the same when gm20b_clk_new()
> > > returns from elsewhere following this call.
> > This shouldn't be necessary. If a subdev constructor fails, and
>
Hi,
First of all, thanks a lot for all your patch. And thanks Emil for your
feedback.
I have a suggestion here:
Emil:
Could you give me your Acked-by or maybe Reviewed-by for the writeback
series? With that, I can finally apply the series.
Sidong:
Secondly, after applying the writeback series,
On 2020-05-31 14:11, Andy Shevchenko wrote:
...
JFYI, we have history.git starting from v0.01.
OK, thanks for that note. According to that history.git [1],
then: drivers/video/pvr2fb.c had get_user_pages_fast() support added to
pvr2fb_write() back in 2004, but only for CONFIG_SH_DMA, as par
On Sat, 30 May 2020 at 19:42, Dinghao Liu wrote:
>
> When gk20a_clk_ctor() returns an error code, pointer "clk"
> should be released. It's the same when gm20b_clk_new()
> returns from elsewhere following this call.
This shouldn't be necessary. If a subdev constructor fails, and
returns a pointer,
On Monday, June 1, 2020, John Hubbard wrote:
> On 2020-05-31 13:58, Sam Ravnborg wrote:
> ...
>
>> Thanks, patches are now applied to drm-misc-next.
>> They will hit -next soon, but you will have to wait
>> until next (not the upcoming) merge window before they hit
>> mainline linux.
>>
>>
On 2020-05-31 13:58, Sam Ravnborg wrote:
...
Thanks, patches are now applied to drm-misc-next.
They will hit -next soon, but you will have to wait
until next (not the upcoming) merge window before they hit
mainline linux.
Sam
Great! That will work out just fine.
thanks,
--
John Hubb
Hi Colin/Greg.
On Thu, May 21, 2020 at 02:50:38PM +0100, Colin King wrote:
> From: Colin Ian King
>
> Currently HSD20_IPS is defined as "true" and will always result in a
> non-zero result even if it is defined as "false" because it is an array
> and that will never be zero. Fix this by defining
Hi John.
On Thu, May 21, 2020 at 09:15:04PM -0700, John Hubbard wrote:
> Hi,
>
> Note that I have only compile-tested this series, although that does
> also include cross-compiling for a few other arches. I'm hoping that
> this posting will lead to some run-time testing.
>
> Also: the proposed fi
Hi Thomas.
On Mon, May 25, 2020 at 01:07:29PM +0200, Thomas Zimmermann wrote:
> Hi
>
> Am 23.05.20 um 09:12 schrieb Sam Ravnborg:
> > Replace all DRM_* logging functions with their drm_ counterparts.
> > checkpatch emits a few "quoted string split across lines",
> > which is left as is. The string
Hi Sidong
On Fri, May 29, 2020 at 02:21:59AM +0900, Sidong Yang wrote:
> Change wrong function name drm_modest_lock_all() to drm_modeset_lock_all()
>
> Signed-off-by: Sidong Yang
Thanks, applied to drm-misc-next.
Sam
> ---
> Documentation/gpu/todo.rst | 2 +-
> 1 file changed, 1 inser
Hi Laurent & Hyun,
Thanks for the review.
>-Original Message-
>From: Laurent Pinchart
>Sent: Sunday, May 24, 2020 8:38 AM
>To: Venkateshwar Rao Gannavarapu
>Cc: Hyun Kwon ; Hyun Kwon ; dri-
>de...@lists.freedesktop.org; airl...@linux.ie; dan...@ffwll.ch; linux-
>ker...@vger.kernel.org;
On Sun, 31 May 2020 at 10:30, Hans de Goede wrote:
>
> Like the Asus T100HA the Asus T101HA also uses a panel which has been
> mounted 90 degrees rotated, add a quirk for this.
>
Reading the commit message, made me wonder: If it's similar why it
doesn't use the same quirk?
Something like the follo
On Sun, 31 May 2020 at 14:12, Sidong Yang wrote:
>
> Optimize looping pixels in compute_crc() and blend(). Calculate
> src_offset in start of looping horizontally and increase it.
> It's better than calculating in every pixels.
>
When you say "optimize" have you observed any actual benefits of the
HI Laurent,
>From a quick glance the series looks really good and neat. Then again,
I don't know much about the hardware to provide meaningful review.
A couple of small ideas below.
On Sat, 30 May 2020 at 04:11, Laurent Pinchart
wrote:
> +#define LCDC_AS_BUF0x220
> +#define
On Thu, May 14, 2020 at 1:11 PM Daniel Vetter wrote:
>
> I honestly don't exactly understand what's going on here, but the
> current code is wrong for sure: It calls dma_buf_vunmap without ever
> calling dma_buf_vmap.
>
> What I'm not sure about is whether the WARN_ON is correct:
> - msm imports d
Originally reported by jghodd[1] in linux-drm-tip-git AUR package [2], also
reported on drm/amd on Freedesktop GitLab [3].
drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c: In function
‘amdgpu_amdkfd_gpuvm_free_memory_of_gpu’:
drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c:1357:2: error: impl
Optimize looping pixels in compute_crc() and blend(). Calculate
src_offset in start of looping horizontally and increase it.
It's better than calculating in every pixels.
Cc: Rodrigo Siqueira
Cc: David Airlie
Cc: dri-devel@lists.freedesktop.org
Cc: linux-ker...@vger.kernel.org
Signed-off-by: Sid
On Thu 2020-05-28 14:07:50, Michal Hocko wrote:
> On Thu 28-05-20 14:03:54, Pavel Machek wrote:
> > On Thu 2020-05-28 11:05:17, Michal Hocko wrote:
> > > On Tue 26-05-20 11:10:54, Pavel Machek wrote:
> > > [...]
> > > > [38617.276517] oom_reaper: reaped process 31769 (chromium), now
> > > > anon-r
https://bugzilla.kernel.org/show_bug.cgi?id=205827
--- Comment #1 from sander44 (ionut_n2...@yahoo.com) ---
Hi Kernel Team,
I retested with new version kernel, and this issue appear.
dmesg | grep drm
[4.080480] [drm] DMA map mode: Caching DMA mappings.
[4.080866] [drm] Capabilities:
[
Like the Asus T100HA the Asus T101HA also uses a panel which has been
mounted 90 degrees rotated, add a quirk for this.
Signed-off-by: Hans de Goede
---
drivers/gpu/drm/drm_panel_orientation_quirks.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/gpu/drm/drm_panel_orientation_
The Acer S1003 has proper DMI strings for sys-vendor and product-name,
so we do not need to match by BIOS-date.
This means that the Acer S1003 can use the generic lcd800x1280_rightside_up
drm_dmi_panel_orientation_data struct which is also used by other quirks.
Signed-off-by: Hans de Goede
---
On Sun, May 24, 2020 at 07:42:25AM +1000, David Airlie wrote:
> On Sun, May 24, 2020 at 2:02 AM Sidong Yang wrote:
> >
> > Hi, Dave.
> >
> > I'm a newbie kernel developer interested in qxl driver. And I want to
> > participate in
> > contributing for QXL module.
> > I wrote some simple patch for
46 matches
Mail list logo