Hi John,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on rdma/for-next]
[also build test ERROR on v5.4 next-20191122]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system. BTW, we also suggest to use '--base' option to spec
https://bugs.freedesktop.org/show_bug.cgi?id=97055
--- Comment #28 from juliasamy ---
I trust somebody learned and ready to take care of business pays heed to this
page and deals with the bug. We also one of the best web development company in
jeddah visit here for more details:
https://www.adweb
'--base' option to specify the
base tree in git format-patch, please see https://stackoverflow.com/a/37406982]
url:
https://github.com/0day-ci/linux/commits/Wei-Hu/video-hyperv-hyperv_fb-Use-physical-memory-for-fb-on-HyperV-Gen-1-VMs/20191124-163533
base:b9d3d01405061bb42358fe53f824e8
Reviewed-by: Evan Quan
> -Original Message-
> From: amd-gfx On Behalf Of Alex
> Deucher
> Sent: Saturday, November 23, 2019 3:19 AM
> To: amd-...@lists.freedesktop.org; dri-devel@lists.freedesktop.org
> Cc: Deucher, Alexander
> Subject: [PATCH] MAINTAINERS: Drop Rex Zhu for amdgpu power
As it says in the updated comment in gup.c: current FOLL_LONGTERM
behavior is incompatible with FAULT_FLAG_ALLOW_RETRY because of the
FS DAX check requirement on vmas.
However, the corresponding restriction in get_user_pages_remote() was
slightly stricter than is actually required: it forbade all
1. Change v4l2 from get_user_pages() to pin_user_pages().
2. Because all FOLL_PIN-acquired pages must be released via
put_user_page(), also convert the put_page() call over to
put_user_pages_dirty_lock().
Acked-by: Hans Verkuil
Cc: Ira Weiny
Signed-off-by: John Hubbard
---
drivers/media/v4l2-
After DMA is complete, and the device and CPU caches are synchronized,
it's still required to mark the CPU pages as dirty, if the data was
coming from the device. However, this driver was just issuing a
bare put_page() call, without any set_page_dirty*() call.
Fix the problem, by calling set_page_
Hi,
Here is a set of well-reviewed (expect for one patch), lower-risk items
that can go into Linux 5.5. The one patch that wasn't reviewed is the
powerpc conversion, and it's still at this point a no-op, because
tracking isn't yet activated.
This is based on linux-next: b9d3d01405061bb42358fe53f
An upcoming patch uses try_get_compound_head() more widely,
so move it to the top of gup.c.
Also fix a tiny spelling error and a checkpatch.pl warning.
Reviewed-by: Christoph Hellwig
Reviewed-by: Jan Kara
Reviewed-by: Ira Weiny
Signed-off-by: John Hubbard
---
mm/gup.c | 29 +++---
Fix the gup benchmark flags to use the symbolic FOLL_WRITE,
instead of a hard-coded "1" value.
Also, clean up the filtering of gup flags a little, by just doing
it once before issuing any of the get_user_pages*() calls. This
makes it harder to overlook, instead of having little "gup_flags & 1"
phr
Update VFIO to take advantage of the recently loosened restriction on
FOLL_LONGTERM with get_user_pages_remote(). Also, now it is possible to
fix a bug: the VFIO caller is logically a FOLL_LONGTERM user, but it
wasn't setting FOLL_LONGTERM.
Also, remove an unnessary pair of calls that were releasi
Convert drm/via to use the new pin_user_pages_fast() call, which sets
FOLL_PIN. Setting FOLL_PIN is now required for code that requires
tracking of pinned pages, and therefore for any code that calls
put_user_page().
In partial anticipation of this work, the drm/via driver was already
calling put_
Convert fs/io_uring to use the new pin_user_pages() call, which sets
FOLL_PIN. Setting FOLL_PIN is now required for code that requires
tracking of pinned pages, and therefore for any code that calls
put_user_page().
In partial anticipation of this work, the io_uring code was already
calling put_us
Convert net/xdp to use the new pin_longterm_pages() call, which sets
FOLL_PIN. Setting FOLL_PIN is now required for code that requires
tracking of pinned pages.
In partial anticipation of this work, the net/xdp code was already
calling put_user_page() instead of put_page(). Therefore, in order to
Introduce pin_user_pages*() variations of get_user_pages*() calls,
and also pin_longterm_pages*() variations.
For now, these are placeholder calls, until the various call sites
are converted to use the correct get_user_pages*() or
pin_user_pages*() API.
These variants will eventually all set FOLL
1. Avoid naming conflicts: rename local static function from
"pin_user_pages()" to "goldfish_pin_pages()".
An upcoming patch will introduce a global pin_user_pages()
function.
Reviewed-by: Jan Kara
Reviewed-by: Jérôme Glisse
Reviewed-by: Ira Weiny
Signed-off-by: John Hubbard
---
drivers/plat
Convert infiniband to use the new pin_user_pages*() calls.
Also, revert earlier changes to Infiniband ODP that had it using
put_user_page(). ODP is "Case 3" in
Documentation/core-api/pin_user_pages.rst, which is to say, normal
get_user_pages() and put_page() is the API to use there.
The new pin_u
From: Dan Williams
After the removal of the device-public infrastructure there are only 2
->page_free() call backs in the kernel. One of those is a device-private
callback in the nouveau driver, the other is a generic wakeup needed in
the DAX case. In the hopes that all ->page_free() callbacks ca
There are four locations in gup.c that have a fair amount of code
duplication. This means that changing one requires making the same
changes in four places, not to mention reading the same code four
times, and wondering if there are subtle differences.
Factor out the common code into static functi
In order to provide a clearer, more symmetric API for pinning
and unpinning DMA pages. This way, pin_user_pages*() calls
match up with unpin_user_pages*() calls, and the API is a lot
closer to being self-explanatory.
Reviewed-by: Jan Kara
Signed-off-by: John Hubbard
---
Documentation/core-api/p
1. Change vfio from get_user_pages_remote(), to
pin_user_pages_remote().
2. Because all FOLL_PIN-acquired pages must be released via
put_user_page(), also convert the put_page() call over to
put_user_pages_dirty_lock().
Note that this effectively changes the code's behavior in
vfio_iommu_type1.c:
Convert process_vm_access to use the new pin_user_pages_remote()
call, which sets FOLL_PIN. Setting FOLL_PIN is now required for
code that requires tracking of pinned pages.
Also, release the pages via put_user_page*().
Also, rename "pages" to "pinned_pages", as this makes for
easier reading of p
1. Call the new global pin_user_pages_fast(), from pin_goldfish_pages().
2. As required by pin_user_pages(), release these pages via
put_user_page(). In this case, do so via put_user_pages_dirty_lock().
That has the side effect of calling set_page_dirty_lock(), instead
of set_page_dirty(). This i
1. Convert from get_user_pages() to pin_user_pages().
2. As required by pin_user_pages(), release these pages via
put_user_page(). In this case, do so via put_user_pages_dirty_lock().
That has the side effect of calling set_page_dirty_lock(), instead
of set_page_dirty(). This is probably more acc
https://bugzilla.kernel.org/show_bug.cgi?id=205169
--- Comment #25 from Shmerl (shtetl...@gmail.com) ---
Also, even with 100 ms timeout, the flip hang still happens just very rarely
and not in the usual scenarios for me. For example when playing The Witcher 3
(Wine+dxvk) and minimizing the game Wi
https://bugzilla.kernel.org/show_bug.cgi?id=205169
--- Comment #24 from Shmerl (shtetl...@gmail.com) ---
Just FYI, 5.4 is out, but the fix didn't land yet, so it needs to be still
applied manually.
--
You are receiving this mail because:
You are watching the assignee of the bug.
On 11/19/19 12:43 AM, Daniel Vetter wrote:
On Mon, Nov 18, 2019 at 4:23 PM kbuild test robot wrote:
Hi Daniel,
I love your patch! Yet something to improve:
[auto build test ERROR on drm-intel/for-linux-next]
[also build test ERROR on v5.4-rc8 next-20191115]
[if your patch is applied to the
On 11/24/19 2:07 AM, Leon Romanovsky wrote:
> On Thu, Nov 21, 2019 at 10:36:43AM -0400, Jason Gunthorpe wrote:
>> On Thu, Nov 21, 2019 at 12:07:46AM -0800, Christoph Hellwig wrote:
>>> On Wed, Nov 20, 2019 at 11:13:37PM -0800, John Hubbard wrote:
And get rid of the mmap_sem calls, as part of t
From: Rob Clark
We can have two cases, when it comes to "zap" fw. Either the fw
requires zap fw to take the GPU out of secure mode at boot, or it does
not and we can write RBBM_SECVID_TRUST_CNTL directly. Previously we
decided based on whether zap fw load succeeded, but this is not a great
plan
On Sat, Nov 23, 2019 at 11:53:52PM +, Jason Gunthorpe wrote:
On Fri, Nov 22, 2019 at 08:44:18PM -0800, Niranjan Vishwanathapura wrote:
On Fri, Nov 22, 2019 at 11:33:12PM +, Jason Gunthorpe wrote:
> On Fri, Nov 22, 2019 at 12:57:27PM -0800, Niranjana Vishwanathapura wrote:
>
> > +static i
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:59PM +0200, Boris Brezillon wrote:
> To iterate over all bridges attached to a specific encoder.
>
> Suggested-by: Laurent Pinchart
> Signed-off-by: Boris Brezillon
> ---
> Changes in v3:
> * None
>
> Changes in v2:
> * New patch
Hi Boris,
On Sun, Nov 24, 2019 at 11:56:16AM +0100, Boris Brezillon wrote:
> On Sun, 24 Nov 2019 12:33:35 +0200 Laurent Pinchart wrote:
> > On Wed, Oct 23, 2019 at 05:44:56PM +0200, Boris Brezillon wrote:
> > > And use it in drivers accessing the bridge->next field directly.
> > > This is part of
Hi Boris,
On Sun, Nov 24, 2019 at 02:17:27PM +0100, Boris Brezillon wrote:
> On Sun, 24 Nov 2019 12:24:33 +0200 Laurent Pinchart wrote:
> > On Wed, Oct 23, 2019 at 05:44:54PM +0200, Boris Brezillon wrote:
> > > Encoder drivers will progressively transition to the drm_bridge
> > > interface in plac
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:58PM +0200, Boris Brezillon wrote:
> So that each element in the chain can easily access its predecessor.
> This will be needed to support bus format negotiation between elements
> of the bridge chain.
>
> Signed-off-by: Boris Brez
On Sun, 24 Nov 2019 12:39:26 +0200
Laurent Pinchart wrote:
> > @@ -1346,7 +1355,7 @@ void drm_atomic_helper_commit_modeset_enables(struct
> > drm_device *dev,
> > funcs->commit(encoder);
> > }
> >
> > - drm_atomic_bridge_chain_enable(encoder->b
On Sun, 24 Nov 2019 14:17:27 +0100
Boris Brezillon wrote:
> > > @@ -1687,16 +1705,18 @@ static int exynos_dsi_bind(struct device *dev,
> > > struct device *master,
> > > drm_encoder_init(drm_dev, encoder, &exynos_dsi_encoder_funcs,
> > >DRM_MODE_ENCODER_TMDS, NULL);
> > >
Hi Laurent,
On Sun, 24 Nov 2019 12:24:33 +0200
Laurent Pinchart wrote:
> Hi Boris,
>
> Thank you for the patch.
>
> On Wed, Oct 23, 2019 at 05:44:54PM +0200, Boris Brezillon wrote:
> > Encoder drivers will progressively transition to the drm_bridge
> > interface in place of the drm_encoder one
On Mon, Nov 11, 2019 at 7:19 AM Adam Ford wrote:
>
> On Fri, Nov 1, 2019 at 2:57 AM Laurent Pinchart
> wrote:
> >
> > On Wed, Oct 30, 2019 at 09:44:20AM -0500, Adam Ford wrote:
> > > On Wed, Oct 16, 2019 at 8:52 AM Adam Ford wrote:
> > > >
> > > > Previously, there was an omap panel-dpi driver t
On Sun, 24 Nov 2019 12:33:35 +0200
Laurent Pinchart wrote:
> Hi Boris,
>
> Thank you for the patch.
>
> On Wed, Oct 23, 2019 at 05:44:56PM +0200, Boris Brezillon wrote:
> > And use it in drivers accessing the bridge->next field directly.
> > This is part of our attempt to make the bridge chain
On Sun, 24 Nov 2019 12:01:30 +0200
Laurent Pinchart wrote:
> Hi Boris,
>
> Thank you for the patch.
>
> On Wed, Oct 23, 2019 at 05:44:52PM +0200, Boris Brezillon wrote:
> > Encoder drivers will progressively transition to the drm_bridge
> > interface in place of the drm_encoder one.
> >
> > Le
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:57PM +0200, Boris Brezillon wrote:
> We are about to replace the single-linked bridge list by a double-linked
> one based on list.h, leading to the suppression of the encoder->bridge
> field. But before we can do that we must provid
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:56PM +0200, Boris Brezillon wrote:
> And use it in drivers accessing the bridge->next field directly.
> This is part of our attempt to make the bridge chain a double-linked list
> based on the generic list helpers.
>
> Signed-off-b
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:55PM +0200, Boris Brezillon wrote:
> Change the prefix of bridge helpers targeting a bridge chain from
> drm_bridge_ to drm_bridge_chain_ to better reflect the fact that
> the operation will happen on all elements of chain, starting
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:54PM +0200, Boris Brezillon wrote:
> Encoder drivers will progressively transition to the drm_bridge
> interface in place of the drm_encoder one.
>
> Converting the Exynos DSI encoder driver to this approach allows us to
> use the
On Thu, Nov 21, 2019 at 10:36:43AM -0400, Jason Gunthorpe wrote:
> On Thu, Nov 21, 2019 at 12:07:46AM -0800, Christoph Hellwig wrote:
> > On Wed, Nov 20, 2019 at 11:13:37PM -0800, John Hubbard wrote:
> > > And get rid of the mmap_sem calls, as part of that. Note
> > > that get_user_pages_fast() wil
Hi Boris,
Thank you for the patch.
On Wed, Oct 23, 2019 at 05:44:52PM +0200, Boris Brezillon wrote:
> Encoder drivers will progressively transition to the drm_bridge
> interface in place of the drm_encoder one.
>
> Let's start with the VC4 driver, and use the ->pre_{enable,disable}()
> hooks to
On Sun, 2019-11-24 at 08:32 +0100, Boris Brezillon wrote:
> On Sun, 24 Nov 2019 09:46:41 +0900
> Ezequiel Garcia wrote:
>
> > Hi Boris, Neil,
> >
> > On Wed, 2019-10-23 at 17:44 +0200, Boris Brezillon wrote:
> > > This patch series aims at adding support for runtime bus-format
> > > negotiation
47 matches
Mail list logo