there are any actual out of bounds dynamic
vector accesses
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/
HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/cd252e0d/attachment.html>
On Thu, Jun 30, 2016 at 03:23:59PM +0100, Chris Wilson wrote:
> On Thu, Jun 30, 2016 at 11:09:47AM -0300, Gustavo Padovan wrote:
> > From: Gustavo Padovan
> >
> > Add helper to check if fence is array.
> >
> > Cc: Chris Wilson
> > Cc: Christian König
> > Signed-off-by: Gustavo Padovan
> > --
next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/44bbba6b/attachment.html>
On Wed, Jun 29, 2016 at 04:17:57PM +0800, Meng Yi wrote:
> dropped the old "fsl,panel" property, using the of_graph dt
> binding syntax
>
> Signed-off-by: Meng Yi
> ---
> Changes in V2:
> -drop the unit address of port
> ---
> Documentation/devicetree/bindings/display/fsl,dcu.txt | 9 +++--
>
Signed-off-by: Matthias Beyer
---
drivers/gpu/drm/amd/powerplay/hwmgr/polaris10_hwmgr.c | 9 +++--
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/polaris10_hwmgr.c
b/drivers/gpu/drm/amd/powerplay/hwmgr/polaris10_hwmgr.c
index 64ee78f..1dcd52
Hi,
after reading your email, I created this patch.
**Please note all**: I'm getting into kernel dev right now (again), so I don't
even know how to test-compile this patch, let alone testing it.
You're more than welcome to teach me things.
Matthias Beyer (1):
drivers: gpu: drm: amd: powerpla
From: Gustavo Padovan
Support the virtio GPU on drmtest.
Signed-off-by: Gustavo Padovan
---
lib/drmtest.c | 9 +
lib/drmtest.h | 1 +
2 files changed, 10 insertions(+)
diff --git a/lib/drmtest.c b/lib/drmtest.c
index 9f3ac7f..b374006 100644
--- a/lib/drmtest.c
+++ b/lib/drmtest.c
@@ -
From: Gustavo Padovan
Now other gpus are supported too.
Signed-off-by: Gustavo Padovan
---
lib/drmtest.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/drmtest.c b/lib/drmtest.c
index 884fe7c..9f3ac7f 100644
--- a/lib/drmtest.c
+++ b/lib/drmtest.c
@@ -263,7 +263,7 @@ i
On 13 April 2016 at 20:15, Emil Velikov wrote:
> Hi Xinliang,
>
> On 11 April 2016 at 09:55, Xinliang Liu wrote:
>
>> +static int kirin_drm_connectors_register(struct drm_device *dev)
>> +{
>> + struct drm_connector *connector;
>> + struct drm_connector *failed_connector;
>> + i
Vblank turn on should be called in crtc's enable callback.
And turn off called in crtc's disable callback.
Thanks to Daniel Vetter, this bug is reported by him.
Reported-by: Daniel Vetter
Signed-off-by: Xinliang Liu
---
drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 2 ++
1 file changed, 2
Hi Dave, here's a batch of i915 fixes for 4.7.
We don't have coverage for next week, so please pick up any serious
fixes directly. Daniel will take over fixes once he returns.
BR,
Jani.
The following changes since commit 4c2e07c6a29e0129e975727b9f57eede813eea85:
Linux 4.7-rc5 (2016-06-26 17:
Add adv7533 HDMI DT node for HiKey board.
And this patch depends on the hikey display dts patch[1]
and adv7533 support patch[2].
[1] https://patchwork.kernel.org/patch/9189287/
[2] http://www.spinics.net/lists/linux-arm-msm/msg21305.html
Signed-off-by: Xinliang Liu
---
arch/arm64/boot/dts/hisi
Call strtolower() rather than walking the string explicitly to convert
it to lowercase.
Signed-off-by: Markus Mayer
---
drivers/gpu/drm/nouveau/nvkm/core/firmware.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/nvkm/core/firmware.c
b/drivers/g
Add a function called strtolower() to convert strings to lower case
in-place, overwriting the original string.
This seems to be a recurring requirement in the kernel that is
currently being solved by several duplicated implementations doing the
same thing.
Signed-off-by: Markus Mayer
---
includ
This series introduces a new generic function strtolower(), which
converts strings to lowercase in-place, overwriting the original
string. This kind of functionality is needed in several places in the
kernel. Right now, everybody seems to be implementing their own copy of
this function. So, we repl
On to, 2016-06-30 at 12:30 +0100, Chris Wilson wrote:
> Backlights controlled by i915.ko and only associated with its
> connectors
> and also only associated with the intel_drmfb fbcon, controlled by
> i915.ko. In this situation, we already handle adjusting the backlight
> when the fbcon is blanked
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
> + * OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
> + * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
> + * IN NO EVENT SHALL TUNGSTEN GRAPHICS AND/OR ITS SUPPLIERS BE LIABLE FOR
> + * ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
> CONTRACT,
> + * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
> + * SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
> + *
> + */
> +
> +#ifndef _UAPI_VGEM_DRM_H_
> +#define _UAPI_VGEM_DRM_H_
> +
> +#include "drm.h"
> +
> +#if defined(__cplusplus)
> +extern "C" {
> +#endif
> +
> +/* Please note that modifications to all structs defined here are
> + * subject to backwards-compatibility constraints.
> + */
> +#define DRM_VGEM_FENCE_ATTACH 0x1
> +#define DRM_VGEM_FENCE_SIGNAL 0x2
> +
> +#define DRM_IOCTL_VGEM_FENCE_ATTACHDRM_IOWR( DRM_COMMAND_BASE +
> DRM_VGEM_FENCE_ATTACH, struct drm_vgem_fence_attach)
> +#define DRM_IOCTL_VGEM_FENCE_SIGNALDRM_IOW( DRM_COMMAND_BASE +
> DRM_VGEM_FENCE_SIGNAL, struct drm_vgem_fence_signal)
> +
> +struct drm_vgem_fence_attach {
> + __u32 handle;
> + __u32 flags;
> +#define VGEM_FENCE_WRITE 0x1
> + __u32 out_fence;
> + __u32 pad;
> +};
> +
> +struct drm_vgem_fence_signal {
> + __u32 fence;
> + __u32 flags;
> +};
> +
> +#if defined(__cplusplus)
> +}
> +#endif
> +
> +#endif /* _UAPI_VGEM_DRM_H_ */
> --
> 2.8.1
>
Acked-by: Zach Reizner
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/d505c446/attachment-0001.html>
++
> drivers/i2c/i2c-core.c | 10 +-
> drivers/soc/tegra/pmc.c| 18 +-
> 7 files changed, 373 insertions(+), 52 deletions(-)
> create mode 100644
> Documentation/devicetree/bindings/pinctrl/nvidia,tegra124-dpaux-padctl.txt
Applied, thanks.
Thierry
-- next part --
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/89c23e49/attachment.sig>
rchives/dri-devel/attachments/20160630/75013b45/attachment.html>
On Thu, Jun 30, 2016 at 11:09:47AM -0300, Gustavo Padovan wrote:
> From: Gustavo Padovan
>
> Add helper to check if fence is array.
>
> Cc: Chris Wilson
> Cc: Christian König
> Signed-off-by: Gustavo Padovan
> ---
> include/linux/fence-array.h | 10 ++
> 1 file changed, 10 insertion
On Thu, Jun 30, 2016 at 11:09:48AM -0300, Gustavo Padovan wrote:
> From: Gustavo Padovan
>
> Create sync_file->fence to abstract the type of fence we are using for
> each sync_file. If only one fence is present we use a normal struct fence
> but if there is more fences to be added to the sync_fil
On Thu, Jun 30, 2016 at 11:26:45AM +0530, Anshuman Khandual wrote:
> >> Did you get a chance to test the driver out ? I am still concerned about
> >> how to
> >> handle the struct address_space override problem within the struct page.
> >
> > Hi Anshuman,
> >
> > Slow but I am working on that
On Thu, 30 Jun 2016, Chris Wilson wrote:
> Backlights controlled by i915.ko and only associated with its connectors
> and also only associated with the intel_drmfb fbcon, controlled by
> i915.ko. In this situation, we already handle adjusting the backlight
> when the fbcon is blanked/unblanked and
Sean,
On 06/29/2016 10:01 PM, Sean Paul wrote:
> On Wed, Jun 29, 2016 at 5:14 AM, Yakir Yang wrote:
>> RK3399 and RK3288 shared the same eDP IP controller, only some light
>> difference with VOP configure and GRF configure.
>>
> The whole set looks good to me. All patches should have my R-b now,
Remove whitespace at the end of line.
diff -b shows only two removed lines
Signed-off-by: Jan Vesely
---
xf86drm.c | 1444 ++---
1 file changed, 721 insertions(+), 723 deletions(-)
diff --git a/xf86drm.c b/xf86drm.c
index 804a413..e99f2e2
:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/957502cc/attachment.html>
Backlights controlled by i915.ko and only associated with its connectors
and also only associated with the intel_drmfb fbcon, controlled by
i915.ko. In this situation, we already handle adjusting the backlight
when the fbcon is blanked/unblanked and do not require backlight trying
to do the same.
On Thu, 30 Jun 2016, Masanari Iida wrote:
> This patch fix a spelling typo found in
> Documentation/DocBook/gpu/API-drm-ioctl-flags.html
> It is because the html file was created from comments in source,
> I have to fix the source.
>
> Signed-off-by: Masanari Iida
Picked up to drm-misc, thanks f
on/pgp-signature
Size: 819 bytes
Desc: not available
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/e2a5df54/attachment.sig>
e bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/8e1d8e7a/attachment.html>
From: Gustavo Padovan
Create sync_file->fence to abstract the type of fence we are using for
each sync_file. If only one fence is present we use a normal struct fence
but if there is more fences to be added to the sync_file a fence_array
is created.
This change cleans up sync_file a bit. We don'
From: Gustavo Padovan
Add helper to check if fence is array.
Cc: Chris Wilson
Cc: Christian König
Signed-off-by: Gustavo Padovan
---
include/linux/fence-array.h | 10 ++
1 file changed, 10 insertions(+)
diff --git a/include/linux/fence-array.h b/include/linux/fence-array.h
index 86
From: Gustavo Padovan
Hi all,
This is an attempt to improve fence support on Sync File. The basic idea
is to have only sync_file->fence and store all fences there, either as
normal fences or fence_arrays. That way we can remove some potential
duplication when using fence_array with sync_file
se:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/5427670c/attachment.html>
se:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/78a996a4/attachment.html>
After switching DMA attributes to unsigned long it is easier to just
compare the bits.
Signed-off-by: Krzysztof Kozlowski
[for avr32]
Acked-by: Hans-Christian Noren Egtvedt
[for arc]
Acked-by: Vineet Gupta
[for arm64 and dma-iommu]
Acked-by: Robin Murphy
---
Documentation/DMA-API.txt
Split out subsystem specific changes for easier reviews. This will be
squashed with main commit.
Signed-off-by: Krzysztof Kozlowski
---
drivers/gpu/drm/rockchip/rockchip_drm_gem.c | 17 +++--
drivers/gpu/drm/rockchip/rockchip_drm_gem.h | 2 +-
2 files changed, 8 insertions(+), 11 de
Split out subsystem specific changes for easier reviews. This will be
squashed with main commit.
Signed-off-by: Krzysztof Kozlowski
---
drivers/gpu/drm/nouveau/nvkm/subdev/instmem/gk20a.c | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/nv
Split out subsystem specific changes for easier reviews. This will be
squashed with main commit.
Signed-off-by: Krzysztof Kozlowski
---
drivers/gpu/drm/msm/msm_drv.c | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/drivers/gpu/drm/msm/msm_drv.c b/drivers/gpu/drm/
Split out subsystem specific changes for easier reviews. This will be
squashed with main commit.
Signed-off-by: Krzysztof Kozlowski
---
drivers/gpu/drm/mediatek/mtk_drm_gem.c | 13 ++---
drivers/gpu/drm/mediatek/mtk_drm_gem.h | 2 +-
2 files changed, 7 insertions(+), 8 deletions(-)
dif
Split out subsystem specific changes for easier reviews. This will be
squashed with main commit.
Signed-off-by: Krzysztof Kozlowski
---
drivers/gpu/drm/exynos/exynos_drm_fbdev.c | 2 +-
drivers/gpu/drm/exynos/exynos_drm_g2d.c | 12 +---
drivers/gpu/drm/exynos/exynos_drm_gem.c | 20 +
Hi,
This is fifth approach for replacing struct dma_attrs with unsigned
long.
The main patch (1/44) doing the change is split into many subpatches
for easier review (2-42). They should be squashed together when
applying.
Rebased on v4.7-rc5.
For easier testing the patchset is available here:
| 2 +-
drivers/gpu/drm/sti/sti_vtg.c | 2 +-
6 files changed, 314 insertions(+), 63 deletions(-)
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/259b9d7d/attachment.html>
This patch fix a spelling typo found in
Documentation/DocBook/gpu/API-drm-ioctl-flags.html
It is because the html file was created from comments in source,
I have to fix the source.
Signed-off-by: Masanari Iida
---
drivers/gpu/drm/drm_ioctl.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
This patch fix a spelling typo found in
Documentation/DocBook/gpu/API-drm-ioctl-flags.html
It is because the html file was created from comments in source,
I have to fix the source.
Signed-off-by: Masanari Iida
---
drivers/gpu/drm/drm_ioctl.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Hi Arnd,
On Wed, 29 Jun 2016 16:51:29 +0200 Arnd Bergmann wrote:
>
> The newly added mediatek HDMI driver clashes with an API change
> for struct hdmi_codec_ops, causing an 'allmodconfig' build to fail:
>
> drivers/gpu/drm/mediatek/mtk_hdmi.c:1653:15: error: initialization from
> incompatible p
Hi
> The newly added mediatek HDMI driver clashes with an API change
> for struct hdmi_codec_ops, causing an 'allmodconfig' build to fail:
>
> drivers/gpu/drm/mediatek/mtk_hdmi.c:1653:15: error: initialization from
> incompatible pointer type [-Werror=incompatible-pointer-types]
> drivers/gpu/d
If class_create() fails, there is no need for class_destroy().
Found by Linux Driver Verification project (linuxtesting.org).
Signed-off-by: Alexey Khoroshilov
---
drivers/gpu/drm/drm_dp_aux_dev.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/drm_dp_aux_d
.
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/bf9b5ca6/attachment.html>
.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/4fb3c36e/attachment-0001.html>
51 matches
Mail list logo