> Actually there is no underflow.
Oh, duh. You're right. Sorry for that.
regards,
dan carpenter
https://bugzilla.kernel.org/show_bug.cgi?id=104551
--- Comment #2 from Michel Dänzer ---
The attached log looks to be from running Catalyst/fglrx. Please attach the log
and dmesg from running the radeon driver.
--
You are receiving this mail because:
You are watching the assignee of the bug.
hi architt
On 2015/9/16 17:10, Archit Taneja wrote:
> Hi,
>
> On 09/16/2015 02:04 PM, Xinwei Kong wrote:
>> hi architt
>>
>> On 2015/9/16 2:11, Rob Herring wrote:
>>> On 09/15/2015 04:37 AM, Xinwei Kong wrote:
This adds documentation of device tree bindings for the
Graphics Processing U
ivers/gpu/drm/hisilicon/hisi_drm_fbdev.h | 24 ++
> >> > 8 files changed, 467 insertions(+), 1 deletion(-)
> >> > create mode 100644 drivers/gpu/drm/hisilicon/hisi_drm_fbdev.c
> >> > create mode 100644 drivers/gpu/drm/hisilicon/hisi_drm_fbdev.h
> >>
> >
> >
> > ___
> > dri-devel mailing list
> > dri-devel at lists.freedesktop.org
> > http://lists.freedesktop.org/mailman/listinfo/dri-devel
> >
>
-- next part --
An HTML attachment was scrubbed...
URL:
<http://lists.freedesktop.org/archives/dri-devel/attachments/20150917/92ec451c/attachment-0001.html>
Hi Danilo,
On Thu, Sep 17, 2015 at 01:34:54PM -0300, Danilo Cesar Lemes de Paula wrote:
> > - * GPU driver interface
> > - * - set_gpu_state - this should do the equiv of s/r for the card
> > - * - this should *not* set the discrete power state
>
> Did you check if this creates th
After sending the below patch away I realized that this change allows
us to simplify the code a bit by dropping the client_is_vga() call
from find_active_client().
I force-pushed an amended version of the commit to my vga_switcheroo_docs
branch on GitHub:
https://github.com/l1k/linux/commit/85dc1f
top.org/mailman/listinfo/dri-devel
>
-- next part --
An HTML attachment was scrubbed...
URL:
<http://lists.freedesktop.org/archives/dri-devel/attachments/20150917/6ad867d8/attachment.html>
Apparently some people see this message and try to turn on
preliminary_hw_support. And then for some reason are surprised
when it doesn't work. So let's set expectations a bit lower.
Signed-off-by: Rob Clark
---
drivers/gpu/drm/i915/i915_drv.c | 3 ++-
1 file changed, 2 insertions(+), 1 deleti
gt;
We have converted to atomic for this version of patches. But maybe we need
to test
atomic mode setting with the DRM_IOCTL_MODE_ATOMIC ioctl.
Thanks,
-Xinliang
> Thanks very much!
>
> Cheers,
> Daniel
> ___
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel
>
-- next part --
An HTML attachment was scrubbed...
URL:
<http://lists.freedesktop.org/archives/dri-devel/attachments/20150917/375d1cb8/attachment.html>
Hi Daniel,
On Tue, Aug 25, 2015 at 10:12:50AM +0200, Daniel Vetter wrote:
> Since you're just diggin around in switcheroo code it would be awesome to
> write proper kerneldoc for all the functions exposed to drivers, move the
> above to a proper kerneldoc for the vfunc tables
Alright, a patch set
From: Ville Syrjälä
On LLC platforms there's no need to use GTT mmap for unsynchronized
maps if the object isn't tiled. So switch to using CPU mmap for linar
objects. This avoids having to use the GTT for GL buffer objects
entirely, and thus we can ignore the GTT mappable size limitation.
For t
On 9/15/2015 3:07 PM, Xinwei Kong wrote:
> This patch enables the adv7533 module which is connecting hisilicon SOC
> by dsi module. while using DSI module and adv7533 module to implement the
> encoder/connector interface of DRM\KMS.
>
> Signed-off-by: Xinliang Liu
> Signed-off-by: Xinwei Kong
>
Hi Luis,
On Thu, 17 Sep 2015 16:20:43 +0200
Luis de Bethencourt wrote:
> This platform driver has a OF device ID table but the OF module
> alias information is not created so module autoloading won't work.
>
> Signed-off-by: Luis de Bethencourt
Acked-by: Boris Brezillon
Thanks,
Boris
> --
On Thu, Sep 17, 2015 at 04:24:21PM +0530, Archit Taneja wrote:
>
>
> On 9/17/2015 2:04 PM, Ingo Molnar wrote:
> >
> >
> >* Ingo Molnar wrote:
> >
> >
> >
> >>So this patch was whitespace damaged - I applied it by hand and made the
> >>commit
> >
> >>below. This has solved the crash, thanks Arch
Hi,
On 9/15/2015 3:07 PM, Xinwei Kong wrote:
> This patch creates this driver itself and register all the sub-components
> which is from DTS inode, this driver uses components framework mechanism
> to bind all the sub-components.
>
> This patch also introduces a memory manager for hisilison drm. A
mgag200_driver_load's error path just calls the drm driver's
driver_unload op. It isn't safe to call this because it doesn't handle
things well if driver_load fails somewhere mid way.
Replace the call to mgag200_driver_unload with a more finegrained
error handling path.
Link: http://lkml.kernel.o
Set up error handling in mgag200_fbdev_init and mgag200fb_create such that
they release the things they allocate, rather than relying on someone
calling mga_fbdev_destroy.
Based on a patch by Sudip Mukherjee
Link: http://lkml.kernel.org/r/55F6E68D.8070800 at codeaurora.org
Reported-by: Ingo Moln
On 9/17/2015 2:04 PM, Ingo Molnar wrote:
>
>
> * Ingo Molnar wrote:
>
>
>
>> So this patch was whitespace damaged - I applied it by hand and made the
>> commit
>
>> below. This has solved the crash, thanks Archit!
>
>
>
> Spoke too soon - the attached (allyesconfig-ish) config still crashes, fi
This platform driver has a OF device ID table but the OF module
alias information is not created so module autoloading won't work.
Signed-off-by: Luis de Bethencourt
---
drivers/gpu/drm/rockchip/rockchip_drm_vop.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/rockchip/rockc
This platform driver has a OF device ID table but the OF module
alias information is not created so module autoloading won't work.
Signed-off-by: Luis de Bethencourt
---
drivers/gpu/drm/omapdrm/omap_dmm_tiler.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/omapdrm/omap_dmm_
This platform driver has a OF device ID table but the OF module
alias information is not created so module autoloading won't work.
Signed-off-by: Luis de Bethencourt
---
drivers/gpu/drm/imx/imx-tve.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/imx/imx-tve.c b/drivers/gpu/
This platform driver has a OF device ID table but the OF module
alias information is not created so module autoloading won't work.
Signed-off-by: Luis de Bethencourt
---
drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_dc.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/atmel-hlcdc/a
These patches add the missing MODULE_DEVICE_TABLE() for OF to export
the information so modules have the correct aliases built-in and
autoloading works correctly.
A longer explanation by Javier Canillas can be found here:
https://lkml.org/lkml/2015/7/30/519
Thanks,
Luis
Luis de Bethencourt (5):
This adds an "Overview" DOC section plus two DOC sections for the modes
of use ("Manual switching and manual power control" and "Driver power
control").
Also included is kernel-doc for all public functions, structs and enums.
Signed-off-by: Lukas Wunner
---
drivers/gpu/vga/vga_switcheroo.c | 28
The active attribute in struct vga_switcheroo_client denotes whether
the outputs are currently switched to this client. The attribute is
only meaningful for vga clients. It is never used for audio clients.
The function vga_switcheroo_register_audio_client() misuses this
attribute to store whether
The following functions iterate over the client list, invoke client
callbacks or invoke handler callbacks without locking anything at all:
- Introduced by c8e9cf7bb240 ("vga_switcheroo: Add a helper function to
get the client state"):
vga_switcheroo_get_client_state()
- Introduced by 0d69704a
Signed-off-by: Lukas Wunner
---
drivers/gpu/vga/vga_switcheroo.c | 17 ++---
include/linux/vga_switcheroo.h | 6 +++---
2 files changed, 13 insertions(+), 10 deletions(-)
diff --git a/drivers/gpu/vga/vga_switcheroo.c b/drivers/gpu/vga/vga_switcheroo.c
index bbd0a8e..6e0e705 100644
Signed-off-by: Lukas Wunner
---
drivers/gpu/vga/vga_switcheroo.c | 17 +
include/linux/vga_switcheroo.h | 4
2 files changed, 13 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/vga/vga_switcheroo.c b/drivers/gpu/vga/vga_switcheroo.c
index 7b53246..bbd0a8e 100644
--
Signed-off-by: Lukas Wunner
---
drivers/gpu/vga/vga_switcheroo.c | 6 +++---
include/linux/vga_switcheroo.h | 4 ++--
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/vga/vga_switcheroo.c b/drivers/gpu/vga/vga_switcheroo.c
index 845e47d..7b53246 100644
--- a/drivers/gp
This is not part of drm.tmpl as vga_switcheroo is a subsystem of its own
which interfaces not just with DRM but also with multiplexer drivers,
ALSA and power management.
Requires Markdown support.
Signed-off-by: Lukas Wunner
---
Documentation/DocBook/Makefile| 5 +-
Documentation/D
On Thu, Sep 17, 2015 at 05:19:02PM +0300, ville.syrjala at linux.intel.com
wrote:
> From: Ville Syrjälä
>
> On LLC platforms there's no need to use GTT mmap for unsynchronized
> maps if the object isn't tiled. So switch to using CPU mmap for linar
> objects. This avoids having to use the GTT f
On Thu, Sep 17, 2015 at 10:57 AM, Eric Anholt wrote:
> This eliminates the need for the "connectors" and "gpus" nodes in the
> devicetree, which we were doing nothing connector- or gpu-specific
> with.
btw, looks pretty good.. hopefully I'll have some time to put my
kernel hat on and test this to
On 09/17/2015 02:31 PM, Lukas Wunner wrote:
> Hi Danilo,
>
> On Thu, Sep 17, 2015 at 01:34:54PM -0300, Danilo Cesar Lemes de Paula wrote:
>>> - * GPU driver interface
>>> - * - set_gpu_state - this should do the equiv of s/r for the card
>>> - * - this should *not* set the discrete
On 9/15/2015 9:13 PM, Rob Herring wrote:
> On 09/15/2015 05:32 AM, Archit Taneja wrote:
>> Hi Rob, Mark,
>>
>> We've been trying to figure out the right way to represent a class
>> of display encoder devices in DT.
>
> I've been meaning to reply on this.
>
>> These devices have registers that are
The size calculation can overflow.
Signed-off-by: Dan Carpenter
diff --git a/drivers/gpu/drm/qxl/qxl_ioctl.c b/drivers/gpu/drm/qxl/qxl_ioctl.c
index 552dc06..5da9a60 100644
--- a/drivers/gpu/drm/qxl/qxl_ioctl.c
+++ b/drivers/gpu/drm/qxl/qxl_ioctl.c
@@ -401,6 +401,8 @@ static int qxl_alloc_surf_i
We check that "byte" isn't writing beyond the end of the array but we
also need to prevent array underflow.
Signed-off-by: Dan Carpenter
diff --git a/drivers/gpu/drm/qxl/qxl_ioctl.c b/drivers/gpu/drm/qxl/qxl_ioctl.c
index b2db482..552dc06 100644
--- a/drivers/gpu/drm/qxl/qxl_ioctl.c
+++ b/driver
qxl_bo_kmap_atomic_page() can fail. I think the user controls
->dst_offset so this can be used to corrupt memory.
Signed-off-by: Dan Carpenter
diff --git a/drivers/gpu/drm/qxl/qxl_ioctl.c b/drivers/gpu/drm/qxl/qxl_ioctl.c
index eda6f30..b2db482 100644
--- a/drivers/gpu/drm/qxl/qxl_ioctl.c
+++ b
This size calculation can overflow on 32 bit systems leading to memory
corruption.
Reported-by: Ilja Van Sprundel
Signed-off-by: Dan Carpenter
diff --git a/drivers/gpu/drm/qxl/qxl_ioctl.c b/drivers/gpu/drm/qxl/qxl_ioctl.c
index bda5c5f..eda6f30 100644
--- a/drivers/gpu/drm/qxl/qxl_ioctl.c
+++ b
Incase of error we printed the error message and returned ret. But ret
was never initialized and so we have been returning garbage value on
error.
Signed-off-by: Sudip Mukherjee
---
drivers/gpu/drm/vmwgfx/vmwgfx_kms.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/
On 08/23/2015 10:18 AM, Lukas Wunner wrote:
> This adds an "Overview" DOC section plus two DOC sections for the modes
> of use ("Manual switching and manual power control" and "Driver power
> control").
>
> Also included is kernel-doc for all public functions, structs and enums.
Regarding the mar
This eliminates the need for the "connectors" and "gpus" nodes in the
devicetree, which we were doing nothing connector- or gpu-specific
with.
Signed-off-by: Eric Anholt
---
drivers/gpu/drm/msm/msm_drv.c | 65 +--
include/drm/drmP.h| 2 +-
2 f
This is a really nice way to handle the component setup. The
subsystem driver knows that it's got a bunch of component drivers, and
for any devices that matched its component drivers, it wants all of
those to bind to it as master.
Signed-off-by: Eric Anholt
---
v2: Extend the kerneldoc.
drive
This matches how exynos handles the registration of its component
drivers.
Signed-off-by: Eric Anholt
---
drivers/gpu/drm/msm/adreno/adreno_device.c | 12 +---
drivers/gpu/drm/msm/dsi/dsi.c | 16 +---
drivers/gpu/drm/msm/dsi/dsi.h | 2 --
drivers/gp
This is mostly just a move of the code from exynos, with a slight
reformat. I wanted to do a similar thing for vc4, and msm looks like
a good candidate as well.
Signed-off-by: Eric Anholt
---
v2: Move to the KMS helper config flag, and add our kerneldoc to
drm.tmpl (under the "Driver Initia
* Ingo Molnar wrote:
> So this patch was whitespace damaged - I applied it by hand and made the
> commit
> below. This has solved the crash, thanks Archit!
Spoke too soon - the attached (allyesconfig-ish) config still crashes, first
there
are a handful of kobject debug warnings, then:
[ 1
>
> We check that "byte" isn't writing beyond the end of the array but we
> also need to prevent array underflow.
>
> Signed-off-by: Dan Carpenter
>
> diff --git a/drivers/gpu/drm/qxl/qxl_ioctl.c
> b/drivers/gpu/drm/qxl/qxl_ioctl.c
> index b2db482..552dc06 100644
> --- a/drivers/gpu/drm/qxl/qxl
Hi all,
Today's linux-next merge of the drm-intel tree got a conflict in:
drivers/gpu/drm/i915/i915_irq.c
between commit:
4e3d1e26c2b2 ("drm/i915: Pass hpd_status_i915[] to intel_get_hpd_pins() in
pre-g4x")
from Linus' tree and commit:
58f2cf241fb9 ("drm/i915: Don't call intel_get_hpd_
On Wed, 16 Sep 2015, Ville Syrjälä wrote:
> On Wed, Sep 16, 2015 at 01:09:54PM -0700, Daniel Vetter wrote:
>> On Tue, Sep 15, 2015 at 10:03:09AM -0700, Rafael Antognolli wrote:
>> > On Tue, Sep 15, 2015 at 07:46:55PM +0300, Ville Syrjälä wrote:
>> > > On Tue, Sep 15, 2015 at 07:41:06PM +0300,
On Wed, Sep 16, 2015 at 5:48 AM, Xinliang Liu
wrote:
>
>
> On 16 September 2015 at 02:25, Rob Herring wrote:
> Hi Rob, thanks a lot for reply:-)
>
>> On 09/15/2015 04:37 AM, Xinwei Kong wrote:
>> > If you config DRM_HISI_FBDEV optional, this patch will only support
>> > fbdev
>> > mode while als
On Thu, Sep 17, 2015 at 12:01 AM, Jani Nikula
wrote:
> On Wed, 16 Sep 2015, Ville Syrjälä wrote:
>> On Wed, Sep 16, 2015 at 01:09:54PM -0700, Daniel Vetter wrote:
>>> On Tue, Sep 15, 2015 at 10:03:09AM -0700, Rafael Antognolli wrote:
>>> > On Tue, Sep 15, 2015 at 07:46:55PM +0300, Ville Syrjäl
From: Dave Airlie
If the server isn't new enough to give us state, report the first
monitor as always connected, otherwise believe the server side.
Signed-off-by: Dave Airlie
---
drivers/gpu/drm/qxl/qxl_display.c | 12 +++-
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/
https://bugzilla.kernel.org/show_bug.cgi?id=102401
--- Comment #11 from Maxqia ---
Any Updates?
--
You are receiving this mail because:
You are watching the assignee of the bug.
Hi Doug,
On 03.09.2015 02:19, Doug Anderson wrote:
> Russell,
>
> On Wed, Sep 2, 2015 at 4:04 PM, Russell King - ARM Linux
> wrote:
Also, is it appropriate to hook non-DDC devices to a DDC bus? I suspect
that's asking for trouble.
>>>
>>> I doubt it's appropriate. Why do you ask?
>>
53 matches
Mail list logo