1010 ./waf configure
1011 ./waf build
[ 74/206] Compiling ntpd/ntp_intercept.c
../../ntpd/ntp_control.c: In function âctl_putpeerâ:
../../ntpd/ntp_control.c:2319:8: error: âstruct peerâ has no member named
âprocptrâ
if (p->procptr != NULL) {
^
../../ntpd/ntp_control.c:
Yo Eric!
On Mon, 27 Jun 2016 00:21:45 -0400
"Eric S. Raymond" wrote:
> The new refclock directive is implemented and documented.
Cool.
> There will be a *limited* open period for bikeshedding about the
> driver names.
Since you opened the door...
> |shm| T | Shared Memory Drive
$ ./waf --list
--- building host ---
The cache directory is empty: reconfigure the project
$
--
These are my opinions. I hate spam.
___
devel mailing list
devel@ntpsec.org
http://lists.ntpsec.org/mailman/listinfo/devel
Hal Murray :
> after a simple ./waf configure
>
> [murray@fed raw]$ ./waf build
> --- building host ---
> Waf: Entering directory `/home/murray/ntpsec/raw/build/host'
> [1/5] Processing ntpd/ntp_parser.y
> [2/5] Compiling build/host/ntpd/ntp_parser.tab.c
> /home/murray/ntpsec/raw/ntpd/ntp_parser.
Hal Murray :
>
> 1007 ./waf configure --refclock=20,22 --enable-debug-gdb
> 1008 ./waf build
> 1009 gdb ./build/main/ntpq/ntpq
>
> (gdb) run -p
> Starting program: /home/murray/ntpsec/raw/build/main/ntpq/ntpq -p
> Missing separate debuginfos, use: dnf debuginfo-install
> glibc-2.21-13.fc22
1007 ./waf configure --refclock=20,22 --enable-debug-gdb
1008 ./waf build
1009 gdb ./build/main/ntpq/ntpq
(gdb) run -p
Starting program: /home/murray/ntpsec/raw/build/main/ntpq/ntpq -p
Missing separate debuginfos, use: dnf debuginfo-install
glibc-2.21-13.fc22.x86_64
[Thread debugging using
after a simple ./waf configure
[murray@fed raw]$ ./waf build
--- building host ---
Waf: Entering directory `/home/murray/ntpsec/raw/build/host'
[1/5] Processing ntpd/ntp_parser.y
[2/5] Compiling build/host/ntpd/ntp_parser.tab.c
/home/murray/ntpsec/raw/ntpd/ntp_parser.y: In function âyyparseâ:
An alternative option would be to implement rereading ntp.conf.
For each line in ntp.conf, there are 3 possibilities. It's new or the value
has changed, nothing has changed, or the item was dropped. The latter is the
tricky case.
The idea is to save a parsed copy of the old ntp.conf. As the
Heads up, Mark!
Achim Gratz :
> > It would be better for code verifiability and security if the
> > only source of configuration information for the daemon were the
> > ntp.conf file. (We can't quite get there due to the requirement
> > to store drift state, but closer would be better.)
>
> If y
Mark Atwood :
> ** CID 149750: Uninitialized variables (UNINIT)
> /ntpd/ntp_intercept.c: 855 in intercept_replay()
Known. Not fixed because that code isn't in the new TESTFRAME branch;
it''s going to go away.
> ** CID 149749:(UNINIT)
> /ntpq/ntpq-subs.c: 1751 in doprintpeers()
> /ntpq/ntpq
The new refclock directive is implemented and documented. This has
had some large consequences.
* Driver numbers and 127.127.t.u addresses are no longer used in the
documentation anywhere but in clockstat file examples - and I may
change that shortly. Some historical mentions of 127.127.t.u
Hal Murray :
>
> e...@thyrsus.com said:
> > Ugh. Our options have just narrowed. I've just seen
> > libgcc_s.so.1 must be installed for pthread_cancel to work Aborted (core
> > dumped)
>
> > with memlock off in the build.
>
> Can you reproduce it?
>
> My guess is that you didn't really get me
e...@thyrsus.com said:
> Ugh. Our options have just narrowed. I've just seen
> libgcc_s.so.1 must be installed for pthread_cancel to work Aborted (core
> dumped)
> with memlock off in the build.
Can you reproduce it?
My guess is that you didn't really get memlock turned off. How about puttin
Possible crazy idea...
How about we never kill the DNS helper thread. Just let it sit there in case
it gets more work to do. The only cost is a bit of memory.
Or maybe only do that if we are locking stuff into memory.
--
These are my opinions. I hate spam.
e...@thyrsus.com said:
>> We could try simplifying things to only supporting lock-everything-I-need
>> rather than specifying how much. There might be a slippery slope if
>> something like a thread stack needs a sane size specified.
> I'm not intimate with mlockall, but it looks like it works
Hal Murray :
> If it uses threads, we still have the problem of not being able to load the
> thread cleanup code.
Maybe. We don't know if the libc implementation is vulnerable to that bug or
not. I should do an experimental implementation on a branch and find out.
--
http://www
- Original message -
From: scan-ad...@coverity.com
Subject: New Defects reported by Coverity Scan for ntpsec
Date: Sat, 25 Jun 2016 20:01:41 -0700
Hi,
Please find the latest report on new defect(s) introduced to ntpsec
found with Coverity Scan.
3 new defect(s) introduced to ntpsec found
e...@thyrsus.com said:
>> Is getaddrinfo_a() in RTEMS? QNX? BSD?
> It's not an OS thing, it's a toolchain thing. getaddrinfo_a() is
> implemented using standard C and POSIX threads, it doesn't need OS-specific
> support.
Or it's in an optional extra library.
> Linux has it because Linux uses
Mark Atwood :
> Is getaddrinfo_a() in RTEMS? QNX? BSD?
It's not an OS thing, it's a toolchain thing. getaddrinfo_a() is implemented
using standard C and POSIX threads, it doesn't need OS-specific support.
Linux has it because Linux uses libc whether you're compiling with gcc
or clang. Any of
Is getaddrinfo_a() in RTEMS? QNX? BSD?
On Sun, Jun 26, 2016 at 7:06 AM Eric S. Raymond wrote:
> Eric S. Raymond :
> > > What would you do if we discovered a case where we wanted it?
> >
> > Cry a lot. Then add logic to force synchronous DNS when memlocking is
> > selected, and document this
Achim Gratz :
> Eric S. Raymond writes:
> > The reason I disagree is I think you're overfocusing on the fact that
> > both refclocks are the same physical device and underfocusing on the
> > fact that they're two different data channels, possibly with different
> > fudges and modes.
>
> No, it's e
Eric S. Raymond writes:
> The reason I disagree is I think you're overfocusing on the fact that
> both refclocks are the same physical device and underfocusing on the
> fact that they're two different data channels, possibly with different
> fudges and modes.
No, it's exactly my contention that th
Hal Murray writes:
> strom...@nexgo.de said:
>> I think that's still perpetuating a mistake. This whole business of having
>> to specify two servers (or refclocks) for the same thing should go away.
>
> There is a fundamental issue. With a PPS, there really are two sources of
> time. Internally
Eric S. Raymond :
> > What would you do if we discovered a case where we wanted it?
>
> Cry a lot. Then add logic to force synchronous DNS when memlocking is
> selected, and document this as a workaround for a bug we haven't fixed yet.
Ugh. Our options have just narrowed. I've just seen
libgc
Hal Murray :
>
> e...@thyrsus.com said:
> > In this case, we have two possible complexity-reducing fixes. One is to
> > drop the memlock feature entirely. The other is to drop the buggy homebrew
> > asynchronous-DNS lookup from Classic and use libc's.
>
> Dropping memlock is an interesting idea
Hal Murray :
>
> strom...@nexgo.de said:
> > I think that's still perpetuating a mistake. This whole business of having
> > to specify two servers (or refclocks) for the same thing should go away.
>
> There is a fundamental issue. With a PPS, there really are two sources of
> time. Internally
Achim Gratz :
> Eric S. Raymond writes:
> > Here's how I think it should look:
> >
> > --
> > refclock shm unit 0 refid GPS
> > refclock shm unit 1 prefer refid PPS
> > --
Hal Murray :
> > Here's how I think it should look:
>
> > --
> > refclock shm unit 0 refid GPS
> > refclock shm unit 1 prefer refid PPS
> > --
>
> I think you sh
strom...@nexgo.de said:
> I think that's still perpetuating a mistake. This whole business of having
> to specify two servers (or refclocks) for the same thing should go away.
There is a fundamental issue. With a PPS, there really are two sources of
time. Internally, ntpd needs two different
Eric S. Raymond writes:
> Here's how I think it should look:
>
> --
> refclock shm unit 0 refid GPS
> refclock shm unit 1 prefer refid PPS
> --
I think that's sti
30 matches
Mail list logo