1. Include install directory
[X] ${prefix}/include/ts
[ ] ${prefix}/include/ats
[ ] ${prefix}/include/trafficserver
2. InkAPI.h rename
[X] ts_api.h
[ ] sdkapi.h
[ ] ats.h
3. RemapAPI.h renam
[X] remap_api.h
[ ] remap.h
4. Versioning of include dir
[ ] No versioning, just plain ${prefix}/i
InkApi.h rename:
[ ] api.h
[X] ts_api.h
[ ] sdkapi.h
Include directory name
-
[X] ${prefix}/ts
[ ] ${prefix}/trafficserver
From: Leif Hedstrom
To: trafficserver-dev@incubator.apache.org
Sent: Wed, Febr
+1 to #1, #2 and #4.
For #3, why not call it ts_api.h. api.h is too generic and ts_api would be
consistent with remap_api.
Thanks.
From: Leif Hedstrom
To: trafficserver-dev@incubator.apache.org
Sent: Tue, February 2, 2010 7:37:35 AM
Subject: [vote] API includ
OK, it's me, sorry to bug you again.
I am following replace-header plugin example to implement a plugin that sets a
cookie.
Here is my call back.
case INK_EVENT_HTTP_SEND_RESPONSE_HDR:
replace_header(txnp, contp);
And below is replace_header(). But when I run it, everything seems fine
Hello,
I am trying to parse cookies via INK_HTTP_READ_REQUEST_HDR_HOOK.
Upon callback, I can read field name (Cookie) via INKMimeHdrFieldNameGet but
INKMimeHdrFieldValueStringGet for that field index returns NULL for char* and
zero for size.
Are there other ways to parse cookies as plug-in?
Hello,
I was reading in SDK doc about yts.cookie.remap plugin but I cannot find it
in the source tree. I am trying to use Traffic Server with cookie based
mapping/redirection.
Is there any plan to release that code soon? If not, any good examples or
advice on how to write such plugin?
Thanks in