Re: [PATCH] svn: Attempted to get textual contents of a *non*-file node

2012-03-06 Thread Daniel Shahaf
Thanks for the patch Alexey. Forwarding it to dev@. Alexey Neyman wrote on Tue, Mar 06, 2012 at 16:27:11 -0800: > Hi Daniel, > > On Monday, March 05, 2012 11:33:33 pm Daniel Shahaf wrote: > > Alexey Neyman wrote on Mon, Mar 05, 2012 at 16:14:24 -0800: > > > Hi all, > > > > > > I ran into the fo

Logging in the python tests

2012-03-06 Thread Hyrum K Wright
After a bit of a bump today, I've added the use of the python logging module to our test suite as a way of logging output from the test framework and the tests themselves. The end goal is to remove all the many print() calls we have in the tests, and run almost everything through the logger, allow

Re: [PATCH] Revision 1297676 broke --list option of command line tests

2012-03-06 Thread Hyrum K Wright
On Tue, Mar 6, 2012 at 3:27 PM, Alexey Neyman wrote: > The code which accesses options.verbose is still there in some places, > including TestRunner.list(): > > 1071809     pburba       # If there is no filter or this test made if through > 1071809     pburba       # the filter then print it! > 10

Re: [PATCH] Revision 1297676 broke --list option of command line tests

2012-03-06 Thread Alexey Neyman
The code which accesses options.verbose is still there in some places, including TestRunner.list(): 1071809 pburba # If there is no filter or this test made if through 1071809 pburba # the filter then print it! 1071809 pburba if options.milestone_filter is None or le

Re: [PATCH] Revision 1297676 broke --list option of command line tests

2012-03-06 Thread Hyrum K Wright
I think the solution here is to rip out places that require options.verbose, rather than attempt to paper over the problem by resurrecting that field. I've attempted to do so in subsequent commits (see r1297724 and r1297725). -Hyrum On Tue, Mar 6, 2012 at 3:11 PM, Alexey Neyman wrote: > Argh, d

Re: [PATCH] Revision 1297676 broke --list option of command line tests

2012-03-06 Thread Alexey Neyman
Argh, damn. Last one: [[[ * subversion/tests/cmdline/svntest/main.py (_create_parser): Partially revert r1297676, other code needs options.verbose. (_parse_options): Call logger.setLevel(logging.DEBUG) if verbose output is requested. ]]] On Tuesday, Mar

Re: svn commit: r1297676 - /subversion/trunk/subversion/tests/cmdline/svntest/main.py

2012-03-06 Thread Hyrum K Wright
On Tue, Mar 6, 2012 at 3:02 PM, Greg Stein wrote: > On Tue, Mar 6, 2012 at 15:58, Hyrum K Wright > wrote: >> On Tue, Mar 6, 2012 at 2:42 PM, Greg Stein wrote: >>... >>> You may as well use the default logger. That way, every module can >>> just: import logging ; logging.info('whatever: %s %s',

Re: svn commit: r1297676 - /subversion/trunk/subversion/tests/cmdline/svntest/main.py

2012-03-06 Thread Greg Stein
On Tue, Mar 6, 2012 at 15:58, Hyrum K Wright wrote: > On Tue, Mar 6, 2012 at 2:42 PM, Greg Stein wrote: >... >> You may as well use the default logger. That way, every module can >> just: import logging ; logging.info('whatever: %s %s', foo, bar) > > I thought about that, but figured using the cu

Re: svn commit: r1297676 - /subversion/trunk/subversion/tests/cmdline/svntest/main.py

2012-03-06 Thread Hyrum K Wright
On Tue, Mar 6, 2012 at 2:42 PM, Greg Stein wrote: > On Tue, Mar 6, 2012 at 15:18,   wrote: >>... >> +++ subversion/trunk/subversion/tests/cmdline/svntest/main.py Tue Mar  6 >> 20:18:16 2012 >>... >> @@ -78,6 +79,10 @@ SVN_VER_MINOR = 8 >> >>  default_num_threads = 5 >> >> +# Set up logging >> +lo

Re: [PATCH] Revision 1297676 broke --list option of command line tests

2012-03-06 Thread Alexey Neyman
Please use the attached patch instead (the first one fixed "--list", but not "--list --verbose"). Regards, Alexey. On Tuesday, March 06, 2012 12:45:21 pm Alexey Neyman wrote: > Hi all, > > Revision 1297676 by hwright broke the command line tests' --list option > (and probably, some other interf

[PATCH] Revision 1297676 broke --list option of command line tests

2012-03-06 Thread Alexey Neyman
Hi all, Revision 1297676 by hwright broke the command line tests' --list option (and probably, some other interfaces): the options dict no longer contains verbose option as --verbose handler was changed from 'store_true' to 'callback'. The attached patch fixes it by reintroducing options.verbos

Re: svn commit: r1297676 - /subversion/trunk/subversion/tests/cmdline/svntest/main.py

2012-03-06 Thread Greg Stein
On Tue, Mar 6, 2012 at 15:18, wrote: >... > +++ subversion/trunk/subversion/tests/cmdline/svntest/main.py Tue Mar  6 > 20:18:16 2012 >... > @@ -78,6 +79,10 @@ SVN_VER_MINOR = 8 > >  default_num_threads = 5 > > +# Set up logging > +logger = logging.getLogger(__name__) You may as well use the def

Re: svn commit: r1296868 - /subversion/trunk/subversion/libsvn_fs_fs/rep-cache-db.sql

2012-03-06 Thread Trent Nelson
On 3/6/12 5:35 PM, "Philip Martin" wrote: >Philip Martin writes: > >> It may be TEXT but it is also PRIMARY KEY and according to the SQLite >> docs: >> >> http://sqlite.org/lang_createtable.html >> >>INTEGER PRIMARY KEY columns aside, both UNIQUE and PRIMARY KEY >>constraints are imple

Re: svn commit: r1297604 [1/12] - in /subversion/branches/reintegrate-keep-alive: ./ build/ build/ac-macros/ build/generator/ build/generator/templates/ build/win32/ notes/ notes/api-errata/1.7/ subve

2012-03-06 Thread Greg Stein
On Tue, Mar 6, 2012 at 12:50, wrote: > Author: julianfoad > Date: Tue Mar  6 17:50:23 2012 > New Revision: 1297604 > > URL: http://svn.apache.org/viewvc?rev=1297604&view=rev > Log: > On the 'reintegrate-keep-alive' branch: Catch up to trunk@1297591. > > Added: >    subversion/branches/reintegrate

Re: svn commit: r1241050 - /subversion/trunk/subversion/mod_dav_svn/mod_dav_svn.c

2012-03-06 Thread Stefan Sperling
On Tue, Mar 06, 2012 at 12:39:27PM +, Julian Foad wrote: > Daniel Shahaf wrote: > > > Daniel Shahaf wrote on Mon, Feb 06, 2012 at 18:20:28 +0200: > >> Stefan Sperling wrote on Mon, Feb 06, 2012 at 17:12:32 +0100: > >> > On Mon, Feb 06, 2012 at 05:59:04PM +0200, Daniel Shahaf wrote: > >> > >

Re: svn commit: r1296868 - /subversion/trunk/subversion/libsvn_fs_fs/rep-cache-db.sql

2012-03-06 Thread Philip Martin
Philip Martin writes: > If I create a repository using 1.7 and look at the rep-cache.db I see: > > $ sqlite3 rep-cache.db "select * from sqlite_master" | grep index > index|sqlite_autoindex_rep_cache_1|rep_cache|4| I'm using SQLite 3.7.8 on Linux. -- uberSVN: Apache Subversion Made Easy http:/

Re: svn commit: r1296868 - /subversion/trunk/subversion/libsvn_fs_fs/rep-cache-db.sql

2012-03-06 Thread Philip Martin
Philip Martin writes: > It may be TEXT but it is also PRIMARY KEY and according to the SQLite > docs: > > http://sqlite.org/lang_createtable.html > >INTEGER PRIMARY KEY columns aside, both UNIQUE and PRIMARY KEY >constraints are implemented by creating an index in the database (in >th

Re: svn commit: r1296868 - /subversion/trunk/subversion/libsvn_fs_fs/rep-cache-db.sql

2012-03-06 Thread Philip Martin
danie...@apache.org writes: > Author: danielsh > Date: Sun Mar 4 20:14:01 2012 > New Revision: 1296868 > > URL: http://svn.apache.org/viewvc?rev=1296868&view=rev > Log: > * subversion/libsvn_fs_fs/rep-cache-db.sql > (I_HASH): New index. > > Suggested by: Trent Nelson > > Modified: > subver

Re: svn commit: r1296604 - in /subversion/trunk/subversion/libsvn_fs_fs: caching.c fs.h fs_fs.c

2012-03-06 Thread Blair Zajac
On 03/05/2012 01:57 PM, Stefan Fuhrmann wrote: On 05.03.2012 15:20, Daniel Shahaf wrote: Philip Martin wrote on Mon, Mar 05, 2012 at 13:58:18 +: Daniel Shahaf writes: Philip Martin wrote on Mon, Mar 05, 2012 at 12:23:40 +: Daniel Shahaf writes: You're right, I misread the code: I m

Re: svn commit: r1241050 - /subversion/trunk/subversion/mod_dav_svn/mod_dav_svn.c

2012-03-06 Thread Julian Foad
Daniel Shahaf wrote: > Daniel Shahaf wrote on Mon, Feb 06, 2012 at 18:20:28 +0200: >> Stefan Sperling wrote on Mon, Feb 06, 2012 at 17:12:32 +0100: >> > On Mon, Feb 06, 2012 at 05:59:04PM +0200, Daniel Shahaf wrote: >> > > This still strips whitespace around ='s in the value: >> > >    SVNHoo

Re: svn commit: r1296596 - /subversion/trunk/subversion/libsvn_delta/xdelta.c

2012-03-06 Thread Julian Foad
Hi Stefan. Please edit the log message for this rev. (I assume you'll revisit this soon, as my original comment still stands.  Sorry if it was confusing.  What I meant, basically, is that the function doesn't return what the doc string says it will return, AFAICT.  Quite likely it's the doc st

Re: svn commit: r1296628 - Make svn ls faster and more streamy on svn://

2012-03-06 Thread Julian Foad
stef...@apache.org wrote: > Log: > Make svn ls faster and more streamy on svn:// > > * subversion/svnserve/serve.c >   (get_dir): don't collect entries but send them immediately > +  /* Fetch the directory entries if requested and send them immediately. */ >    if (want_contents) >      { > + 

Re: svn commit: r1296640 - use sizeof() instead of magic numbers

2012-03-06 Thread Julian Foad
stef...@apache.org wrote: > URL: http://svn.apache.org/viewvc?rev=1296640&view=rev > Log: > * subversion/libsvn_repos/rev_hunt.c >   (svn_repos_get_committed_info): use sizeof() instead of magic numbers > -  committed_date_s = apr_hash_get(revprops, > -                                  SVN_PROP_

Re: svn commit: r1297239 - /subversion/trunk/build/run_tests.py

2012-03-06 Thread Julian Foad
Hyrum K Wright wrote: > Greg Stein wrote: >> On Mon, Mar 5, 2012 at 16:49,   wrote: >>> Author: danielsh >>> Date: Mon Mar  5 21:49:15 2012 >>> New Revision: 1297239 >>> >>> URL: http://svn.apache.org/viewvc?rev=1297239&view=rev >>> Log: >>> Revert r1297223 and r1297231. >>> >>> Modified: >>>    s

Re: svn commit: r1296604 - in /subversion/trunk/subversion/libsvn_fs_fs: caching.c fs.h fs_fs.c

2012-03-06 Thread Philip Martin
Daniel Shahaf writes: > I believe you cannot assume svn_fs_t's will be short lived, and > _certainly_ cannot assume that the access pattern to an svn_fs_t > will be in any way related to random clients having random RA > sessions; for all the FS API knows, svnserve is a daemon that calls > svn_fs