Any progress? Or direction, maybe I can help.
On Mon, Jul 27, 2015 at 1:54 PM Jesse Gross wrote:
> On Fri, Jul 24, 2015 at 2:28 AM, Zang MingJie
> wrote:
> > Newer kernel will do gro on vxlan packet, after gro the tcp checksum
> > encapsulated in the packet is wrong but the origin checksum is a
On 08/07/2015 07:08 PM, Justin Pettit wrote:
> When reviewing the OpenFlow flows generated by ovn-controller, it's nice
> to have this information.
>
> Signed-off-by: Justin Pettit
Acked-by: Russell Bryant
--
Russell Bryant
___
dev mailing list
dev@
Acked-by: Neil Horman
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Currently coverage_counter_register() is called only from
constructor functions at program initialization time by
main thread. Coverage counter values are static and
thread local.
This means, that all COVERAGE_INC() calls from pmd threads
leads to increment of thread local variables of that thread
Hello, Alex.
I think, that this problem doesn't depend on dpdk. It is generic problem with
ukeys.
I found it while testing ODP-OVS from (Linaro Networking Group) without dpdk.
IMHO, there must be opportunity to install ukeys for same flow by different pmd
threads
anyway, because they are reading
On Mon, Aug 10, 2015 at 2:05 AM, Zang MingJie wrote:
> Any progress? Or direction, maybe I can help.
>
Sorry for late reply. Attached is patch I was working on. Can you try it?
Thanks,
Pravin.
> On Mon, Jul 27, 2015 at 1:54 PM Jesse Gross wrote:
>>
>> On Fri, Jul 24, 2015 at 2:28 AM, Zang MingJ
On Mon, Aug 03, 2015 at 02:03:28PM -0700, David Miller wrote:
> From: Glenn Griffin
> Date: Mon, 3 Aug 2015 09:56:54 -0700
>
> > openvswitch modifies the L4 checksum of a packet when modifying
> > the ip address. When an IP packet is fragmented only the first
> > fragment contains an L4 header an
Hey IIya,
Thx for the reply, Daniele helped me reproduced the issue offline and we
confirmed that this is not DPDK issue.
However, this is also not a ufid issue either...
Let me explain,
First to clear up, with "packets from the same flow (or stream)", I mean
packets with same src/dst MAC, IP,
From: Glenn Griffin
Date: Mon, 10 Aug 2015 10:43:16 -0700
> On Mon, Aug 03, 2015 at 02:03:28PM -0700, David Miller wrote:
>> From: Glenn Griffin
>> Date: Mon, 3 Aug 2015 09:56:54 -0700
>>
>> > openvswitch modifies the L4 checksum of a packet when modifying
>> > the ip address. When an IP packet
I'm surprised as well that the tests were passing.
Sorry about this and thanks for finding out
Acked-by: Daniele Di Proietto
On 08/08/2015 00:28, "Joe Stringer" wrote:
>This was renamed. Surprisingly, the tests still pass without this,
>however the extra checks that this command performs were
> On Aug 10, 2015, at 4:30 AM, Russell Bryant wrote:
>
> On 08/07/2015 07:08 PM, Justin Pettit wrote:
>> When reviewing the OpenFlow flows generated by ovn-controller, it's nice
>> to have this information.
>>
>> Signed-off-by: Justin Pettit
>
> Acked-by: Russell Bryant
Thanks. I pushed th
I guess you need this to use quotes("") inside 'command'.
One effect of this change is that if 'command' contains a pipe
(or &&, or ||) just the first command will be executed inside
the namespace. I'm not sure if it's a big problem. What do you
think?
On 08/08/2015 00:28, "Joe Stringer" wrote
My idea was to use ADD_BR inside the OVS_TRAFFIC_VSWITCHD_START()
parameters, but I'm fine with this approach too.
Acked-by: Daniele Di Proietto
On 08/08/2015 00:28, "Joe Stringer" wrote:
>This patch splits ADD_BR into two commands, so they can be used from
>different contexts:
>
>ADD_BR(...)
On 08/09/2015 10:50 PM, Alex Wang wrote:
> This commit lays down the foundation for a new controller in OVN, the
> ovn-controller-vtep, for controlling the vtep enabled gateways.
>
> Signed-off-by: Alex Wang
Acked-by: Russell Bryant
--
Russell Bryant
__
On 08/09/2015 10:50 PM, Alex Wang wrote:
> This commit adds the gateway module to ovn-controller-vtep. The
> module will register the physical switches to ovnsb as chassis and
> constantly update the "vtep_logical_switches" column in Chassis table.
>
> Limitation (Recorded in TODO file):
>
> - D
Hmm. The problem I was having is that if we wrap 'command' in quotes
here, and 'command' itself includes quotes (eg, command='echo "foo" |
bar'), then rather than quoting "foo", the command ends up quoting
everything up to 'foo', then unquoting 'foo', then quoting everything
after 'foo'. The ICMP r
This is an attempt at getting better consistency. ADD_VLAN,
ADD_NATIVE_TUNNEL, etc. all work as separate commands in the test.
Having ADD_BR act differently is more difficult for the reader to
parse.
Thanks for the review.
On 10 August 2015 at 11:45, Daniele Di Proietto wrote:
> My idea was to u
Your call either way. I don't feel strongly.
Ethan
On Thu, Aug 6, 2015 at 1:07 PM, Justin Pettit wrote:
> This is cleaner than I was expecting. Do you think we want to backport it to
> 2.3?
>
> --Justin
>
>
>> On Aug 6, 2015, at 12:30 PM, Jarno Rajahalme wrote:
>>
>> Ethan,
>>
>> This ended
From: Ethan Jackson
Since revalidator_sweep() doesn't hold the ukey mutex for each full
loop iteration, it's theoretically possible that two threads may
call ukey_delete() on the same ukey. If this happens, they both will
attempt to remove the ukey from he cmap, causing the loser of the race
to
From: Ethan Jackson
There are certain use cases (such as bond rebalancing) where a
datapath flow's actions may change, while it's wildcard pattern
remains the same. Before this patch, revalidators would note the
change, delete the flow, and wait for the handlers to install an
updated version. T
When dpdk configuration changes, all pmd threads are recreated
and rx queues of each port are reloaded. After this process,
rx queue could be mapped to a different pmd thread other than
the one before reconfiguration. However, this is totally
transparent to ofproto layer modules. So, if the ofpr
Signed-off-by: Alex Wang
---
ofproto/ofproto-dpif-upcall.c |4
1 file changed, 4 insertions(+)
diff --git a/ofproto/ofproto-dpif-upcall.c b/ofproto/ofproto-dpif-upcall.c
index 6385abc..4fed956 100644
--- a/ofproto/ofproto-dpif-upcall.c
+++ b/ofproto/ofproto-dpif-upcall.c
@@ -1060,6 +106
Just post a proposed fix here,
http://openvswitch.org/pipermail/dev/2015-August/058760.html
Any comments are welcomed,
On Mon, Aug 10, 2015 at 11:12 AM, Alex Wang wrote:
> Hey IIya,
>
> Thx for the reply, Daniele helped me reproduced the issue offline and we
> confirmed that this is not DPDK
Thanks so much for the review and suggestions,
Applied the patch 1-3 to master~
Thanks,
Alex Wang,
On Mon, Aug 10, 2015 at 12:30 PM, Russell Bryant wrote:
> On 08/09/2015 10:50 PM, Alex Wang wrote:
> > This commit adds the gateway module to ovn-controller-vtep. The
> > module will register th
I frequently view the contents of the Logical_Flow table while working
on OVN. Add a patch that can output the contents of this table in a
sorted way that makes it easier to read through. It's sorted by
logical datapath, pipeline, table id, priority, and match.
Signed-off-by: Russell Bryant
---
Thanks. I got it.
E.g:
sample(sample=100.0%,actions(userspace(pid=0,ipfix(output_port=1),tunnel_ou
t_port=1)))
==> userspace(pid=0,ipfix(output_port=1),tunnel_out_port=1)
Is it right?
Bests,
Wenyu
On 8/6/15, 2:24 AM, "Ben Pfaff" wrote:
>On Wed, Aug 05, 2015 at 10:01:26AM -0700,
> On Aug 10, 2015, at 8:53 PM, Wenyu Zhang wrote:
>
> Thanks. I got it.
> E.g:
> sample(sample=100.0%,actions(userspace(pid=0,ipfix(output_port=1),tunnel_ou
> t_port=1)))
>==> userspace(pid=0,ipfix(output_port=1),tunnel_out_port=1)
>
> Is it right?
Yep, that's it.
--Justin
27 matches
Mail list logo