Re: [ovs-dev] [tunnel 00/11] Flow based tunneling.

2013-01-28 Thread Ed Maste
On 27 January 2013 19:58, Ethan Jackson wrote: > This version of the series implements enough of the flow based > tunneling that we can begin testing. There are still some things > which need to be done (described in ofproto/tunnel.c) which we will > need to complete before making a release. As

Re: [ovs-dev] [tunnel 00/11] Flow based tunneling.

2013-01-28 Thread Ben Pfaff
On Mon, Jan 28, 2013 at 10:43:23AM -0500, Ed Maste wrote: > On 27 January 2013 19:58, Ethan Jackson wrote: > > This version of the series implements enough of the flow based > > tunneling that we can begin testing. There are still some things > > which need to be done (described in ofproto/tunnel

Re: [ovs-dev] [tunnel 00/11] Flow based tunneling.

2013-01-28 Thread Ed Maste
On 28 January 2013 12:44, Ben Pfaff wrote: > On Mon, Jan 28, 2013 at 10:43:23AM -0500, Ed Maste wrote: >> On 27 January 2013 19:58, Ethan Jackson wrote: >> > This version of the series implements enough of the flow based >> > tunneling that we can begin testing. There are still some things >> >

Re: [ovs-dev] [tunnel 01/11] route-table: Add route_table_wait() to the stub implementation.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:02PM -0800, Ethan Jackson wrote: > Signed-off-by: Ethan Jackson Looks good, thanks. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [tunnel 02/11] ofproto-dpif: Use ofproto_receive() in update_stats().

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:03PM -0800, Ethan Jackson wrote: > This removes a bit of duplicate code, and will be necessary to > support future patches. > > Signed-off-by: Ethan Jackson This changes seems reasonable. Thanks, Ben. ___ dev mailing lis

Re: [ovs-dev] [tunnel 03/11] ofproto-dpif: Require an in_port when tracing datapath flows.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:04PM -0800, Ethan Jackson wrote: > All datapath flows should have an in_port, so it doesn't make a lot > of sense to allow omitting it when tracing. If a user wants to > trace a flow which has no in_port, they can use the OpenFlow syntax > which doesn't go through ofp

[ovs-dev] [PATCH] ofproto-dpif: Clear revalidation flags only once, not per-ofproto.

2013-01-28 Thread Ben Pfaff
Found by inspection. CC: Ethan Jackson Signed-off-by: Ben Pfaff --- I noticed this while reviewing one of your "tunnel" patches. ofproto/ofproto-dpif.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofproto-dpif.c index 1d08baf..

Re: [ovs-dev] [tunnel 04/11] ofproto-dpif: Install drops for flows from invalid in_ports.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:05PM -0800, Ethan Jackson wrote: > Before this patch, if a packet came in on a port which userspace > doesn't know about, it would be silently dropped without installing > a drop flow. Historically, this has been fine because this > situation could only occur during t

[ovs-dev] [PATCH] ovs-ctl: Update comment.

2013-01-28 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- utilities/ovs-ctl.in |7 --- 1 files changed, 4 insertions(+), 3 deletions(-) diff --git a/utilities/ovs-ctl.in b/utilities/ovs-ctl.in index 78f67a3..8288e13 100755 --- a/utilities/ovs-ctl.in +++ b/utilities/ovs-ctl.in @@ -1,5 +1,5 @@ #! /bin/sh -# Copyright

Re: [ovs-dev] [tunnel 05/11] dpif-netdev: Allow stub interfaces on the dummy datapath.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:06PM -0800, Ethan Jackson wrote: > Future patches will need to add netdevs to the dummy datapath which > can't actually send or receive packets. > > Signed-off-by: Ethan Jackson Looks good, thanks. ___ dev mailing list dev

Re: [ovs-dev] [tunnel 06/11] packets: Create global helper is_ip_any().

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:07PM -0800, Ethan Jackson wrote: > Used outside of meta-flow in future patches. > > Signed-off-by: Ethan Jackson There are some existing potential users you could throw in: diff --git a/lib/match.c b/lib/match.c index f1bf63c..bedb1a1 100644 --- a/lib/match.c +++ b

Re: [ovs-dev] [PATCH 0/6] Remove unused kernel functionality.

2013-01-28 Thread Jesse Gross
On Fri, Jan 25, 2013 at 8:34 PM, Ben Pfaff wrote: > On Fri, Jan 25, 2013 at 03:54:21PM -0800, Jesse Gross wrote: >> As a result of the ongoing tunnel and patch port work, there are a >> number of kernel components that are no longer supported or used >> by userspace. This removes those usused com

Re: [ovs-dev] [PATCH 1/6] datapath: Remove support for Don't Fragment inheritance.

2013-01-28 Thread Jesse Gross
On Sun, Jan 27, 2013 at 6:31 PM, Kyle Mestery (kmestery) wrote: > On Jan 25, 2013, at 5:54 PM, Jesse Gross wrote: >> Inheritance of the Don't Fragment bit in tunnels will not be >> supported with flow based tunneling and has already been removed >> from userspace. This removes the corresponding

Re: [ovs-dev] [tunnel 08/11] tunnel: Userspace implementation of tunnel manipulation.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:09PM -0800, Ethan Jackson wrote: > From: Jesse Gross > > The kernel tunneling code currently needs to handle a large number > of operations when tunnel packets are encapsulated and > decapsulated. Some examples of this are: finding the correct > tunnel port on recei

Re: [ovs-dev] [tunnel 07/11] netdev: New function netdev_get_dpif_port().

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:08PM -0800, Ethan Jackson wrote: > In future patches, a netdev's datapath port name may not > necessarily be the same as its device name. This patch prepares for > this by making the distinction in the netdev and dpif layers. > > Signed-off-by: Ethan Jackson I don't

Re: [ovs-dev] [BUG] broad-/multicast & SLB bonding -> FAIL

2013-01-28 Thread Jesse Gross
On Fri, Jan 25, 2013 at 10:26 AM, Markus Schuster wrote: > On Thursday 24 January 2013 18:49:16 Jesse Gross wrote: >> Can you try to isolate broadcast/multicast traffic as much as possible >> and then run: >> ovs-dpctl dump-flows xapi1 >> while the problem is happening? > > Sorry it took me a bit

Re: [ovs-dev] [tunnel 07/11] netdev: New function netdev_get_dpif_port().

2013-01-28 Thread Ed Maste
On 27 January 2013 19:58, Ethan Jackson wrote: > diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c > index f0f1dc2..a06aef3 100644 > --- a/lib/netdev-linux.c > +++ b/lib/netdev-linux.c > @@ -2430,6 +2430,7 @@ netdev_linux_change_seq(const struct netdev *netdev) >

[ovs-dev] [PATCHv2] Add support for LISP tunneling

2013-01-28 Thread Lorand Jakab
LISP is an experimental layer 3 tunneling protocol, described in RFC 6830. This patch adds support for LISP tunneling. Since LISP encapsulated packets do not carry an Ethernet header, it is removed before encapsulation, and added with hardcoded source and destination MAC addresses after decapsula

Re: [ovs-dev] [BUG] broad-/multicast & SLB bonding -> FAIL

2013-01-28 Thread Markus Schuster
On Monday 28 January 2013 20:29:01 Jesse Gross wrote: > Are you configuring bonding directly through the OVS command line or > using Xen tools? I'm using the Xen tools to configure all networking related settings. Currently I'm not deep enough into Open vSwitch - on the ToDo list since a few yea

Re: [ovs-dev] [PATCH] ovs-ctl: Update comment.

2013-01-28 Thread Kyle Mestery (kmestery)
On Jan 28, 2013, at 1:00 PM, Ben Pfaff wrote: > Signed-off-by: Ben Pfaff Acked-by: Kyle Mestery ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH] ofproto-dpif: Clear revalidation flags only once, not per-ofproto.

2013-01-28 Thread Ethan Jackson
Thanks for fixing this. Acked-by: Ethan Jackson On Mon, Jan 28, 2013 at 10:45 AM, Ben Pfaff wrote: > Found by inspection. > > CC: Ethan Jackson > Signed-off-by: Ben Pfaff > --- > I noticed this while reviewing one of your "tunnel" patches. > > ofproto/ofproto-dpif.c |8 > 1 files

Re: [ovs-dev] [tunnel 09/11] lib: Switch to flow based tunneling.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:10PM -0800, Ethan Jackson wrote: > With this patch, ovs-vswitchd uses flow based tunneling > exclusively. I.E. each kind of tunnel shares a single tunnel > backer in the datapath. Tunnel headers are set by userspace using > the ipv4_tunnel datapath action. And, the

Re: [ovs-dev] [tunnel 10/11] tests: Add tunnel unit tests.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:11PM -0800, Ethan Jackson wrote: > This commit adds unit tests which exercise the flow based > tunneling code added in previous patches. > > Signed-off-by: Ethan Jackson Thanks for the tests. ___ dev mailing list dev@openv

Re: [ovs-dev] [tunnel 11/11] netdev-vport: Build on all platforms.

2013-01-28 Thread Ben Pfaff
On Sun, Jan 27, 2013 at 04:58:12PM -0800, Ethan Jackson wrote: > This patch removes the final bit of linux specific code which > prevents building netdev-vport everywhere. With this, other > platforms automatically get access to patch ports, and (if their > datapath supports it), flow based tunnel

Re: [ovs-dev] [tunnel 06/11] packets: Create global helper is_ip_any().

2013-01-28 Thread Ethan Jackson
Thanks this looks good, I've folded it in. Ethan On Mon, Jan 28, 2013 at 11:10 AM, Ben Pfaff wrote: > On Sun, Jan 27, 2013 at 04:58:07PM -0800, Ethan Jackson wrote: >> Used outside of meta-flow in future patches. >> >> Signed-off-by: Ethan Jackson > > There are some existing potential users you

Re: [ovs-dev] [tunnel 04/11] ofproto-dpif: Install drops for flows from invalid in_ports.

2013-01-28 Thread Ethan Jackson
> In update_stats(), I think that we could save some time by only > calling drop_key_lookup() if ofproto_receive() returns ENODEV, since > drop keys should not be the common case. Actually, upon reflection I've realized that we don't need the drop_key_lookup() in update_stats() at all. ofproto_re

Re: [ovs-dev] [tunnel 07/11] netdev: New function netdev_get_dpif_port().

2013-01-28 Thread Ethan Jackson
> Can you fold in the equivalent change to netdev-bsd.c? Sorry about that, I've folded the changes in. Incidentally, I've also downloaded a copy of FreeBSD and verified it builds and the tests pass (with some modifications I'll send out). Thanks, Ethan ___

Re: [ovs-dev] [tunnel 08/11] tunnel: Userspace implementation of tunnel manipulation.

2013-01-28 Thread Ethan Jackson
> I looked over this briefly but I think we fully reviewed it earlier. > The only change I noticed was the new void_tnl_port. I didn't > scrutinize that but it seemed straightforward. They only real changes since the last version is the module's interface. The void_tunnel_port is one of these ch

Re: [ovs-dev] [tunnel 09/11] lib: Switch to flow based tunneling.

2013-01-28 Thread Ethan Jackson
> Normally the author and the first sign-off should be the same. Is > this adapted with significant changes from a patch of Jesse's? It's > reasonable to change the authorship in that case if the changes seem > significant enough but then one would ordinarily change the first > sign-off to a text

Re: [ovs-dev] [tunnel 11/11] netdev-vport: Build on all platforms.

2013-01-28 Thread Ethan Jackson
This is a version of the patch which I've tested in FreeBSD. The main difference is that it registers the patch port provider, and registers the tunnel provider when dummy is enabled (to support the unit tests). I've built and tested this, but if you have time would you mind trying it out Ed?

Re: [ovs-dev] [tunnel 07/11] netdev: New function netdev_get_dpif_port().

2013-01-28 Thread Ethan Jackson
> I don't see a problem with this except for a layering violation: the > generic "netdev" layer now has a function and a function pointer in it > that is specific to the dpif code. I can see two ways to deal with > this: either move it out of the generic "netdev" layer into some other > place, or

Re: [ovs-dev] [tunnel 00/11] Flow based tunneling.

2013-01-28 Thread Ben Pfaff
On Mon, Jan 28, 2013 at 01:06:50PM -0500, Ed Maste wrote: > On 28 January 2013 12:44, Ben Pfaff wrote: > > On Mon, Jan 28, 2013 at 10:43:23AM -0500, Ed Maste wrote: > >> On 27 January 2013 19:58, Ethan Jackson wrote: > >> > This version of the series implements enough of the flow based > >> > tun