since there seems to be a problem with detecting
>>> the presence of the definition with at least some kernels.
>>>
>>> Reported-by: Wang Sheng-Hui
>>> Signed-off-by: Ben Pfaff
>>
>>
>> I don't have access to a CentOS 6.5 box to try t
WHY-OVS has been renamed to WHY-OVS.md. Update the filenames in run-oftest
and run-ryu scripts
Signed-off-by: Wang Sheng-Hui
---
tests/run-oftest | 2 +-
tests/run-ryu| 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/run-oftest b/tests/run-oftest
index c73c25c
Hi,
I used CentOS 6.5, and failed building the latest ovs:
libtool: compile: gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I ./include -I ./include
-I ./lib -I ./lib -Wstrict-prototypes -Wall -Wextra -Wno-sign-compare
-Wpointer-arith -Wno-format-zero-length -Wswitch-enum -Wunused-parameter
-Wbad-functi
ETH_ADDR_LEN is defined in lib/packets.h, valued 6.
Use this macro instead of magic number 6 to represent the length
of eth mac address.
Signed-off-by: Wang Sheng-Hui
---
lib/bfd.h| 4 +++-
lib/cfm.c| 5 +++--
lib/cfm.h| 3 ++-
lib
On 2014年10月07日 23:28, Ben Pfaff wrote:
> On Tue, Oct 07, 2014 at 08:36:44PM +0800, Wang Sheng-Hui wrote:
>> In min_attr_len and max_attr_len, it assumes the value equality between
>> NL_A_U* and NL_A_BE* types. Here return the attr len for NL_A_BE* types
>> explicitly.
>
In min_attr_len and max_attr_len, it assumes the value equality between
NL_A_U* and NL_A_BE* types. Here return the attr len for NL_A_BE* types
explicitly.
Signed-off-by: Wang Sheng-Hui
---
lib/netlink.c | 18 --
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/lib
Headroom and tailroom both are removed.
Signed-off-by: Wang Sheng-Hui
---
lib/ofpbuf.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/ofpbuf.c b/lib/ofpbuf.c
index c0cf144..4f3e8db 100644
--- a/lib/ofpbuf.c
+++ b/lib/ofpbuf.c
@@ -313,8 +313,8
Correct the old comment like ofpbuf_reserve to descript the expected
behavior of ofpbuf_reserve_with_tailroom
Signed-off-by: Wang Sheng-Hui
---
lib/ofpbuf.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/lib/ofpbuf.c b/lib/ofpbuf.c
index 198bbf6..c0cf144 100644
--- a
The return type of ofpbuf_tail and ofpbuf_end is pointer, not byte.
Signed-off-by: Wang Sheng-Hui
---
lib/ofpbuf.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/lib/ofpbuf.h b/lib/ofpbuf.h
index adaf526..53c43fb 100644
--- a/lib/ofpbuf.h
+++ b/lib/ofpbuf.h
It's for miniflow equalness check, not flow.
Signed-off-by: Wang Sheng-Hui
---
lib/flow.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/flow.c b/lib/flow.c
index b9f1820..4f22597 100644
--- a/lib/flow.c
+++ b/lib/flow.c
@@ -1770,7 +1770,7 @@ miniflow_get(const s
Remove the duplicated comment
"/* The following definitions are for users of the vport subsytem: */"
in vport.h
Signed-off-by: Wang Sheng-Hui
---
net/openvswitch/vport.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/net/openvswitch/vport.h b/net/openvswitch/vport.h
index 35f89d
11 matches
Mail list logo