[ovs-dev] [PATCH 22/23] ovn-northd: Add stages for logical routers.

2015-10-09 Thread Ben Pfaff
Until now, ovn-northd has only set up flows for logical switches. With the arrival of logical routers, it needs to set up flows for them too. The stages within logical routers are completely different from those for logical switches, so this prepares for that by adding logic for identifying those

[ovs-dev] [PATCH 23/23] ovn: Implement basic logical L3 routing.

2015-10-09 Thread Ben Pfaff
This implement basic logical L3 routing. It has a lot of caveats, including the following regarding testing: * Only single-router hops have been tested. Chains or trees of logical routers may work but definitely need testing and may need a little extra code. * No testing of logi

[ovs-dev] [PATCH 21/23] packets: New function ip_parse_masked().

2015-10-09 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- lib/meta-flow.c | 19 +-- lib/packets.c | 21 + lib/packets.h | 2 ++ 3 files changed, 24 insertions(+), 18 deletions(-) diff --git a/lib/meta-flow.c b/lib/meta-flow.c index 224ba53..fba628c 100644 --- a/lib/meta-flow.c +++ b/

[ovs-dev] [PATCH 20/23] ovn-nb: Add "enabled" column to Logical_Router_Port.

2015-10-09 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- ovn/ovn-nb.ovsschema | 3 ++- ovn/ovn-nb.xml | 7 +++ 2 files changed, 9 insertions(+), 1 deletion(-) diff --git a/ovn/ovn-nb.ovsschema b/ovn/ovn-nb.ovsschema index 9d254e8..d45a682 100644 --- a/ovn/ovn-nb.ovsschema +++ b/ovn/ovn-nb.ovsschema @@ -1,7 +1,7 @

[ovs-dev] [PATCH 19/23] ovn-nb: Change how router ports work.

2015-10-09 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- ovn/TODO | 14 -- ovn/ovn-nb.ovsschema | 8 ++-- ovn/ovn-nb.xml | 49 + 3 files changed, 27 insertions(+), 44 deletions(-) diff --git a/ovn/TODO b/ovn/TODO index 240804c..8ea0d17 10064

[ovs-dev] [PATCH 16/23] ovn-nb: Rename Port_Bindings 'macs' column to 'addresses'.

2015-10-09 Thread Ben Pfaff
In an upcoming commit this column will also support IP+MAC pairs. Signed-off-by: Ben Pfaff --- ovn/northd/ovn-northd.c | 17 +- ovn/ovn-nb.ovsschema| 8 ++--- ovn/ovn-nb.xml | 2 +- ovn/utilities/ovn-nbctl.8.xml | 14 ovn/

[ovs-dev] [PATCH 17/23] ovn-nb: Add support for IP+MAC binding pairs in Port_Binding 'address'.

2015-10-09 Thread Ben Pfaff
When a logical router can statically obtain the IP+MAC pairs for its attached logical switches, it can avoid expensive ARP resolution. Signed-off-by: Ben Pfaff --- ovn/TODO | 9 --- ovn/northd/ovn-northd.8.xml | 11 + ovn/ovn-nb.xml| 56 +++

[ovs-dev] [PATCH 18/23] ovn-nb.xml: Reorganize documentation for Logical_Port table.

2015-10-09 Thread Ben Pfaff
This uses the column grouping feature and the ability to document an individual key within a column to better, in my opinion, organize the documentation for the Logical_Port table. This will make it easier to document a new port type that a future commit will add. Signed-off-by: Ben Pfaff --- o

[ovs-dev] [PATCH 15/23] ovn-nb: Extend schema to support networks of routers.

2015-10-09 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- ovn/TODO | 6 -- ovn/ovn-nb.ovsschema | 10 +++--- ovn/ovn-nb.xml | 49 ++--- 3 files changed, 45 insertions(+), 20 deletions(-) diff --git a/ovn/TODO b/ovn/TODO index c914c10..c8a0338 100644 ---

[ovs-dev] [PATCH 13/23] ovn: Implement logical patch ports.

2015-10-09 Thread Ben Pfaff
This implementation is suboptimal for several reasons. First, it creates an OVS port for every OVN logical patch port, not just for the ones that are actually useful on this hypervisor. Second, it's wasteful to create an OVS patch port per OVN logical patch port, when really there's no benefit to

[ovs-dev] [PATCH 11/23] patch: Allow client to determine port names.

2015-10-09 Thread Ben Pfaff
Calculating the patch port names from the bridge names makes sense when there's only one pair of patch ports between a pair of bridges, but that won't be the case for an upcoming use of patch ports. This changes makes it easy to check for existing patch ports in create_patch_port(), instead of in

[ovs-dev] [PATCH 12/23] ovn-controller: Rename "ovn-patch-port" to "ovn-localnet-port".

2015-10-09 Thread Ben Pfaff
An upcoming patch will introduce a different use for patch ports, so ovn-patch-port would become an ambiguous name. Signed-off-by: Ben Pfaff --- ovn/controller/ovn-controller.8.xml | 6 -- ovn/controller/patch.c | 4 ++-- ovn/controller/physical.c | 2 +- 3 files chang

[ovs-dev] [PATCH 14/23] ovn: Add new predicates for matching broadcast and multicast packets.

2015-10-09 Thread Ben Pfaff
In my opinion, "eth.mcast" is a bit more readable than "eth.dst[40]", and so on. Signed-off-by: Ben Pfaff --- ovn/controller/lflow.c | 4 ovn/northd/ovn-northd.8.xml | 4 ++-- ovn/northd/ovn-northd.c | 4 ++-- ovn/ovn-sb.xml | 3 +++ 4 files changed, 11 insertions(+),

[ovs-dev] [PATCH 06/23] ovn: Update TODO, ovn-northd flow table design, ovn-architecture for L3.

2015-10-09 Thread Ben Pfaff
This is a proposed plan for logical L3 in OVN. It is not entirely complete but it includes many important details and I believe that it moves planning forward. Signed-off-by: Ben Pfaff --- ovn/TODO| 269 +++ ovn/northd/ovn-northd.8.xml | 376 +

[ovs-dev] [PATCH 08/23] ovn-controller: Factor patch port management into new "patch" module.

2015-10-09 Thread Ben Pfaff
Upcoming patches will introduce new extensive use of patch ports and it seems reasonable to put it into its own file. This is mostly code motion. Code changes are limited to those necessary to make the separated code compile, except for renaming init_bridge_mappings() to patch_run(). Signed-off-

[ovs-dev] [PATCH 07/23] ovn-controller: Un-inline get_chassis_by_name().

2015-10-09 Thread Ben Pfaff
I don't know of any reason to inline this. Also rename for consistency with get_bridge(). Signed-off-by: Ben Pfaff --- ovn/controller/binding.c| 4 ++-- ovn/controller/chassis.c| 4 ++-- ovn/controller/ovn-controller.c | 14 ++ ovn/controller/ovn-controller.h | 15

[ovs-dev] [PATCH 10/23] patch: Refactor to better support new kinds of patches.

2015-10-09 Thread Ben Pfaff
Until now, the code here lumped together what was necessary to create and destroy patch ports, with what was necessary to identify the patch ports that were needed. An upcoming patch will add new reasons to create patch ports, so this commit more cleanly separates those two functions. Signed-off-

[ovs-dev] [PATCH 09/23] patch: Bail out earlier if OVS IDL transactions cannot be executed.

2015-10-09 Thread Ben Pfaff
The whole point of this module is side effects on the Open vSwitch database, so the whole thing can be skipped if those are impossible. Signed-off-by: Ben Pfaff --- ovn/controller/patch.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/ovn/controller/patch.c b/ovn/con

[ovs-dev] [PATCH 05/23] nx-match: Serialize match on IP TTL even when outputting OXM.

2015-10-09 Thread Ben Pfaff
The 'oxm' parameter to nxm_put_ip() indicates whether NXM or OXM code points should be used in cases where both exist. It shouldn't cause matches to be dropped entirely, since that changes the meaning, but that's what was done here for matches on the IP (v4 or v6) TTL. This commit fixes the probl

[ovs-dev] [PATCH 04/23] ovn-nbctl: Remove external-ids commands.

2015-10-09 Thread Ben Pfaff
Users are served just as well through the general-purpose "set" and "get" database commands, so avoid the additional code and documentation. (ovs-vsctl does have special external-ids commands for bridges, but those exist because of special handling for "fake bridges".) Signed-off-by: Ben Pfaff -

[ovs-dev] [PATCH 03/23] ovn: Change h1 titles to title case in documentation.

2015-10-09 Thread Ben Pfaff
Manpage section titles are traditionally all-uppercase, but OVS's XML-to-nroff translator takes care of that and there's no need to actually provide them in all-caps (and it looks ugly). Signed-off-by: Ben Pfaff --- ovn/controller/ovn-controller.8.xml | 2 +- ovn/northd/ovn-northd.8.xml

[ovs-dev] [PATCH 00/23] ovn: Implement basic logical L3 routing.

2015-10-09 Thread Ben Pfaff
This series adds basic support for logical L3 routing to OVN, for your review. Ben Pfaff (23): ovn: Extend logical "next" action to jump to arbitrary flow tables. ovn: Implement logical action to decrement IPv4 TTL. ovn: Change h1 titles to title case in documentation. ovn-nbctl: Remove ex

[ovs-dev] [PATCH 02/23] ovn: Implement logical action to decrement IPv4 TTL.

2015-10-09 Thread Ben Pfaff
This is necessary for IPv4 routing. Signed-off-by: Ben Pfaff --- ovn/lib/actions.c | 9 + ovn/lib/lex.c | 13 + ovn/lib/lex.h | 1 + tests/ovn.at | 6 +- 4 files changed, 28 insertions(+), 1 deletion(-) diff --git a/ovn/lib/actions.c b/ovn/lib/actions.c i

[ovs-dev] [PATCH 01/23] ovn: Extend logical "next" action to jump to arbitrary flow tables.

2015-10-09 Thread Ben Pfaff
This makes it easier to route a "destination unreachable" message generated because of an IP routing failure, because the destination unreachable message must itself be routed the same way. Signed-off-by: Ben Pfaff --- ovn/controller/lflow.c | 15 + ovn/lib/actions.c | 88 ++

[ovs-dev] (no subject)

2015-10-09 Thread Dobson Alison
You are a recipient to Ms Alice Dawson Donation. Contact dawsonalice...@163.com for claims   Wi

Re: [ovs-dev] [PATCH] meta-flow.h: Remove circular dependency that crept into meta-flow.h via the ofputil_protocol enum. This one is defined in ofp-util.h which itself includes meta-flow.h. This chang

2015-10-09 Thread Jarno Rajahalme
John, For some reason that email did not get to my email, nor our patchwork (https://patchwork.ozlabs.org/project/openvswitch/list/), but I found it from the dev@openvswitch.org archive. You did not include a Signed-off-by line, so, in the interest of time, I put y

Re: [ovs-dev] [Debian-non-root 4/4] Debian: start daemons as ovs(non-root) user

2015-10-09 Thread Andy Zhou
On Thu, Oct 8, 2015 at 4:01 PM, Ansis Atteka wrote: > On Wed, Oct 7, 2015 at 8:20 PM, Andy Zhou wrote: >> On Wed, Oct 7, 2015 at 6:49 PM, Ansis Atteka wrote: >>> On Mon, Oct 5, 2015 at 6:38 PM, Andy Zhou wrote: >>> >>> Thanks Andy for doing this! I will have another more careful look at >>> thi

[ovs-dev] [Debian-non-root v2 3/4] ovs-ctl: add --no-run-as-root option

2015-10-09 Thread Andy Zhou
Add option to ovs-ctl script to specify whether to start the daemons as root user or ovs user. The default is 'run-as-root', which preserves the script's current behavior. Signed-off-by: Andy Zhou --- utilities/ovs-ctl.in | 13 +++-- utilities/ovs-lib.in | 9 - 2 files changed,

[ovs-dev] [Debian-non-root v2 4/4] Debian: start daemons as ovs(non-root) user

2015-10-09 Thread Andy Zhou
Changes to Debian packaging scripts to create the ovs user and group. Fix the permissions of ovs created files and directories so that they are accessible by users belong to the ovs group. Start daemons as the ovs user. Signed-off-by: Andy Zhou This patch does not include changes to the ips

[ovs-dev] [Debian-non-root v2 2/4] ovs-ctl: Remove hard coded root user and group

2015-10-09 Thread Andy Zhou
Replace hard coded root user and group with OVS_USER and OVS_GROUP. Signed-off-by: Andy Zhou Acked-by: Ansis Atteka --- utilities/ovs-ctl.in | 3 +++ utilities/ovs-lib.in | 6 +++--- 2 files changed, 6 insertions(+), 3 deletions(-) diff --git a/utilities/ovs-ctl.in b/utilities/ovs-ctl.in index

[ovs-dev] [Debian-non-root v2 1/4] Debian: require libcap-ng library for building packages

2015-10-09 Thread Andy Zhou
libcap-ng is going to be required to build Debian packages. Daemons will run as the ovs user and group, instead of root, to improve security. Signed-off-by: Andy Zhou Acked-by: Ansis Atteka --- debian/control | 1 + debian/rules | 2 +- 2 files changed, 2 insertions(+), 1 deletion(-) diff --

Re: [ovs-dev] [PATCH] ovs: do not allocate memory from offline numa node

2015-10-09 Thread Jarno Rajahalme
> On Oct 9, 2015, at 3:11 PM, Jesse Gross wrote: > > On Fri, Oct 9, 2015 at 8:54 AM, Jarno Rajahalme > wrote: >> >> On Oct 8, 2015, at 4:03 PM, Jesse Gross wrote: >> >> On Wed, Oct 7, 2015 at 10:47 AM, Jarno Rajahalme >> wrote: >> >> >> On Oct 6, 2015, at 6:0

Re: [ovs-dev] [PATCH] ovs: do not allocate memory from offline numa node

2015-10-09 Thread Jesse Gross
On Fri, Oct 9, 2015 at 8:54 AM, Jarno Rajahalme wrote: > > On Oct 8, 2015, at 4:03 PM, Jesse Gross wrote: > > On Wed, Oct 7, 2015 at 10:47 AM, Jarno Rajahalme > wrote: > > > On Oct 6, 2015, at 6:01 PM, Jesse Gross wrote: > > On Mon, Oct 5, 2015 at 1:25 PM, Alexander Duyck > wrote: > > On 10/05

Re: [ovs-dev] [PATCH net-next] openvswitch: report features supported by the kernel datapath

2015-10-09 Thread Jesse Gross
On Fri, Oct 9, 2015 at 2:46 AM, Jiri Benc wrote: > On Fri, 9 Oct 2015 11:24:53 +0200, Thomas Graf wrote: >> On 10/08/15 at 03:40pm, Jesse Gross wrote: >> > I have similar concerns as were expressed in the other thread. The >> > features listed here aren't OVS components and I don't think that it >

Re: [ovs-dev] [PATCH] datapath: Fix compilation on kernel 2.6.32

2015-10-09 Thread Pravin Shelar
On Fri, Oct 9, 2015 at 2:03 PM, Joe Stringer wrote: > On 9 October 2015 at 13:21, Pravin B Shelar wrote: >> Fixes following compilation error: >> >> CC [M] /home/travis/build/openvswitch/ovs/datapath/linux/actions.o >> >> In file included from >> /home/travis/build/openvswitch/ovs/datapath/linux

Re: [ovs-dev] [PATCH] datapath: Fix compilation on kernel 2.6.32

2015-10-09 Thread Joe Stringer
On 9 October 2015 at 13:21, Pravin B Shelar wrote: > Fixes following compilation error: > > CC [M] /home/travis/build/openvswitch/ovs/datapath/linux/actions.o > > In file included from > /home/travis/build/openvswitch/ovs/datapath/linux/actions.c:21:0: > > /home/travis/build/openvswitch/ovs/datap

[ovs-dev] [PATCH] datapath: Fix compilation on kernel 2.6.32

2015-10-09 Thread Pravin B Shelar
Fixes following compilation error: CC [M] /home/travis/build/openvswitch/ovs/datapath/linux/actions.o In file included from /home/travis/build/openvswitch/ovs/datapath/linux/actions.c:21:0: /home/travis/build/openvswitch/ovs/datapath/linux/compat/include/linux/skbuff.h: In function ‘rpl_skb_pos

Re: [ovs-dev] [PATCH] netdev_dpdk.c: Add QoS functionality.

2015-10-09 Thread Daniele Di Proietto
Hi, Thanks for the patch, the implementation looks simpler than I expected. General questions: * It appears that we're using the srCTM, but * We're only sending the green packets and dropping the rest. * The `input_color` is always green. Therefore * `other-config:ebs` is ignored (isn't

Re: [ovs-dev] [PATCH] ovs: do not allocate memory from offline numa node

2015-10-09 Thread Jarno Rajahalme
> On Oct 8, 2015, at 4:03 PM, Jesse Gross wrote: > > On Wed, Oct 7, 2015 at 10:47 AM, Jarno Rajahalme > wrote: >> >>> On Oct 6, 2015, at 6:01 PM, Jesse Gross wrote: >>> >>> On Mon, Oct 5, 2015 at 1:25 PM, Alexander Duyck >>> wrote: On 10/05/2015 06:59 AM,

Re: [ovs-dev] [PATCH RFC] ofproto: RFC extended statistics patch

2015-10-09 Thread Ben Pfaff
On Fri, Oct 09, 2015 at 01:49:33PM +0100, mweglicx wrote: > Implementation of new statistics extension: > - new counters definition based on RFC2819, > - new command line option for ovs-ofctl: port-dump-ext, > - new message definition has been created in nicira-ext.h, > - new raw types OFPRAW_NXST_

[ovs-dev] [PATCH RFC] ofproto: RFC extended statistics patch

2015-10-09 Thread mweglicx
Implementation of new statistics extension: - new counters definition based on RFC2819, - new command line option for ovs-ofctl: port-dump-ext, - new message definition has been created in nicira-ext.h, - new raw types OFPRAW_NXST_PORT_REQUEST, OFPRAW_NXST_PORT_REPLY have been created. - new exte

Re: [ovs-dev] [PATCH net-next] openvswitch: report features supported by the kernel datapath

2015-10-09 Thread Jiri Benc
On Fri, 9 Oct 2015 11:24:53 +0200, Thomas Graf wrote: > On 10/08/15 at 03:40pm, Jesse Gross wrote: > > I have similar concerns as were expressed in the other thread. The > > features listed here aren't OVS components and I don't think that it > > makes sense for OVS to try to cover everything that

Re: [ovs-dev] [PATCH net-next] openvswitch: report features supported by the kernel datapath

2015-10-09 Thread Thomas Graf
On 10/08/15 at 03:40pm, Jesse Gross wrote: > On Thu, Oct 8, 2015 at 6:53 AM, Jiri Benc wrote: > > Allow the user space to query what features are supported by the openvswitch > > module. This will be used to allow or disallow certain configurations and/or > > switch between newer and older APIs de