Hi Folks,
Wanted to touch base, if any of other developers started implementing OF
1.4 set/get async cfg feature ? I see this feature is still open under
OPENFLOW-1.1+.md/OpenFlow 1.4 only (Not sure if there's any other doc with
updated TODO tasks, some one can re-direct if so).
I'm pretty much v
On Tue, Jan 27, 2015 at 08:35:32AM -0800, Gurucharan Shetty wrote:
> When Open vSwitch is run in hundreds of hypervisors, it is
> useful to collect log messages through log collectors. To
> collect log messages like this, it is useful to log them
> in a particular RFC5424 facility in the local syst
The previous workflow is to convert dot diagrams into .pic format and
embed into manpages; double borders and arrows were not used in dot but
introduced in .pic conversion; edge routing in .pic were also worse than
dot.
The updated workflow specifies directly in dot diagram double boarders
for "ro
Eitan,
Like we discussed offline, I am not comfortable with a netlink call waiting on
another thread in a synchronous context. For what it is worth, all the calls
from userspace to kernel are non-blocking. It would be great if we can not have
a separate thread, and instead use some primitives su
> On Jan 26, 2015, at 11:00 AM, Sorin Vinturis
> wrote:
>
> If the OVS extension was previously enabled and the driver unloaded,
> when the driver is loaded again a BSOD is triggered.
>
> This happens because the OVS extension registers its FilterXxx routines
> to NDIS, by calling NdisFRegister
When Open vSwitch is run in hundreds of hypervisors, it is
useful to collect log messages through log collectors. To
collect log messages like this, it is useful to log them
in a particular RFC5424 facility in the local system. The
log collectors can then be used to collect logs anytime
desired.
T
Hi! How are you?
It works! http://blog.leatherup.com/Kayden.php?arivumani_gmail_com
arivum...@gmail.com
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
I don't understand why you want to do this by intercepting output
ports. Define a new action to do what you want, then use that action.
On Tue, Jan 27, 2015 at 04:16:34PM +0530, Sree Vidya S D wrote:
> The thing is I want alternate packets to use different paths ... similar to
> a loadbalancer
>
Supports a new "exts" field in the tunnel configuration which takes a
comma separated list of enabled extensions.
The only extension supported so far is GBP but this can be used to
enable RCO and possibly others as soon as the OVS datapath supports
them.
Signed-off-by: Thomas Graf
---
lib/dpif-
Upstream commit:
openvswitch: Support VXLAN Group Policy extension
Introduces support for the group policy extension to the VXLAN virtual
port. The extension is disabled by default and only enabled if the user
has provided the respective configuration.
ovs-vsctl add-port br0
Upstream commit:
genetlink: pass only network namespace to genl_has_listeners()
There's no point to force the caller to know about the internal
genl_sock to use inside struct net, just have them pass the network
namespace. This doesn't really change code generation since it's
a
Backport of upstream commit:
openvswitch: Rename GENEVE_TUN_OPTS() to TUN_METADATA_OPTS()
Also factors out Geneve validation code into a new separate function
validate_and_copy_geneve_opts().
A subsequent patch will introduce VXLAN options. Rename the existing
GENEVE_TUN_OPTS
From: Madhu Challa
Introduces two new NXMs to represent VXLAN-GBP [0] fields.
actions=load:0x10->NXM_NX_TUN_GBP_ID[],NORMAL
tun_gbp_id=0x10,actions=drop
This enables existing VXLAN tunnels to carry security label
information such as a SELinux context to other network peers.
The values are
Upstream commit:
net: rename vlan_tx_* helpers since "tx" is misleading there
The same macros are used for rx as well. So rename it.
Signed-off-by: Jiri Pirko
Signed-off-by: David S. Miller
Upstream: df8a39d ("net: rename vlan_tx_* helpers since "tx" is misleading
there")
Sign
Signed-off-by: Thomas Graf
---
FAQ.md | 1 +
NEWS | 2 +-
acinclude.m4 | 4 ++--
3 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/FAQ.md b/FAQ.md
index 02fe2d3..2de4936 100644
--- a/FAQ.md
+++ b/FAQ.md
@@ -147,6 +147,7 @@ A: The following table lists the Linux kernel v
genlmsg_end() no longer returns an error value. Not a problem as it
never returned an error code anyway.
Upstream: 053c09 ("netlink: make nlmsg_end() and genlmsg_end() void")
Signed-off-by: Thomas Graf
---
datapath/datapath.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff -
Upstream commit:
openvswitch: Allow for any level of nesting in flow attributes
nlattr_set() is currently hardcoded to two levels of nesting. This change
introduces struct ovs_len_tbl to define minimal length requirements plus
next level nesting tables to traverse the key attribute
This brings the compat version of vxlan_udp_encap_recv() and
vxlan_xmit_skb() in line with upstream commit:
commit 3bf3947526c1053ddf2523f261395d682718f56c
Author: Tom Herbert
Date: Thu Jan 8 12:31:18 2015 -0800
vxlan: Improve support for header flags
This patc
v2:
- Documentation in vswitch.xml and section in ovs-ofctl(8)
- New test in ovs-ofctl.at to check OXM/NXM availability
This series accounts for various upstream kernel changes and then
introduces VXLAN-GBP:
Introduces support for the group policy extension to the VXLAN virtual
port. The extens
Upstream commit:
vxlan: Group Policy extension
Implements supports for the Group Policy VXLAN extension [0] to provide
a lightweight and simple security label mechanism across network peers
based on VXLAN. The security context and associated metadata is mapped
to/from skb->mark
On 01/27/15 at 05:12pm, Simon Horman wrote:
> This parameter is not modified so it may be marked as const.
>
> Signed-off-by: Simon Horman
Straight forward, pushed to master. Thanks!
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailm
Hi! How are you?
It works!
http://probingoor.nl/uploads/assets//images/Kingsley.php?arivumani_gmail_com
arivum...@gmail.com
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On 01/27/15 at 09:22am, Simon Horman wrote:
> Hi Ben, Hi Thomas,
>
> On Mon, Jan 26, 2015 at 11:19:53AM -0800, Ben Pfaff wrote:
> > On Mon, Jan 26, 2015 at 02:44:07PM +0100, Thomas Graf wrote:
> > > list_moved() not handling the list_empty() case is somewhat rude.
> > > Why not just handle that sp
The thing is I want alternate packets to use different paths ... similar to
a loadbalancer
So the idea was like to embed all the paths in the header (say 3 paths) and
use a random number (1- 3) for packet i and route the packet via that path
On Tue, Jan 27, 2015 at 12:51 AM, Ben Pfaff wrote:
On Tue, Jan 27, 2015 at 05:22:30PM +0900, Simon Horman wrote:
> This parameter is not modified so it may be marked as const.
>
> Signed-off-by: Simon Horman
Apologies, I seem to have sent this twice. Please ignore this duplicate.
> ---
> lib/ofp-util.c | 6 +++---
> lib/ofp-util.h | 2 +-
> 2
This parameter is not modified so it may be marked as const.
Signed-off-by: Simon Horman
---
lib/ofp-util.c | 6 +++---
lib/ofp-util.h | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/lib/ofp-util.c b/lib/ofp-util.c
index 2270a93..bf55fb2 100644
--- a/lib/ofp-util.c
+++ b/l
This parameter is not modified so it may be marked as const.
Signed-off-by: Simon Horman
---
lib/ofp-util.c | 6 +++---
lib/ofp-util.h | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/lib/ofp-util.c b/lib/ofp-util.c
index 2270a93..bf55fb2 100644
--- a/lib/ofp-util.c
+++ b/l
27 matches
Mail list logo