Re: [ovs-dev] [PATCH 0/7] Datapath backports to support 3.18.x, net, net-next

2014-12-29 Thread Pravin Shelar
On Mon, Dec 29, 2014 at 4:19 PM, Thomas Graf wrote: > This series includes several backports which affect the datapath > and brings it closer to upstream. It also allows to build the > datapath against current net and net-next kernels. > > Thomas Graf (7): > datapath: Account for rename to vlan_

[ovs-dev] [PATCH 7/7] travis: Update build matrix to include latest stable kernels

2014-12-29 Thread Thomas Graf
Signed-off-by: Thomas Graf --- .travis.yml | 17 + 1 file changed, 9 insertions(+), 8 deletions(-) diff --git a/.travis.yml b/.travis.yml index b91327d..67354c7 100644 --- a/.travis.yml +++ b/.travis.yml @@ -7,16 +7,17 @@ before_install: ./.travis/prepare.sh env: - OPTS="--

[ovs-dev] [PATCH 6/7] datapath: replace remaining users of arch_fast_hash with jhash

2014-12-29 Thread Thomas Graf
This patch effectively reverts commit 500f80872645 ("net: ovs: use CRC32 accelerated flow hash if available"), and other remaining arch_fast_hash() users such as from nfsd via commit 6282cd565553 ("NFSD: Don't hand out delegations for 30 seconds after recalling them.") where it has been used as a h

[ovs-dev] [PATCH 5/7] datapath: introduce rtnl ops stub

2014-12-29 Thread Thomas Graf
This stub now allows userspace to see IFLA_INFO_KIND for ovs master and IFLA_INFO_SLAVE_KIND for slave. Upstream: 5b9e7e16 ("openvswitch: introduce rtnl ops stub") Signed-off-by: Thomas Graf --- datapath/datapath.c | 9 - datapath/vport-internal_dev.c | 15 +++ dat

[ovs-dev] [PATCH 4/7] datapath: move vlan pop/push functions into common code

2014-12-29 Thread Thomas Graf
So it can be used from out of openvswitch code. Did couple of cosmetic changes on the way, namely variable naming and adding support for 8021AD proto. Note on backwards compatability: Unlike the upstream version, the backport of skb_vlan_push() does not support translating a hardware accelerated 8

[ovs-dev] [PATCH 3/7] datapath: move make_writable helper into common code

2014-12-29 Thread Thomas Graf
note that skb_make_writable already exists in net/netfilter/core.c but does something slightly different. Upstream: e219512 ("net: move make_writable helper into common code") Signed-off-by: Thomas Graf --- acinclude.m4 | 1 + datapath/actions.c

[ovs-dev] [PATCH 1/7] datapath: Account for rename to vlan_insert_tag_set_proto()

2014-12-29 Thread Thomas Graf
__vlan_put_tag() was renamed to vlan_insert_tag_set_proto() with the argument list kept intact. Upstream: 62749e ("vlan: rename __vlan_put_tag to vlan_insert_tag_set_proto") Signed-off-by: Thomas Graf --- acinclude.m4 | 1 + datapath/actions.c

[ovs-dev] [PATCH 0/7] Datapath backports to support 3.18.x, net, net-next

2014-12-29 Thread Thomas Graf
This series includes several backports which affect the datapath and brings it closer to upstream. It also allows to build the datapath against current net and net-next kernels. Thomas Graf (7): datapath: Account for rename to vlan_insert_tag_set_proto() datapath: vlan: introduce __vlan_insert

[ovs-dev] [branch-2.3] ofproto-dpif-upcall: Make handler always call poll_block.

2014-12-29 Thread Alex Wang
This commit makes handler threads always call poll_block() at the end of each handling cycle. If there are upcalls received in the current cycle, the handler will register to wake up immediately. Otherwise, it will wait on both the netlink socket and the exit latch. Calling poll_block() at every

Re: [ovs-dev] '27: test atomic operations' unit test hanging

2014-12-29 Thread Sharo, Randall A CIV SPAWARSYSCEN-ATLANTIC, 55200
Please see the following backtraces for test 27: (gdb) attach 128246 Attaching to program: ovs/tests/ovstest, process 128246 [...] (gdb) bt #0 0x7ffebd820f37 in pthread_join () from /lib64/libpthread.so.0 #1 0x00471ed9 in xpthread_join (arg1=arg1@entry=140732040972032

Re: [ovs-dev] [PATCH trivial 2/3] ovs-dpctl: Minor manpages fixes.

2014-12-29 Thread Ben Pfaff
On Mon, Dec 15, 2014 at 03:30:04PM -0800, Joe Stringer wrote: > Signed-off-by: Joe Stringer Acked-by: Ben Pfaff ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH trivial 3/3] odp-util: Format UFID hi/lo in correct order.

2014-12-29 Thread Ben Pfaff
On Mon, Dec 15, 2014 at 03:30:05PM -0800, Joe Stringer wrote: > Signed-off-by: Joe Stringer Seem obviously correct. Acked-by: Ben Pfaff ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH 2/2] miniflow: Use 64-bit data.

2014-12-29 Thread Ben Pfaff
On Wed, Dec 17, 2014 at 10:30:42AM -0800, Jarno Rajahalme wrote: > So far the compressed flow data in struct miniflow has been in 32-bit > words with a 63-bit map, allowing for a maximum size of struct flow of > 252 bytes. With the forthcoming Geneve options this is not sufficient > any more. > >

Re: [ovs-dev] [PATCH 1/2] hash: Add hash_add64().

2014-12-29 Thread Ben Pfaff
On Mon, Dec 29, 2014 at 02:12:14PM -0800, Ben Pfaff wrote: > On Wed, Dec 17, 2014 at 10:30:41AM -0800, Jarno Rajahalme wrote: > > Add support for adding 64-bit words to hashes. This will be used by > > subsequent patches. > > > > Signed-off-by: Jarno Rajahalme > > Other than that philosophical i

[ovs-dev] [PATCH] ofproto-dpif: Do not allow recirc_id freed by non-owning ofproto.

2014-12-29 Thread Alex Wang
This commit changes the VLOG_ERR (for warning unmatched ofproto) in ofproto_dpif_free_recirc_id() to an assert statement, so that recirc_id is never allowed to be freed by non-owning ofproto. Suggested-by: Ben Pfaff Signed-off-by: Alex Wang --- ofproto/ofproto-dpif.c |7 ++- 1 file chan

Re: [ovs-dev] [PATCH 1/2] hash: Add hash_add64().

2014-12-29 Thread Ben Pfaff
On Wed, Dec 17, 2014 at 10:30:41AM -0800, Jarno Rajahalme wrote: > Add support for adding 64-bit words to hashes. This will be used by > subsequent patches. > > Signed-off-by: Jarno Rajahalme I noticed that hash_words64() takes a 64-bit basis (which is not new). That seems odd because it return

Re: [ovs-dev] [PATCH] Warn the free of 'recirc_id' by wrong 'ofproto'.

2014-12-29 Thread Alex Wang
On Mon, Dec 29, 2014 at 12:47 PM, Ben Pfaff wrote: > On Tue, Dec 23, 2014 at 02:21:06PM -0800, Alex Wang wrote: > > Issues a ERR log when the 'recirc_id' is not freed by the > > owning 'ofproto'. > > > > Signed-off-by: Alex Wang > > How did this come up? (Should this be an assertion?) > Hey Be

Re: [ovs-dev] How to know if sampled packet was cache miss?

2014-12-29 Thread Ben Pfaff
On Thu, Dec 18, 2014 at 05:13:47PM -0800, Neil McKee wrote: > I want the sFlow module to know when a sampled packet was a cache miss in > the datapath. That way we can include this information with the sFlow > sample feed that is sent out, and applications can analyze the data to see > what mix o

Re: [ovs-dev] [PATCH] ofproto-dpif-upcall: Prevent revalidation during purge.

2014-12-29 Thread Joe Stringer
Thanks Alex, On 23 December 2014 at 19:04, Alex Wang wrote: > When 'ovs-appctl revalidator/purge' is called, the main thread > sweeps and destroys all ukeys and the associated datapath flows. > If, at the same time, revalidators are dumping those flows from > datapath, the ukey lookup of dumped f

Re: [ovs-dev] [PATCH] cfm: Mark CFM as deprecated.

2014-12-29 Thread Ben Pfaff
On Thu, Dec 18, 2014 at 01:10:07PM -0800, Ethan Jackson wrote: > The current implementation is not standards compliant and inferior to > BFD in every way. This patch marks it as deprecated so it may be > removed in the future. > > Signed-off-by: Ethan Jackson I wonder whether anyone uses CFM to

Re: [ovs-dev] [PATCH] configure.ac: Enable 'tar-ustar' by default

2014-12-29 Thread Ben Pfaff
On Fri, Dec 19, 2014 at 10:19:10AM +, Stephen Finucane wrote: > Automake defaults to the 'v7' legacy tar format in GNU tar, through > passing of the '-o' parameter to GNU tar. Enabling this option results > in errors for users with 32 bit UIDs: > > $ make dist > ... > tardir=openvs

[ovs-dev] [PATCH] odp-util: Generate MPLS and vlan actions in correct order.

2014-12-29 Thread Pravin B Shelar
Kernel datapath expect specific order when it comes to mpls and vlan action combination. Datapath can push mpls first and then vlan and reverse for pop action. Following patch generate actions in correct order and enforces this requirement for Open Flow actions so that user can see rejected actions

Re: [ovs-dev] [PATCH] Warn the free of 'recirc_id' by wrong 'ofproto'.

2014-12-29 Thread Ben Pfaff
On Tue, Dec 23, 2014 at 02:21:06PM -0800, Alex Wang wrote: > Issues a ERR log when the 'recirc_id' is not freed by the > owning 'ofproto'. > > Signed-off-by: Alex Wang How did this come up? (Should this be an assertion?) ___ dev mailing list dev@openv

Re: [ovs-dev] '27: test atomic operations' unit test hanging

2014-12-29 Thread Ben Pfaff
On Tue, Dec 23, 2014 at 11:56:40PM +, Sharo, Randall A CIV SPAWARSYSCEN-ATLANTIC, 55200 wrote: > I see this same error, Stephen -- the test gets caught in an > infinite while loop where the atomic reader waits for an atomic > writer that is not running (maybe terminated or failed to spawn). I

Re: [ovs-dev] [per-pmd ftb/cls V2 3/3] dpif-netdev: Add per-pmd flow-table/classifier.

2014-12-29 Thread Pravin Shelar
On Sat, Dec 20, 2014 at 12:35 AM, Alex Wang wrote: > This commit changes the per dpif-netdev datapath flow-table/ > classifier to per pmd-thread. As direct benefit, datapath > and flow statistics no longer need to be protected by mutex > or be declared as per-thread variable, since they are only

Re: [ovs-dev] [per-pmd ftb/cls V2 2/3] ovs-numa: Refine the module.

2014-12-29 Thread Pravin Shelar
On Sat, Dec 20, 2014 at 12:35 AM, Alex Wang wrote: > This commit refines the ovs-numa module by eliminating > duplicated codes and exposing API for dumping the cores > on numa node. > > Signed-off-by: Alex Wang > LGTM Acked-by: Pravin B Shelar ___ dev

Re: [ovs-dev] [per-pmd ftb/cls V2 1/3] dpif-netdev: Add function to get pmd using core id.

2014-12-29 Thread Pravin Shelar
On Sat, Dec 20, 2014 at 12:35 AM, Alex Wang wrote: > This commit adds the function dp_netdev_get_pmd() which allows > users to get 'struct dp_netdev_pmd_thread' based on the core id. > > Signed-off-by: Alex Wang > LGTM Acked-by: Pravin B Shelar > --- > PATCH->V2: > - rebase to master. > --- > l