[ovs-dev] [PATCH] dpif-linux: Fix a NULL pointer refernce in vport_del_channels()

2014-04-20 Thread Andy Zhou
When testing megaflow bond implement I ran into a case where dpif->handler[0].channels is NULL. Indexing into channels causes vswitchd to crash. Not sure this is the best way to fix it, but it worked for me. Signed-off-by: Andy Zhou --- lib/dpif-linux.c |4 1 file changed, 4 insertions(

[ovs-dev] [PATCH 2/2] datapath: add recirc action

2014-04-20 Thread Andy Zhou
Recirculation implementation for Linux kernel data path. Signed-off-by: Andy Zhou --- v4 -> v5: * Always export dp_hash flow key attributes * Define dp_hash == 0 as uncomputed hash value. v3 -> v4: * OVS_CB input_port may be NULL for ovs_packet_cmd_execute()

[ovs-dev] [PATCH 1/2] datapath: add hash action

2014-04-20 Thread Andy Zhou
Signed-off-by: Andy Zhou V4->V5: * Make sure OVS_CB(Skb)->input_port is always set. * always export recirc_id. V3->v4: * Rehash the hash with hash_basis * always accept dp_hash mask * add mask to ovs_nla_put_flow() API V2->V3: * rename dp_hash to o

Re: [ovs-dev] [PATCH 02/10] lib: Inline functions used in classifier_lookup

2014-04-20 Thread YAMAMOTO Takashi
do these inlining yield measurable improvements? YAMAMOTO Takashi ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH 01/10] lib/flow: Simplify miniflow accessors, add ipv6 support.

2014-04-20 Thread YAMAMOTO Takashi
> +hash = mhash_finish(hash, 13); /* No need to match byte length here. > */ is it worth being special? YAMAMOTO Takashi ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

[ovs-dev] Would Physical Interface Driver impact OVS re-direct flow functionality?

2014-04-20 Thread Qing Wang
Hey, My question will be very briefly here. I was wondering if physical interface driver would a factor that cause the ovs re-direct flow(using ovs-ofctl) functionality failed? So I have a ovs bridge that attached couple interfaces(could be virtual and physical interface), and I know one physical

[ovs-dev] [PATCH] datapath: remove unneeded declaration of new_vport().

2014-04-20 Thread Rami Rosen
This patch removes the new_vport() forward declaration in datapath.c as it is not needed. Signed-off-by: Rami Rosen --- datapath/datapath.c | 1 - 1 file changed, 1 deletion(-) diff --git a/datapath/datapath.c b/datapath/datapath.c index 25edd7d..8ce6164 100644 --- a/datapath/datapath.c +++ b/d