Re: [ovs-dev] [PATCH] Fix packet-in reason for OpenFlow1.3 table-miss flow entries

2013-10-22 Thread YAMAMOTO Takashi
> On Fri, Oct 18, 2013 at 01:28:44PM +0900, YAMAMOTO Takashi wrote: >> As per spec, make packet-in reason for OpenFlow1.3 table-miss flow >> entries no_match rather than action. >> >> Signed-off-by: YAMAMOTO Takashi > > Thanks a lot for sending a second version. > > The more I thought about thi

Re: [ovs-dev] [PATCH v2.44 1/5] odp: Allow VLAN actions after MPLS actions

2013-10-22 Thread Simon Horman
On Tue, Oct 22, 2013 at 01:55:41PM -0700, Ben Pfaff wrote: > On Tue, Oct 22, 2013 at 11:30:26AM -0700, Joe Stringer wrote: > > You're quite right. I think for OF1.2, this is similar to existing > > behaviour, but for OF1.3 it's just incorrect. There is an additional issue > > with the LOAD action.

[ovs-dev] [PATCH 3/3] OPENFLOW-1.1+: update multipart stuff

2013-10-22 Thread YAMAMOTO Takashi
Signed-off-by: YAMAMOTO Takashi --- OPENFLOW-1.1+ | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/OPENFLOW-1.1+ b/OPENFLOW-1.1+ index 22be72c..82191e1 100644 --- a/OPENFLOW-1.1+ +++ b/OPENFLOW-1.1+ @@ -116,10 +116,8 @@ following additional work. (This is based on the chang

[ovs-dev] [PATCH 2/3] ofproto: report multipart buffer overflow

2013-10-22 Thread YAMAMOTO Takashi
because our size of the multipart request buffer is effectively 0, always report multipart buffer overflow error for multipart requests with "more" flag set. while this might be simpler if done in ofp-msgs.c, i put this in ofproto.c because it seems like a better place to implement the buffering l

[ovs-dev] [PATCH 0/3] multipart request fixes

2013-10-22 Thread YAMAMOTO Takashi
YAMAMOTO Takashi (3): ofproto: report correct errors for unsupported stats/multipart messages ofproto: report multipart buffer overflow OPENFLOW-1.1+: update multipart stuff OPENFLOW-1.1+ | 4 +--- lib/ofp-msgs.c| 26 -- lib/ofp-msgs.h| 1 + ofproto

[ovs-dev] [PATCH 1/3] ofproto: report correct errors for unsupported stats/multipart messages

2013-10-22 Thread YAMAMOTO Takashi
the correct error in that case is OFPERR_OFPBRC_BAD_STAT, not OFPERR_OFPBRC_BAD_TYPE. Signed-off-by: YAMAMOTO Takashi --- lib/ofp-msgs.c| 26 -- lib/ofp-msgs.h| 1 + ofproto/ofproto.c | 8 ++-- 3 files changed, 27 insertions(+), 8 deletions(-) diff --git a/

Re: [ovs-dev] [PATCH] Fix packet-in reason for OpenFlow1.3 table-miss flow entries

2013-10-22 Thread Ben Pfaff
On Fri, Oct 18, 2013 at 01:28:44PM +0900, YAMAMOTO Takashi wrote: > As per spec, make packet-in reason for OpenFlow1.3 table-miss flow > entries no_match rather than action. > > Signed-off-by: YAMAMOTO Takashi Thanks a lot for sending a second version. The more I thought about this, the more ug

[ovs-dev] [packet-in 6/8] fail-open: Add function to identify its own flows.

2013-10-22 Thread Ben Pfaff
This seems slightly cleaner than embedding this logic directing into ofproto-dpif, since it is an interface that theoretically could be useful to other ofproto providers. Signed-off-by: Ben Pfaff --- ofproto/fail-open.h | 12 ++-- ofproto/ofproto-dpif-xlate.c |2 +- ofprot

[ovs-dev] [packet-in 3/8] connmgr: Move send_len from ofputil_packet_in to ofproto_packet_in.

2013-10-22 Thread Ben Pfaff
send_len is not directly part of the OpenFlow packet_in message, at least given that it is partially redundant with packet_len. send_len is, rather, a request to the connmgr that expresses how many bytes the action requested be sent to the controller, but the connmgr cannot always honor it. Signe

[ovs-dev] [packet-in 4/8] ofp-util: Improve comments on struct ofputil_packet_in.

2013-10-22 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- lib/ofp-util.h | 30 +++--- 1 file changed, 23 insertions(+), 7 deletions(-) diff --git a/lib/ofp-util.h b/lib/ofp-util.h index b1275d7..edf7ad2 100644 --- a/lib/ofp-util.h +++ b/lib/ofp-util.h @@ -376,17 +376,33 @@ struct ofpbuf *ofputil_en

[ovs-dev] [packet-in 7/8] connmgr: Fix packet-in reason for OpenFlow1.3 table-miss flow entries.

2013-10-22 Thread Ben Pfaff
From: YAMAMOTO Takashi As per spec, make packet-in reason for OpenFlow1.3 table-miss flow entries no_match rather than action. Signed-off-by: YAMAMOTO Takashi Signed-off-by: Ben Pfaff --- OPENFLOW-1.1+ |3 --- ofproto/connmgr.c | 32 ++

[ovs-dev] [packet-in 5/8] ofp-util: Use correct cookie value in "packet_in"s when no flow involved.

2013-10-22 Thread Ben Pfaff
OpenFlow 1.3 uses all-1-bits in a packet_in to indicate that the packet_in was not generated by a flow, but Open vSwitch incorrectly used 0. This fixes the problem. For consistency, this commit also changes NXT_PACKET_IN to use all-1-bits for this case, event though NXT_PACKET_IN was previously d

[ovs-dev] [packet-in 0/8] refactor, fix, improve packet-in handling

2013-10-22 Thread Ben Pfaff
The purpose of this series is to implement OpenFlow 1.3 table-miss handling, but it does a lot of related cleanup and at least one bug fix too. Ben Pfaff (7): ofproto, ofp-util: Begin disentangling packet-in wire format and handling. connmgr: Move controller_id from ofputil_packet_in to

[ovs-dev] [packet-in 8/8] pinsched: Eliminate function callback in interface.

2013-10-22 Thread Ben Pfaff
I'm not a fan of function callbacks because I feel that they obscure interfaces. This eliminates the function callback used until now in the pinsched code. Signed-off-by: Ben Pfaff --- ofproto/connmgr.c | 28 +--- ofproto/pinsched.c | 15 +-- ofproto/pin

[ovs-dev] [packet-in 1/8] ofproto, ofp-util: Begin disentangling packet-in wire format and handling.

2013-10-22 Thread Ben Pfaff
struct ofputil_packet_in mixes data included in OpenFlow packet_in messages with data that used internally by ofproto and connmgr to queue and route packet_ins. This commit begins disentangling these purposes by adding a new struct ofproto_packet_in that wraps struct ofputil_packet_in. Adding thi

[ovs-dev] [packet-in 2/8] connmgr: Move controller_id from ofputil_packet_in to ofproto_packet_in.

2013-10-22 Thread Ben Pfaff
controller_id isn't part of the OpenFlow message, so it shouldn't be in ofputil_packet_in. Signed-off-by: Ben Pfaff --- lib/ofp-util.h|1 - ofproto/connmgr.c |2 +- ofproto/connmgr.h |1 + ofproto/ofproto-dpif-upcall.c |2 +- ofproto/ofprot

[ovs-dev] [PATCH v2 13/15] lib/ofp-actions: Translate deprecated actions as set fields.

2013-10-22 Thread Jarno Rajahalme
Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c | 139 lib/ofp-actions.h |3 +- tests/ovs-ofctl.at | 12 - 3 files changed, 151 insertions(+), 3 deletions(-) diff --git a/lib/ofp-actions.c b/lib/ofp-actions.c index 32c8e10..2

[ovs-dev] [PATCH v2 14/15] lib/ofp-actions: Log a warning on deprecated actions.

2013-10-22 Thread Jarno Rajahalme
Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/lib/ofp-actions.c b/lib/ofp-actions.c index 20814db..12d2f75 100644 --- a/lib/ofp-actions.c +++ b/lib/ofp-actions.c @@ -1090,6 +1090,24 @@ ofpact_from_openflow11(const un

[ovs-dev] [PATCH v2 10/15] Native OpenFlow 1.2 set field action.

2013-10-22 Thread Jarno Rajahalme
Signed-off-by: Jarno Rajahalme --- lib/meta-flow.c | 203 ++ lib/meta-flow.h | 20 - lib/nx-match.c | 135 ++-- lib/nx-match.h |2 - lib/ofp-actions.c| 14

[ovs-dev] [PATCH v2 06/15] Add OF11 SET IP TTL action.

2013-10-22 Thread Jarno Rajahalme
Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c| 21 + lib/ofp-actions.h|9 + lib/ofp-parse.c | 11 ++- lib/ofp-util.def |2 +- ofproto/ofproto-dpif-xlate.c |7 +++ tests/ovs-ofctl.at

[ovs-dev] [PATCH v2 15/15] Add OF11 SET MPLS LABEL and SET MPLS TC actions.

2013-10-22 Thread Jarno Rajahalme
Signed-off-by: Jarno Rajahalme --- include/openflow/nicira-ext.h | 24 lib/ofp-actions.c | 82 +++-- lib/ofp-actions.h | 22 ++- lib/ofp-parse.c | 46 +++ lib/ofp-util.c

[ovs-dev] [PATCH v2 09/15] Inline mf_from_id(), add OXM names.

2013-10-22 Thread Jarno Rajahalme
mf_from_id accesses a static table, so the compiler should be able to completely optimize it away. Add OXM inspired names to fields that don't have them (e.g., "ip_proto" and "ip_dscp", which is nicer than "nw_tos_shifted"). Fix MFF_IP_DSCP_SHIFTED bit width to 6. Also use OVS_PACKED_ENUM to was

[ovs-dev] [PATCH v2 12/15] lib/ofp-action: Simplify interface and internal structure.

2013-10-22 Thread Jarno Rajahalme
This makes later changes simpler. Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c | 274 +++-- lib/ofp-actions.h | 32 +++--- lib/ofp-util.c| 127 +-- lib/ofp-util.h|1 + utilities/ovs-ofctl.c |

[ovs-dev] [PATCH v2 04/15] Rename OFPACT_SET_IPV4_DSCP to OFPACT_SET_IP_DSCP.

2013-10-22 Thread Jarno Rajahalme
Allow OFPACT_SET_IP_DSCP to act on both IPv4 and IPv6 packets. This removes semantic differences between different OpenFlow versions, making it easier to translate between them. Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c| 28 ++-- lib/ofp-actions.h

[ovs-dev] [PATCH v2 02/15] Fix ovs-ofctl documentation.

2013-10-22 Thread Jarno Rajahalme
State that if decrementing makes a TTL zero, controller notifications may be sent. Signed-off-by: Jarno Rajahalme --- utilities/ovs-ofctl.8.in |9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/utilities/ovs-ofctl.8.in b/utilities/ovs-ofctl.8.in index b2bc8d7..3d3879

[ovs-dev] [PATCH v2 11/15] lib/ofp-actions: Set field OF 1.0/1.1 compatibility.

2013-10-22 Thread Jarno Rajahalme
Output set field actions as standard OF1.0/1.1 set actions or to reg_load instructions, when a compatible set action(s) do not exist. Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c | 209 lib/ofp-actions.h |1 + tests/ovs-ofctl.at

[ovs-dev] [PATCH v2 08/15] OF 1.1 pop vlan compatibility.

2013-10-22 Thread Jarno Rajahalme
Store the original action code with the strip vlan action, so that it can be printed back properly. Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c|7 --- lib/ofp-parse.c |2 +- tests/ofp-actions.at |2 +- tests/ovs-ofctl.at |4 ++-- 4 files changed, 8 inserti

[ovs-dev] [PATCH v2 00/15] Enhanced OpenFlow 1.1+ action support

2013-10-22 Thread Jarno Rajahalme
This series adds many of the missing OpenFlow 1.1 actions. Due to the different semantics, the vlan actions are annotated based on the policy on missing vlan header. A native OF 1.2 Set Field action with translation to/from OF 1.0/1.1 actions is added. Action consistency is enforced for OF 1.1+,

[ovs-dev] [PATCH v2 07/15] OF 1.1 set vlan vid/pcp compatibility.

2013-10-22 Thread Jarno Rajahalme
OpenFlow 1.1 set vlan actions only modify existing vlan headers, while OF 1.0 actions push a new vlan header if one does not exist already. Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c| 91 +- lib/ofp-actions.h| 20 +

[ovs-dev] [PATCH v2 01/15] ofp-actions: Make union ofp_action more generic.

2013-10-22 Thread Jarno Rajahalme
Make union ofp_action more generic by allowing it to be used for all actions. OFP_ACTION_ALIGN (which is 8, as the sizeof(union ofp_action) used to be) is now used where sizeof union ofp_action was used before. On the same note, variable name 'n_actions' is changed to 'max_actions' as the number

[ovs-dev] [PATCH v2 05/15] Add OF11 set IPv4 ECN action.

2013-10-22 Thread Jarno Rajahalme
Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c| 24 lib/ofp-actions.h|9 + lib/ofp-parse.c | 14 +- lib/ofp-util.def |2 +- ofproto/ofproto-dpif-xlate.c |8 tests/ovs-ofctl

[ovs-dev] [PATCH v2 03/15] lib/ofp-actions: Enforce action consistency.

2013-10-22 Thread Jarno Rajahalme
OpenFlow 1.1+ specs encourage switches to verify action consistency at flow setup time. Implement this for OpenFlow 1.1+ only to not break any current OF 1.0 based use. Signed-off-by: Jarno Rajahalme --- lib/ofp-actions.c | 61 lib/ofp-act

Re: [ovs-dev] [PATCH] sFlow export: include standard tunnel structures (for GRE, VXLAN etc.)

2013-10-22 Thread Jesse Gross
On Mon, Oct 21, 2013 at 2:33 PM, Romain Lenglet wrote: > - Original Message - >> From: "Romain Lenglet" >> To: "Jesse Gross" >> Cc: dev@openvswitch.org >> Sent: Friday, October 18, 2013 6:46:05 PM >> Subject: Re: [ovs-dev] [PATCH] sFlow export: include standard tunnel >> structures (for

Re: [ovs-dev] [Nicira-build] openvswitch (master) 30260: failure

2013-10-22 Thread Jesse Gross
On Tue, Oct 22, 2013 at 2:19 PM, Ben Pfaff wrote: > The autobuilder reports RHEL 6.1 kernel build failures with recent changes: > >> /root/rpmbuild/BUILD/openvswitch-2.0.90.30260/_default/datapath/linux/datapath.c:760: >> error: expected '=', ',', ';', 'asm' or '__attribute__' before 'n_mask_hit'

Re: [ovs-dev] [Nicira-build] openvswitch (master) 30260: failure

2013-10-22 Thread Ben Pfaff
The autobuilder reports RHEL 6.1 kernel build failures with recent changes: > /root/rpmbuild/BUILD/openvswitch-2.0.90.30260/_default/datapath/linux/datapath.c:760: > error: expected '=', ',', ';', 'asm' or '__attribute__' before 'n_mask_hit' > 14:12:24 INFO (chroot: rhel61_x86_64) - > /root/rp

Re: [ovs-dev] filename encoding in Python--any Python programmers in the house?

2013-10-22 Thread Ben Pfaff
Thanks for all the information. After some experimentation this morning, I think I'm pretty close to a solution good enough to make the tests pass. In general string encoding in Python seems to be a big mess. On Mon, Oct 21, 2013 at 07:37:12PM -0700, Reid Price wrote: > Apologies for the long an

Re: [ovs-dev] [PATCH v2.44 1/5] odp: Allow VLAN actions after MPLS actions

2013-10-22 Thread Ben Pfaff
On Tue, Oct 22, 2013 at 11:30:26AM -0700, Joe Stringer wrote: > You're quite right. I think for OF1.2, this is similar to existing > behaviour, but for OF1.3 it's just incorrect. There is an additional issue > with the LOAD action. > > OF1.2: > "push_vlan(A),push_mpls,push_vlan(B)" > In OF1.2, thi

Re: [ovs-dev] [PATCH] Update AUTHORS

2013-10-22 Thread Ethan Jackson
Applied On Mon, Oct 21, 2013 at 3:11 PM, Joe Stringer wrote: > Signed-off-by: Joe Stringer > --- > AUTHORS |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/AUTHORS b/AUTHORS > index 11da939..ac7886b 100644 > --- a/AUTHORS > +++ b/AUTHORS > @@ -55,7 +55,7 @@ Jeremy Str

[ovs-dev] [PATCH] Update AUTHORS

2013-10-22 Thread Joe Stringer
Signed-off-by: Joe Stringer --- AUTHORS |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/AUTHORS b/AUTHORS index 11da939..ac7886b 100644 --- a/AUTHORS +++ b/AUTHORS @@ -55,7 +55,7 @@ Jeremy Striblingst...@nicira.com Jesse Gross je...@nicira.com Jing Ai

Re: [ovs-dev] [PATCH v2.44 1/5] odp: Allow VLAN actions after MPLS actions

2013-10-22 Thread Joe Stringer
You're quite right. I think for OF1.2, this is similar to existing behaviour, but for OF1.3 it's just incorrect. There is an additional issue with the LOAD action. OF1.2: "push_vlan(A),push_mpls,push_vlan(B)" In OF1.2, this has the same result as:- "push_mpls,push_vlan(A),push_vlan(B)" When trans

Re: [ovs-dev] [mega mask stats v4 1/2] datapath: collect mega flow mask stats

2013-10-22 Thread Jesse Gross
On Mon, Oct 21, 2013 at 2:37 PM, Andy Zhou wrote: > Collect mega flow mask stats. ovs-dpctl show command can be used to > display them. > > Signed-off-by: Andy Zhou Applied, thanks. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailma

Re: [ovs-dev] [mega mask stats v4 2/2] dpif-linux: collect and display mega flow mask stats

2013-10-22 Thread Jesse Gross
On Mon, Oct 21, 2013 at 2:47 PM, Ben Pfaff wrote: > On Mon, Oct 21, 2013 at 02:37:34PM -0700, Andy Zhou wrote: >> Signed-off-by: Andy Zhou > > Acked-by: Ben Pfaff Also applied. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/li

Re: [ovs-dev] RFC: Handle IPv4 fragmentation in kernel

2013-10-22 Thread Jesse Gross
On Thu, Oct 17, 2013 at 9:24 PM, Takayuki Usui wrote: > Hi All, > > I'm working an experimental patch to handle IPv4 fragmentation and > reassembly in kernel. The goals are (1) flow matching an entire > datagram, not a single fragment, and (2) Path MTU Discovery across > an OVS network. I would re

Re: [ovs-dev] OVS bonding features - liblagg

2013-10-22 Thread Ben Pfaff
On Tue, Oct 22, 2013 at 05:59:51PM +0200, Jiri Pirko wrote: > Tue, Oct 22, 2013 at 05:30:16PM CEST, b...@nicira.com wrote: > >So for me that prompts a new question. I can easily believe that teamd > >has two or three times as many bonding features as OVS. But do you have > >a way to know or guess

Re: [ovs-dev] OVS bonding features - liblagg

2013-10-22 Thread Jiri Pirko
Tue, Oct 22, 2013 at 05:30:16PM CEST, b...@nicira.com wrote: >On Tue, Oct 22, 2013 at 11:16:41AM +0200, Jiri Pirko wrote: >> Tue, Oct 22, 2013 at 08:15:38AM CEST, b...@nicira.com wrote: >> >That wouldn't be a big deal if the library solved a thorny problem or >> >required a lot of code or was diffi

Re: [ovs-dev] OVS bonding features - liblagg

2013-10-22 Thread Ben Pfaff
On Tue, Oct 22, 2013 at 11:16:41AM +0200, Jiri Pirko wrote: > Tue, Oct 22, 2013 at 08:15:38AM CEST, b...@nicira.com wrote: > >That wouldn't be a big deal if the library solved a thorny problem or > >required a lot of code or was difficult to maintain. Good examples of > >libraries in those categor

Re: [ovs-dev] OVS bonding features - liblagg

2013-10-22 Thread Jiri Pirko
Tue, Oct 22, 2013 at 08:15:38AM CEST, b...@nicira.com wrote: >Hi Jiri. > >Sorry about the delay in responding. I've been taking my time to mull >the various issues that came up as I thought about it. > >When you suggested this off-list, my first thought was that this could >be beneficial to all pa

[ovs-dev] [PATCH 1/2 v2] include/openflow: Add OpenFlow 1.4 header file

2013-10-22 Thread Alexandru Copot
It contains only Set-Async-Config and Role status message definitions. Signed-off-by: Alexandru Copot Cc: Daniel Baluta --- The OFPACPT_ and OFPTFPT_ are still named like this. It's the way they are defined in the header file in the specification. build-aux/extract-ofp-msgs | 3 + inc

[ovs-dev] [PATCH 0/2 v2] Add Role Status Message support (OF1.4)

2013-10-22 Thread Alexandru Copot
This series adds the required functionality for notifying controllers with the OFPT_ROLE_STATUS message introduced in OpenFlow 1.4. Currently, this message is sent only when another controller asks that his role is changed to master. --- Changes since v1: - only 2 patches now - removed zero length

[ovs-dev] [PATCH 2/2 v2] add support for sending OFPTYPE_ROLE_STATUS messages

2013-10-22 Thread Alexandru Copot
When a controller changes its role to MASTER, the others are marked as SLAVE. This patch makes it possible to notify the controllers of this change. Signed-off-by: Alexandru Copot Cc: Daniel Baluta --- include/openflow/openflow-1.4.h | 3 +- lib/ofp-print.c | 65 +++