On Wed, Oct 9, 2013 at 11:07 PM, Pravin Shelar wrote:
> On Wed, Oct 9, 2013 at 9:11 PM, Alexei Starovoitov wrote:
>> On Wed, Oct 9, 2013 at 8:02 PM, Pravin Shelar wrote:
>>> On Tue, Oct 8, 2013 at 8:07 PM, Alexei Starovoitov
>>> wrote:
The combination of two commits
commit 8e4e1
On Wed, Oct 9, 2013 at 9:11 PM, Alexei Starovoitov wrote:
> On Wed, Oct 9, 2013 at 8:02 PM, Pravin Shelar wrote:
>> On Tue, Oct 8, 2013 at 8:07 PM, Alexei Starovoitov wrote:
>>> The combination of two commits
>>>
>>> commit 8e4e1713e4
>>> ("openvswitch: Simplify datapath locking.")
>>>
>>> and
>
On Wed, Oct 9, 2013 at 8:02 PM, Pravin Shelar wrote:
> On Tue, Oct 8, 2013 at 8:07 PM, Alexei Starovoitov wrote:
>> The combination of two commits
>>
>> commit 8e4e1713e4
>> ("openvswitch: Simplify datapath locking.")
>>
>> and
>>
>> commit 2537b4dd0a
>> ("openvswitch:: link upper device for port
On Tue, Oct 8, 2013 at 8:07 PM, Alexei Starovoitov wrote:
> The combination of two commits
>
> commit 8e4e1713e4
> ("openvswitch: Simplify datapath locking.")
>
> and
>
> commit 2537b4dd0a
> ("openvswitch:: link upper device for port devices")
>
> introduced a bug where upper_dev wasn't unlinked u
On Wed, Oct 09, 2013 at 06:22:25PM -0700, Reid Price wrote:
> Hi Luigi,
>
> At some level it is a logical error to create flows that:
> - have the same priority
> - have overlapping match criteria
> - have different actions
>
> You are already in trouble if you have
>
> priority=100, nw_src=1.
On Tue, Oct 8, 2013 at 8:07 PM, Alexei Starovoitov wrote:
> The combination of two commits
>
> commit 8e4e1713e4
> ("openvswitch: Simplify datapath locking.")
>
> and
>
> commit 2537b4dd0a
> ("openvswitch:: link upper device for port devices")
>
> introduced a bug where upper_dev wasn't unlinked u
Hi Luigi,
At some level it is a logical error to create flows that:
- have the same priority
- have overlapping match criteria
- have different actions
You are already in trouble if you have
priority=100, nw_src=1.2.3.0/24,actions=1
priority=100, nw_dst=5.6.7.0/24,actions=2
Since the action
On Wed, Oct 09, 2013 at 05:59:43PM -0700, Ben Pfaff wrote:
> Your question deserves a more detailed answer, but here's an easy part.
>
> On Thu, Oct 10, 2013 at 02:54:19AM +0200, Luigi Rizzo wrote:
> > Perhaps a simple example could help me -- e.g. say you have these
> > four flow entries, how man
If the datapath actions exceed the maximum size of a Netlink attribute
(about 64 kB), then previously we would assert-fail (before commit
542024c4c3d36 "ofproto-dpif-xlate: Suppress oversize datapath actions.")
or just drop all of them (after that commit). This commit makes OVS cope
by slow-pathin
Your question deserves a more detailed answer, but here's an easy part.
On Thu, Oct 10, 2013 at 02:54:19AM +0200, Luigi Rizzo wrote:
> Perhaps a simple example could help me -- e.g. say you have these
> four flow entries, how many hash tables are created with megaflows ?
>
> (1) nw_src=1.
Hi,
I am trying to figure out the cost of using megaflows compared to
the previous exact match table (I understand the benefits of megaflows).
Since I have not followed the list recently, and failed to find a
summary description of the implementation, i had a look at the
source code trying to unde
yes, please go ahead,
On Wed, Oct 9, 2013 at 5:42 PM, Ben Pfaff wrote:
> Thanks. Since you said off-list that you were happy with this series, I
> applied it to master.
>
>
> On Wed, Oct 9, 2013 at 1:40 PM, Alex Wang wrote:
>
>> The changes and tests all look good to me,
>>
>>
>> On Mon, Sep
Thanks. Since you said off-list that you were happy with this series, I
applied it to master.
On Wed, Oct 9, 2013 at 1:40 PM, Alex Wang wrote:
> The changes and tests all look good to me,
>
>
> On Mon, Sep 23, 2013 at 10:49 AM, Ben Pfaff wrote:
>
>> This support is added through the userspace
On Mon, Oct 07, 2013 at 05:00:42PM +0900, Simon Horman wrote:
> Hi,
>
> This series implements MPLS actions and matches based on work by
> Ravi K, Leo Alterman, Yamahata-san and Joe Stringer.
>
> This series provides two changes
>
> * Patches 1 - 3
>
> Provide user-space support for the VLAN/
Implementation note:
All actions which modify a field are added to the action set
at the point where "set" actions should be added. In general
modifying a field many times is the same as only modifying it
the last time so the implementation simply adds all set actions to
the action set in the orde
This is a first step towards implementing the dpif side of groups.
In order to be useful the action translation code needs
to be taught about groups.
Signed-off-by: Simon Horman
---
v4
* No change
v3
* Rebase for "ofproto-dpif: Hide struct rule_dpif internally"
* Hide group_dpif in a similar
Allow translation of indirect and all groups. Also allow insertion of
indirect and all groups by changing the maximum permitted number in the
groups table from 0 to OFPG_MAX.
Implementation note:
After translating the actions for each bucket ctx->flow is reset to its
state prior to translation o
Hi,
After a bit of a hiatus I would like to revisit this series.
I have rebased it and addressed the issues which I felt
were conclusively discussed in response to v3 of this patchset.
This series is comprised of two components.
A. Support write actions.
With this in place it is possible to
On Wed, Oct 09, 2013 at 04:08:58PM -0700, Ethan Jackson wrote:
> None of the functions available in ofproto-dpif.h are thread safe
> unless holding the xlate_rwlock because one can't know that an ofproto
> or ofport used as argument will survive during the function call. For
> this reason, ofproto
None of the functions available in ofproto-dpif.h are thread safe
unless holding the xlate_rwlock because one can't know that an ofproto
or ofport used as argument will survive during the function call. For
this reason, ofproto-dpif-upcall's invocation of rule_dpif_lookup()
is unsafe because the o
On Wed, Oct 09, 2013 at 04:50:29PM +0900, YAMAMOTO Takashi wrote:
> Signed-off-by: YAMAMOTO Takashi
Applied, although I'm not certain how valuable the comment is.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Wed, Oct 09, 2013 at 03:24:28PM -0700, Ben Pfaff wrote:
> On Wed, Oct 09, 2013 at 01:50:51PM -0700, Jarno Rajahalme wrote:
> > Signed-off-by: Jarno Rajahalme
>
> Acked-by: Ben Pfaff
Oops, I mean: Applied. Thank you!
___
dev mailing list
dev@openvs
On Wed, Oct 09, 2013 at 01:50:51PM -0700, Jarno Rajahalme wrote:
> Signed-off-by: Jarno Rajahalme
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Signed-off-by: Ben Pfaff
---
FAQ | 11 ---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/FAQ b/FAQ
index d36495c..14fb1c0 100644
--- a/FAQ
+++ b/FAQ
@@ -1235,9 +1235,11 @@ A: To debug network behavior problems, trace the path of
a packet,
Q: How do I make a flow drop
On Wed, Oct 09, 2013 at 11:25:09AM -0700, Alex Wang wrote:
> The changes all make sense and look good to me. still want to discuss with
> you about my understanding later, to see if i fully understand this patch.
OK.
I'll be back in the office on Friday, we can talk then.
___
On Oct 8, 2013, at 5:13 PM, Ben Pfaff wrote:
> The issue is not the minimum Ethernet frame size but the minimum IP
> fragment size. IP fragments are 8-byte aligned and a multiple of 8
> bytes in length. One way to implement a simple firewall that handles
> fragments properly is to pass all "la
Signed-off-by: Jarno Rajahalme
---
lib/meta-flow.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/meta-flow.c b/lib/meta-flow.c
index 3a31c29..73da929 100644
--- a/lib/meta-flow.c
+++ b/lib/meta-flow.c
@@ -2175,7 +2175,7 @@ mf_random_value(const struct mf_field *mf, un
Use the offset of the last member in struct flow instead of the
struct size to help catch changes in the declaration.
Add flow_random_hash_fields() used for testing in places where
struct flow was used without zero initialization before.
With these changes we do not need to keep updating explicit
The changes and tests all look good to me,
On Mon, Sep 23, 2013 at 10:49 AM, Ben Pfaff wrote:
> This support is added through the userspace slow path, because we don't
> judge that this is important enough to require permanent support in the
> Linux kernel ABI.
>
> CC: Teemu Koponen
> CC: Pank
On Oct 8, 2013, at 7:38 PM, Jesse Gross wrote:
> I don't think that it's necessarily a given that the collector can see
> both layers from the transit switches.
True, if the tunnel is encrypted then the transit switch will see *only*
the tunnel. But the analyzer can still know what that traf
Honestly speaking, this patch helps me understand more about how dpif works.
The changes all make sense and look good to me. still want to discuss with
you about my understanding later, to see if i fully understand this patch.
On Mon, Sep 23, 2013 at 10:49 AM, Ben Pfaff wrote:
> Until now, OV
Before this commit, each time ofproto-dpif-monitor thread wakes up,
all monitored ports will be iterated. This adds a hugh overhead to
the monitor thread. This commit uses heap to order the wakeup
time of monitored port. So each time the monitor thread is waken up,
it will only iterate those mon
This commit adds a new function "cfm_wake_time()" that returns the
next wakeup time associated with the "struct cfm".
Signed-off-by: Alex Wang
---
v2 -> v3:
- fix the code duplication.
v1 -> v2:
- rebase to master.
---
lib/cfm.c | 19 +--
lib/cfm.h |1 +
2 files changed,
This commit adds a new function "bfd_wake_time()" that returns the
next wakeup time associated with the "struct bfd".
Signed-off-by: Alex Wang
---
v2 -> v3:
- fix the code duplication.
v1 -> v2:
- rebase to master.
---
lib/bfd.c | 26 --
lib/bfd.h |2 +-
2 files
This commit changes the variable type of priority in "struct heap"
from uint32_t to uint64_t.
Signed-off-by: Alex Wang
---
v2 -> v3:
- no change for this patch
v1 -> v2:
- rebase to master.
---
lib/heap.c |6 +++---
lib/heap.h | 12 ++--
2 files changed, 9 insertions(+), 9 delet
This commit moves the ofproto-dpif-monitor module into a
dedicated thread. This helps eliminate the burden of main
thread having to wake up very frequently for periodic
interface monitoring (bfd, cfm). Also, this commit greatly
increases the number of bfd/cfm sessions that can be supported
by ovs
Hi,
I was sent you a email 7 days before, didn't mean to disturb you. This is Seven
from Mutrade Parking China. Just to be sure, if you would like to add an option
to your supplier.
Mutrade Parking focus on 2 �M 4 post car elevator lift、scissor car elevator、
Puzzle parking system(2-30 flo
This is a first step towards implementing the dpif side of groups.
In order to be useful the action translation code needs
to be taught about groups.
Signed-off-by: Simon Horman
---
v4
* No change
v3
* Rebase for "ofproto-dpif: Hide struct rule_dpif internally"
* Hide group_dpif in a similar
Allow translation of indirect and all groups. Also allow insertion of
indirect and all groups by changing the maximum permitted number in the
groups table from 0 to OFPG_MAX.
Implementation note:
After translating the actions for each bucket ctx->flow is reset to its
state prior to translation o
Implementation note:
All actions which modify a field are added to the action set
at the point where "set" actions should be added. In general
modifying a field many times is the same as only modifying it
the last time so the implementation simply adds all set actions to
the action set in the orde
Hi,
After a bit of a hiatus I would like to revisit this series.
I have rebased it and addressed the issues which I felt
were conclusively discussed in response to v3 of this patchset.
This series is comprised of two components.
A. Support write actions.
With this in place it is possible to
PLEASE CAN YOU HELP ME ?
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Wed, Oct 9, 2013 at 12:31 AM, Ben Pfaff wrote:
> Thank you for the contribution.
>
> My only overall comment is that this series seems to be broken up into
> too many patches. I think that it's logically a one or two patch
> series.
Thank you for the feedback. I will try to address all the is
Signed-off-by: YAMAMOTO Takashi
---
tests/ofp-print.at | 1 +
1 file changed, 1 insertion(+)
diff --git a/tests/ofp-print.at b/tests/ofp-print.at
index 52b84ef..87d5da8 100644
--- a/tests/ofp-print.at
+++ b/tests/ofp-print.at
@@ -996,6 +996,7 @@ OFPT_TABLE_MOD (OF1.2) (xid=0x2): table_id=2,
flo
Signed-off-by: YAMAMOTO Takashi
---
OPENFLOW-1.1+ | 9 +
1 file changed, 9 insertions(+)
diff --git a/OPENFLOW-1.1+ b/OPENFLOW-1.1+
index 90f811f..6fabde1 100644
--- a/OPENFLOW-1.1+
+++ b/OPENFLOW-1.1+
@@ -124,6 +124,15 @@ didn't compare the specs carefully yet.)
[optional for OF1
45 matches
Mail list logo