Re: [ovs-dev] [PATCH 0/5] ipv4_tunnels: Modularize ipv4 tunneling.

2013-01-09 Thread David Miller
From: Pravin B Shelar Date: Mon, 7 Jan 2013 18:31:32 -0800 > Following patch series restructure GRE and IPIP tunneling code > to make it modular. It adds ip_tunnel module which acts as > generic tunneling layer which has common code. I have patch > to do same for VXLAN too. > > In Addidtion to

[ovs-dev] [PATCH] netdev-vport: Remove useless struct netdev-vport.

2013-01-09 Thread Ethan Jackson
Signed-off-by: Ethan Jackson --- lib/netdev-vport.c | 25 - 1 file changed, 4 insertions(+), 21 deletions(-) diff --git a/lib/netdev-vport.c b/lib/netdev-vport.c index e0e9479..d6a17a9 100644 --- a/lib/netdev-vport.c +++ b/lib/netdev-vport.c @@ -59,10 +59,6 @@ struct ne

Re: [ovs-dev] [leaks 7/7] tests: Fix memory leaks in test-classifier program.

2013-01-09 Thread Ethan Jackson
Acked-by: Ethan Jackson On Wed, Dec 26, 2012 at 12:38 PM, Ben Pfaff wrote: > Signed-off-by: Ben Pfaff > --- > tests/test-classifier.c | 19 +-- > 1 files changed, 17 insertions(+), 2 deletions(-) > > diff --git a/tests/test-classifier.c b/tests/test-classifier.c > index 79c

Re: [ovs-dev] [leaks 6/7] classifier: Fix theoretical leak in classifier_destroy().

2013-01-09 Thread Ethan Jackson
Acked-by: Ethan Jackson On Wed, Dec 26, 2012 at 12:38 PM, Ben Pfaff wrote: > The open-coded version of destroy_table() in classifier_destroy() didn't > free the table's minimatch. Use destroy_table() to do it properly. > > This is only a theoretical leak because all the existing callers actua

[ovs-dev] [PATCH] alloc_ofp_port does not allocate the port number correctly

2013-01-09 Thread Krishna Kondaka
From: Krishna Kondaka alloc_ofp_port() does not allocate the port number correctly if the port number passed initially is already in use. The following if block if (ofp_port >= ofproto->max_ports || bitmap_is_set(ofproto->ofp_port_ids, ofp_port)) { is entered when either of the two

Re: [ovs-dev] [PATCH 4/4] ofproto: Implement IPFIX exporter

2013-01-09 Thread Ben Pfaff
On Tue, Dec 18, 2012 at 11:52:12AM -0800, Romain Lenglet wrote: > Send one IPFIX data record message for every packet sampled by a > sample_ipfix action, and send IPFIX template set messages > periodically. Automatically generate IPFIX entity definitions from > the IANA specs. > > Signed-off-by:

[ovs-dev] [RFC flow tunnels 8/8] tests: Add tunnel unit tests.

2013-01-09 Thread Ethan Jackson
This commit adds unit tests which exercise the flow based tunneling code added in previous patches. Signed-off-by: Ethan Jackson --- tests/automake.mk |1 + tests/testsuite.at |1 + tests/tunnel.at| 312 3 files changed, 314 inse

[ovs-dev] [RFC flow tunnels 7/8] lib: Switch to flow based tunneling.

2013-01-09 Thread Ethan Jackson
With this patch, ovs-vswitchd uses flow based tunneling exclusively. I.E. each kind of tunnel shares a single tunnel backer in the datapath. Tunnel headers are set by userspace using the ipv4_tunnel datapath action. There are still some significant pieces of work to do, but the basic building bl

[ovs-dev] [RFC flow tunnels 6/8] netdev: New function netdev_get_dpif_port().

2013-01-09 Thread Ethan Jackson
In future patches, a netdev's datapath port name may not necessarily be the same as it's device name. This patch prepares for this by making the distinction in the netdev and dpif layers. Signed-off-by: Ethan Jackson --- lib/dpif-linux.c |4 ++-- lib/dpif-netdev.c | 17 +--

[ovs-dev] [RFC flow tunnels 2/8] dpif-netdev: Allow stub interfaces on the dummy datapath.

2013-01-09 Thread Ethan Jackson
Future patches will need to add netdevs to the dummy datapath which can't actually send or receive packets. Signed-off-by: Ethan Jackson --- lib/dpif-netdev.c | 11 +-- 1 file changed, 9 insertions(+), 2 deletions(-) diff --git a/lib/dpif-netdev.c b/lib/dpif-netdev.c index 682dfc9..d0

[ovs-dev] [RFC flow tunnels 5/8] tunnel: Userspace implementation of tunnel manipulation.

2013-01-09 Thread Ethan Jackson
From: Jesse Gross The kernel tunneling code currently needs to handle a large number of operations when tunnel packets are encapsulated and decapsulated. Some examples of this are: finding the correct tunnel port on receive, TTL and ToS inheritance, ECN handling, etc. All of these can be done on

[ovs-dev] [RFC flow tunnels 1/8] tunnels: Remove support for df_inherit from userspace.

2013-01-09 Thread Ethan Jackson
This will be required to support flow based tunneling. Signed-off-by: Ethan Jackson --- NEWS |2 ++ lib/netdev-vport.c |6 ++ vswitchd/vswitch.xml | 14 +++--- 3 files changed, 7 insertions(+), 15 deletions(-) diff --git a/NEWS b/NEWS index ab7ef4d..d30c4

[ovs-dev] [RFC flow tunnels 0/8] Flow based tunneling.

2013-01-09 Thread Ethan Jackson
The first 5 patches of this series are ready to be merged (pending review), though we may want to hold off until the last two are ready. There are still some significant missing features required before the last two patches can be merged (see TODO in ofproto/tunnel.c). Ethan Jackson (7): tunnel

[ovs-dev] [RFC flow tunnels 4/8] netdev: Parse and make available tunnel configuration.

2013-01-09 Thread Ethan Jackson
Future patches will need to know the details of a netdev's tunnel configuration from outside the netdev library. Signed-off-by: Ethan Jackson --- lib/netdev-dummy.c|1 + lib/netdev-linux.c|1 + lib/netdev-provider.h |7 +++ lib/netdev-vport.c| 154 +++

[ovs-dev] [RFC flow tunnels 3/8] netdev-vport: Create new TUNNEL_CLASS macro.

2013-01-09 Thread Ethan Jackson
There are a lot of tunnels, and they all use the exact same functions, so it makes sense to collapse their initialization into a macro. Suggested-by: Jesse Gross Signed-off-by: Ethan Jackson --- lib/netdev-vport.c | 34 +++--- 1 file changed, 11 insertions(+), 23 d

Re: [ovs-dev] [PATCH] ofproto: Fix remaining incorrect users of OVSP_LOCAL.

2013-01-09 Thread Justin Pettit
On Jan 9, 2013, at 10:01 AM, Ben Pfaff wrote: > On Tue, Jan 08, 2013 at 04:49:11PM -0800, Justin Pettit wrote: >> In the switch to a single datapath, the simple mapping between >> OFPP_LOCAL and OVSP_LOCAL was broken. Unfortunately, a couple of >> translations were missed, so this commit fixes t

Re: [ovs-dev] [PATCH] dpif: Add much more documentation.

2013-01-09 Thread Ben Pfaff
Thanks, I applied it to master. On Wed, Jan 09, 2013 at 02:38:16PM -0800, Justin Pettit wrote: > Looks great. Thanks. > > --Justin > > > On Jan 9, 2013, at 2:10 PM, Ben Pfaff wrote: > > > On Tue, Jan 08, 2013 at 06:16:58PM -0800, Justin Pettit wrote: > >>> + *- A "flow", that is, a summa

Re: [ovs-dev] [PATCH] dpif: Add much more documentation.

2013-01-09 Thread Justin Pettit
Looks great. Thanks. --Justin On Jan 9, 2013, at 2:10 PM, Ben Pfaff wrote: > On Tue, Jan 08, 2013 at 06:16:58PM -0800, Justin Pettit wrote: >>> + *- A "flow", that is, a summary of the headers in a Ethernet packet. >>> The >> >> s/a/an/ > > Fixed. > >> This sort of sounds like only t

Re: [ovs-dev] [PATCH] datapath: Change the single ENOENT return value to ENODEV...

2013-01-09 Thread Jesse Gross
On Wed, Jan 9, 2013 at 12:16 PM, Jarno Rajahalme wrote: > > On Jan 9, 2013, at 20:19 , ext Jesse Gross wrote: > >> On Wed, Jan 9, 2013 at 2:33 AM, Jarno Rajahalme >> wrote: >>> >>> On Jan 8, 2013, at 21:07 , ext Jesse Gross wrote: >>> On Tue, Jan 8, 2013 at 3:41 AM, Jarno Rajahalme w

Re: [ovs-dev] [PATCH] ofproto-dpif: Eliminate unneeded call to ofproto_dpif_cast().

2013-01-09 Thread Ben Pfaff
Thanks, I applied this to master. On Wed, Jan 09, 2013 at 11:56:32PM +0200, Jarno Rajahalme wrote: > Looks the same as the other, which is good :-) > > Jarno > > On Jan 9, 2013, at 20:31 , ext Ben Pfaff wrote: > > > I noticed this was unneeded while looking over commit 7c33b18807804f > > (ofpr

Re: [ovs-dev] [PATCH] dpif: Add much more documentation.

2013-01-09 Thread Ben Pfaff
On Tue, Jan 08, 2013 at 06:16:58PM -0800, Justin Pettit wrote: > > + *- A "flow", that is, a summary of the headers in a Ethernet packet. > > The > > s/a/an/ Fixed. > This sort of sounds like only the Ethernet header fields make up the > flow. Maybe "L2/L3/L4 headers" or something like th

Re: [ovs-dev] [PATCH] ofproto-dpif: Eliminate unneeded call to ofproto_dpif_cast().

2013-01-09 Thread Jarno Rajahalme
Looks the same as the other, which is good :-) Jarno On Jan 9, 2013, at 20:31 , ext Ben Pfaff wrote: > I noticed this was unneeded while looking over commit 7c33b18807804f > (ofproto-dpif: More efficient implementation of get_odp_port().). > > Signed-off-by: Ben Pfaff > --- > ofproto/ofproto-

Re: [ovs-dev] [PATCH 3/3] bond: Fix comment on bond_entry::tag

2013-01-09 Thread Ben Pfaff
On Mon, Jan 07, 2013 at 10:39:56PM +, Zoltan Kiss wrote: > On 07/01/13 19:33, Ben Pfaff wrote: > >On Sat, Jan 05, 2013 at 09:42:16PM +, Zoltan Kiss wrote: > >>The hash entry tag connects to facet(s), not slaves. > >> > >>Signed-off-by: Zoltan Kiss > >>--- > >> lib/bond.c | 2 +- > >> 1 fi

Re: [ovs-dev] [PATCH 1/3] bond: Change rebalance ratio to be more fair

2013-01-09 Thread Ben Pfaff
Done. On Tue, Jan 08, 2013 at 12:16:34PM +, Zoltan Kiss wrote: > Thanks, can you merge it to 1.4 branch please? We plan to release > this in an XS 6.1 hotfix sometime. > > Zoli > > On 07/01/13 23:16, Ben Pfaff wrote: > >On Mon, Jan 07, 2013 at 10:47:51PM +, Zoltan Kiss wrote: > >>The old

Re: [ovs-dev] [PATCH] ofproto-dpif: More efficient implementation of get_odp_port().

2013-01-09 Thread Ben Pfaff
On Wed, Jan 09, 2013 at 10:25:14PM +0200, Jarno Rajahalme wrote: > On Jan 9, 2013, at 20:30 , ext Ben Pfaff wrote: > > > On Wed, Jan 09, 2013 at 02:21:47PM +0200, Jarno Rajahalme wrote: > >> Avoids unnecessary hash bucket traversal (ofproto_get_port()), since we > >> have the ofport_dpif already a

Re: [ovs-dev] [PATCH] ofproto-dpif: More efficient implementation of get_odp_port().

2013-01-09 Thread Jarno Rajahalme
On Jan 9, 2013, at 20:30 , ext Ben Pfaff wrote: > On Wed, Jan 09, 2013 at 02:21:47PM +0200, Jarno Rajahalme wrote: >> Avoids unnecessary hash bucket traversal (ofproto_get_port()), since we >> have the ofport_dpif already after odp_port_to_ofport(). >> >> Signed-off-by: Jarno Rajahalme > > Than

Re: [ovs-dev] [PATCH] datapath: Change the single ENOENT return value to ENODEV...

2013-01-09 Thread Jarno Rajahalme
On Jan 9, 2013, at 20:19 , ext Jesse Gross wrote: > On Wed, Jan 9, 2013 at 2:33 AM, Jarno Rajahalme > wrote: >> >> On Jan 8, 2013, at 21:07 , ext Jesse Gross wrote: >> >>> On Tue, Jan 8, 2013 at 3:41 AM, Jarno Rajahalme >>> wrote: Userspace code will need to keep on checking for both E

Re: [ovs-dev] [PATCH] datapath: Fix a kernel crash when adding a 2nd VXLAN port with existing UDP port

2013-01-09 Thread Jesse Gross
On Wed, Jan 9, 2013 at 11:47 AM, Kyle Mestery wrote: > When creating a second VXLAN tunnel port with the same UDP > port as an existing VXLAN tunnel port, make sure to set > *vxport before returning. Fixes a kernel crash. > > Reported-by: Todd Ruch > Signed-off-by: Kyle Mestery Applied, thanks

Re: [ovs-dev] [PATCHv2] dpif-linux: Give each port its own userspace-kernel channel.

2013-01-09 Thread Ben Pfaff
Thanks for the revision. I have some further comments. On Mon, Jan 07, 2013 at 05:32:29PM -0800, Justin Pettit wrote: > +- The Linux datapath implementation creates a different kernel- > + userspace channel for each port instead of sharing a static 16 > + channels to provide better

[ovs-dev] [PATCH] datapath: Fix a kernel crash when adding a 2nd VXLAN port with existing UDP port

2013-01-09 Thread Kyle Mestery
When creating a second VXLAN tunnel port with the same UDP port as an existing VXLAN tunnel port, make sure to set *vxport before returning. Fixes a kernel crash. Reported-by: Todd Ruch Signed-off-by: Kyle Mestery --- datapath/vport-vxlan.c | 1 + 1 file changed, 1 insertion(+) diff --git a/da

Re: [ovs-dev] [ovs-discuss] How to specify the OF version in OVS?

2013-01-09 Thread Ben Pfaff
On Wed, Jan 09, 2013 at 07:15:26PM +, Jing Ai wrote: > > Thanks for documenting it. It really helps. > I have one follow-up question. Is this command valid only in the > master now? That is correct. > Therefore, does OVS 1.9 and previous version support all OF versions > by default? OVS sup

Re: [ovs-dev] [ovs-discuss] How to specify the OF version in OVS?

2013-01-09 Thread Jing Ai
Thanks for documenting it. It really helps. I have one follow-up question. Is this command valid only in the master now? I just tried OVS 1.9 branch, ovs-vsctl does not understand "protocols". ovs-vsctl list bridge_uuid : 84b55699-399e-4cd4-8838-81270aa8600ccontroller : []

[ovs-dev] [PATCH] ofproto-dpif: Eliminate unneeded call to ofproto_dpif_cast().

2013-01-09 Thread Ben Pfaff
I noticed this was unneeded while looking over commit 7c33b18807804f (ofproto-dpif: More efficient implementation of get_odp_port().). Signed-off-by: Ben Pfaff --- ofproto/ofproto-dpif.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/ofproto/ofproto-dpif.c b/ofproto/of

Re: [ovs-dev] [PATCH] ofproto-dpif: More efficient implementation of get_odp_port().

2013-01-09 Thread Ben Pfaff
On Wed, Jan 09, 2013 at 02:21:47PM +0200, Jarno Rajahalme wrote: > Avoids unnecessary hash bucket traversal (ofproto_get_port()), since we > have the ofport_dpif already after odp_port_to_ofport(). > > Signed-off-by: Jarno Rajahalme Thanks! I was able to simplify the test to eliminate the ofpro

Re: [ovs-dev] [PATCH] datapath: Change the single ENOENT return value to ENODEV...

2013-01-09 Thread Jesse Gross
On Wed, Jan 9, 2013 at 2:33 AM, Jarno Rajahalme wrote: > > On Jan 8, 2013, at 21:07 , ext Jesse Gross wrote: > >> On Tue, Jan 8, 2013 at 3:41 AM, Jarno Rajahalme >> wrote: >>> Userspace code will need to keep on checking for both ENODEV and ENOENT as >>> long as older kernel modules are around.

Re: [ovs-dev] [PATCH] ofproto: Fix remaining incorrect users of OVSP_LOCAL.

2013-01-09 Thread Ben Pfaff
On Tue, Jan 08, 2013 at 04:49:11PM -0800, Justin Pettit wrote: > In the switch to a single datapath, the simple mapping between > OFPP_LOCAL and OVSP_LOCAL was broken. Unfortunately, a couple of > translations were missed, so this commit fixes them. > > Reported-by: Jesse Gross > Signed-off-by:

[ovs-dev] [PATCH] ofproto-dpif: More efficient implementation of get_odp_port().

2013-01-09 Thread Jarno Rajahalme
Avoids unnecessary hash bucket traversal (ofproto_get_port()), since we have the ofport_dpif already after odp_port_to_ofport(). Signed-off-by: Jarno Rajahalme --- ofproto/ofproto-dpif.c |7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git a/ofproto/ofproto-dpif.c b/ofproto

Re: [ovs-dev] [PATCH] datapath: Change the single ENOENT return value to ENODEV...

2013-01-09 Thread Jarno Rajahalme
On Jan 8, 2013, at 21:07 , ext Jesse Gross wrote: > On Tue, Jan 8, 2013 at 3:41 AM, Jarno Rajahalme > wrote: >> Userspace code will need to keep on checking for both ENODEV and ENOENT as >> long as older kernel modules are around. >> >> Signed-off-by: Jarno Rajahalme > > OVS userspace actual