[ovs-dev] [PATCH] ofp-actions: Allow write_metadata instruction before goto_table instruction.

2013-01-02 Thread Jing Ai
In the current codes, when running "ovs-ofctl add-flow br0 ,actions=write_metadata:<64-bit metadata>,goto_table:", it gives the following error:2012-12-29T00:23:23Z|1|ofp_actions|WARN|write_metadata instruction must be specified after other instructions/actionsovs-ofctl: Incorrect instruct

Re: [ovs-dev] Fwd: [ovs-discuss] Regarding open-vSwitch errors

2013-01-02 Thread APURVA PATIL
And how does that occur in Bridge networking ?? On Thu, Jan 3, 2013 at 10:19 AM, Jesse Gross wrote: > On Wed, Jan 2, 2013 at 7:48 PM, APURVA PATIL wrote: > > > > On establishing the open-vSwitch connection on the host , I have a doubt > in > > properly understanding the folloowing problems :

Re: [ovs-dev] Fwd: [ovs-discuss] Regarding open-vSwitch errors

2013-01-02 Thread Jesse Gross
On Wed, Jan 2, 2013 at 7:48 PM, APURVA PATIL wrote: > > On establishing the open-vSwitch connection on the host , I have a doubt in > properly understanding the folloowing problems : > > I am not getting the networking details how does the host gets Internet > connectivity even when the eth0 gets

[ovs-dev] Fwd: [ovs-discuss] Regarding open-vSwitch errors

2013-01-02 Thread APURVA PATIL
On establishing the open-vSwitch connection on the host , I have a doubt in properly understanding the folloowing problems : I am not getting the networking details how does the host gets Internet connectivity even when the eth0 gets an IP of 0.0.0.0? Is it through br0? What doe up while specify

Re: [ovs-dev] [PATCH 1/6] ofproto-dpif: New function ofproto_receive().

2013-01-02 Thread Jesse Gross
On Wed, Jan 2, 2013 at 5:00 PM, Ethan Jackson wrote: > Sounds good. I've applied the following minor changes to the patch which I > think is good enough for now. Let me know if there's anthing else that needs > to change before we do the appropriate refactoring. There's one other thing that I h

[ovs-dev] [PATCH 12/16] dpif-netdev: Inner And Outer Flows

2013-01-02 Thread Simon Horman
This is the user-space datapath component of this change Allow a flow to be visible in two forms, an outer flow and an inner flow. This may occur if the actions allow further decoding of a packet to provide a more fine-grained match. In this case the first-pass coarse-grained match will hit the ou

[ovs-dev] [PATCH 15/16] Add support for copy_ttl_out action

2013-01-02 Thread Simon Horman
This adds support for the OpenFlow 1.1+ copy_ttl_out action. And also adds an NX copy_ttl_out action. The implementation does not support copying in the case where the outermost header is IP as it is unclear to me that Open vSwtich has a notion of an inner IP header to copy the TLL from. The hand

[ovs-dev] [PATCH 16/16] Add support for copy_ttl_in action

2013-01-02 Thread Simon Horman
This adds support for the OpenFlow 1.1+ copy_ttl_in action. And also adds an NX copy_ttl_out action. The implementation does not support copying in the case where the outermost header is IP as it is unclear to me that Open vSwtich has a notion of an inner IP header to copy the TLL from. The imple

[ovs-dev] [PATCH 01/16] datapath: Add basic MPLS support to kernel

2013-01-02 Thread Simon Horman
Allow datapath to recognize and extract MPLS labels into flow keys and execute actions which push, pop, and set labels on packets. Based heavily on work by Leo Alterman and Ravi K. Cc: Ravi K Cc: Leo Alterman Reviewed-by: Isaku Yamahata Signed-off-by: Simon Horman --- v2.13 * As suggested b

[ovs-dev] [PATCH 11/16] ofproto: Allow actions richer matches based on actions

2013-01-02 Thread Simon Horman
If the actions of a flow allow further decoding of L3 and L4 data to provide a richer match then use this richer match. For example: In the case of MPLS, L3 and L4 information may not initially be decoded from the frame as the ethernet type of the frame is an MPLS type and no information is known

[ovs-dev] [PATCH 0/16 v2.13] Basic MPLS actions and matches

2013-01-02 Thread Simon Horman
Hi, This series implements basic MPLS actions and matches based on work by Ravi K, Leo Alterman and Yamahata-san. The main limitation of this implementation is that it only supports manipulating the outer-most MPLS label. Key differences between the v2.12 and v2.13: * Rebase * Add Inner and Oute

[ovs-dev] [PATCH 14/16] Add support for set_mpls_ttl action

2013-01-02 Thread Simon Horman
This adds support for the OpenFlow 1.1+ set_mpls_ttl action. And also adds an NX set_mpls_ttl action. The handling of the TTL modification is entirely handled in userspace. Reviewed-by: Isaku Yamahata Signed-off-by: Simon Horman --- v2.13 * No change v2.12 * Use eth_type_mpls() helper v2.11

[ovs-dev] [PATCH 06/16] datapath: Allow IP actions for MPLS

2013-01-02 Thread Simon Horman
Allow copy_ttl_in to function in the case where: a) The outer header is MPLS; b) The next-outer header is IP and; c) The resulting nw ttl will be different from its existing value In this circumstance a set ipv4 action will be used to adjust the TTL but the dl_type of the match will be ETH_P_MPLS_

[ovs-dev] [PATCH 02/16] datapath: Split ovs_flow_extract

2013-01-02 Thread Simon Horman
Allow repeated extraction of flow from packets Split the L3 and above portion of ovs_flow_extract() out into ovs_flow_extract_l3_onwards() and call ovs_flow_extract_l3_onwards() from ovs_flow_extract(). This is to allow re-extraction of L3 and higher information using an ethernet type supplied by

[ovs-dev] [PATCH 09/16] packet: packet_get_tcp_flags: use flow's innermost dl_type

2013-01-02 Thread Simon Horman
Use the innermost dl_type when decoding L3 and L4 data from a packet. Signed-off-by: Simon Horman --- v2.13 * No change v2.12 * Use flow_innermost_dl_type helper v2.11 * First post --- lib/packets.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/lib/packets.c b/li

[ovs-dev] [PATCH 13/16] Add support for dec_mpls_ttl action

2013-01-02 Thread Simon Horman
This adds support for the OpenFlow 1.1+ dec_mpls_ttl action. And also adds an NX dec_mpls_ttl action. The handling of the TTL modification is entirely handled in userspace. Reviewed-by: Isaku Yamahata Signed-off-by: Simon Horman --- v2.13 * No change v2.12 * Use eth_type_mpls() helper v2.11

[ovs-dev] [PATCH 10/16] actions: Allow secondary decoding of a flow

2013-01-02 Thread Simon Horman
Actions may provide information to allow further decoding of a flow. For example: In the case of MPLS, L3 and L4 information may not initially be decoded from the frame as the ethernet type of the frame is an MPLS type and no information is known about the type of the inner frame. However, the t

[ovs-dev] [PATCH 03/16] datapath: Inner And Outer Flows

2013-01-02 Thread Simon Horman
Allow a flow to be visible in two forms, an outer flow and an inner flow. This may occur if the actions allow further decoding of a packet to provide a more fine-grained match. In this case the first-pass coarse-grained match will hit the outer-flow and the second-pass fined-grained match will hit

[ovs-dev] [PATCH 04/16] datapath: ovs_flow_to_nlattrs: use encap_eth_type

2013-01-02 Thread Simon Horman
The ethernet type of an encapsulated frame may be obtained from actions. If so it should be used to allow a richer conversion of a flow to nlattrs. Signed-off-by: Simon Horman --- v2.13 * No change v2.12 * No change v2.11 * First post --- datapath/datapath.c |4 ++-- datapath/flow.c

[ovs-dev] [PATCH 05/16] datapath: ovs_flow_used: use encap_eth_type

2013-01-02 Thread Simon Horman
The ethernet type of an encapsulated frame may be obtained from actions. If so it should be used to correct decoding of L3 and L4 packet data. Signed-off-by: Simon Horman --- v2.13 * As suggested by Jarno Rajahalme - Initialise encap_eth_type as 0 in ovs_dp_process_received_packet() v2.12 *

[ovs-dev] [PATCH 08/16] odp-util: commit_set_nw_action: use flow's innermost dl_type

2013-01-02 Thread Simon Horman
Use the innermost dl_type when decoding L3 and L4 data from a packet. Signed-off-by: Simon Horman --- v2.13 * No change v2.12 * Use flow_innermost_dl_type helper v2.11 * First post --- lib/odp-util.c |6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/lib/odp-util.c

Re: [ovs-dev] [PATCH 5/6] vswitch: Remove PMTUD support from userspace.

2013-01-02 Thread Ethan Jackson
> I would spell this out as tunnel path MTU discovery since it's > probably not obvious to most people but otherwise this looks good. > Changed. Thanks for the review. Ethan ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listin

Re: [ovs-dev] [PATCH 4/6] netdev-vport: New helper netdev_get_vport_dev().

2013-01-02 Thread Ethan Jackson
> I'd be inclined to call this netdev_vport_get_dev() instead since it > currently sounds like something that I would expect to find in > netdev.c but otherwise this looks fine. > Good idea, I changed the name. Thanks for the review. Ethan ___ dev mail

Re: [ovs-dev] [PATCH 3/6] netdev: Rename get_drv_info() to get_status().

2013-01-02 Thread Ethan Jackson
> Not sure why you moved the function implementations around, I couldn't > tell at a glance whether there were any real changes. > It marginally improved the diffs in some future patches. Nothing should have changed. Thanks for the reviews, I'll merge this soon. Ethan __

Re: [ovs-dev] [PATCH 2/6] netdev-vport: Fix theoretical null pointer dereference.

2013-01-02 Thread Ethan Jackson
> I think making it fetch the config is the right thing to do, although > since the code is going away and it's not a current problem it may not > be worth it (although I think the necessary refactoring is minimal). > I'm going to make a judgement call on this one and say it's not worth it given t

Re: [ovs-dev] [PATCH 2/6] netdev-vport: Fix theoretical null pointer dereference.

2013-01-02 Thread Ethan Jackson
Thanks for the comments, I've folded them in. On Thu, Dec 27, 2012 at 11:34 AM, Ben Pfaff wrote: > On Wed, Dec 26, 2012 at 05:16:42PM -0800, Ethan Jackson wrote: > > Theoretically, it's possible for netdev_get_status() to be called > > on a netdev-vport which hasn't had it's configuration set ye

[ovs-dev] [bug 14265 3/3] rconn: Fix null pointer dereference in rconn_add_monitor().

2013-01-02 Thread Ben Pfaff
rconn_add_monitor() tries to check the version of the controller connection being monitored, so that it can decide what OpenFlow version to tell the monitor connection to negotiate. But at any given time an rconn may not have a controller connection (e.g. during backoff), so rc->vconn may be null

[ovs-dev] [bug 14265 1/3] vconn: Fix parameters for vconn_open(), vconn_open_block(), pvconn_open().

2013-01-02 Thread Ben Pfaff
The customary parameter order in Open vSwitch is to put input parameters before output parameters, but vconn_open() and pvconn_open() had the 'dscp' input parameter at the end, which bugged me a bit. Also, vconn_open_block() didn't take a 'dscp' parameter at all even though it's otherwise a wrappe

[ovs-dev] [bug 14265 2/3] ovs-ofctl: Use vconn_open() instead of vconn_open_block() in open_vconn__().

2013-01-02 Thread Ben Pfaff
All of the paths in open_vconn__(), except the one path that calls vconn_open() directly, just start the connection and do not block until it completes. This changes the remaining path to work the same way. This will be important in an upcoming commit when in some cases we need to take an action

Re: [ovs-dev] [PATCH 1/6] ofproto-dpif: New function ofproto_receive().

2013-01-02 Thread Ethan Jackson
Sounds good. I've applied the following minor changes to the patch which I think is good enough for now. Let me know if there's anthing else that needs to change before we do the appropriate refactoring. Ethan --- ofproto/ofproto-dpif.c |6 +- 1 file changed, 5 insertions(+), 1 deletio

Re: [ovs-dev] [PATCH 1/1] lacp: Fix dumping of aggregation key

2013-01-02 Thread Ethan Jackson
Thanks for the patch. I made some minor tweaks to the commit message and merged it. Ethan On Wed, Jan 2, 2013 at 9:23 AM, Anoob Soman wrote: > While dumping lacp information using ovs-appctl, "aggregation key" field > displays port_id even though aggregation-key is set using > "other-config:la

Re: [ovs-dev] [PATCH] ovs-ofctl: Document to work with any OpenFlow switch.

2013-01-02 Thread Ethan Jackson
Acked-by: Ethan Jackson On Wed, Jan 2, 2013 at 9:56 AM, Ben Pfaff wrote: > I've always intended ovs-ofctl to work with any OpenFlow switch, not just > with Open vSwitch. This explicitly documents that intention. > > Signed-off-by: Ben Pfaff > --- > utilities/ovs-ofctl.8.in |1 + > 1 fil

Re: [ovs-dev] [PATCH] manpages: Put version number instead of date at bottom of page.

2013-01-02 Thread Ethan Jackson
Acked-by: Ethan Jackson On Wed, Jan 2, 2013 at 10:19 AM, Ben Pfaff wrote: > We're really good about keeping manpages up to date, but terrible at > updating the dates at the bottom of the manpages. So, instead of using > manually updated dates, this commit switches to using automatically updat

Re: [ovs-dev] [PATCH] bridge: Log version number precisely once.

2013-01-02 Thread Ethan Jackson
Thanks I merged this. Ethan On Wed, Jan 2, 2013 at 1:33 PM, Ben Pfaff wrote: > On Wed, Jan 02, 2013 at 01:29:44PM -0800, Ethan Jackson wrote: > > Before this patch, ovs-vswitchd logged its version number every > > time the database changed. > > > > Signed-off-by: Ethan Jackson > > Looks good,

Re: [ovs-dev] [PATCH] bridge: Log version number precisely once.

2013-01-02 Thread Ben Pfaff
On Wed, Jan 02, 2013 at 01:29:44PM -0800, Ethan Jackson wrote: > Before this patch, ovs-vswitchd logged its version number every > time the database changed. > > Signed-off-by: Ethan Jackson Looks good, thanks. ___ dev mailing list dev@openvswitch.org

[ovs-dev] [PATCH] bridge: Log version number precisely once.

2013-01-02 Thread Ethan Jackson
Before this patch, ovs-vswitchd logged its version number every time the database changed. Signed-off-by: Ethan Jackson --- vswitchd/bridge.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/vswitchd/bridge.c b/vswitchd/bridge.c index e58c3c4..beb8b93 100644 --- a/vswitchd/

[ovs-dev] [PATCH] manpages: Put version number instead of date at bottom of page.

2013-01-02 Thread Ben Pfaff
We're really good about keeping manpages up to date, but terrible at updating the dates at the bottom of the manpages. So, instead of using manually updated dates, this commit switches to using automatically updated version numbers. We can only use automatically updated version numbers for manpag

[ovs-dev] [PATCH] ovs-ofctl: Document to work with any OpenFlow switch.

2013-01-02 Thread Ben Pfaff
I've always intended ovs-ofctl to work with any OpenFlow switch, not just with Open vSwitch. This explicitly documents that intention. Signed-off-by: Ben Pfaff --- utilities/ovs-ofctl.8.in |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/utilities/ovs-ofctl.8.in b/utilit

[ovs-dev] [PATCH 1/1] lacp: Fix dumping of aggregation key

2013-01-02 Thread Anoob Soman
While dumping lacp information using ovs-appctl, "aggregation key" field displays port_id even though aggregation-key is set using "other-config:lacp-aggregation-key". Signed-off-by: Anoob Soman --- lib/lacp.c |4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/lib/lacp.c b