On 12/01/2012 01:27 AM, Jesse Gross wrote:
On Fri, Nov 30, 2012 at 4:24 PM, Ben Pfaff wrote:
On Fri, Nov 30, 2012 at 04:20:33PM -0800, Jesse Gross wrote:
It might not be a bad idea to make mark hex as well.
I don't know anything about the semantics of skb_mark. I'll take your
word for it.
Previously, ovs-ctl would determine which bridges to run "ovs-save
save-flows" on by running "ovs-vsctl list-br". In addition to real
bridges, that command also returns fake bridges. An error is returned
when "ovs-save save-flows" is run on a fake bridge. By using the newly
added "--only-real" f
By default, "ovs-vsctl list-br" returns all bridges, real or fake. This
commit adds a "--only-real" option that limits the output to only real
bridges. This will be useful in a future commit that needs to perform
actions only on real bridges.
Signed-off-by: Justin Pettit
---
utilities/ovs-vsct
On Fri, Nov 30, 2012 at 5:04 PM, Ansis Atteka wrote:
> On Fri, Nov 30, 2012 at 4:27 PM, Jesse Gross wrote:
>> On Fri, Nov 30, 2012 at 4:24 PM, Ben Pfaff wrote:
>>> On Fri, Nov 30, 2012 at 04:20:33PM -0800, Jesse Gross wrote:
On Fri, Nov 30, 2012 at 4:13 PM, Ben Pfaff wrote:
> On Fri,
On Fri, Nov 30, 2012 at 4:27 PM, Jesse Gross wrote:
> On Fri, Nov 30, 2012 at 4:24 PM, Ben Pfaff wrote:
>> On Fri, Nov 30, 2012 at 04:20:33PM -0800, Jesse Gross wrote:
>>> On Fri, Nov 30, 2012 at 4:13 PM, Ben Pfaff wrote:
>>> > On Fri, Nov 30, 2012 at 04:07:29PM -0800, Ansis Atteka wrote:
>>> >>
On Fri, Nov 30, 2012 at 4:24 PM, Ben Pfaff wrote:
> On Fri, Nov 30, 2012 at 04:20:33PM -0800, Jesse Gross wrote:
>> On Fri, Nov 30, 2012 at 4:13 PM, Ben Pfaff wrote:
>> > On Fri, Nov 30, 2012 at 04:07:29PM -0800, Ansis Atteka wrote:
>> >> This patch adds logging support for skb_mark and skb_prior
On Fri, Nov 30, 2012 at 04:20:33PM -0800, Jesse Gross wrote:
> On Fri, Nov 30, 2012 at 4:13 PM, Ben Pfaff wrote:
> > On Fri, Nov 30, 2012 at 04:07:29PM -0800, Ansis Atteka wrote:
> >> This patch adds logging support for skb_mark and skb_priority.
> >>
> >> Signed-off-by: Ansis Atteka
> >
> > skb_p
On Fri, Nov 30, 2012 at 4:13 PM, Ben Pfaff wrote:
> On Fri, Nov 30, 2012 at 04:07:29PM -0800, Ansis Atteka wrote:
>> This patch adds logging support for skb_mark and skb_priority.
>>
>> Signed-off-by: Ansis Atteka
>
> skb_priority has two 16-bit subfields, at least with the qdiscs that
> I'm famil
On Fri, Nov 30, 2012 at 04:07:29PM -0800, Ansis Atteka wrote:
> This patch adds logging support for skb_mark and skb_priority.
>
> Signed-off-by: Ansis Atteka
skb_priority has two 16-bit subfields, at least with the qdiscs that
I'm familiar with, so it's easier to read when it's printed in
hexade
This patch adds logging support for skb_mark and skb_priority.
Signed-off-by: Ansis Atteka
---
lib/match.c| 30 +++
lib/match.h|2 ++
lib/meta-flow.c| 68
lib/meta-flow.h|2 ++
lib/ofp-uti
On Fri, Nov 30, 2012 at 10:04:07AM +0900, Simon Horman wrote:
> This is based on an existing OpenFlow 1.0 variant of this test.
>
> Signed-off-by: Simon Horman
Applied, thanks.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/lis
On Fri, Nov 30, 2012 at 10:04:06AM +0900, Simon Horman wrote:
> Signed-off-by: Simon Horman
Applied. I had to fix a test failure by folding this in:
diff --git a/tests/ofp-actions.at b/tests/ofp-actions.at
index e232435..f30fa06 100644
--- a/tests/ofp-actions.at
+++ b/tests/ofp-actions.at
@@ -1
On Fri, Nov 30, 2012 at 06:53:59PM -0800, Pravin B Shelar wrote:
> Currently brcompat does not on master due to recent
> datapath changes. We have decided to remove it as it is
> not used very widely.
>
> Signed-off-by: Pravin B Shelar
Thank you!
I did a test build. "make check" passed.
The o
From: Jesse Gross
Date: Thu, 29 Nov 2012 10:35:42 -0800
> This series of improvements for 3.8/net-next contains four components:
> * Support for modifying IPv6 headers
> * Support for matching and setting skb->mark for better integration with
>things like iptables
> * Ability to recognize
Hello,
I'm configuring sflow on openvswitch ( branch 1.9 ) as explained in cookbook.
DEV-10.98.98.1:/cc# ovs-vsctl list sflow
_uuid : c1a2fdd8-5e15-4ceb-827c-90cb1339fbc9
agent : neoEtap
external_ids: {}
header : 128
polling : 10
samplin
Removed error category types (OFPERR_OFPET_*) from enum ofperr to make it
harder for contributors to use
unencodable error codes. Removed corresponding functions
ofperr_is_category() and ofperr_decode_type().
Added OFPERR_NX__UNKNOWN_ERROR (NX1.0+(0xfffe,256)), which is now encoded
i
16 matches
Mail list logo