On Wed, Dec 28, 2011 at 05:52:34PM -0800, Ethan Jackson wrote:
> This will ease implementation of future unit tests.
You could add a mention of this to NEWS, I guess. I won't insist on it.
Looks good.
___
dev mailing list
dev@openvswitch.org
http://ope
On Wed, Dec 28, 2011 at 05:52:33PM -0800, Ethan Jackson wrote:
> This will improve the unit tests of future patches.
Seems reasonable, thanks.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Wed, Dec 28, 2011 at 05:52:32PM -0800, Ethan Jackson wrote:
> Instead this patch uses flow_format() which gives very similar
> output. This patch will improve the reliability of unit tests in
> future patches which rely on the results of ofp_packet_to_string().
This looks good as far as it goe
Ben, do you think it's worth putting a small comment above the assignment?
Otherwise, it looks kind of odd.
--Justin
On Dec 28, 2011, at 10:50 PM, Ethan Jackson wrote:
> Looks good.
>
> Ethan
>
> On Tue, Dec 27, 2011 at 14:32, Ben Pfaff wrote:
>> gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-48)
The only place I've found it's used are logs and ofctl monitor for packet ins.
I doubt anything depends on either of those.
Ethan (iPhone)
On Dec 29, 2011, at 0:57, Ben Pfaff wrote:
> On Wed, Dec 28, 2011 at 05:52:30PM -0800, Ethan Jackson wrote:
>> I find this significantly easier to read.
>
On Wed, Dec 28, 2011 at 05:52:31PM -0800, Ethan Jackson wrote:
> ofp_print_packet() and ofp_packet_to_string() don't use the
> 'total_len' argument which they require callers to supply.
Looks good, thanks.
___
dev mailing list
dev@openvswitch.org
http://
On Wed, Dec 28, 2011 at 05:52:30PM -0800, Ethan Jackson wrote:
> I find this significantly easier to read.
Seems fine to me. I doubt anything external really depends on this
format.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman
This looks good, thanks.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Looks good.
Ethan
On Thu, Dec 22, 2011 at 18:51, Ben Pfaff wrote:
> Without this change, if a unixctl command name is 23 character long or
> longer, no space appeared between the command name and its usage. This
> commit ensures that at least one space always appears.
>
> No command yet has a n
Looks good.
Ethan
On Tue, Dec 27, 2011 at 14:32, Ben Pfaff wrote:
> gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-48) warned:
>
> ofproto/ofproto-dpif.c: In function 'bundle_send_learning_packets':
> ofproto/ofproto-dpif.c:1835: warning: dereferencing type-punned pointer
> will break strict-a
Looks good.
This conflicts with a series I just sent out. Once you merge, I'll
resend the relevant patch.
Ethan
On Tue, Dec 27, 2011 at 16:25, Ben Pfaff wrote:
> There's no point in executing an empty set of actions.
>
> dpif_execute() has had this optimization internally for a long time but
>
On Wed, Dec 28, 2011 at 05:52:28PM -0800, Ethan Jackson wrote:
> -void cls_rule_set_in_port(struct cls_rule *, uint16_t odp_port);
> +void cls_rule_set_in_port(struct cls_rule *, uint16_t ofp_port);
Looks good, thanks.
___
dev mailing list
dev@openvswitc
On Thu, Dec 29, 2011 at 09:41:31AM +0800, Emmily wrote:
> We have developed a new feature on "OpenvSwitch with Hook Point".
>
> This feature provides hook points for developers to intercept packets on
> the packet processing.
>
> To commit this feature "OpenvSwitch with Hook Point" , what process
The new PACKET_IN format implemented in this patch includes flow
metadata such as the cookie, table_id, and registers.
---
include/openflow/nicira-ext.h | 46 +-
lib/learning-switch.c |2 +
lib/nx-match.h|2 +-
lib/ofp-print.c | 34
In future patches, PACKET_IN messages will include meta-data which
is only available in userspace during action translation. Either,
this data needs to be stored until it's required by a userspace
datapath action, or the PACKET_IN messages must be sent at the time
the data is available. This patc
This commit pulls code used to modify L3 and L4 header fields
from dp_netdev into the packet library. An additional user will
be added in a future commit.
---
lib/dpif-netdev.c | 120 +
lib/packets.c | 101 +
---
lib/ofp-print.c| 39 +++
lib/ofp-util.c | 28
lib/ofp-util.h |3 +++
ofproto/ofproto-dpif.c |2 ++
4 files changed, 56 insertions(+), 16 deletions(-)
diff --git a/lib/ofp-print.c b/lib/ofp-pri
This will make the memory ownership clearer when future patches
make more extensive use of ofputil_packet_in.
---
lib/ofp-util.c |4 ++--
lib/ofp-util.h |4 ++--
ofproto/connmgr.c |5 +++--
ofproto/ofproto-dpif.c |4 ++--
4 files changed, 9 insertions(+), 8 del
---
tests/ofproto-dpif.at | 168 +
1 files changed, 168 insertions(+), 0 deletions(-)
diff --git a/tests/ofproto-dpif.at b/tests/ofproto-dpif.at
index 55d1500..73bca1d 100644
--- a/tests/ofproto-dpif.at
+++ b/tests/ofproto-dpif.at
@@ -165,6 +165,17
This will ease implementation of future unit tests.
---
manpages.mk |2 +
utilities/ovs-ofctl.8.in | 11
utilities/ovs-ofctl.c| 62 +++--
3 files changed, 72 insertions(+), 3 deletions(-)
diff --git a/manpages.mk b/manpages
This will improve the unit tests of future patches.
---
lib/ofp-print.c| 13 +
tests/ofp-print.at |2 +-
2 files changed, 14 insertions(+), 1 deletions(-)
diff --git a/lib/ofp-print.c b/lib/ofp-print.c
index 0417e9d..37c5823 100644
--- a/lib/ofp-print.c
+++ b/lib/ofp-print.c
Instead this patch uses flow_format() which gives very similar
output. This patch will improve the reliability of unit tests in
future patches which rely on the results of ofp_packet_to_string().
---
lib/ofp-print.c| 58 ---
tests/ofp-print.at
ofp_print_packet() and ofp_packet_to_string() don't use the
'total_len' argument which they require callers to supply.
---
lib/dpif.c |3 +--
lib/ofp-print.c| 13 +
lib/ofp-print.h|4 ++--
ofproto/ofproto-dpif.c |2 +-
tests/test-flows.c |
I find this significantly easier to read.
---
lib/flow.c | 32
tests/ofp-print.at |2 +-
2 files changed, 17 insertions(+), 17 deletions(-)
diff --git a/lib/flow.c b/lib/flow.c
index fa7ae4f..5d18212 100644
--- a/lib/flow.c
+++ b/lib/flow.c
@@ -518,4
---
lib/ofpbuf.c | 25 ++---
1 files changed, 22 insertions(+), 3 deletions(-)
diff --git a/lib/ofpbuf.c b/lib/ofpbuf.c
index 3887481..29698dc 100644
--- a/lib/ofpbuf.c
+++ b/lib/ofpbuf.c
@@ -129,7 +129,7 @@ ofpbuf_new_with_headroom(size_t size, size_t headroom)
struct ofpb
---
lib/classifier.h |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/lib/classifier.h b/lib/classifier.h
index c33f1e1..d55475d 100644
--- a/lib/classifier.h
+++ b/lib/classifier.h
@@ -96,7 +96,7 @@ void cls_rule_set_reg_masked(struct cls_rule *, unsigned int
reg_idx,
v
Hi,
We have developed a new feature on "OpenvSwitch with Hook Point".
This feature provides hook points for developers to intercept packets on
the packet processing.
To commit this feature "OpenvSwitch with Hook Point" , what processes need
to do?
Best regards,
Emmily
The AF_PACKET raw socket implementation of sendmsg() doesn't initialize
skb->protocol, but ovs_vport_receive() expects that skb->protocol to be
valid. Thus, datapath code that depends on skb->protocol did not properly
recognize packet type. This fixes the problem by always extracting the
protocol
On Tue, Dec 27, 2011 at 8:17 PM, Pravin Shelar wrote:
> On Thu, Dec 22, 2011 at 5:01 PM, Jesse Gross wrote:
>> On Dec 21, 2011, at 8:28 PM, Pravin B Shelar wrote:
>>> + skb_get(genlmsg_skb);
>>> +
>>> + nlh = genlmsg_put(genlmsg_skb, 0, 0, &genl_exec_family,
>>> NLM_F_REQUEST, GENL_EXEC_
29 matches
Mail list logo