Jerin, Santosh,
As you are introducing improved I/O access API, I would like to ask to
change ENA platform code to:
* #define ENA_REG_WRITE32(value, reg) rte_write32_relaxed((value), (reg))*
* #define ENA_REG_READ32(reg) rte_read32_relaxed((reg))*
There is no more need to have read/write functio
Jerin,
Thanks for the very quick replay.
Actually I would like to keep *ena_com* untouched, as this layer suppose to
be common between platforms. That's why it is better to leave definition in
*ena_plat_dpdk.h*. Here is the patch that I would like to propose:
diff --git a/drivers/net/ena/base/en
Thank you very much!
Hello,
Sorry for late response.
>From ENA perspective, we need to dig deeper about the requirements and use
cases, but I'm pretty confident (95%) that ena will need to implement
tx_prep() API. There is at least one scenario, when HW relay on partial
checksum.
Jan
Despite the issue with naming convention (either it will be writel or
write32), I'm fine with this change and new API.
Acked-by: Jan Medala
Jan
2016-12-14 2:55 GMT+01:00 Jerin Jacob :
> From: Santosh Shukla
>
> Replace the raw I/O device memory read/write access with eal
> abstraction for I
Hello,
> Is there any update on that subject?
>
At this point we need to have only pseudo-header checksum for TSO. Maybe
there will be new requirements, but that's something I cannot predict at
this point.
> So it seems that standard pseudo-header checksum calculation should be
> enough.
>
> >At this point we need to have only pseudo-header checksum for TSO. Maybe
> there will be new requirements, but that's something I cannot predict at
> this point.
>
> Ok great, then we'll add a patch for ENA for v14, unless you guys would
> like to do it yourself.
>
That'd be great!
>We
Acked-by: Jan Medala
Jan
2017-02-14 13:37 GMT+01:00 Yong Wang :
> In function ena_com_set_hash_ctrl(), the return value is assigned to
> "ret" variable, but it is not returned. Fix it by adding the return.
>
> Signed-off-by: Yong Wang
> ---
> drivers/net/ena/base/ena_com.c | 2 +-
> 1 file
Acked-by: Jan Medala
Jan
2017-02-14 13:37 GMT+01:00 Yong Wang :
> Signed-off-by: Yong Wang
> ---
> drivers/net/ena/base/ena_com.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/net/ena/base/ena_com.c b/drivers/net/ena/base/ena_
> com.c
> index bd6f3c6..
I would recommend to check if packet type is IPv4 before processing IPv4 header
for DF flag.
This patch can break logic and go to unknown state when mbuf will contain IPv6
packet. I believe that in case of IPv6 pkt the loop should be skipped to next
mbuf, if exists.
Best regards,
Jan
Bruce,
We've got a small minor fixes and we will create V3 version later this week
(targeting Friday).
What's final deadline for 16.07 integration?
Regards,
Jan
2016-06-29 13:01 GMT+02:00 Bruce Richardson :
> On Fri, Jun 24, 2016 at 12:52:39PM +0100, Bruce Richardson wrote:
> > On Tue, Jun 2
Hello Thomas,
2016-01-28 16:40 GMT+01:00 Thomas Monjalon :
> > lib/librte_eal/linuxapp/ena_uio/ena_uio_driver.c | 276 +++
>
> Sorry the kernel module party is over.
> One day, igb_uio will be removed.
> I suggest to make a first version without interrupt support
> and work with Linux communit
Bruce,
Here's explanation of readless communication (on behalf of Alex):
> "readless" refers to ability to read ENA registers without actually
> issuing read request from host (x86).
> Instead, host programs 2 registers on device that trigger DMA from device
> to host and report register value.
>
Bruce,
That'd be very kind of you if you can fix trailing zeros.
This patch
Fixes: b5b8cd9 ("ena: update of ENA communication layer")
Regards,
Jan
2016-07-05 18:19 GMT+02:00 Bruce Richardson :
> On Tue, Jul 05, 2016 at 09:52:09AM +0100, Ferruh Yigit wrote:
> > On 6/30/2016 4:04 PM, Jan
Yes, this is correct.
Jan
2016-07-05 18:13 GMT+02:00 Bruce Richardson :
> On Mon, Jul 04, 2016 at 05:27:50PM +0100, Bruce Richardson wrote:
> > On Thu, Jun 30, 2016 at 05:04:58PM +0200, Jan Medala wrote:
> > > After allocating memzone it's required to zeroize memory in it.
> > > Freeing memzon
Yes, this is correct.
Jan
2016-07-05 18:13 GMT+02:00 Bruce Richardson :
> On Mon, Jul 04, 2016 at 05:27:50PM +0100, Bruce Richardson wrote:
> > On Thu, Jun 30, 2016 at 05:04:58PM +0200, Jan Medala wrote:
> > > After allocating memzone it's required to zeroize memory in it.
> > > Freeing memzon
Uhm, wait, I think that sha is wrong, please let me check it double time.
Jan
2016-07-05 19:03 GMT+02:00 Jan M?dala :
> Bruce,
>
>
> That'd be very kind of you if you can fix trailing zeros.
>
>
> This patch
>
> Fixes: b5b8cd9 ("ena: update of ENA communication layer")
>
>
> Regards,
>
> Jan
Let me point it this way:
??This patch fixes: [dpdk-dev,v3,1/6] ena: update of ENA communication layer
Jan
2016-07-05 19:04 GMT+02:00 Jan M?dala :
> Uhm, wait, I think that sha is wrong, please let me check it double time.
>
> Jan
>
> 2016-07-05 19:03 GMT+02:00 Jan M?dala :
>
>> Bruce,
>>
>>
There are no obstacles.
We first produced patches 1-5, then tested on different compilers so patch
no. 6 was made.
Thank you Bruce for support!
I'm still learning DPDK's submission/upstream process so all comments and
gained knowledge will easier future patches.
Jan
2016-07-06 10:14 GMT+02:00
Avoid submitting doorbell when:
* no packets have been submitted to TX
* no free resources have been submitted while RX
Sending doorbell without actual work to be performed by device
violates ENA specification and can lead to unpredictable behavior.
Fixes: 1173fca25af9 ("ena: add polling-mode dri
Hello Yu Liu,
I've sent second version of patch to test on icc16 compiler, Yongjie is
helping me to test issues on icc.
Jan
Ferruh,
Actually we can stay with this patch. It's ok.
Acked-by: Jan Medala
Jan
2016-07-19 12:48 GMT+02:00 Ferruh Yigit :
> On 7/19/2016 10:33 AM, Ferruh Yigit wrote:
> > compile error:
> > CC ena_com.o
> > .../drivers/net/ena/base/ena_com.c(346):
> > error #3656: variable "dev_node" may
I'd like to kindly request for review and comments.
Jan
>
> > #
> > +# Compile burst-oriented Amazon ENA PMD driver
> > +#
> > +CONFIG_RTE_LIBRTE_ENA_PMD=y
> > +CONFIG_RTE_LIBRTE_ENA_DEBUG_INIT=y
>
> Do you really want initialization debuggin to be on by default? Normally,
> we
> keep all debug options disabled.
This is actually error logging, so it's
2016-03-17 14:57 GMT+01:00 Thomas Monjalon :
> 2016-03-17 14:48, Jan M?dala:
> > >
> > > > #
> > > > +# Compile burst-oriented Amazon ENA PMD driver
> > > > +#
> > > > +CONFIG_RTE_LIBRTE_ENA_PMD=y
> > > > +CONFIG_RTE_LIBRTE_ENA_DEBUG_INIT=y
> > >
> > > Do you really want initialization debuggin t
Great news!
We are going to extend functionality of the ENA PMD, so from now I will
send patches based on v8 version.
Thanks,
Jan
2016-03-18 18:04 GMT+01:00 Bruce Richardson :
> On Thu, Mar 17, 2016 at 03:31:14PM +0100, Jan Medala wrote:
> > v3:
> > Additional features for Amazon ENA:
> > * L
Stephen,
This will be fixed
dpdk-dev,
ping for more comments/review
Thanks,
Jan
Jan
2016-02-08 22:30 GMT+01:00 Stephen Hemminger :
> On Fri, 5 Feb 2016 19:20:28 +0100
> Jan Medala wrote:
>
> > +
> > +typedef _Bool bool;
>
>
> > +#define true ((bool)1)
> > +#define false((bool)0)
>
Stephen,
does it mean we should insert those defines to PMD driver files?
dpdk-dev,
ping for more comments/review
Thanks,
Jan
Jan
2016-02-08 22:27 GMT+01:00 Stephen Hemminger :
> On Fri, 5 Feb 2016 19:20:26 +0100
> Jan Medala wrote:
>
> > +
> > +#ifndef PCI_VENDOR_ID_AMAZON
> > +/** Vendor
ping for comments/review
Thanks,
Jan
2016-02-05 19:20 GMT+01:00 Jan Medala :
> This is a PMD for the Amazon ethernet ENA family.
> The driver operates variety of ENA adapters through feature negotiation
> with the adapter and upgradable commands set.
> ENA driver handles PCI Physical and Virt
ping for comments/review
Thanks,
Jan
P.S. Sorry for replaying with whole code in previous messages.
30 matches
Mail list logo