From: Abdullah Ömer Yamaç
In some use cases inserting data with the same key shouldn't be
overwritten. We use a new flag in this patch to disable overwriting
data for the same key.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: Yipeng Wang
Cc: Sameh Gobriel
Cc: Bruce Richardson
Cc: Vla
In some use cases inserting data with the same key shouldn't be
overwritten. We use a new flag in this patch to disable overwriting
data for the same key.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: Yipeng Wang
Cc: Sameh Gobriel
Cc: Bruce Richardson
Cc: Vladimir Medvedkin
Cc: David Mar
This patch fixes the syntax error when using the single-core
for both rx and distributor functions.
Fixes: 4a7f40c0ff9a ("examples/distributor: add dedicated core")
Cc: sta...@dpdk.org
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: david.h...@intel.com
---
examples/distributor/main.c |
n the different core.
* Syntax error of the single RX and distributor core is fixed.
* When "-c" parameter is active, the wasted distributor core is
also deactivated in the main function.
Fixes: 4a7f40c0ff9a ("examples/distributor: add dedicated core")
Cc: sta...@dpdk
n the different core.
* Syntax error of the single RX and distributor core is fixed.
* When "-c" parameter is active, the wasted distributor core is
also deactivated in the main function.
Fixes: 4a7f40c0ff9a ("examples/distributor: add dedicated core")
Cc: sta...@dpdk
When "-c" parameter is active, the wasted distributor core is
also deactivated in the main function.
Fixes: 4a7f40c0ff9a ("examples/distributor: add dedicated core")
Cc: sta...@dpdk.org
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: david.h...@intel.com
---
doc/guides/sample_app
When "-c" parameter is active, the wasted distributor core is
also deactivated in the main function.
Fixes: 4a7f40c0ff9a ("examples/distributor: add dedicated core")
Cc: sta...@dpdk.org
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: david.h...@intel.com
---
doc/guides/sample_app
defer queue will not be counted and freed. Therefore I
added a new API to get the number of hidden (defer queue) elements
in the hash table. Then the user can calculate the total number of
elements that are available in the hash table.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: Honnappa Nagarahalli
calculate the total number of
> > elements that are available in the hash table.
> >
> > Signed-off-by: Abdullah Ömer Yamaç
> >
> > ---
> > Cc: Honnappa Nagarahalli
> > Cc: Yipeng Wang
> > Cc: Sameh Gobriel
> > Cc: Bruce Richardson
>
m> wrote:
>
>
> > On Feb 19, 2024, at 3:28 PM, Abdullah Ömer Yamaç
> wrote:
> >
> > Hello,
> >
> > Let me explain a use case;
> >
> > I have a hash table whose key value is IP addresses, and data (let's say
> the username of the IP) is
On Wed, Feb 21, 2024 at 6:24 AM Honnappa Nagarahalli <
honnappa.nagaraha...@arm.com> wrote:
>
>
> > On Feb 20, 2024, at 12:58 PM, Abdullah Ömer Yamaç
> wrote:
> >
> > I appreciate that you gave me suggestions and comments. I will make
> changes according to
As a final decision, I will add a new hash API that forces the reclaim. Is
it ok for everyone?
On Thu, Feb 22, 2024 at 5:37 AM Honnappa Nagarahalli <
honnappa.nagaraha...@arm.com> wrote:
>
>
> > On Feb 21, 2024, at 3:51 PM, Abdullah Ömer Yamaç
> wrote:
> >
> >
> > On Feb 22, 2024, at 6:39 AM, Abdullah Ömer Yamaç
> wrote:
> >
> > As a final decision, I will add a new hash API that forces the reclaim.
> Is it ok for everyone?
> Ack from my side
>
> >
> > On Thu, Feb 22, 2024 at 5:37 AM Honnappa Nagarahalli &l
Sorry for the late reply. I understood what you mean. I will create only
the reclaim API for the hash library. Thanks for the explanation.
On Wed, Feb 28, 2024 at 5:51 PM Honnappa Nagarahalli <
honnappa.nagaraha...@arm.com> wrote:
>
>
> > On Feb 28, 2024, at 5:44 AM, Abdullah Ö
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
Acked-by: Honnappa
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
Acked-by: Honnappa
Hello, is there any other comment on this patch? Thanks
On Mon, Apr 15, 2024 at 2:26 PM Abdullah Ömer Yamaç
wrote:
> This patch adds a new feature to the hash library to allow the user to
> reclaim the defer queue. This is useful when the user wants to force
> reclaim resources tha
Hello,
Any comment on this patch?
On Wed, Apr 17, 2024 at 4:39 PM Abdullah Ömer Yamaç
wrote:
> In the previous implementation, the maximum reclamation size was set
> to RTE_HASH_RCU_DQ_RECLAIM_MAX and it was not configurable. This patch
> uses the configuration argument to set th
Thanks for the comments. This is due to the tab size, and I will fix them.
On Wed, Apr 24, 2024 at 12:24 AM Stephen Hemminger <
step...@networkplumber.org> wrote:
> On Mon, 15 Apr 2024 11:26:02 +
> Abdullah Ömer Yamaç wrote:
>
> > + ret = rte_rcu_qsbr_dq_reclaim(h-&
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
app/test/test_hash.c
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 30 ++
1 file changed, 30 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b/.clang-format
new file
> ...
>
> 1. Some options are failing for me [1], I don't know if it requires a
> specific version of clang-format
>
I fixed these errors, and the clang-format version should be 17. I will
send them after some discussions, as I've shared below.
>
> 2. Current options are not fully aligned with cod
e.
...
if (devargs_str == NULL) {
...
I will send the current configuration as v2. You can test it.
On Mon, Apr 29, 2024 at 6:43 PM Stephen Hemminger <
step...@networkplumber.org> wrote:
> On Mon, 29 Apr 2024 14:32:43 +0100
> Ferruh Yigit wrote:
>
> > On 4/29/2024 2:04 PM, Abdulla
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 42 ++
1 file changed, 42 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b/.clang
I was confused about the kernel functions. I didn't understand what you
meant at first, but now I understand. I will send a new patch with all
DPDK-related foreach macros.
On Sat, May 4, 2024 at 7:27 PM Stephen Hemminger
wrote:
> On Sat, 4 May 2024 13:41:35 +
> Abdullah Ömer Y
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 138 ++
1 file changed, 138 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b
On Sun, May 5, 2024 at 7:18 PM Stephen Hemminger
wrote:
> On Sat, 4 May 2024 19:18:37 +
> Abdullah Ömer Yamaç wrote:
>
> > clang-format is a tool to format C/C++/Objective-C code. It can be used
> > to reformat code to match a given coding style, or to ensure that
On Sun, May 5, 2024 at 7:21 PM Stephen Hemminger
wrote:
> On Sat, 4 May 2024 19:18:37 +
> Abdullah Ömer Yamaç wrote:
>
> > clang-format is a tool to format C/C++/Objective-C code. It can be used
> > to reformat code to match a given coding style, or to ensure that
On Sun, May 5, 2024 at 11:38 PM Stephen Hemminger <
step...@networkplumber.org> wrote:
> On Sun, 5 May 2024 22:42:57 +0300
> Abdullah Ömer Yamaç wrote:
>
> > > Also, this looks wrong. The initialized arrays looked better before.
> > >
> > &
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 141 ++
1 file changed, 141 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b
Hello,
Any other comments?
On Sat, Apr 27, 2024 at 10:54 PM Abdullah Ömer Yamaç
wrote:
> This patch adds a new feature to the hash library to allow the user to
> reclaim the defer queue. This is useful when the user wants to force
> reclaim resources that are not being used. This AP
Hello,
Is there any comment on this patch?
On Tue, Apr 23, 2024 at 4:51 PM Abdullah Ömer Yamaç
wrote:
> Hello,
> Any comment on this patch?
>
> On Wed, Apr 17, 2024 at 4:39 PM Abdullah Ömer Yamaç
> wrote:
>
>> In the previous implementation, the maximum reclam
armik.thak...@arm.com
Cc: Honnappa Nagarahalli
Cc: Yipeng Wang
Cc: Sameh Gobriel
Cc: Bruce Richardson
Cc: Vladimir Medvedkin
Signed-off-by: Abdullah Ömer Yamaç
---
lib/hash/rte_cuckoo_hash.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/hash/rte_cuckoo_hash.c b/lib/hash/rte_cuckoo_ha
version.
>
> > On May 13, 2024, at 5:00 AM, Abdullah Ömer Yamaç
> wrote:
> >
> > In the previous implementation, the maximum reclamation size was set
> > to RTE_HASH_RCU_DQ_RECLAIM_MAX and it was not configurable. This patch
> > uses the configuration a
n Mon, May 13, 2024 at 8:25 AM Honnappa Nagarahalli <
honnappa.nagaraha...@arm.com> wrote:
> Hi Abdullah,
> This looks good, except for one comment inline.
>
> > On Apr 27, 2024, at 2:54 PM, Abdullah Ömer Yamaç
> wrote:
> >
> > This patch adds a new feature
ned-off-by: Abdullah Ömer Yamaç
---
lib/hash/rte_cuckoo_hash.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/hash/rte_cuckoo_hash.c b/lib/hash/rte_cuckoo_hash.c
index 9cf94645f6..f7f0fdfd21 100644
--- a/lib/hash/rte_cuckoo_hash.c
+++ b/lib/hash/rte_cuckoo_hash.c
@@ -1557
I want to update you.
On Mon, May 13, 2024 at 4:08 PM Ferruh Yigit wrote:
> On 5/8/2024 10:19 PM, Abdullah Ömer Yamaç wrote:
> > clang-format is a tool to format C/C++/Objective-C code. It can be used
> > to reformat code to match a given coding style, or to ensure that code
&
On Wed, May 15, 2024 at 11:43 AM Bruce Richardson <
bruce.richard...@intel.com> wrote:
> On Wed, May 15, 2024 at 11:28:33AM +0300, Abdullah Ömer Yamaç wrote:
> >I want to update you.
> >On Mon, May 13, 2024 at 4:08 PM Ferruh Yigit <[1]ferruh.yi...@amd.com
> >
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
app/test/test_hash.c
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
app/test/test_hash.c
On Wed, May 15, 2024 at 6:07 PM Stephen Hemminger <
step...@networkplumber.org> wrote:
> On Wed, 15 May 2024 09:43:22 +0100
> Bruce Richardson wrote:
>
> > On Wed, May 15, 2024 at 11:28:33AM +0300, Abdullah Ömer Yamaç wrote:
> > >I want to update you.
> >
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 149 ++
1 file changed, 149 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b
r queue reclaim API”
>
> > On Mar 2, 2024, at 3:27 PM, Abdullah Ömer Yamaç
> wrote:
> >
> > This patch adds a new feature to the hash library to allow the user to
> > reclaim the defer queue. This is useful when the user wants to force
> > reclaim resources that
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
lib/hash
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
lib/hash
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
lib/hash
Hello,
Is there any other comment on this?
On Wed, Mar 6, 2024 at 1:13 PM Abdullah Ömer Yamaç
wrote:
> This patch adds a new feature to the hash library to allow the user to
> reclaim the defer queue. This is useful when the user wants to force
> reclaim resources that are not being u
Hello,
Could you check the last commit?
Thanks
On Thu, Mar 14, 2024 at 10:04 AM Abdullah Ömer Yamaç
wrote:
> Hello,
> Is there any other comment on this?
>
> On Wed, Mar 6, 2024 at 1:13 PM Abdullah Ömer Yamaç
> wrote:
>
>> This patch adds a new feature to the hash libr
This patch adds a new feature to the hash library to allow the user to
reclaim the defer queue. This is useful when the user wants to force
reclaim resources that are not being used. This API is only available
if the RCU is enabled.
Signed-off-by: Abdullah Ömer Yamaç
---
app/test/test_hash.c
armik.thak...@arm.com
Cc: Honnappa Nagarahalli
Cc: Yipeng Wang
Cc: Sameh Gobriel
Cc: Bruce Richardson
Cc: Vladimir Medvedkin
Signed-off-by: Abdullah Ömer Yamaç
---
lib/hash/rte_cuckoo_hash.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/hash/rte_cuckoo_hash.c b/lib/hash/rte_cuckoo_ha
In some use cases inserting data with the same key shouldn't be
overwritten. We use a new flag in this patch to disable overwriting
data for the same key.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: Yipeng Wang
---
lib/hash/rte_cuckoo_hash.c | 10 +-
lib/hash/rte_cuckoo_hash.h
In some use cases inserting data with the same key shouldn't be
overwritten. We use a new flag in this patch to disable overwriting
data for the same key.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: Yipeng Wang
---
lib/hash/rte_cuckoo_hash.c | 10 +-
lib/hash/rte_cuckoo_hash.h
In this patch we suggest a new name for lcore-worker.
In case of more than 99 logical cores, name is truncated
(length is restricted to 16 characters, including the
terminating null byte ('\0')) and it makes hard to follow threads.
Signed-off-by: Abdullah Ömer Yamaç
---
lib/eal/linux
In this patch we suggest a new name for lcore-worker.
In case of more than 99 logical cores, name is truncated
(length is restricted to 16 characters, including the
terminating null byte ('\0')) and it makes hard to follow threads.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: Davi
In this patch we suggest a new name for lcore-worker.
In case of more than 99 logical cores, name is truncated
(length is restricted to 16 characters, including the
terminating null byte ('\0')) and it makes hard to follow threads.
Signed-off-by: Abdullah Ömer Yamaç
Acked-by: Stephen
In this patch we suggest a new name for lcore-worker.
In case of more than 99 logical cores, name is truncated
(length is restricted to 16 characters, including the
terminating null byte ('\0')) and it makes hard to follow threads.
Signed-off-by: Abdullah Ömer Yamaç
Acked-by: Stephen
following arguments:
--lcores=0,10@1,100@2
Then we have;
lcore-worker-10
lcore-worker-10
Signed-off-by: Abdullah Ömer Yamaç
Acked-by: Stephen Hemminger
---
Cc: David Marchand
---
lib/eal/freebsd/eal.c | 2 +-
lib/eal/linux/eal.c | 2 +-
2 files changed, 2 insertions(+), 2 deletion
In this patch, we remove all version.map files which include
only the below part:
`DPDK_23 {
local: *;
};`
Then we modify the meson.build to be able to compile without version.map
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
---
drivers/baseband/la12xx/version.map
to update these files for each release, you can just
remove them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
---
Depends on: patch-116222 ("build: increase minimum meson version to 0.53")
---
drivers/meson.build | 63 -
With the previous patch, some version.map files are not necessary.
In this patch, we removed them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
---
Depends on: patch-116222 ("build: increase minimum meson version to 0.53")
---
drivers/baseband/la12xx/version
With the previous patch, some version.map files are not necessary.
In this patch, we removed them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
---
Depends on: patch-116222 ("build: increase minimum meson version to 0.53")
---
drivers/baseband/la12xx/version
In this patch, we removed the necessity of the version files and
you don't need to update these files for each release, you can just
remove them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
---
Depends on: patch-116222 ("build: increase minimum meson versi
In this patch, we removed the necessity of the version files and
you don't need to update these files for each release, you can just
remove them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
Series-acked-by: Bruce Richardson
---
drivers/baseband/la12xx/version.map
In this patch, we removed the necessity of the version files and
you don't need to update these files for each release, you can just
remove them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
Series-acked-by: Bruce Richardson
---
drivers/meson.build
In this patch, we removed the necessity of the version files and
you don't need to update these files for each release, you can just
remove them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
Series-acked-by: Bruce Richardson
---
drivers/meson.build
With the previous patch, some version.map files are not necessary.
In this patch, we removed them.
Signed-off-by: Abdullah Ömer Yamaç
Suggested-by: Ferruh Yigit
Series-acked-by: Bruce Richardson
---
drivers/baseband/la12xx/version.map | 3 ---
drivers/baseband/null/version.map | 3
One line of commented code was dead code, this line and releated
comments are removed. Naming of rx,RX and tx,TX are replaced by Rx and
Tx.
Signed-off-by: Abdullah Ömer Yamaç
---
CC: Thomas Monjalon
---
examples/distributor/main.c | 51 +
1 file changed, 23
One line of commented code was dead code, this line and related
comments are removed. Naming of rx,RX and tx,TX are replaced by Rx and
Tx.
Signed-off-by: Abdullah Ömer Yamaç
---
CC: Thomas Monjalon
---
examples/distributor/main.c | 51 +
1 file changed, 23
One line of commented code was dead code, this line and related
comments are removed. Naming of rx,RX and tx,TX are replaced by Rx and
Tx.
Signed-off-by: Abdullah Ömer Yamaç
---
CC: Thomas Monjalon
---
examples/distributor/main.c | 53 +
1 file changed, 24
One line of commented code was dead code, this line and related
comments are removed. Naming of rx,RX and tx,TX are replaced by Rx and
Tx.
Signed-off-by: Abdullah Ömer Yamaç
---
CC: Thomas Monjalon
---
examples/distributor/main.c | 55 +
1 file changed, 25
ore is
also deactivated in the main function.
Signed-off-by: Abdullah Ömer Yamaç
---
Cc: david.h...@intel.com
---
doc/guides/sample_app_ug/dist_app.rst | 3 +-
examples/distributor/main.c | 222 ++
2 files changed, 159 insertions(+), 66 deletions(-)
diff --git a/
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 153 ++
1 file changed, 153 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b
style options provided by
clang-format and large set of IDEs and text editors support it.
Signed-off-by: Abdullah Ömer Yamaç
---
.clang-format | 153 ++
1 file changed, 153 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b
73 matches
Mail list logo