RE: [PATCH] test/event: fix number of queues in eventdev conf

2025-02-25 Thread Pavan Nikhilesh Bhagavatula
> -Original Message- > From: Shijith Thotton > Sent: Thursday, February 6, 2025 8:03 PM > To: Jerin Jacob > Cc: dev@dpdk.org; Pavan Nikhilesh Bhagavatula > ; Shijith Thotton ; > sta...@dpdk.org; Naga Harish K S V > Subject: [PATCH] test/event: fix number of queues in eventdev conf >

[PATCH v2 0/6] Added RSS functions and tests.

2025-02-25 Thread Thomas Wilks
v2: - Added RSS capabilities check. - Added testsuite that tests RSS hashes. - Added testsuite that tests updating the RSS hash key. - Added testsuite that verifies the RETA size. Alex Chapman (5): dts: add RSS functions to testpmd dts: add utils for PMD RSS testsuites dts: add PMD RSS hash

[PATCH v2 1/6] dts: add RSS functions to testpmd

2025-02-25 Thread Thomas Wilks
From: Alex Chapman This patch adds the required functionality for the RSS key_update, RETA, and hash test suites. This includes: The setting of custom RETA values for routing packets to specific queues. The setting of the RSS mode on all ports, to specify how to hash the packets. The updating of

[PATCH v2 2/6] dts: add utils for PMD RSS testsuites

2025-02-25 Thread Thomas Wilks
From: Alex Chapman To reduce the amount of maintenance and code duplication, common functionality between the rss_key_update, pmd_rss_reta and pmd_rss_hash test suites has been collated into a single file called rss_utils. It contains 3 main functions: 1. verify that a packets RSS hash correctly

Re: [PATCH 5/6] acl: make compatible with instruction set updates for MSVC

2025-02-25 Thread Andre Muezerie
On Tue, Feb 25, 2025 at 05:21:10PM +, Bruce Richardson wrote: > On Tue, Feb 25, 2025 at 08:37:27AM -0800, Andre Muezerie wrote: > > On Tue, Feb 25, 2025 at 09:03:37AM +, Bruce Richardson wrote: > > > On Mon, Feb 24, 2025 at 01:01:18PM -0800, Andre Muezerie wrote: > > > > Top level 'cc_avx2_

Re: [PATCH 5/6] acl: make compatible with instruction set updates for MSVC

2025-02-25 Thread Andre Muezerie
On Tue, Feb 25, 2025 at 09:03:37AM +, Bruce Richardson wrote: > On Mon, Feb 24, 2025 at 01:01:18PM -0800, Andre Muezerie wrote: > > Top level 'cc_avx2_flags' was created and holds the correct flags > > depending on the compiler used. > > > > File meson.build was updated to handle the correct A

RE: [PATCH] net/mlx5: add eCPRI support

2025-02-25 Thread Dariusz Sosnowski
> -Original Message- > From: Bing Zhao > Sent: Tuesday, February 25, 2025 17:03 > To: Slava Ovsiienko ; dev@dpdk.org; Raslan > Darawsheh > Cc: Ori Kam ; Dariusz Sosnowski ; > Suanming Mou ; Matan Azrad ; > Hamdan Agbariya > Subject: [PATCH] net/mlx5: add eCPRI support > > Support eCP

Re: [PATCH 4/6] drivers/net: make compatible with instruction set updates for MSVC

2025-02-25 Thread Andre Muezerie
On Tue, Feb 25, 2025 at 09:06:26AM +, Bruce Richardson wrote: > On Mon, Feb 24, 2025 at 01:01:17PM -0800, Andre Muezerie wrote: > > Top level 'cc_avx2_flags' was created and holds the correct flags > > depending on the compiler used. > > > > Signed-off-by: Andre Muezerie > > --- > > drivers/

Re: [PATCH] net/ice: fix incorrect mbuf cleanup function

2025-02-25 Thread Bruce Richardson
On Mon, Feb 24, 2025 at 02:43:07PM +0100, Burakov, Anatoly wrote: > On 21/02/2025 17:04, Bruce Richardson wrote: > > The mbuf cleanup function is not being called correctly on close of the > > driver, due to the vector_tx flag not being set correctly on each Tx > > queue. Normally, this causes no v

Re: [PATCH 5/6] acl: make compatible with instruction set updates for MSVC

2025-02-25 Thread Bruce Richardson
On Tue, Feb 25, 2025 at 08:37:27AM -0800, Andre Muezerie wrote: > On Tue, Feb 25, 2025 at 09:03:37AM +, Bruce Richardson wrote: > > On Mon, Feb 24, 2025 at 01:01:18PM -0800, Andre Muezerie wrote: > > > Top level 'cc_avx2_flags' was created and holds the correct flags > > > depending on the comp

[PATCH v1] event/dlb2: enhancement to DLB credit management

2025-02-25 Thread Pravin Pathak
Updates are added to enable releasing of unused credits by threads to avoid deadlock and starving of other active threads needing credits. It also adds compile time options to enable/disable credit checks. Signed-off-by: Pravin Pathak Signed-off-by: Tirthendu Sarkar --- .mailmap

Re: [PATCH 3/6] config: allow faster instruction sets to be used with MSVC

2025-02-25 Thread Bruce Richardson
On Mon, Feb 24, 2025 at 01:01:16PM -0800, Andre Muezerie wrote: > Up to now MSVC has being used with the default mode, which uses SSE2 > instructions for scalar floating-point and vector calculations. > https://learn.microsoft.com/en-us/cpp/build/reference/arch-x64?view=msvc-170 > > This patch all

[PATCH v2 5/6] dts: add PMD RSS key update testsuite

2025-02-25 Thread Thomas Wilks
From: Alex Chapman Port over the rss_key_update test suite from old DTS. This suite verifies that setting a new hash key when Receive Side Scaling (RSS) will result in a change in the packets destination queue. This test suite also verifies that the reported key size of the NIC is correct. Signe

[PATCH v2 3/6] dts: add PMD RSS hash testsuite

2025-02-25 Thread Thomas Wilks
From: Alex Chapman Port over the pmd_rss_hash test suite from old DTS. This suite verifies that the 4 supported types of hashing algorithm used in Receive Side Scaling (RSS) function correctly. Them being DEFAULT, TOEPLITZ SYMMETRIC_TOEPLITZ and SIMPLE_XOR. This test suite also verifies the suppo

[PATCH v2 4/6] dts: add PMD RSS RETA testsuite

2025-02-25 Thread Thomas Wilks
From: Alex Chapman Port over the pmd_rss_reta test suite from old DTS. This suite verifies that Redirection Tables (RETAs) of different sizes function correctly in Receive Side Scaling (RSS). This test suite also verifies that the reported reta size of the NIC is correct. Signed-off-by: Alex Cha

[PATCH v2 6/6] dts: add NIC capabilities for hash algorithms

2025-02-25 Thread Thomas Wilks
Added checks for if a nic supports the simple_xor, symmetric_toeplitz, symmetric_toeplitz_sort, toeplitz, and default hashing algorithms. Signed-off-by: Thomas Wilks Reviewed-by: Paul Szczepanek --- dts/framework/remote_session/testpmd_shell.py | 146 ++ dts/tests/TestSuite_pmd

[PATCH V1 1/4] common/mlx5: support FDB unified capability query

2025-02-25 Thread Ophir Munk
This commit queries the FW for the new unified FDB mode and saves it in mlx5 shared device as fdb_unified_en bit. Signed-off-by: Ophir Munk --- drivers/common/mlx5/mlx5_devx_cmds.c | 3 +++ drivers/common/mlx5/mlx5_devx_cmds.h | 1 + 2 files changed, 4 insertions(+) diff --git a/drivers/common/

[PATCH V1 2/4] net/mlx5: support FDB unified domain

2025-02-25 Thread Ophir Munk
Legacy FDB domain is enhanced with optional three sub-domains: FDB_RX FDB_TX and FDB_UNIFIED. Based on FW capability bit mlx5 will work in either legacy or unified mode. To work in fdb unified mode the flow attribute transfer bit must be set and the fdb sub domains are determined by the table speci

[PATCH V1 3/4] net/mlx5: remove unneeded FDB flag on representor action

2025-02-25 Thread Ophir Munk
From: Bing Zhao The "send_to_kernel" action is shared and created during the HWS configuration stage. By default, the NIC Rx and Tx flags are needed. There is only one case that the FDB* flags are needed when creating the action, the same as other shared actions. Only the transfer proxy port nee

[PATCH V1 4/4] net/mlx5/hws: allow different types in miss validation

2025-02-25 Thread Ophir Munk
In validating Jump from group A to default miss group B DPDK requests that both groups types will be identical. In practice jumping from FDB_UNIFIED to FDB_RX or FDB_TX group types (or vice versa) is allowed. This commit enables this jumping between the different types. Fixes: b81f95ca770d ("net/m

Re: [PATCH v2] net/ixgbe: fix min Rx/Tx descriptors

2025-02-25 Thread Bruce Richardson
On Tue, Feb 25, 2025 at 09:12:36AM +, Mingjin Ye wrote: > The minimum free packet threshold (tx_free_thresh) and the minimum RS bit > threshold (tx_rs_thresh) both have a default value of 32. Therefore, the > default minimum number of ring descriptors value is 64. > > For reference, see "Confi

[PATCH] net/mlx5: add eCPRI support

2025-02-25 Thread Bing Zhao
Support eCPRI item matching over L2 (ETHER / VLAN) in HWS, both for template API and backward compatibility API. Signed-off-by: Bing Zhao --- drivers/net/mlx5/hws/mlx5dr_definer.c | 86 +++ drivers/net/mlx5/mlx5_flow.h | 3 + drivers/net/mlx5/mlx5_flow_hw.c

RE: [PATCH V1 3/4] net/mlx5: remove unneeded FDB flag on representor action

2025-02-25 Thread Dariusz Sosnowski
> -Original Message- > From: Ophir Munk > Sent: Tuesday, February 25, 2025 13:02 > To: Dariusz Sosnowski ; Slava Ovsiienko > ; Bing Zhao ; Ori Kam > ; Suanming Mou ; Matan Azrad > > Cc: dev@dpdk.org; Raslan Darawsheh ; Jiawei(Jonny) > Wang > Subject: [PATCH V1 3/4] net/mlx5: remove un

RE: [PATCH V1 1/4] common/mlx5: support FDB unified capability query

2025-02-25 Thread Dariusz Sosnowski
> -Original Message- > From: Ophir Munk > Sent: Tuesday, February 25, 2025 13:02 > To: Dariusz Sosnowski ; Slava Ovsiienko > ; Bing Zhao ; Ori Kam > ; Suanming Mou ; Matan Azrad > > Cc: dev@dpdk.org; Raslan Darawsheh > Subject: [PATCH V1 1/4] common/mlx5: support FDB unified capabilit

RE: [PATCH V1 2/4] net/mlx5: support FDB unified domain

2025-02-25 Thread Dariusz Sosnowski
> -Original Message- > From: Ophir Munk > Sent: Tuesday, February 25, 2025 13:02 > To: Dariusz Sosnowski ; Slava Ovsiienko > ; Bing Zhao ; Ori Kam > ; Suanming Mou ; Matan Azrad > > Cc: dev@dpdk.org; Raslan Darawsheh > Subject: [PATCH V1 2/4] net/mlx5: support FDB unified domain > >

RE: [PATCH V1 4/4] net/mlx5/hws: allow different types in miss validation

2025-02-25 Thread Dariusz Sosnowski
> -Original Message- > From: Ophir Munk > Sent: Tuesday, February 25, 2025 13:02 > To: Dariusz Sosnowski ; Slava Ovsiienko > ; Bing Zhao ; Ori Kam > ; Suanming Mou ; Matan Azrad > > Cc: dev@dpdk.org; Raslan Darawsheh > Subject: [PATCH V1 4/4] net/mlx5/hws: allow different types in mis

RE: [PATCH v3 02/14] eventdev: remover unnecessary deref on function pointers

2025-02-25 Thread Pavan Nikhilesh Bhagavatula
> > -Original Message- > > From: Stephen Hemminger > > Sent: Thursday, February 20, 2025 10:25 PM > > To: dev@dpdk.org > > Cc: Stephen Hemminger ; Morten Brørup > > ; Richardson, Bruce > > ; Gujjar, Abhinandan S > > ; Jerin Jacob ; Amit > > Prakash Shukla ; Naga Harish K, S V > > > > Sub

RE: [PATCH v3 02/14] eventdev: remover unnecessary deref on function pointers

2025-02-25 Thread Amit Prakash Shukla
> -Original Message- > From: Pavan Nikhilesh Bhagavatula > Sent: Tuesday, February 25, 2025 6:48 PM > To: Gujjar, Abhinandan S ; Stephen > Hemminger ; dev@dpdk.org > Cc: Morten Brørup ; Richardson, Bruce > ; Jerin Jacob ; Amit > Prakash Shukla ; Naga Harish K, S V > > Subject: RE: [PATC

Re: [PATCH v2] net/virtio: add virtio hash report feature

2025-02-25 Thread Maxime Coquelin
Hi, On 1/27/25 8:41 AM, Kommula Shiva Shankar wrote: This patch adds virtio hash report feature, which is supported in packet queue mode with scalar version Why only restrict to packed ring? isn't it also compatible with split ring? Signed-off-by: Kommula Shiva Shankar --- drivers/net/vi

Re: [PATCH v3 00/16] net/zxdh: updated net zxdh driver

2025-02-25 Thread Stephen Hemminger
On Tue, 25 Feb 2025 18:42:52 +0800 Junlong Wang wrote: > V3: > - fix warning enable asserts compile. > - fix warning enable address sanitizer for undefined checks. > - modify extra memset and cast. > - remove __rte_unused from function prototypes. > - fix indentation in mtr get and use

Re: [PATCH v15 09/29] net/rnp: add queue stop and start operations

2025-02-25 Thread Stephen Hemminger
On Tue, 25 Feb 2025 16:41:06 +0800 Wenbo Cao wrote: > diff --git a/doc/guides/nics/rnp.rst b/doc/guides/nics/rnp.rst > index 99b96e9b8e..c3547c38b6 100644 > --- a/doc/guides/nics/rnp.rst > +++ b/doc/guides/nics/rnp.rst > @@ -71,6 +71,10 @@ Listed below are the rte_eth functions supported: > * ``

Re: [v5 1/5] vhost: skip crypto op fetch before vring init

2025-02-25 Thread Maxime Coquelin
On 2/24/25 11:35 AM, Gowrishankar Muthukrishnan wrote: Until virtio avail ring is initialized (by VHOST_USER_SET_VRING_ADDR), worker thread should not try to fetch crypto op, which would lead to memory fault. Fixes: 939066d96563 ("vhost/crypto: add public function implementation") Cc: sta...@

Re: [PATCH] net/nfp: fix get represetor wrong port stats

2025-02-25 Thread Stephen Hemminger
On Tue, 25 Feb 2025 09:34:54 +0800 Chaoyong He wrote: > From: Long Wu > > The 'ipackets'/'opackets' are used to record the number > of packets on represetor port received/sent. But the > code does not consider concurrent calculation of > 'ipackets'/'opackets'. If multiple queues are calculated

<    1   2