Here adds configs for PHYTIUM server.
Signed-off-by: luzhipeng
---
v2->v1:
1. add ccache for cross build
2. rename fts2500 to tys2500 and modify the corresponding position
---
config/arm/arm64_tys2500_linux_gcc | 16
config/arm/meson.build | 26 ++
Here adds configs for PHYTIUM server.
Signed-off-by: luzhipeng
---
v2->v1:
1. add ccache for cross build
2. rename fts2500 to tys2500 and modify the corresponding position
config/arm/arm64_tys2500_linux_gcc | 16
config/arm/meson.build | 26 ++
> -Original Message-
> From: Pei, Andy
> Sent: Thursday, September 8, 2022 1:54 PM
> To: dev@dpdk.org
> Cc: Xia, Chenbo ; Xu, Rosen ;
> Huang, Wei ; Cao, Gang ;
> maxime.coque...@redhat.com; Huang Wei
> Subject: [PATCH v2 4/8] vdpa/ifc: write queue count to MQ register
>
> Write queue co
Hi Chenbo,
Thanks for your reply.
I will send V3 patch to address your 2 comments.
> -Original Message-
> From: Xia, Chenbo
> Sent: Friday, September 9, 2022 8:29 AM
> To: Pei, Andy ; dev@dpdk.org
> Cc: Xu, Rosen ; Huang, Wei ; Cao,
> Gang ; maxime.coque...@redhat.com; Huang Wei
>
> Su
Hi Chenbo,
Thanks for your reply.
My reply is inline.
> -Original Message-
> From: Xia, Chenbo
> Sent: Friday, September 9, 2022 8:29 AM
> To: Pei, Andy ; dev@dpdk.org
> Cc: Xu, Rosen ; Huang, Wei ; Cao,
> Gang ; maxime.coque...@redhat.com; Huang Wei
>
> Subject: RE: [PATCH v2 2/8] vdpa
> -Original Message-
> From: luzhipeng
> Sent: Friday, September 9, 2022 3:11 PM
> To: dev@dpdk.org
> Cc: Jan Viktorin ; Ruifeng Wang
> ; Bruce
> Richardson ; luzhipeng
> Subject: [PATCH v2 RESEND] config/arm: add PHYTIUM tys2500
>
> Here adds configs for PHYTIUM server.
>
> Signed-off
Hi Chenbo,
For BLK devices, ifc driver does not have VHOST_USER_SET_VRING_ENABLE msg.
So it does not need to dynamic configuration.
But now I think it is fine to use the same logic.
> -Original Message-
> From: Xia, Chenbo
> Sent: Friday, September 9, 2022 3:35 PM
> To: Pei, Andy ; dev
Here adds configs for PHYTIUM server.
Signed-off-by: luzhipeng
---
v3->v2:
1. fix typos
v2->v1:
1. add ccache for cross build
2. rename fts2500 to tys2500 and modify the corresponding code
config/arm/arm64_tys2500_linux_gcc | 16
config/arm/meson.build
On 9/9/2022 8:11 AM, luzhipeng wrote:
Here adds configs for PHYTIUM server.
Signed-off-by: luzhipeng
Hi luzhipeng,
What does 'RESEND' mean in the patch title?
Also can you please use following format for the sign-off:
`Signed-off-by: Real-name Real-surname `
More detail can be found at
-
Kindly ping.
Any feedback is appreciated.
On 2022年08月29日 16:29, Min Zhou wrote:
On CentOS 8 or Debian 10.4 systems using gcc 12.1 to cross
compile DPDK, gcc shows a following warning which will cause
build to fail when build is run with -werror:
In function 'mbuf_to_desc',
inlined from '
Kindly ping.
Any feedback is appreciated.
On 2022年08月27日 16:59, Min Zhou wrote:
Dear team,
The following patch set is intended to support DPDK running on LoongArch
architecture.
LoongArch is the general processor architecture of Loongson Corporation
and is a new RISC ISA, which is a bit like
[Public]
Acked-by: Chandubabu Namburu
-Original Message-
From: Modali, Bhagyada
Sent: Thursday, September 8, 2022 11:45 PM
To: Namburu, Chandu-babu ; Yigit, Ferruh
Cc: dev@dpdk.org; sta...@dpdk.org; Modali, Bhagyada
Subject: [PATCH v2] net/axgbe: support segmented Tx
Enable segmente
For string values returned from telemetry, escape any values that cannot
normally appear in a json string. According to the json spec[1], the
characters than need to be handled are control chars (char value < 0x20)
and '"' and '\' characters.
To handle this, we replace the snprintf call with a sep
This patchset contains fixes for the problem of handling characters returned by
telemetry callbacks which require escaping when encoded in JSON format. It also
includes unit tests to validate the correct encoding in such scenarios and a
number of smaller enhancements to telemetry and telemetry test
Add unit test to validate that when creating a string response in json,
that characters such as \n or quotes are properly escaped.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
app/test/test_telemetry_json.c | 17 +
1 file changed, 17 inserti
When strings are added to an array variable, we need to properly escape
the invalid json characters in the strings.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
lib/telemetry/telemetry_json.h | 28 +++-
1 file changed, 19 insertions(
To save issues with encoding the names of values in dicts, we limit the
allowed names to a subset of character values. This list of allowed
characters can be expanded as necessary in future.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
lib/telemetry/rte_tel
Add test-case to validate that when adding strings to arrays, the
strings are properly escaped to remove any invalid characters.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
app/test/test_telemetry_json.c | 24
1 file changed, 24 in
rather than just printing out success or failure at the end of the test
only, print out "OK" or "ERROR" for each individual test case within the
overall test. As part of this, ensure each case returns 0 on success and
any other value on failure.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Pow
Add a test-case to validate that when adding strings either as the name
or the value of an entry in an object, that all values are escaped
properly.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
app/test/test_telemetry_json.c | 24
1
When strings are added to an dict variable, we need to properly escape
the invalid json characters in the strings.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
lib/telemetry/telemetry_json.h | 12
1 file changed, 8 insertions(+), 4 deletions(-)
Limit the telemetry command characters to the minimum set needed for
current implementations. This prevents issues with invalid json
characters needing to be escaped on replies.
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten Brørup
---
doc/guides/rel_notes/deprecation.r
To help with the writing and maintaining of test cases in this file we
can make the following changes to it:
- rename non-test-case functions i.e. the infrastructure functions, to
not start with "test_", so that each sub-test case can be identified
by starting with that prefix.
- add a comment
Add in some basic unit tests to validate the character escaping being
done on string data values, which tests end-to-end processing of those
values beyond just the json-encoding steps tested by the
"telemetry_json_autotest".
Signed-off-by: Bruce Richardson
Acked-by: Ciara Power
Acked-by: Morten
When preparing the json response to a telemetry socket query, the code
for prefixing the command name, and appending the file "}" on the end of
the response was duplicated for multiple reply types. Taking this code
out of the switch statement reduces the duplication and makes the code
more maintain
The /help telemetry command prints out the help text for the given
command passed in as parameter. However, entering /help without any
parameters does not give any useful information as to the fact that you
need to pass in a command to get help on. Update the command so it
prints its own help text
Very nice to me. Thank you very much!
Thanks & Best Regards,
Jianhua Xie
-邮件原件-
发件人: dev-boun...@dpdk.org 代表 luzhipeng
发送时间: 2022年9月9日 16:43
收件人: dev@dpdk.org
抄送: Jan Viktorin ; Ruifeng Wang
; Bruce Richardson ;
luzhipeng
主题: [PATCH v3] config/arm: add PHYTIUM tys2500
Here adds config
On 9/9/2022 3:36 AM, Chaoyong He wrote:
On 9/8/2022 9:44 AM, Chaoyong He wrote:
Adds the vNIC initialization logic for the flower PF vNIC. The flower
firmware exposes this vNIC for the purposes of fallback traffic in the
switchdev use-case.
Adds minimal dev_ops for this PF device. Because the d
On 9/9/2022 6:43 AM, Chaoyong He wrote:
On 9/8/2022 9:44 AM, Chaoyong He wrote:
The NFP card can load different firmware applications. Currently
only the CoreNIC application is supported. This commit makes needed
infrastructure changes in order to support other firmware
applications too.
Cleare
On 9/9/2022 3:36 AM, Chaoyong He wrote:
On 9/8/2022 9:44 AM, Chaoyong He wrote:
Adds the vNIC initialization logic for the flower PF vNIC. The flower
firmware exposes this vNIC for the purposes of fallback traffic in the
switchdev use-case.
Adds minimal dev_ops for this PF device. Because the d
> -Original Message-
> From: Bruce Richardson
> Sent: Wednesday, September 7, 2022 6:17 PM
> To: Juraj Linkeš
> Cc: tho...@monjalon.net; david.march...@redhat.com;
> ronan.rand...@intel.com; honnappa.nagaraha...@arm.com;
> ohily...@iol.unh.edu; lijuan...@intel.com; dev@dpdk.org
> Subjec
On Fri, Sep 09, 2022 at 01:38:33PM +, Juraj Linkeš wrote:
>
>
> > -Original Message-
> > From: Bruce Richardson
> > Sent: Wednesday, September 7, 2022 6:17 PM
> > To: Juraj Linkeš
> > Cc: tho...@monjalon.net; david.march...@redhat.com;
> > ronan.rand...@intel.com; honnappa.nagaraha.
> -Original Message-
> From: Bruce Richardson
> Sent: Friday, September 9, 2022 3:53 PM
> To: Juraj Linkeš
> Cc: tho...@monjalon.net; david.march...@redhat.com;
> ronan.rand...@intel.com; honnappa.nagaraha...@arm.com;
> ohily...@iol.unh.edu; lijuan...@intel.com; dev@dpdk.org
> Subject:
https://bugs.dpdk.org/show_bug.cgi?id=1078
David Marchand (david.march...@redhat.com) changed:
What|Removed |Added
Status|UNCONFIRMED |RESOLVED
Res
Try and find the script in the sources of the currently running kernel
so that users do not have to specify DPDK_CHECKPATCH_PATH which might
well be the same location found by the educated guess.
Signed-off-by: Henning Schild
---
devtools/checkpatches.sh | 16 +++-
1 file changed, 11
There is no point in such a call and UBSan complains about a call to
memcpy with a null pointer as second arg.
When building with -Db_sanitize=undefined, Clang gives the following
warning
../lib/bpf/bpf_load.c:37:20: runtime error: null pointer passed as
argument 2, which is declared to ne
Updating AMD CCP crypto maintainer
Signed-off-by: Sunil Uttarwar
---
MAINTAINERS | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 32ffdd1a61..5f5516385b 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -1030,7 +1030,7 @@ T: git://dpdk.org/next/dpdk
This is a *untested* cleanup series after looking for usage of
rte_pci_device objects in DPDK drivers.
I can't test those patches by lack of hw, so I hope the driver maintainer
can look into them.
Thanks.
--
David Marchand
David Marchand (4):
crypto/ccp: remove some printf
crypto/ccp: remove
uio_fd is unused.
Fixes: 09a0fd736a08 ("crypto/ccp: enable IOMMU")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
drivers/crypto/ccp/ccp_dev.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/crypto/ccp/ccp_dev.c b/drivers/crypto/ccp/ccp_dev.c
index 9c9cb81236..410e62121e 10
A DPDK application must _not_ use printf.
Use log framework.
Fixes: ef4b04f87fa6 ("crypto/ccp: support device init")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
drivers/crypto/ccp/ccp_dev.c | 4 ++--
drivers/crypto/ccp/ccp_pci.c | 3 ++-
drivers/crypto/ccp/rte_ccp_pmd.c | 2 +-
Using IOVA or physical addresses is something that the user (via
--iova-mode=) or the bus code decides.
The crypto/ccp PCI driver should only use rte_mem_virt2iova.
It should not try to decide what to use solely based on the kmod
the PCI device is bound to.
While at it, the global variable sha_ct
This driver has been converted from a vdev driver to a pci driver some
time ago. This conversion is buggy as it tries to probe any pci devices
present on a system for *each* probe request from the PCI bus.
Rely on the passed pci device and only probe what is requested.
While at it:
- stop copyin
Greetings,
This is to let you know that we are executing upgrades today for the open
0-day robot that we run for OVS and DPDK projects. We don't expect that
the robot will be offline for a very long time, but just note that there
will be some down time as we bring the systems back online.
Upgrad
43 matches
Mail list logo