On Thu, Apr 14, 2022 at 11:58 AM Abdelfattah Chehab
wrote:
>
> The global variable is not accessible from libdpdk.so
> I don't really see how the linker can find it in this case.
Well, the initial mail was missing a description of the problem.
The patch is badly formatted and sent against 20.11,
On Tue, Jun 28, 2022 at 8:23 PM Tyler Retzlaff
wrote:
>
> On Tue, Jun 28, 2022 at 10:38:27AM -0700, Stephen Hemminger wrote:
> > On Tue, 28 Jun 2022 10:07:12 -0700
> > Tyler Retzlaff wrote:
> >
> > > > > to avoid people tripping over mishandling pointers in/out of the api
> > > > > surface taking
Rely on a local flag rather than dereference a bus object.
This will help next commits.
Signed-off-by: David Marchand
---
drivers/common/mlx5/linux/mlx5_common_auxiliary.c | 10 --
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/drivers/common/mlx5/linux/mlx5_common_auxilia
This is a PoC for hiding the rte_bus, rte_driver and rte_device objects.
And mark associated driver only API as internal.
A good amount of the patches are preparation work on rte_bus.h,
rte_dev.h, rte_devargs.h and rte_eal.h headers, removing dependencies
between them. This is something I had in s
There is no in-tree user for this accessor that returns the PCI bus
object.
On the other hand, a bus object can be retrieved by name using
rte_bus_find_by_name.
We can remove driver specific API.
Signed-off-by: David Marchand
---
drivers/raw/ifpga/ifpga_rawdev.c | 7 +--
drivers/raw/ifpga/
addr and id fields are deprecated and are not used in the kni library.
Stop populating them in in-tree examples.
Signed-off-by: David Marchand
---
app/test/test_kni.c| 30 --
examples/ip_pipeline/kni.c | 10 --
2 files changed, 40 deletions(-)
diff --
For any bus that does not support device iteration, rte_dev_iterator_init
both returned an error code and logged an error message.
An application (like testpmd) that only wants to list devices, would have
no choice but to inspect a bus object to avoid spewing error logs.
Make those log messages de
Rely on the generic device name rather than restrict to only supporting
PCI devices.
Signed-off-by: David Marchand
---
examples/ethtool/lib/rte_ethtool.c | 17 ++---
1 file changed, 2 insertions(+), 15 deletions(-)
diff --git a/examples/ethtool/lib/rte_ethtool.c
b/examples/ethtool/
We don't need to include rte_bus.h.
Only a forward declaration of rte_bus and an inclusion of rte_dev.h are
needed.
Signed-off-by: David Marchand
---
app/test/test_vdev.c | 1 +
lib/eal/include/rte_devargs.h | 4 +++-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/app/tes
RTE_FUNC_PTR_OR_* macros have nothing to do with the rte_device object
and associated API.
Move them to rte_common.h and include it where needed.
Signed-off-by: David Marchand
---
drivers/common/qat/qat_device.c| 1 +
drivers/compress/qat/qat_comp_pmd.c| 1 +
Those files don't need to include rte_bus.h.
Signed-off-by: David Marchand
---
drivers/bus/auxiliary/linux/auxiliary.c | 1 -
drivers/bus/ifpga/ifpga_common.c| 1 -
drivers/bus/ifpga/rte_bus_ifpga.h | 1 -
drivers/bus/vdev/vdev_params.c | 1 -
drivers/bus/vmbus/linux/vmbus
iova enum definition does not need to be defined as part of the bus API.
Move it to rte_eal.h.
With this step, rte_eal.h does not depend on rte_bus.h and rte_dev.h.
Fix existing code that was relying on these implicit inclusions.
Signed-off-by: David Marchand
---
app/test-compress-perf/comp_perf
There is no need for a back reference to a singleton object in the bus
driver objects: each function is contextually aware of which bus object
it should manipulate.
Signed-off-by: David Marchand
---
drivers/bus/auxiliary/auxiliary_common.c | 2 --
drivers/bus/auxiliary/rte_bus_auxiliary.h | 2
Now that there is no bus specific object referenced in the driver
objects, we can hide rte_dpaa_bus, rte_fslmc_bus, rte_pci_bus,
rte_vmbus_bus specific structures into their bus code.
While at it:
- move enumerators only used in the bus code itself,
- remove unneeded list head structure type,
- re
Add helpers to get a rte_bus object details.
This will be used externally.
Internal users may still dereference a rte_bus object.
Signed-off-by: David Marchand
---
Changes since RFC v1:
- changed approach: only external users are updated,
---
app/test-pmd/config.c| 6 ++
rte_bbdev_pmd.h is a driver only header.
Signed-off-by: David Marchand
---
lib/bbdev/meson.build | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/lib/bbdev/meson.build b/lib/bbdev/meson.build
index 07685e7578..7d035065f1 100644
--- a/lib/bbdev/meson.build
+++ b/lib/bbdev/
Make rte_bus opaque for non internal users.
This will make extending this object possible without breaking the ABI.
Introduce a new driver header and move rte_bus definition and helpers.
Update drivers and library to use the internal header.
Signed-off-by: David Marchand
---
Changes since RFC v1
Those headers are for drivers as they include ethdev_driver.h, a
driver-only header.
Fixes: 19cc526d6c79 ("ethdev: install driver headers")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
lib/ethdev/meson.build | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/lib/
Same as for device classes, external DPDK users may need to include some
bus headers for their out of tree drivers.
Signed-off-by: David Marchand
---
drivers/meson.build | 4
1 file changed, 4 insertions(+)
diff --git a/drivers/meson.build b/drivers/meson.build
index b22c2adda7..7449643fa9
rte_rawdev_pmd.h is a driver only header.
Signed-off-by: David Marchand
---
lib/rawdev/meson.build | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/lib/rawdev/meson.build b/lib/rawdev/meson.build
index 7dfc3d5cf9..ccfd922fda 100644
--- a/lib/rawdev/meson.build
+++ b/lib/rawd
The auxiliary bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
drivers/bus/auxiliary/auxiliary_common.c | 1 -
drivers/bus/auxiliary/auxiliary_params.c | 1 -
...rte_bus_auxiliary.h => bus_au
The dpaa bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
drivers/bus/dpaa/base/qbman/qman.c | 2 +-
drivers/bus/dpaa/{rte_dpaa_bus.h => bus_dpaa_driver.h} | 9 ++---
drivers/bus/dpaa/dpa
The fslmc bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
drivers/bus/fslmc/{rte_fslmc.h => bus_fslmc_driver.h} | 7 ---
drivers/bus/fslmc/fslmc_bus.c | 1 -
drivers/bus/fslmc/fslmc_
Remove unused symbols (exposed only in an internal header which
guarantees that no application out there relied on them).
Remove rte_ prefix and inline the rest to avoid having to expose them as
global symbols for a relatively small added value.
Signed-off-by: David Marchand
---
drivers/bus/ifp
The ifpga bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
.../bus/ifpga/{rte_bus_ifpga.h => bus_ifpga_driver.h} | 11 ---
drivers/bus/ifpga/ifpga_bus.c | 4 ++--
drivers/bus/ifp
The pci bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
app/test-pmd/testpmd.h| 2 +-
app/test/virtual_pmd.c| 2 +-
drivers/baseband/acc100/rte_acc100_pmd.c
The vdev bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
app/test/test_vdev.c | 2 +-
drivers/baseband/la12xx/bbdev_la12xx.c| 2 +-
drivers/baseband/null/bbdev_null.c
The vmbus bus interface is for drivers only.
Mark as internal and move the header on the driver headers list.
Signed-off-by: David Marchand
---
drivers/bus/vmbus/bus_vmbus_driver.h | 106 +++
drivers/bus/vmbus/meson.build| 1 +
drivers/bus/vmbus/private.h
Add a helper to get a rte_driver object name.
This will be used externally.
Internal users may still dereference a rte_driver object.
Signed-off-by: David Marchand
---
app/test-pmd/config.c | 2 +-
lib/eal/common/eal_common_dev.c | 6 ++
lib/eal/include/rte_dev.h | 13 +
Make rte_driver opaque for non internal users.
This will make extending this object possible without breaking the ABI.
Introduce a new driver header and move rte_driver definition.
Update drivers and library to use the internal header.
Signed-off-by: David Marchand
---
drivers/baseband/acc100/r
Prepare for making the device object opaque by adding accessors.
Update existing "external" users.
Signed-off-by: David Marchand
---
app/proc-info/main.c | 6 ++--
examples/ethtool/lib/rte_ethtool.c | 2 +-
examples/l3fwd/l3fwd_em.c | 4 +--
examples/l3fwd/l3fwd_fib.c
Make rte_device opaque for non internal users.
This will make extending this object possible without breaking the ABI.
Signed-off-by: David Marchand
---
lib/eal/common/eal_private.h | 2 +-
lib/eal/include/dev_driver.h | 14 ++
lib/eal/include/rte_dev.h| 13 +
lib/vh
From: Shiqi Liu <835703...@qq.com>
As the possible failure of the rte_malloc(), the not_checked and
checked could be NULL pointer.
Therefore, it should be better to check it in order to avoid
the dereference of the NULL pointer.
Fixes: 09a0fd736a0 ("crypto/ccp: enable IOMMU")
Signed-off-by: Shiqi
On Sat, 9 Jul 2022 00:04:27 +0200
Morten Brørup wrote:
> > > typedef struct {
> > > - volatile int32_t cnt; /**< -1 when W lock held, > 0 when R locks
> > held.
> > > */
> > > + volatile int32_t cnt;
>
> Not signed anymore, so consider uint32_t. Suggest also rename to cnt_state or
> simi
On Sat, 9 Jul 2022 00:04:27 +0200
Morten Brørup wrote:
> Always the creative mind, Stephen. :-)
>
> You might consider adding/updating even more comments.
>
> Acked-by: Morten Brørup
The motivation is that our work load is reader/writer lock heavy
with small number of threads. Therefore the n
On Sat, 9 Jul 2022 10:16:43 +0200
David Marchand wrote:
> On Tue, Jun 28, 2022 at 8:23 PM Tyler Retzlaff
> wrote:
> >
> > On Tue, Jun 28, 2022 at 10:38:27AM -0700, Stephen Hemminger wrote:
> > > On Tue, 28 Jun 2022 10:07:12 -0700
> > > Tyler Retzlaff wrote:
> > >
> > > > > > to avoid people
On Sat, 9 Jul 2022 10:26:15 +0200
David Marchand wrote:
> This is a PoC for hiding the rte_bus, rte_driver and rte_device objects.
> And mark associated driver only API as internal.
>
> A good amount of the patches are preparation work on rte_bus.h,
> rte_dev.h, rte_devargs.h and rte_eal.h head
rte_driver and rte_device are unnecessarily exposed in the public API/ABI.
Announce that they will be made opaque in the public API and mark
associated API as internal.
This impacts all bus, as their driver registration mechanism will be
made internal.
Note: the PCI bus had a similar deprecation n
Currently, when vm_power_manager exits, we are using a LIST_FOREACH
macro to iterate over VM info structures while freeing them. This
leads to use-after-free error. To address this, replace all usages of
LIST_* with TAILQ_* macros, and use the RTE_TAILQ_FOREACH_SAFE macro
to iterate and delete VM i
> -Original Message-
> From: Thomas Monjalon
> Sent: Thursday 7 July 2022 20:10
> To: Khan, Hamza
> Cc: dev@dpdk.org
> Subject: Re: [PATCH 1/2] common: add safe version of foreach-list to Linux
>
> 07/07/2022 17:59, Khan, Hamza:
> >
> > > -Original Message-
> > > From: Thomas
>-Original Message-
>From: David Marchand
>Sent: Friday, July 8, 2022 1:43 PM
>To: abhimanyu.sa...@xilinx.com; vsriv...@xilinx.com
>Cc: Maxime Coquelin ; dev ;
>Xia, Chenbo ; Andrew Rybchenko
>; Saini, Abhimanyu
>
>Subject: Re: [PATCH] vdpa/sfc: resolve race between libvhost and dev_conf
>From: Abhimanyu Saini
>
>The used/avail queue indexes are not bound by queue size, because the
>descriptor entry index is calculated by a simple modulo between queue index
>and queue_size
>
>So, do not check initial used and avail queue indexes against queue size
>because it is possible for these
42 matches
Mail list logo