Re: [dpdk-dev] [PATCH] add flow shared action API

2020-07-04 Thread Andrey Vesnovaty
Hi, Jerin & Thomas. On Fri, Jul 3, 2020 at 6:21 PM Thomas Monjalon wrote: > 03/07/2020 17:02, Jerin Jacob: > > On Fri, Jul 3, 2020 at 8:07 PM Andrey Vesnovaty > wrote: > > > Signed-off-by: Andrey Vesnovaty > > > Signed-off-by: Andrey Vesnovaty > > > Signed-off-by: Andrey Vesnovaty > > > > D

Re: [dpdk-dev] [PATCH] add flow shared action API

2020-07-04 Thread Andrey Vesnovaty
Thanks, Andrey Vesnovaty (+972)*526775512* | *Skype:* andrey775512 On Fri, Jul 3, 2020 at 6:02 PM Jerin Jacob wrote: > On Fri, Jul 3, 2020 at 8:07 PM Andrey Vesnovaty > wrote: > > > > From: Andrey Vesnovaty > > > > This commit introduces extension of DPDK flow action API enabling > > sharing

[dpdk-dev] [PATCH 4/4] doc: update feature list of hns3 rst document

2020-07-04 Thread Wei Hu (Xavier)
From: Lijun Ou This patch updates the feature list for hns3 PMD driver document. Signed-off-by: Lijun Ou Signed-off-by: Wei Hu (Xavier) --- doc/guides/nics/hns3.rst | 11 ++- 1 file changed, 10 insertions(+), 1 deletion(-) diff --git a/doc/guides/nics/hns3.rst b/doc/guides/nics/hns3.

[dpdk-dev] [PATCH 2/4] net/hns3: cleanup duplicate code when processing TSO in Tx

2020-07-04 Thread Wei Hu (Xavier)
From: Chengchang Tang This patch fixes up paylen calculation twice when processing TSO request in the '.tx_pkt_burst' ops implementation function to avoid performance loss. Fixes: 6dca716c9e1d ("net/hns3: support TSO") Cc: sta...@dpdk.org Signed-off-by: Chengchang Tang Signed-off-by: Wei Hu (X

[dpdk-dev] [PATCH 0/4] updates for hns3 PMD driver

2020-07-04 Thread Wei Hu (Xavier)
This series are updates for hns3 PMD driver. Chengchang Tang (1): net/hns3: cleanup duplicate code when processing TSO in Tx Lijun Ou (1): doc: update feature list of hns3 rst document Wei Hu (Xavier) (2): net/hns3: check if registering mp action successfully net/hns3: fix VLAN tag inser

[dpdk-dev] [PATCH 3/4] net/hns3: fix VLAN tag inserted in wrong position in Tx

2020-07-04 Thread Wei Hu (Xavier)
Based on hns3 network engine, in order to configure hardware VLAN insert offload in Tx direction, PMD driver reads the VLAN tags from the vlan_tci_outer and vlan_tci of the structure rte_mbuf, fills them into the Tx Buffer Descriptor and sets the related offload flag for every packet. Currently, t

[dpdk-dev] [PATCH 1/4] net/hns3: check if registering mp action successfully

2020-07-04 Thread Wei Hu (Xavier)
Currently, there is a coverity defect warning about hns3 PMD driver, the detail information as blow: CID 289969 (#1 of 1): Unchecked return value (CHECKED_RETURN) 1. check_return: Calling rte_mp_action_register without checking return value (as is done elsewhere 11 out of 13 times). The problem

[dpdk-dev] [PATCH v3] build: check functionality rather than binutils version

2020-07-04 Thread Bruce Richardson
Rather than checking the binutils version number, which can lead to unnecessary disabling of AVX512 if fixes have been backported to distro versions, we can instead check the output of "as" from binutils to see if it is correct. The check in the script uses the minimal assembly reproduction code p

Re: [dpdk-dev] [PATCH] add flow shared action API

2020-07-04 Thread Jerin Jacob
On Sat, Jul 4, 2020 at 3:40 PM Andrey Vesnovaty wrote: > > > Thanks, > > Andrey Vesnovaty > (+972)526775512 | Skype: andrey775512 > > > On Fri, Jul 3, 2020 at 6:02 PM Jerin Jacob wrote: >> >> On Fri, Jul 3, 2020 at 8:07 PM Andrey Vesnovaty wrote: >> > >> > From: Andrey Vesnovaty >> > >> > This

Re: [dpdk-dev] [PATCH v2 1/7] ethdev: introduce sample action for rte flow

2020-07-04 Thread Andrew Rybchenko
On 7/2/20 9:43 PM, Jiawei Wang wrote: > When using full offload, all traffic will be handled by the HW, and > directed to the requested vf or wire, the control application loses vf->VF > visibility on the traffic. > So there's a need for an action that will enable the control application > some v

Re: [dpdk-dev] [PATCH v4] examples/l2fwd: add cmdline option for forwarding port info

2020-07-04 Thread Jerin Jacob
On Mon, May 25, 2020 at 2:59 PM Bruce Richardson wrote: > > On Sun, May 24, 2020 at 06:13:22PM +0200, Thomas Monjalon wrote: > > Bruce, as maintainer of l2fwd example, any opinion about this change? > > > Assuming all previous discussion on it is resolved, I'm fine with this > patch, though I susp

Re: [dpdk-dev] [PATCH v2] build: remove special handling for node library

2020-07-04 Thread Jerin Jacob
On Thu, Jul 2, 2020 at 9:39 PM Thomas Monjalon wrote: > > The node library had a need of being linked as a whole > to make some constructors effective. > Now that all libraries are linked with --whole-archive, > there is no need to have this library separate. > > Fixes: e2db26f76673 ("build: alway

Re: [dpdk-dev] [PATCH 2/8] trace: simplify trace point registration

2020-07-04 Thread Jerin Jacob
On Mon, May 4, 2020 at 2:02 AM David Marchand wrote: > > RTE_TRACE_POINT_DEFINE and RTE_TRACE_POINT_REGISTER must come in pairs. > Merge them and let RTE_TRACE_POINT_REGISTER handle the constructor part. > > Signed-off-by: David Marchand > --- > app/test/test_trace_register.c| 1

[dpdk-dev] [PATCH] service: fix wrong lcore indexes

2020-07-04 Thread Andrew Rybchenko
From: Igor Romanov The service core list is populated, but not used. Incorrect lcore states are examined for a service. Use the populated list to iterate over service cores. Fixes: e30dd31847d2 ("service: add mechanism for quiescing") Cc: sta...@dpdk.org Signed-off-by: Igor Romanov Signed-off

Re: [dpdk-dev] [PATCH v3 6/9] eal: register non-EAL threads as lcores

2020-07-04 Thread David Marchand
On Fri, Jul 3, 2020 at 6:40 PM Ananyev, Konstantin wrote: > what are the advantages of current approach (forbid MP support on the fly) > over explicit start-up parameters (either --proc-type=single or > --lcore-allow=...)? > Why do you think it is a better one? I don't want to perpetuate the "pl

Re: [dpdk-dev] [PATCH] service: fix wrong lcore indexes

2020-07-04 Thread Honnappa Nagarahalli
Hi Andrew/Igor, A effective test case is missing for this, can you please add a test case? Otherwise it looks good. > -Original Message- > From: dev On Behalf Of Andrew Rybchenko > Sent: Saturday, July 4, 2020 9:36 AM > To: dev@dpdk.org > Cc: Igor Romanov ; sta...@dpdk.org; Harry

Re: [dpdk-dev] [PATCH] service: fix wrong lcore indexes

2020-07-04 Thread David Marchand
On Sat, Jul 4, 2020 at 5:07 PM Honnappa Nagarahalli wrote: > > Hi Andrew/Igor, > A effective test case is missing for this, can you please add a test > case? Otherwise it looks good. +1, I was about to reply this. -- David Marchand

[dpdk-dev] [PATCH v2] trace: simplify trace point registration

2020-07-04 Thread David Marchand
RTE_TRACE_POINT_DEFINE and RTE_TRACE_POINT_REGISTER must come in pairs. Merge them and let RTE_TRACE_POINT_REGISTER handle the constructor part. Signed-off-by: David Marchand Acked-by: Jerin Jacob --- Changes since v1: - rebased on main branch, --- app/test/test_trace_register.c

Re: [dpdk-dev] [PATCH v5 1/3] lib/lpm: integrate RCU QSBR

2020-07-04 Thread Ruifeng Wang
Hi David, Sorry, I missed tracking of this thread. > -Original Message- > From: David Marchand > Sent: Monday, June 29, 2020 7:56 PM > To: Ruifeng Wang ; Vladimir Medvedkin > ; Bruce Richardson > > Cc: John McNamara ; Marko Kovacevic > ; Ray Kinsella ; Neil Horman > ; dev ; Ananyev, Kon

Re: [dpdk-dev] [dpdk-dev v4 1/4] cryptodev: add symmetric crypto data-path APIs

2020-07-04 Thread Akhil Goyal
Hi Fan, > + > +/** > + * Asynchronous operation job descriptor. > + * Used by HW crypto devices direct API call that supports such activity > + **/ > +struct rte_crypto_sym_job { > + union { > + /** > + * When RTE_CRYPTO_HW_ENQ_FLAG_IS_SGL bit is set in flags, > sgl >

Re: [dpdk-dev] [PATCH v2] examples: add multi process crypto application

2020-07-04 Thread Akhil Goyal
> > > > > > > This multi process app is only taking care of crypto queues while others > > > are > > > for NICs. > > > Is it not worth to have crypto+NIC multi process app instead of this app? > > [Arek] - initially main purpose was to check PMD behavior when: > > 1) configure cryptodev, session

Re: [dpdk-dev] [PATCH v2 1/7] ethdev: introduce sample action for rte flow

2020-07-04 Thread Ajit Khaparde
On Fri, Jul 3, 2020 at 8:27 AM Thomas Monjalon wrote: > 03/07/2020 17:08, Jerin Jacob: > > On Fri, Jul 3, 2020 at 8:25 PM Matan Azrad wrote: > > > From: Jerin Jacob: > > > > When adding overlapping API(rte_eth_mirror_rule_set()) in the same > > > > library(ethdev). > > > > Please depreciate the

Re: [dpdk-dev] [PATCH v2 1/7] ethdev: introduce sample action for rte flow

2020-07-04 Thread Ajit Khaparde
On Thu, Jul 2, 2020 at 11:40 PM Jerin Jacob wrote: > On Fri, Jul 3, 2020 at 12:13 AM Jiawei Wang wrote: > > > > When using full offload, all traffic will be handled by the HW, and > > directed to the requested vf or wire, the control application loses > > visibility on the traffic. > > So there'

Re: [dpdk-dev] [PATCH v2 1/7] ethdev: introduce sample action for rte flow

2020-07-04 Thread Matan Azrad
Hi all From: Jerin Jacob: > On Fri, Jul 3, 2020 at 8:57 PM Thomas Monjalon > wrote: > > > > 03/07/2020 17:08, Jerin Jacob: > > > On Fri, Jul 3, 2020 at 8:25 PM Matan Azrad > wrote: > > > > From: Jerin Jacob: > > > > > When adding overlapping API(rte_eth_mirror_rule_set()) in the > > > > > same l

Re: [dpdk-dev] [PATCH v4 0/7] add support for DOCSIS protocol

2020-07-04 Thread Akhil Goyal
> Introduction > > > This patchset adds support for the DOCSIS protocol to the DPDK Security > API (rte_security), to be used by the AESNI-MB and QAT crypto devices to > combine and accelerate Crypto and CRC functions of the DOCSIS protocol > into a single operation. > > Performing t

Re: [dpdk-dev] [PATCH v4 3/7] crypto/aesni_mb: add support for DOCSIS protocol

2020-07-04 Thread Akhil Goyal
> +#ifdef RTE_LIBRTE_SECURITYY > + rte_free(cryptodev->security_ctx); > +#endif > + Fixed typo while merging.

Re: [dpdk-dev] [PATCH v2 1/8] common/cpt: fix encryption offset

2020-07-04 Thread Akhil Goyal
> In case of gmac auth the encryption offset should be set to zero. > > Fixes: b74652f3a91f ("common/cpt: add microcode interface for encryption") > Fixes: 177b41ceee61 ("common/cpt: add microcode interface for decryption") > Cc: sta...@dpdk.org > > Signed-off-by: Ankur Dwivedi > --- Series appl

Re: [dpdk-dev] [PATCH] crypto/qat: fix AES-XTS capabilities

2020-07-04 Thread Akhil Goyal
> > This patch fixes the increment field of the AES-XTS cipher key size. > > > > Fixes: 7d5ef3bb32cd ("crypto/qat: support XTS") > > > > Cc: sta...@dpdk.org > > > > Signed-off-by: Adam Dybkowski > Acked-by: Fiona Trahe Applied to dpdk-next-crypto Thanks.

Re: [dpdk-dev] [PATCH 2/2] cryptodev: add cryptodev trace in multi process function

2020-07-04 Thread Akhil Goyal
> > From: Fiona Trahe > > > > This patch adds traces to some Cryptodev functions that are used > > in primary/secondary context. > > > > Signed-off-by: Fiona Trahe > Acked-by: Fiona Trahe Self Ack is not required and should not be done. Acked-by: Akhil Goyal Applied to dpdk-next-crypto Thank

Re: [dpdk-dev] [PATCH v2] cryptodev: add function to check if qp was setup

2020-07-04 Thread Akhil Goyal
> > Hi Arek/Fiona, > > > > > > From: Fiona Trahe > > > > > > This patch adds function that can check if queue pair was already > > > setup. This may be useful when dealing with multi process approach in > > > cryptodev. > > > > > > Signed-off-by: Fiona Trahe > > > --- > > > v2: > > > - changed re

Re: [dpdk-dev] [PATCH 2/2] crypto/octeontx2: add ChaCha20-Poly1305 support

2020-07-04 Thread Akhil Goyal
> From: Tejasree Kondoj > > Add ChaCha20-Poly1305 AEAD algorithm support in crypto_octeontx2 PMD > > Signed-off-by: Anoob Joseph > Signed-off-by: Tejasree Kondoj > --- Series Applied to dpdk-next-crypto Thanks.

Re: [dpdk-dev] [PATCH v3 6/9] eal: register non-EAL threads as lcores

2020-07-04 Thread Ananyev, Konstantin
> > On Fri, Jul 3, 2020 at 6:40 PM Ananyev, Konstantin > wrote: > > what are the advantages of current approach (forbid MP support on the fly) > > over explicit start-up parameters (either --proc-type=single or > > --lcore-allow=...)? > > Why do you think it is a better one? > > I don't want t

Re: [dpdk-dev] [PATCH v3 3/3] doc: update deprecation of CIO barrier APIs

2020-07-04 Thread Jerin Jacob
On Sat, Jul 4, 2020 at 12:28 AM Honnappa Nagarahalli wrote: > > rte_cio_*mb APIs will be deprecated in 20.11 release. > > Signed-off-by: Honnappa Nagarahalli Acked-by: Jerin Jacob > --- > doc/guides/rel_notes/deprecation.rst | 6 ++ > 1 file changed, 6 insertions(+) > > diff --git a/doc/

Re: [dpdk-dev] [PATCH v3 2/3] doc: update armv8-a IO barrier changes

2020-07-04 Thread Jerin Jacob
On Sat, Jul 4, 2020 at 12:28 AM Honnappa Nagarahalli wrote: > > Updated the use of DMB instruction in rte_*mb APIs for Armv8-a. > > Signed-off-by: Honnappa Nagarahalli > --- > doc/guides/rel_notes/release_20_08.rst | 7 +++ > 1 file changed, 7 insertions(+) > > diff --git a/doc/guides/rel_no

Re: [dpdk-dev] [PATCH v2 1/7] ethdev: introduce sample action for rte flow

2020-07-04 Thread Jerin Jacob
On Sun, Jul 5, 2020 at 12:56 AM Matan Azrad wrote: > > Hi all > > From: Jerin Jacob: > > On Fri, Jul 3, 2020 at 8:57 PM Thomas Monjalon > > wrote: > > > > > > 03/07/2020 17:08, Jerin Jacob: > > > > On Fri, Jul 3, 2020 at 8:25 PM Matan Azrad > > wrote: > > > > > From: Jerin Jacob: > > > > > > Whe

[dpdk-dev] [pull-request] next-eventdev 20.08 RC1

2020-07-04 Thread Jerin Jacob Kollanukkaran
The following changes since commit 9c99878aa1b16de26fcce82c112b401766dd910e: log: introduce logtype register macro (2020-07-03 15:52:51 +0200) are available in the Git repository at: http://dpdk.org/git/next/dpdk-next-eventdev for you to fetch changes up to 50efcc7264847627c7556fada8d860c00

Re: [dpdk-dev] [PATCH v2 1/7] ethdev: introduce sample action for rte flow

2020-07-04 Thread Matan Azrad
From: Jerin Jacob: > On Sun, Jul 5, 2020 at 12:56 AM Matan Azrad wrote: > > > > Hi all > > > > From: Jerin Jacob: > > > On Fri, Jul 3, 2020 at 8:57 PM Thomas Monjalon > > > wrote: > > > > > > > > 03/07/2020 17:08, Jerin Jacob: > > > > > On Fri, Jul 3, 2020 at 8:25 PM Matan Azrad > > > wrote: >