Hi David & Thomas,
On 2/24/20 4:14 PM, Marvin Liu wrote:
> Available buffer ID should be stored in the zmbuf in the packed-ring
> dequeue path. There's no guarantee that local queue avail index is
> equal to buffer ID.
>
> Fixes: d1eafb532268 ("vhost: add packed ring zcopy batch and single dequeu
Hello,
On Mon, Feb 24, 2020 at 7:35 AM humin (Q) wrote:
> We found that if OS transparent hugepage uses non 'always', mlockall function
> in the main function of testpmd takes more than 25s to execute.
> The results of running on both x86 and ARM are the same. It's very
> unreasonable and deadl
On 2/21/20 1:25 PM, Ferruh Yigit wrote:
> On 1/30/2020 2:20 PM, Ferruh Yigit wrote:
>> Adding the deprecation notice as reminder for next ABI breakage release
>> (20.11).
>> This one time breakage is required to be able to extend enum/define
>> without breaking ABI.
>>
>> Signed-off-by: Ferruh Yigi
> -Original Message-
> From: Thomas Monjalon
> Sent: Friday, February 21, 2020 16:59
> To: dev@dpdk.org
> Cc: Gal Cohen ; Matan Azrad ;
> Shahaf Shuler ; Slava Ovsiienko
> ; John McNamara ;
> Marko Kovacevic
> Subject: [PATCH] doc: fix naming of Mellanox devices
>
> The devices of the fa
On 21/02/2020 16:57, Thomas Monjalon wrote:
> 19/02/2020 14:50, Ray Kinsella:
>> On 19/02/2020 12:43, Thomas Monjalon wrote:
>>> 19/02/2020 12:43, Neil Horman:
On Tue, Feb 18, 2020 at 10:50:09AM +0100, Thomas Monjalon wrote:
> 18/02/2020 10:42, Bruce Richardson:
>> On Tue, Feb 18, 2
On Mon, Feb 24, 2020 at 9:28 AM Maxime Coquelin
wrote:
>
> Hi David & Thomas,
>
> On 2/24/20 4:14 PM, Marvin Liu wrote:
> > Available buffer ID should be stored in the zmbuf in the packed-ring
> > dequeue path. There's no guarantee that local queue avail index is
> > equal to buffer ID.
> >
> > Fi
On 22/02/2020 10:24, Jerin Jacob wrote:
> On Sat, Feb 22, 2020 at 3:23 PM Thomas Monjalon wrote:
>>
>> 22/02/2020 10:05, Jerin Jacob:
>>> On Fri, Feb 21, 2020 at 9:44 PM Thomas Monjalon wrote:
21/02/2020 16:56, Jerin Jacob:
> On Fri, Feb 21, 2020 at 4:40 PM Thomas Monjalon
> wro
On 2/24/20 11:32 AM, David Marchand wrote:
> On Mon, Feb 24, 2020 at 9:28 AM Maxime Coquelin
> wrote:
>>
>> Hi David & Thomas,
>>
>> On 2/24/20 4:14 PM, Marvin Liu wrote:
>>> Available buffer ID should be stored in the zmbuf in the packed-ring
>>> dequeue path. There's no guarantee that local q
Upfront note - that RFC is not a complete patch.
It introduces an ABI breakage, plus it doesn't update ring_elem
code properly, etc.
I plan to deal with all these things in later versions.
Right now I seek an initial feedback about proposed ideas.
Would also ask people to repeat performance tests (
Introduce new test-case to measure ring perfomance under contention
(miltiple producers/consumers).
Starts dequeue/enqueue loop on all available slave lcores.
Signed-off-by: Konstantin Ananyev
---
app/test/Makefile | 1 +
app/test/meson.build| 1 +
app/test/test_ring_stress
Introduce relaxed tail sync (RTS) mode for MT ring synchronization.
Aim to reduce stall times in case when ring is used on
overcommited cpus (multiple active threads on the same cpu).
The main difference from original MP/MC algorithm is that
tail value is increased not by every thread that finished
Introduce head/tail sync mode for MT ring synchronization.
In that mode enqueue/dequeue operation is fully serialized:
only one thread at a time is allowed to perform given op.
Suppose to reduce stall times in case when ring is used on
overcommitted cpus (multiple active threads on the same cpu).
A
Change from *single* to *sync_type* to allow different
synchronisation schemes to be applied.
Change layout to make sure that *sync_type* and *tail*
will always reside on same offsets.
Signed-off-by: Konstantin Ananyev
---
app/test/test_pdump.c | 6 +--
lib/librte_pdump/rte_pdump.c
Introduce new test case to test HTS ring mode under contention.
Signed-off-by: Konstantin Ananyev
---
app/test/Makefile | 1 +
app/test/meson.build| 1 +
app/test/test_ring_hts_stress.c | 28
3 files changed, 30 insertions(+)
create mode
Introduce new test case to test RTS ring mode under contention.
Signed-off-by: Konstantin Ananyev
---
app/test/Makefile | 1 +
app/test/meson.build| 1 +
app/test/test_ring_rts_stress.c | 28
3 files changed, 30 insertions(+)
create mode
From: Sean Morrissey
Moved title syntax to a separate file so that it improves code
readability and allows easy addition.
Also logic changed from checking for bad pattern to checking good
pattern which documents the expected syntax more clearly, and does not
have gaps in the checks.
Signed-off-
Add the actions RTE_FLOW_ACTION_TYPE_SET_[IPV4/IPV6]_DSCP support to the
release note.
Signed-off-by: Suanming Mou
---
doc/guides/rel_notes/release_20_02.rst | 5 +
1 file changed, 5 insertions(+)
diff --git a/doc/guides/rel_notes/release_20_02.rst
b/doc/guides/rel_notes/release_20_02.rst
Add the actions RTE_FLOW_ACTION_TYPE_SET_[IPV4/IPV6]_DSCP support to the
release note.
Signed-off-by: Suanming Mou
---
v2: fix coding style issue.
---
doc/guides/rel_notes/release_20_02.rst | 5 +
1 file changed, 5 insertions(+)
diff --git a/doc/guides/rel_notes/release_20_02.rst
b/doc/g
24/02/2020 13:02, Ferruh Yigit:
> From: Sean Morrissey
>
> Moved title syntax to a separate file so that it improves code
> readability and allows easy addition.
>
> Also logic changed from checking for bad pattern to checking good
> pattern which documents the expected syntax more clearly, and
Hi Anoob/Lukasz,
>
> This series introduces event-mode additions to ipsec-secgw.
>
> With this series, ipsec-secgw would be able to run in eventmode. The
> worker thread (executing loop) would be receiving events and would be
> submitting it back to the eventdev after the processing. This way,
>
Hi Lukasz/Anoob,
>
> Add application inbound/outbound worker thread and
> IPsec application processing code for event mode.
>
> Example ipsec-secgw command in app mode:
> ipsec-secgw -w 0002:02:00.0,ipsec_in_max_spi=128
> -w 0002:03:00.0,ipsec_in_max_spi=128 -w 0002:0e:00.0 -w 0002:10:00.1
> --l
On 2/24/2020 1:39 PM, Thomas Monjalon wrote:
> 24/02/2020 13:02, Ferruh Yigit:
>> From: Sean Morrissey
>>
>> Moved title syntax to a separate file so that it improves code
>> readability and allows easy addition.
>>
>> Also logic changed from checking for bad pattern to checking good
>> pattern wh
From: Sean Morrissey
Moved title syntax to a separate file so that it improves code
readability and allows easy addition.
Also logic changed from checking for bad pattern to checking good
pattern which documents the expected syntax more clearly, and does not
have gaps in the checks.
Signed-off-
On Sun, Feb 23, 2020 at 11:58 AM John McNamara wrote:
> diff --git a/doc/guides/rel_notes/release_20_02.rst
> b/doc/guides/rel_notes/release_20_02.rst
> index dfebc46..8a493e4 100644
> --- a/doc/guides/rel_notes/release_20_02.rst
> +++ b/doc/guides/rel_notes/release_20_02.rst
[snip]
> @@ -279,6 +
When the HW finishes to consume the guest Rx descriptors, it creates a
CQE in the CQ.
The mlx5 driver arms the CQ to get notifications when a specific CQE
index is created - the index to be armed is the next CQE index which
should be polled by the driver.
The mlx5 driver configured the kernel dri
The first Mellanox OFED version to support mlx5 vDPA driver is 5.0.
Signed-off-by: Matan Azrad
---
doc/guides/vdpadevs/mlx5.rst | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/doc/guides/vdpadevs/mlx5.rst b/doc/guides/vdpadevs/mlx5.rst
index ce7c8a7..1660192 100644
--- a/doc/
On Mon, 24 Feb 2020 11:35:09 +
Konstantin Ananyev wrote:
> Upfront note - that RFC is not a complete patch.
> It introduces an ABI breakage, plus it doesn't update ring_elem
> code properly, etc.
> I plan to deal with all these things in later versions.
> Right now I seek an initial feedback
Document the new mbuf pools with external pinned buffers.
Signed-off-by: Viacheslav Ovsiienko
---
doc/guides/prog_guide/mbuf_lib.rst | 34 ++
doc/guides/rel_notes/release_20_02.rst | 5 +
2 files changed, 39 insertions(+)
diff --git a/doc/guides/prog_gui
- metadata limitation is described
- no inline hint flag is described
Signed-off-by: Viacheslav Ovsiienko
---
doc/guides/nics/mlx5.rst | 32
1 file changed, 32 insertions(+)
diff --git a/doc/guides/nics/mlx5.rst b/doc/guides/nics/mlx5.rst
index dd2fbde..2542248
On Mon, Feb 24, 2020 at 10:29 PM Stephen Hemminger
wrote:
>
> On Mon, 24 Feb 2020 11:35:09 +
> Konstantin Ananyev wrote:
>
> > Upfront note - that RFC is not a complete patch.
> > It introduces an ABI breakage, plus it doesn't update ring_elem
> > code properly, etc.
> > I plan to deal with a
On Mon, 24 Feb 2020 23:29:57 +0530
Jerin Jacob wrote:
> On Mon, Feb 24, 2020 at 10:29 PM Stephen Hemminger
> wrote:
> >
> > On Mon, 24 Feb 2020 11:35:09 +
> > Konstantin Ananyev wrote:
> >
> > > Upfront note - that RFC is not a complete patch.
> > > It introduces an ABI breakage, plus it
The new rte_flow feature for DSCP field rewrite offload was
missing in the release notes.
The mlx5 requirements for DSCP field rewrite offload were missing.
Fixes: 8482ffe4b68b ("ethdev: add IPv4/IPv6 DSCP rewrite action")
Fixes: 6f26e604a9c3 ("net/mlx5: support IPv4/IPv6 DSCP rewrite action")
S
When adding GTP to the list of supported tunnels,
the old line was not removed.
Fixes: f31d7a0171da ("net/mlx5: support GTP")
Signed-off-by: Thomas Monjalon
---
doc/guides/nics/mlx5.rst | 1 -
1 file changed, 1 deletion(-)
diff --git a/doc/guides/nics/mlx5.rst b/doc/guides/nics/mlx5.rst
index
Only the supported features are supposed to be listed
in the networking features matrix.
Signed-off-by: Thomas Monjalon
---
doc/guides/nics/features/hinic.ini | 4
1 file changed, 4 deletions(-)
diff --git a/doc/guides/nics/features/hinic.ini
b/doc/guides/nics/features/hinic.ini
index 7d4
The devices of the family ConnectX may have two letters as suffix.
Such suffix is preceded with a space and the second x is lowercase:
- ConnectX-4 Lx
- ConnectX-5 Ex
- ConnectX-6 Dx
Uppercase of the device family name BlueField is also fixed.
The lists of supported devices are fixed.
> > The devices of the family ConnectX may have two letters as suffix.
> > Such suffix is preceded with a space and the second x is lowercase:
> > - ConnectX-4 Lx
> > - ConnectX-5 Ex
> > - ConnectX-6 Dx
> >
> > Uppercase of the device family name BlueField is also fixed.
> >
> > Signe
Add scatter gather APIs to avoid intermediate memcpy. Serial
dequeue APIs are added to support access to ring elements
before actual dequeue.
Signed-off-by: Honnappa Nagarahalli
Reviewed-by: Gavin Hu
Reviewed-by: Ola Liljedahl
---
lib/librte_ring/Makefile | 1 +
lib/librte_ring/mes
Cover-letter:
RCU defer queue (DQ) APIs place 3 requirements on rte_ring library.
1) Multiple entities are responsible for providing/consuming the
data in a single element of the DQ. Existing rte_ring APIs
require an intermediate memcpy in such cases.
RCU DQ API, rte_rcu_qsbr_dq_enqueue,
> -Original Message-
> From: dev On Behalf Of Stephen Hemminger
> Sent: Monday, February 24, 2020 1:35 PM
> To: Jerin Jacob
> Cc: Konstantin Ananyev ; dpdk-dev
> ; Olivier Matz
> Subject: Re: [dpdk-dev] [RFC 0/6] New sync modes for ring
>
> On Mon, 24 Feb 2020 23:29:57 +0530
> Jerin
Simple script to look for drivers and scripts that
are missing requires SPDX header.
Update the contribution guidelines to indicate that SPDX license
identfier is required for this project.
Signed-off-by: Stephen Hemminger
---
v4 - add MAINTAINERS entry
update coding style document
cha
On 2/20/20 11:24 AM, David Christensen wrote:
Running DPDK 20.02-rc3 and attempting to use the MLX5 PMD as a non-root
user. When starting testpmd I'm receiving the following error on both
Power and x86_64 platforms (full output further down):
net_mlx5: probe of PCI device :01:00.0 a
The maximum number of rings in af_packet is hard coded as 16.
The user should be able to configure this as part of DPDK config.
Signed-off-by: Stephen Hemminger
---
config/common_base| 1 +
drivers/net/af_packet/rte_eth_af_packet.c | 3 +++
2 files changed, 4 insertions(+
>
> On Mon, Feb 24, 2020 at 10:29 PM Stephen Hemminger
> wrote:
> >
> > On Mon, 24 Feb 2020 11:35:09 +
> > Konstantin Ananyev wrote:
> >
> > > Upfront note - that RFC is not a complete patch.
> > > It introduces an ABI breakage, plus it doesn't update ring_elem code
> > > properly, etc.
>
> Oh boy! If DriverEntry() is not being called, the loader is finding something
> wrong and is unable to load the driver.
>
> @Harini: Can Jeffrey (@MS) help here?
By trial and error I determined that changing device class from "Net" to a
custom one fixes the issue (see attached patch), root cau
>
> From: Jerin Jacob
>
> This RFC is targeted for v20.05 release.
>
> This RFC patch includes an implementation of graph architecture for packet
> processing using DPDK primitives.
>
> Using graph traversal for packet processing is a proven architecture that has
> been implemented in variou
> > 4) app/test/test_regexdev.c like app/test/test_eventdev.c
>
> We started to create a super basic app, after the API will be finalized and
> we will have HW
> we can push it. (if you need it faster than feel free)
A simple Unit test case needs to be present for the APIs. On the
course of devel
On 2020/2/25 上午10:33, Tian, Kevin wrote:
From: Alex Williamson
Sent: Thursday, February 20, 2020 2:54 AM
Changes since v1 are primarily to patch 3/7 where the commit log is
rewritten, along with option parsing and failure logging based on
upstream discussions. The primary user visible differe
On Tue, Feb 25, 2020 at 10:53 AM Honnappa Nagarahalli
wrote:
> > 2) Based on our experience, NPU HW accelerates are so different than one
> > vendor to another vendor. Going forward, We believe, API abstraction may
> > not be enough abstract the difference in HW. The Vendor-specific nodes can
> >
[PATCH v4 1/4] net/virtio: refactor devargs parsing
[PATCH v4 2/4] net/virtio: add link speed devarg
[PATCH v4 3/4] net/virtio-user: fix devargs parsing
[PATCH v4 4/4] net/virtio-user: adding link speed devarg
---
v4 changes:
* link_speed renamed to speed devarg
* speed devarg is added to virtio-
virtio driver already parses speed devarg. virtio-user should add
it to list of valid devargs and call eth_virtio_dev_init function
which init speed value.
eth_virtio_dev_init already is called from virtio_user_pmd_probe
function. The only change is required to enable speed devargs:
adding speed t
Some applications like pktgen use link_speed to calculate
transmit rate. It limits outcome traffic to hardcoded 10G.
This patch adds link_speed devarg which allows to configure
link_speed of virtio device.
Signed-off-by: Ivan Dyukov
---
doc/guides/nics/virtio.rst | 7 +++
drivers/net/v
strtoull returns 0 if it fails to parse input string. It's ignored
in get_integer_arg.
This patch handles error cases for strtoull function.
Signed-off-by: Ivan Dyukov
---
drivers/net/virtio/virtio_user_ethdev.c | 13 +
1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/d
refactor vdpa specific devargs parsing to more generic way
Signed-off-by: Ivan Dyukov
---
drivers/net/virtio/virtio_ethdev.c | 35 +-
1 file changed, 25 insertions(+), 10 deletions(-)
diff --git a/drivers/net/virtio/virtio_ethdev.c
b/drivers/net/virtio/virtio_ethdev
This test suite is derived from fast-tests suite. Cases in this
suite are run with '--no-huge' flag.
The suite aims to cover as many as possible test cases out of the
fast-tests suites in the environments without huge pages support,
like containers.
Signed-off-by: Ruifeng Wang
Reviewed-by: Gavin
> -Original Message-
> From: Jerin Jacob
> Sent: Tuesday, February 25, 2020 7:57 AM
> To: Ori Kam
> Cc: Jerin Jacob ; xiang.w.w...@intel.com; dpdk-dev
> ; Pavan Nikhilesh ; Shahaf
> Shuler ; Hemant Agrawal
> ; Opher Reviv ; Alex
> Rosenbaum ; dov...@marvell.com; Prasun Kapoor
> ; Nipun
55 matches
Mail list logo