Hi Zhang,
On Wed, Dec 20, 2017 at 04:34:44PM -0500, Qi Zhang wrote:
> This patch extend rte_flow API.
> The purpose is to provide comfortable programming interface for virtual switch
> software (such as OVS) to take advantage of incoming device's vSwitch
> acceleration
> capability when using DPD
v2:
* Add internal vhost_vring_call() helper function [Maxime]
These patches eliminate code duplication for vhost_virtqueue->callfd users by
introducing rte_vhost_vring_call() (public API) and vhost_vring_call()
(librte_vhost-internal API).
Stefan Hajnoczi (2):
vhost: add vhost_vring_call() he
Extract the callfd eventfd signal operation so virtio_net.c does not
have to repeat it multiple times.
Signed-off-by: Stefan Hajnoczi
---
lib/librte_vhost/vhost.h | 12
lib/librte_vhost/virtio_net.c | 23 +++
2 files changed, 15 insertions(+), 20 deletions(-
Users of librte_vhost currently implement the vring call operation
themselves. Each caller performs the operation slightly differently.
This patch introduces a new librte_vhost API called
rte_vhost_vring_call() that performs the operation so that vhost-user
applications don't have to duplicate it
On 12/26/2017 2:06 AM, Stephen Hemminger wrote:
On Thu, 2 Nov 2017 04:16:44 +0800
Jeff Guo wrote:
+int
+rte_dev_bind_driver(const char *dev_name, const char *drv_type) {
Bracket left after declaration.
thanks.
+ snprintf(drv_override_path, sizeof(drv_override_path),
+
This patch aim to add a general uevent mechanism in eal device layer,
to enable all linux kernel object hot plug monitoring, so user could use these
APIs to monitor and read out the device status info that sent from the kernel
side, then corresponding to handle it, such as detach or attach the
devi
So far, about hot plug in dpdk, we already have hot plug add/remove
api and fail-safe driver to offload the fail-safe work from the app
user. But there are still lack of a general event api, since the interrupt
event, which hot plug related with, is diversity between each device and
driver, such as
use testpmd for example, to show app how to request and use
uevent monitoring to handle the hot removal event and the
hot insertion event.
Signed-off-by: Jeff Guo
---
v7->v6:
fix the system hung after send packcet issue.
---
app/test-pmd/testpmd.c | 178 ++
hi,moti
please see v7 patch set , thanks.
On 12/24/2017 11:12 PM, Mordechay Haimovsky wrote:
Thanks Jeff,
Do you have an estimation on when will these patches be ready ?
Moti H.
-Original Message-
From: Guo, Jia [mailto:jia@intel.com]
Sent: Friday, December 22, 2017 2:16 AM
To:
Make pktmbuf pool size a function of ports and lcores detected instead
of using constant 8192.
Signed-off-by: Pavan Nikhilesh
---
v2 Changes:
- used variable inplace rather than having a macro.
examples/l2fwd/main.c | 25 +++--
1 file changed, 15 insertions(+), 10 deletio
From: wang zhike
v3:
* Fix duplicate variable name, which leads to unexpected memory write.
v2:
* Move fdset_del before conn destroy.
* Fix coding style.
This patch fixes below race condition:
1. one thread calls: rte_vhost_driver_unregister->lock conn_mutex
->fdset_del->loop to check fd.busy
-Original Message-
> Date: Sat, 30 Dec 2017 23:47:23 +0100
> From: Thomas Monjalon
> To: dev@dpdk.org
> Cc: Stephen Hemminger , Jerin Jacob
>
> Subject: [PATCH v2] eal/x86: get hypervisor name
> X-Mailer: git-send-email 2.15.1
>
> The CPUID instruction is catched by hypervisor which can
Hi Stefan,
On 01/02/2018 10:31 AM, Stefan Hajnoczi wrote:
v2:
* Add internal vhost_vring_call() helper function [Maxime]
These patches eliminate code duplication for vhost_virtqueue->callfd users by
introducing rte_vhost_vring_call() (public API) and vhost_vring_call()
(librte_vhost-internal
Hi Declan,
On 12/22/2017 12:21 AM, Doherty, Declan wrote:
This RFC contains a proposal to add a new tunnel endpoint API to DPDK that when
used
in conjunction with rte_flow enables the configuration of inline data path
encapsulation
and decapsulation of tunnel endpoint network overlays on acce
On Fri, Dec 22, 2017 at 03:25:43PM +0800, Jiayu Hu wrote:
> - Remove needless check and variants
> - For better understanding, update the programmer guide and rename
> internal functions and variants
> - For supporting tunneled gro, move common internal functions from
> gro_tcp4.c to gro_tcp4.h
Hi Thomas,
> -Original Message-
> From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Thomas Monjalon
> Sent: Friday, December 29, 2017 1:37 PM
> To: dev@dpdk.org
> Cc: Yigit, Ferruh
> Subject: [dpdk-dev] [PATCH v3 1/5] ethdev: remove useless parameter in
> callback process
>
> The poin
On Tue, Jan 02, 2018 at 11:35:02AM +, Iremonger, Bernard wrote:
> Hi Thomas,
>
> > -Original Message-
> > From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Thomas Monjalon
> > Sent: Friday, December 29, 2017 1:37 PM
> > To: dev@dpdk.org
> > Cc: Yigit, Ferruh
> > Subject: [dpdk-dev]
A device is DPDK has a flavor to it - ethernet, crypto, event etc.
A rawdevice represents a generic device map-able to a device flavour
not being currently handled out-of-the-box by DPDK framework.
A device which can be scanned on an installed bus (pci, fslmc, ...)
or instantiated through devargs,
Rawdevice Support in DPDK
-
RFC [1]: http://dpdk.org/ml/archives/dev/2017-November/081550.html
(from: hemant.agra...@nxp.com)
This patchset introduces rawdevices or generic device support in DPDK.
Motivation
==
In terms of device flavor (type) support, D
Signed-off-by: Shreyansh Jain
---
config/common_base | 1 +
drivers/Makefile | 2 ++
mk/rte.app.mk | 4
3 files changed, 7 insertions(+)
diff --git a/config/common_base b/config/common_base
index 3d2e12c31..5f7dfd9e9 100644
--- a/config/common_base
+++ b/config/common_base
@@ -798,6
Add config option CONFIG_RTE_LIBRTE_RAWDEV for toggling rawdev
library support. This patch also enables compilation of the library.
Signed-off-by: Shreyansh Jain
---
config/common_base | 7 +++
lib/Makefile | 3 +++
mk/rte.app.mk | 1 +
3 files changed, 11 insertions(+)
diff --gi
Patch introduces rawdev unit testcase for validation against the
Skeleton rawdev dummy PMD implementation.
Signed-off-by: Shreyansh Jain
---
test/test/Makefile | 4 +
test/test/test_rawdev.c | 376
2 files changed, 380 insertions(+)
create
Skeleton rawdevice driver, on the lines of eventdev skeleton, is for
showcasing the rawdev library. This driver implements some of the
operations of the library based on which a test module can be
developed.
* Design of skeleton involves a virtual device which is plugged into
VDEV bus on initial
> -Original Message-
> From: Xing, Beilei
> Sent: Friday, December 8, 2017 3:52 PM
> To: Wu, Jingjing ; Lu, Wenzhuo
> ; Zhang, Qi Z
> Cc: dev@dpdk.org; Chilikin, Andrey
> Subject: [PATCH v6 1/2] net/i40e: support input set configuration
>
> This patch supports getting/setting input set
FSLMC bus detects a multiple type of logical objects representing
components of the datapath.
Using the type of device, a newly introduced API
rte_fslmc_get_device_count can return the count of devices
scanned of that device type.
Signed-off-by: Shreyansh Jain
---
:: This patch is based on *net-
Hi Shachar,
Please see small comment bellow,
On Sun, Dec 31, 2017 at 07:52:51AM +, Shachar Beiser wrote:
> MLX5 PMD loads libraries: libibverbs and libmlx5.
> MLX5 PMD is not linked to external libraries.
>
> Signed-off-by: Shachar Beiser
> ---
> v1:
> load external libraries in run-ti
> -Original Message-
> From: Adrien Mazarguil [mailto:adrien.mazarg...@6wind.com]
> Sent: Thursday, December 21, 2017 1:00 PM
> To: dev@dpdk.org
> Cc: Yigit, Ferruh ; Iremonger, Bernard
>
> Subject: [PATCH v1 3/6] flow_classify: fix issue in exported header
>
> Reported by check-include
On 27/12/2017 15:50, Alex Rosenbaum wrote:
On Wed, Dec 27, 2017 at 11:40 AM, Mohammad Abdul Awal
wrote:
On 22/12/2017 22:33, Alex Rosenbaum wrote:
On Fri, Dec 22, 2017 at 4:31 PM, Mohammad Abdul Awal
On 21/12/2017 14:51, Alex Rosenbaum wrote:
By hotplug I did not mean HW hotplug, rather I
Hi Alan,
NAK for now.
There is a good reason for truncating the WRR cost to 8-bit value, which is
keeping the size of the rte_sched_pipe structure to single cache line (64
bytes). This is done for performance reasons at the expense of some accuracy
loss for the scheduling of the 4x queues per
> -Original Message-
> From: alangordonde...@gmail.com [mailto:alangordonde...@gmail.com]
> Sent: Thursday, November 30, 2017 9:05 AM
> To: Dumitrescu, Cristian
> Cc: dev@dpdk.org; Alan Dewar
> Subject: [PATCH v2] test: new sched WRR unit-test
>
> From: Alan Dewar
>
> New unit-test f
> -Original Message-
> From: Dumitrescu, Cristian
> Sent: Tuesday, October 3, 2017 6:16 PM
> To: alangordonde...@gmail.com; Kantecki, Tomasz
>
> Cc: dev@dpdk.org; Alan Dewar
> Subject: RE: [PATCH v4] sched: make RED scaling configurable
>
> Adding Tomasz.
>
> > -Original Message--
On Sat, 30 Dec 2017 23:47:23 +0100
Thomas Monjalon wrote:
> The CPUID instruction is catched by hypervisor which can return
> a flag indicating one is running, and its name.
>
> Suggested-by: Stephen Hemminger
> Signed-off-by: Thomas Monjalon
> ---
> v2 changes:
> - remove C99 style decl
Hi Alan,
Thanks for your work!
I do have some comments (see below), but generally looks good to me.
> -Original Message-
> From: alangordonde...@gmail.com [mailto:alangordonde...@gmail.com]
> Sent: Tuesday, October 3, 2017 10:22 AM
> To: Dumitrescu, Cristian
> Cc: dev@dpdk.org; Alan Dew
Hi Jeff
Maybe I'm touching in previous discussions but please see some
comments\questions.
From: Jeff Guo:
> This patch aim to add a general uevent mechanism in eal device layer,
> to enable all linux kernel object hot plug monitoring, so user could use these
> APIs to monitor and read out the d
> On Dec 30, 2017, at 11:34 PM, Shachar Beiser wrote:
>
> There are parameters that are not copy from
> spec to verbs structure in the vtc_label
>
> Fixes: 43e9d97 ("net/mlx5: support upstream rdma-core")
> Cc: sta...@dpdk.org
>
> Signed-off-by: Shachar Beiser
> ---
Acked-by: Yongseok Koh
Trying to eliminate all runtime calls to look at kernel version
to determine API because they are source of portablity problems
in distributions.
Stephen Hemminger (2):
mlx5: don't pass unused argument to sub-functions
mlx5: don't depend on kernel version
drivers/net/mlx5/mlx5_ethdev.c | 118
This driver uses ethtool to get link status. The ethtool API has new
and old deprecated API. Rather than checking kernel version, use the
same algorithm that the ethtool command does; check the new API first
and if that fails, try the old one.
Also, use common code for getting link state up/down a
Since wait_to_complete is unused, don't pass it to helper functions.
Use the standard RTE macro to indicate this is an unused parameter.
Signed-off-by: Stephen Hemminger
---
drivers/net/mlx5/mlx5_ethdev.c | 16 +---
1 file changed, 5 insertions(+), 11 deletions(-)
diff --git a/drive
The current driver requires v16. It will not work or build with
the older version (as in Debian stable). Note: libmlx5 is rolled
into rdma-core in current versions.
Mlx4 probably requires similar documentation update.
Signed-off-by: Stephen Hemminger
---
doc/guides/nics/mlx5.rst | 18 +
> -Original Message-
> From: Richardson, Bruce
> Sent: Tuesday, January 2, 2018 7:26 PM
> To: Hu, Jiayu
> Cc: dev@dpdk.org; Tan, Jianfeng; Chen, Junjie J; Ananyev, Konstantin;
> step...@networkplumber.org; Yigit, Ferruh; Yao, Lei A
> Subject: Re: [dpdk-dev] [PATCH v3 1/2] gro: code cleanu
> -Original Message-
> From: Thomas Monjalon [mailto:tho...@monjalon.net]
> Sent: Sunday, December 31, 2017 5:22 AM
> To: Tan, Jianfeng
> Cc: dev@dpdk.org
> Subject: [PATCH v2] bus/vdev: add custom scan hook
>
> The scan callback allows to spawn a vdev automatically
> given some custom s
On Wed, 3 Jan 2018 01:07:37 +
"Tan, Jianfeng" wrote:
> > -Original Message-
> > From: Richardson, Bruce
> > Sent: Tuesday, January 2, 2018 7:26 PM
> > To: Hu, Jiayu
> > Cc: dev@dpdk.org; Tan, Jianfeng; Chen, Junjie J; Ananyev, Konstantin;
> > step...@networkplumber.org; Yigit, Ferruh;
Hi,
> -Original Message-
> From: Bie, Tiwei
> Sent: Monday, December 4, 2017 4:47 PM
> To: Wang, Xiao W
> Cc: y...@fridaylinux.org; dev@dpdk.org; step...@networkplumber.org
> Subject: Re: [PATCH v2 2/2] net/virtio: support GUEST ANNOUNCE
>
> On Mon, Dec 04, 2017 at 06:02:08AM -0800, Xiao
> -Original Message-
> From: Bie, Tiwei
> Sent: Wednesday, December 6, 2017 7:23 PM
> To: Wang, Xiao W
> Cc: y...@fridaylinux.org; dev@dpdk.org; step...@networkplumber.org
> Subject: Re: [PATCH v2 2/2] net/virtio: support GUEST ANNOUNCE
>
> On Mon, Dec 04, 2017 at 06:02:08AM -0800, Xiao
> -Original Message-
> From: Yuanhan Liu [mailto:y...@fridaylinux.org]
> Sent: Tuesday, December 5, 2017 10:26 PM
> To: Wang, Xiao W
> Cc: dev@dpdk.org; Bie, Tiwei
> Subject: Re: [PATCH 2/2] net/virtio: support GUEST ANNOUNCE
>
> On Thu, Nov 30, 2017 at 02:41:12AM +, Wang, Xiao W w
> -Original Message-
> From: Thomas Monjalon [mailto:tho...@monjalon.net]
> Sent: Friday, December 29, 2017 7:07 PM
> To: Yang, Zhiyong
> Cc: dev@dpdk.org; Yigit, Ferruh ; sta...@dpdk.org
> Subject: Re: [PATCH v2] bus/pci: fix wrong intr_handle.type with
> uio_pci_generic
>
> 29/12/201
Hi, zhangqi
> -Original Message-
> From: Zhang, Qi Z
> Sent: Friday, December 22, 2017 11:31 AM
> To: Zhao1, Wei ; dev@dpdk.org
> Cc: Zhao1, Wei
> Subject: RE: [dpdk-dev] [PATCH v2] net/i40e: fix port segmentation fault
> when restart
>
> > -Original Message-
> > From: dev [mailt
This series is to convert mlx4 and mlx5 PMDs to the new offloads API [1].
On v2:
- New design to hold PMD specific args and combine
them with offloads requested.
- Fix missing IPV4 checksum flag on vector function selection.
- Verify Txq flags ignore bit before checking for valid offloads
Change the function prototype to return the function pointer of the
selected Tx/Rx burst function instead of assigning it directly to the
device context.
Such change will enable to use those select functions to query the burst
function that will be selected according to the device configuration.
Ethdev Tx offloads API has changed since:
commit cba7f53b717d ("ethdev: introduce Tx queue offloads API")
This commit support the new Tx offloads API.
Signed-off-by: Shahaf Shuler
Acked-by: Nelio Laranjeiro
---
doc/guides/nics/mlx5.rst | 15 +++
drivers/net/mlx5/mlx5.c |
Move device configuration and features capabilities to its own structure.
This structure is filled by mlx5_pci_probe(), outside of this function
it should be treated as *read only*.
This configuration struct will be used for the Tx/Rx queue setup to
select the Tx/Rx queue parameters based on the u
From: Nelio Laranjeiro
Counter_set is a counter used for flows when its support is available.
Renaming it to flow counter.
Signed-off-by: Nelio Laranjeiro
---
drivers/net/mlx5/mlx5.c | 3 +--
drivers/net/mlx5/mlx5.h | 2 +-
drivers/net/mlx5/mlx5_flow.c | 2 +-
3 files changed, 3 inse
Ethdev Rx offloads API has changed since:
commit ce17eddefc20 ("ethdev: introduce Rx queue offloads API")
This commit support the new Rx offloads API.
Signed-off-by: Shahaf Shuler
Acked-by: Nelio Laranjeiro
---
drivers/net/mlx5/mlx5_ethdev.c | 23 +---
drivers/net/mlx5/mlx5_rxq.c| 10
Ethdev Rx offloads API has changed since:
commit ce17eddefc20 ("ethdev: introduce Rx queue offloads API")
This commit support the new Rx offloads API.
Signed-off-by: Shahaf Shuler
---
drivers/net/mlx4/mlx4_ethdev.c | 10 ++---
drivers/net/mlx4/mlx4_flow.c | 5 ++-
drivers/net/mlx4/mlx4_rxq.
Ethdev Tx offloads API has changed since:
commit cba7f53b717d ("ethdev: introduce Tx queue offloads API")
This commit support the new Tx offloads API.
Signed-off-by: Shahaf Shuler
---
drivers/net/mlx4/mlx4_ethdev.c | 7 +---
drivers/net/mlx4/mlx4_rxtx.h | 1 +
drivers/net/mlx4/mlx4_txq.c
This patch will clear all queue region related configuration
when dev stop even if threr is no queue region config,
so this may cause error. So add check if there is queue
configuration exist when flush queue region config and
remove this process when device stop. Queue region clear
only do when de
Hi Stephen,
Please see few comments bellow,
On Tue, Jan 02, 2018 at 12:53:10PM -0800, Stephen Hemminger wrote:
> This driver uses ethtool to get link status. The ethtool API has new
> and old deprecated API. Rather than checking kernel version, use the
> same algorithm that the ethtool command do
Hi Stephen,
On Tue, Jan 02, 2018 at 12:53:09PM -0800, Stephen Hemminger wrote:
> Since wait_to_complete is unused, don't pass it to helper functions.
> Use the standard RTE macro to indicate this is an unused parameter.
I would suggest to use the (void) as it is done in the whole driver, a
specif
Hi Stephen,
Seems you missed an important point, MLNX_OFED is still supported with
this driver allowing it to work on stable releases like strict debian 9
i.e. without updating the Linux kernel.
On Tue, Jan 02, 2018 at 01:44:21PM -0800, Stephen Hemminger wrote:
> The current driver requires v16.
59 matches
Mail list logo