This patchset makes some extra changes after the modification
of the PMD_REGISTER_DRIVER macro, including renaming back
some virtual device driver names (virtio could not be renamed)
and fixing/adding arguments of some drivers.
Pablo de Lara (5):
drivers: revert vdev driver names to original
In order to avoid API breakage, the driver names of the virtual devices
have been renamed to their original name, before the modification
of the PMD_REGISTER_DRIVER macro, which sets now the driver names.
Fixes: cb6696d22023 ("drivers: update registration macro usage")
Signed-off-by: Pablo de Lar
Since now the PMD_REGISTER_DRIVER macro sets the driver names,
there is no need to have the rte_driver structure setting it
statically, as it will get overridden.
Signed-off-by: Pablo de Lara
---
drivers/net/af_packet/rte_eth_af_packet.c | 1 -
drivers/net/bnxt/bnxt_ethdev.c| 1 -
dr
Driver arguments shown with DRIVER_REGISTER_PARAM_STRING
have been separated in multiple lines and indented to
ease their readability.
Signed-off-by: Pablo de Lara
---
drivers/crypto/aesni_gcm/aesni_gcm_pmd.c | 6 --
drivers/crypto/aesni_mb/rte_aesni_mb_pmd.c | 6 --
drivers/crypto/k
Virtio and Xenvirt are two virtual device drivers that admit
arguments, so DRIVER_REGISTER_PARAM_STRING should be used
in them.
Fixes: cb6696d22023 ("drivers: update registration macro usage")
Signed-off-by: Pablo de Lara
---
drivers/net/virtio/virtio_user_ethdev.c | 6 ++
drivers/net/xenvi
The range of the supported bonding modes is 0-6, instead of 0-4.
Fixes: cb6696d22023 ("drivers: update registration macro usage")
Signed-off-by: Pablo de Lara
---
drivers/net/bonding/rte_eth_bond_pmd.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/bonding/rte_e
On 7/8/2016 6:27 PM, Thomas Monjalon wrote:
> 2016-05-11 18:24, Ferruh Yigit:
>> On 5/11/2016 8:35 AM, Alejandro Lucero wrote:
>>> On Tue, May 10, 2016 at 4:59 PM, Stephen Hemminger <
>>> stephen at networkplumber.org> wrote:
>>>
On Tue, 10 May 2016 19:21:41 +0800
Zhe Tao wrote:
>>
On Fri, Jul 08, 2016 at 07:03:10PM +, Mcnamara, John wrote:
> > -Original Message-
> > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Neil Horman
> > Sent: Friday, July 8, 2016 2:42 PM
> > To: Thomas Monjalon
> > Cc: De Lara Guarch, Pablo ; dev at
> > dpdk.org;
> > Richardson
On Sat, Jul 09, 2016 at 02:06:09AM +0100, Pablo de Lara wrote:
> This patchset makes some extra changes after the modification
> of the PMD_REGISTER_DRIVER macro, including renaming back
> some virtual device driver names (virtio could not be renamed)
> and fixing/adding arguments of some drivers.
Hi Thomas,
On Friday 08 July 2016 06:27 PM, Thomas Monjalon wrote:
> The comment and these lines can be removed and rely on default
> enabling in config/common_base. I suggest to enable (remove disabling)
> a feature at a time in the patch fixing the feature for PPC.
Sure. So, do you suggest t
Plaintexts and ciphertexts are dumped when debugging is enabled,
using TEST_HEXDUMP. For Snow3G and KASUMI, their lengths are in bits,
but TEST_HEXDUMP uses bytes, so lenghts are passed in bytes now.
Fixes: 47df73a1a62f ("app/test: use hexdump if debug log is enabled")
Signed-off-by: Pablo de Lar
> -Original Message-
> From: Neil Horman [mailto:nhorman at tuxdriver.com]
> Sent: Saturday, July 9, 2016 2:34 PM
> To: Mcnamara, John
> Cc: Thomas Monjalon ; De Lara Guarch, Pablo
> ; dev at dpdk.org; Richardson, Bruce
> ; Stephen Hemminger
> ; Panu Matilainen
> Subject: Re: [dpdk-dev] [
KASUMI PMD only supports bit-level cipher operations
when destination buffer is different from the source
(out of place operations). This commit adds a check
in the code to prevent the user from trying to perform
in-place bit-level ciphering.
Fixes: 2773c86d061a ("crypto/kasumi: add driver for KAS
Driver names for all the supported devices in DPDK do not have
a naming convention. Some are using a prefix, some are not
and some have long names. Driver names are used when creating
virtual devices, so it is useful to have consistency in the names.
Signed-off-by: Pablo de Lara
---
doc/guides/r
2016-07-09 20:08, gowrishankar:
> Hi Thomas,
>
> On Friday 08 July 2016 06:27 PM, Thomas Monjalon wrote:
> > The comment and these lines can be removed and rely on default
> > enabling in config/common_base. I suggest to enable (remove disabling)
> > a feature at a time in the patch fixing the f
2016-07-08 16:44, Remy Horton:
> When fetching xstats values the driver specific parameters are
> placed after the generic ones, but when fetching xstats names
> the driver specific parameter names came first. This patch fixes
> the resulting id mismatch between names and values.
>
> Fixes: bd6aa1
2016-07-09 09:45, Neil Horman:
> On Sat, Jul 09, 2016 at 02:06:09AM +0100, Pablo de Lara wrote:
> > This patchset makes some extra changes after the modification
> > of the PMD_REGISTER_DRIVER macro, including renaming back
> > some virtual device driver names (virtio could not be renamed)
> > and
2016-07-08 21:37, Bruce Richardson:
> This patchset fixes pmdinfogen and pmdinfo.py so that they can work on
> FreeBSD. It's been tested with static binaries compiled using clang and gcc
> on FreeBSD, as well as gcc-generated dynamic libraries. For some reason
> clang wasn't able to build dynamic l
18 matches
Mail list logo