The conversion from guest physical address to machine physical address
is fast when the caller knows the memseg corresponding to the gpa.
But in case the user does not know this information, just find it
by browsing the segments. This feature will be used by next commit.
Signed-off-by: Olivier Ma
Avoid to have a specific file for that, and remove #ifdefs.
Now that we have introduced a function to populate a mempool
with a virtual area, the support of xen dom0 is much easier.
The only thing we need to do is to convert the guest physical
address into the machine physical address using rte_me
Instead of creating the internal ring at mempool creation, do
it when populating the mempool with the first memory chunk. The
objective here is to simplify the change of external handler
when it will be introduced.
For instance, this will be possible:
mp = rte_mempool_create_empty(...)
rte_me
Add the following functions to the public mempool API:
- rte_mempool_create_empty()
- rte_mempool_populate_phys()
- rte_mempool_populate_phys_tab()
- rte_mempool_populate_virt()
- rte_mempool_populate_default()
- rte_mempool_populate_anon()
- rte_mempool_free()
Signed-off-by: Olivier Matz
---
l
Now that mempool library provide functions to populate with anonymous
mmap'd memory, we can remove this specific code from test-pmd.
Signed-off-by: Olivier Matz
---
app/test-pmd/Makefile| 4 -
app/test-pmd/mempool_anon.c | 201 ---
app/test-pmd/
Check the return value of snprintf to ensure that the name of
the object is not truncated.
By the way, update the test to avoid to trigger an error in
that case.
Signed-off-by: Olivier Matz
---
app/test/test_mempool.c| 12
lib/librte_eal/common/eal_common_memzon
Before this patch, the mempool elements were initialized at the time
they were added to the mempool. This patch changes this to do the
initialization of all objects once the mempool is populated, using
rte_mempool_obj_iter() introduced in previous commits.
Thanks to this modification, we are getti
Add a new flag to remove the constraint of having physically contiguous
objects inside a mempool.
Add this flag to the log history mempool to start, but we could add
it in most cases where objects are not mbufs.
Signed-off-by: Olivier Matz
---
lib/librte_eal/common/eal_common_log.c | 2 +-
lib
Now that we can populate a mempool with any virtual memory,
it is easier to introduce a function to populate a mempool
with memory coming from an anonymous mapping, as it's done
in test-pmd.
The next commit will replace test-pmd anonymous mapping by
this function.
Signed-off-by: Olivier Matz
---
Update the copyright of files touched by this patch series.
Signed-off-by: Olivier Matz
---
lib/librte_mempool/rte_mempool.c | 1 +
lib/librte_mempool/rte_mempool.h | 1 +
2 files changed, 2 insertions(+)
diff --git a/lib/librte_mempool/rte_mempool.c b/lib/librte_mempool/rte_mempool.c
index 209
2016-03-09 16:17, Ananyev, Konstantin:
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> > 2016-03-09 15:42, Ananyev, Konstantin:
> > > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> > > > 2016-03-09 15:23, Ananyev, Konstantin:
> > > > > >
> > > > > > 2016-03-09 13:36,
On Thu, Mar 03, 2016 at 03:27:10PM +0100, Adrien Mazarguil wrote:
> This patchset improves the mlx5 PMD performance by doing better prefetching,
> by reordering internal structure fields and by removing a few unnecessary
> operations.
>
> Note: should be applied after "Add flow director and RX VLA
Hi Olivier,
On 3/9/2016 2:59 PM, Olivier MATZ wrote:
> Hi David,
>
> On 03/09/2016 12:30 PM, Hunt, David wrote:
>> Hi Panu,
>>
>> On 3/9/2016 10:46 AM, Panu Matilainen wrote:
>>> On 03/09/2016 11:50 AM, David Hunt wrote:
This patch is for those people who want to be easily able to switch
Hi David,
On 03/09/2016 05:28 PM, Hunt, David wrote:
>> Sorry, maybe I wasn't very clear in my previous messages. For me, the
>> NEXT_ABI is not the proper solution because, as Panu stated, it makes
>> the patch hard to read. My understanding of NEXT_ABI is that it should
>> only be used if the ch
> -Original Message-
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> Sent: Tuesday, March 8, 2016 23:52
> To: Kulasek, TomaszX
> Cc: dev at dpdk.org; Ananyev, Konstantin
> Subject: Re: [dpdk-dev] [PATCH v2 1/2] ethdev: add buffered tx api
>
> Hi,
>
[...]
> > +/**
> >
Hi Olivier,
On 3/9/2016 4:31 PM, Olivier MATZ wrote:
> Hi David,
>
> On 03/09/2016 05:28 PM, Hunt, David wrote:
>
>> Sure, v4 will remove the NEXT_ABI patch , and replace it with just the
>> ABI break announcement for 16.07. For anyone who what's to try out the
>> patch, they can always get it fro
On 03/09/2016 05:19 PM, Olivier Matz wrote:
> This series is a rework of mempool.
>
> [...]
I forgot to mention that this series applies on top of Keith's
patch, which is also planned for 16.07:
http://www.dpdk.org/dev/patchwork/patch/10492/
Olivier
'noon,
On 09/03/2016 08:45, Vivek Gupta wrote:
> Hi
>
> I want to write a Client Server application using DPDK API on a
> single machine. What are the basic building block for that. How can
> we write such application?
examples/l2fwd/main.c and examples/ethtool/ethtool-app/main.c are
probably th
From: Michal Kobylinski
This patchset extend next_hop field from 8-bits to 24-bits in LPM library for
IPv4.
As next_hop field is increased now the maximum number of tbl8s is 2^24.
A new rte_lpm_config structure is used so LPM library will allocate
exactly the amount of memory which is necessar
From: Michal Kobylinski
This patch extend next_hop field from 8-bits to 24-bits in LPM library
for IPv4.
Added versioning symbols to functions and updated
library and applications that have a dependency on LPM library.
Signed-off-by: Michal Kobylinski
Acked-by: David Hunt
---
app/test/test_l
From: Michal Kobylinski
This patch has depend on: lpm: extended ipv4 next_hop field (v4).
A new rte_lpm_config structure is used so LPM library will allocate
exactly the amount of memory which is necessary to hold application?s
rules.
Signed-off-by: Michal Kobylinski
Acked-by: David Hunt
---
2016-03-09 15:28, Jingjing Wu:
> A new doc "i40e.rst" is added to introduce i40e pmd driver.
>
> v3 changes:
> - update table in overview.rst.
> - rework index.rst to keep an alphabetical order.
>
> v2 changes:
> - restrict long code line
> - fix typo
>
> Jingjing Wu (2):
> doc: add doc fo
2016-03-09 16:35, Kulasek, TomaszX:
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> > > +void
> > > +rte_eth_count_unsent_packet_callback(struct rte_mbuf **pkts, uint16_t
> > unsent,
> > > + void *userdata);
> >
> > What about rte_eth_tx_buffer_default_callback as name?
>
> Signed-off-by: Matej Vido
> ---
> doc/guides/nics/overview.rst | 20 ++--
> 1 file changed, 10 insertions(+), 10 deletions(-)
Applied, thanks
2016-03-08 14:29, Harry van Haaren:
> This patch adds a note to the ixgbe PMD guide, stating
> the minimum time that statistics must be polled from
> the hardware in order to avoid register values becoming
> saturated and "sticking" to the max value.
>
> Reported-by: Jerry Zhang
> Tested-by: Marc
2016-03-08 17:16, Harry van Haaren:
> This patch documents that the statistics of fm10k based NICs must be
> read regularly in order to avoid an undetected 32 bit integer-overflow.
>
> Signed-off-by: Harry van Haaren
> Acked-by: John McNamara
Applied, thanks
> > From: "Chen Jing D(Mark)"
>
> Acked-by: John McNamara
Applied, thanks
Next step: fill the matrix in overview.rst :)
On 03/09/2016 03:29 AM, Stephen Hemminger wrote:
> If page size is large (like 64K on ARM) and object size is small
> then don't waste lots of memory by rounding up to page size.
> Instead, round up so that 1 or more objects all fit in a page.
>
> This preserves the requirement that an object must
> -Original Message-
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> Sent: Wednesday, March 9, 2016 18:07
> To: Kulasek, TomaszX
> Cc: dev at dpdk.org; Ananyev, Konstantin
> Subject: Re: [dpdk-dev] [PATCH v2 1/2] ethdev: add buffered tx api
>
> 2016-03-09 16:35, Kulasek
One thing I noticed while fixing mempool bug, was that there was a printf
in the library there. A reminder, code in DPDK library should never call printf
directly. printf in a real application is often ratholed off to /dev/null
and real output is through API's or syslog.
Offenders now:
rte_mempoo
On Thu, Jan 28, 2016 at 06:14:45PM +, Nicolas Pernas Maradei wrote:
> Hi Dror,
>
> Good catch. What you are saying makes sense and it is also explained in
> pcap's documentation. Was your setup unusual though?
> This might sound like a silly question but I don't remember seeing that
> issue an
I understand that 6Wind has made major contributions to DPDK in many places.
I would prefer that each file not get copyright additions from each
contributor,
otherwise this starts a bad precedent where the source gets cluttered with
every contributor.
On Wed, Mar 9, 2016 at 8:19 AM, Olivier Matz
Can't we just write correct code rather than trying to trick the compiler.
On Wed, Mar 9, 2016 at 8:19 AM, Olivier Matz wrote:
> This macro removes the const attribute of a variable. It must be used
> with care in specific situations. It's better to use this macro instead
> of a manual cast, as
> On 3/8/2016 4:54 PM, Panu Matilainen wrote:
> > On 03/04/2016 12:05 PM, Jianfeng Tan wrote:
> >> This patch adds option, --avail-cores, to use lcores which are
> >> available
> >> by calling pthread_getaffinity_np() to narrow down detected cores
> >>
Hi,
On 03/09/2016 07:53 PM, Stephen Hemminger wrote:
> Can't we just write correct code rather than trying to trick the compiler.
Thank you for your comment. This macro is introduced for next
commit, I would be happy if you could help me to remove it.
My opinion is that using a macro like this i
On 9 March 2016 at 11:09, N?lio Laranjeiro
wrote:
> On Wed, Mar 09, 2016 at 10:29:38AM +0100, N?lio Laranjeiro wrote:
> > On Tue, Mar 08, 2016 at 05:53:05PM +0100, N?lio Laranjeiro wrote:
> > > On Tue, Mar 08, 2016 at 04:00:29PM +0100, Marc Sune wrote:
> > > > 2016-03-01 1:45 GMT+01:00 Marc Sune
On Wed, 9 Mar 2016 21:47:35 +0100
Olivier MATZ wrote:
> Hi,
>
> On 03/09/2016 07:53 PM, Stephen Hemminger wrote:
> > Can't we just write correct code rather than trying to trick the compiler.
>
> Thank you for your comment. This macro is introduced for next
> commit, I would be happy if you cou
If page size is large (like 64K on ARM) and object size is small
then don't waste lots of memory by rounding up to page size.
Instead, round up so that 1 or more objects all fit in a page.
This preserves the requirement that an object must not a page
or virt2phys would break, and makes sure 62K is
On Wed, Mar 09, 2016 at 09:47:35PM +0100, Olivier MATZ wrote:
> Hi,
>
> On 03/09/2016 07:53 PM, Stephen Hemminger wrote:
> > Can't we just write correct code rather than trying to trick the compiler.
>
> Thank you for your comment. This macro is introduced for next
> commit, I would be happy if y
Hi Michael
If you agree on the #ifdef protection I explained in my previous mail, I
will re-submit the patch with refactoring the the commit log with less than
80 characters per line.
Thanks
Dhana
On Thu, Mar 3, 2016 at 8:00 PM, Dhananjaya Reddy Eadala
wrote:
> Hi Michael
>
> Please see my an
On Fri, Mar 04, 2016 at 08:25:07AM -0500, Kyle Larose wrote:
> On Fri, Mar 4, 2016 at 3:11 AM, Tom Kiely wrote:
> > Sure.
> >Tom
> >
> >
> > On 03/04/2016 06:16 AM, Xie, Huawei wrote:
> >>
> >> On 2/23/2016 12:23 AM, Tom Kiely wrote:
> >>>
> >>> Hi,
> >>> Sorry I missed the last few messa
On Mon, Feb 29, 2016 at 05:51:23AM +, Pei, Yulong wrote:
> This patch caused build error with i686-native-linuxapp-gcc (gcc version is
> 4.8.3)
>
Yes. It also breaks the build with gcc 4.4 (strict aliasing rules errors).
There are probably some combination of flags can we can remove, but t
2016-03-09 17:57, Michal Jastrzebski:
> From: Michal Kobylinski
>
> This patchset extend next_hop field from 8-bits to 24-bits in LPM library for
> IPv4.
>
> As next_hop field is increased now the maximum number of tbl8s is 2^24.
> A new rte_lpm_config structure is used so LPM library will all
2016-03-08 23:33, Huawei Xie:
> PMD_INIT_LOG(INFO, "trying with legacy virtio pci.");
> - if (legacy_virtio_resource_init(dev, hw) < 0)
> + if (legacy_virtio_resource_init(dev, hw) < 0) {
> + if (dev->kdrv == RTE_KDRV_UNKNOWN &&
> + dev->devargs->type != RT
On 01/02/2016 11:26, Jerin Jacob wrote:
> On Mon, Feb 01, 2016 at 11:09:16AM +, Sergio Gonzalez Monroy wrote:
>> On 31/01/2016 14:39, Jerin Jacob wrote:
>>> On Fri, Jan 29, 2016 at 08:29:12PM +, Sergio Gonzalez Monroy wrote:
>>>
>>> IMO, an option for single SA based outbound processing wo
201 - 245 of 245 matches
Mail list logo