Hi,
this is a follow-up to my post from 3 weeks ago [1]. I'm starting a new
thread here since I now got a completely new test setup for improved
reproducibility.
Background for anyone that didn't catch my last post:
I'm investigating a performance regression in my packet generator [2]
that occ
Hi Nissim
Are you using PF pass-through or VF pass-through?
For PF pass-through, you might have already gotten the fix.
For VF pass-through, there is a bug fix which is needed for supporting jumbo
frame and multiple mbuf. http://www.dpdk.org/dev/patchwork/patch/4641/
Regards,
Helin
> -Orig
On 5/8/2015 10:57 AM, Stephen Hemminger wrote:
> On Tue, 5 May 2015 13:39:38 +0800
> Cunming Liang wrote:
>
>> +else if (rc < 0) {
>> +/* epoll_wait fail */
>> +RTE_LOG(ERR, EAL, "epoll_wait returns with fail %s\n",
>> +strerror(errno));
> In real
Hi,
I am using PF pass-through and it doesn't work even with 2000 bytes of server
response page size.
Looks like the first segment of each session is not received.
When i am changing the server response size to 1000 bytes, all works as
expected.
I am working with dpdk 1.8 version.
Any idea wh
This patch set extends flow director to support L2_paylod type and VF filtering
in i40e driver.
Jingjing Wu (6):
ethdev: add struct rte_eth_l2_flow to support l2_payload flow type
i40e: extend flow diretcor to support l2_payload flow type
ethdev: extend struct to support flow director in VF
This patch adds a new struct rte_eth_l2_flow to support l2_payload flow type
Signed-off-by: Jingjing Wu
---
lib/librte_ether/rte_eth_ctrl.h | 8
1 file changed, 8 insertions(+)
diff --git a/lib/librte_ether/rte_eth_ctrl.h b/lib/librte_ether/rte_eth_ctrl.h
index 498fc85..0e30dd9 100644
This patch extends flow diretcor to support l2_payload flow
type in i40e driver.
Signed-off-by: Jingjing Wu
---
lib/librte_pmd_i40e/i40e_fdir.c | 24 +---
1 file changed, 21 insertions(+), 3 deletions(-)
diff --git a/lib/librte_pmd_i40e/i40e_fdir.c b/lib/librte_pmd_i40e/i40e
This patch extends struct rte_eth_fdir_flow_ext to support flow
director in VFs.
Signed-off-by: Jingjing Wu
---
lib/librte_ether/rte_eth_ctrl.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/lib/librte_ether/rte_eth_ctrl.h b/lib/librte_ether/rte_eth_ctrl.h
index 0e30dd9..601a4d3 100644
--
This patch extends flow diretcor to filterting in VFs.
Signed-off-by: Jingjing Wu
---
lib/librte_pmd_i40e/i40e_fdir.c | 15 ---
1 file changed, 12 insertions(+), 3 deletions(-)
diff --git a/lib/librte_pmd_i40e/i40e_fdir.c b/lib/librte_pmd_i40e/i40e_fdir.c
index 27c2102..2f4c247 1006
Modify the doc about flow director commands to support l2_payload
flow type and filtering in VFs.
Signed-off-by: Jingjing Wu
---
doc/guides/testpmd_app_ug/testpmd_funcs.rst | 15 ---
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/doc/guides/testpmd_app_ug/testpmd_funcs
This patch extends commands to support l2_payload flow type
and filtering in VFs of flow director.
Signed-off-by: Jingjing Wu
---
app/test-pmd/cmdline.c | 87 ++
1 file changed, 81 insertions(+), 6 deletions(-)
diff --git a/app/test-pmd/cmdline.c
On 5/6/2015 7:16 AM, Stephen Hemminger wrote:
> On Tue, 5 May 2015 13:39:45 +0800
> Cunming Liang wrote:
>
>> The patch does below for igb PF:
>> - Setup NIC to generate MSI-X interrupts
>> - Set the IVAR register to map interrupt causes to vectors
>> - Implement interrupt enable/disable functi
On 3/21/2015 4:51 AM, Stephen Hemminger wrote:
> On Fri, 27 Feb 2015 12:56:15 +0800
> Cunming Liang wrote:
>
>>
>> /*
>> + * It clears the interrupt causes and enables the interrupt.
>> + * It will be called once only during nic initialized.
>> + *
>> + * @param dev
>> + * Pointer to struc
On 5/6/2015 2:36 AM, Stephen Hemminger wrote:
> On Tue, 5 May 2015 13:39:44 +0800
> Cunming Liang wrote:
>
>>
>> +/* set max interrupt vfio request */
>> +if (pci_dev->intr_handle.vec_en) {
>> +pci_dev->intr_handle.max_intr = hw->mac.max_rx_queues +
>> +
2015-05-10 23:01, De Lara Guarch, Pablo:
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> > I have the following errors with Linux 4.0.1:
> >
> > lib/librte_eal/linuxapp/kni/igb_main.c:2321:2: error: initialization from
> > incompatible pointer type
> > .ndo_bridge_setlink = igb_n
> Due to commit c0371da6 in kernel 3.19, which removed msg_iov
> and msg_iovlen from struct msghdr, DPDK would not build.
> Also, functions memcpy_toiovecend and memcpy_fromiovecend
> were removed in commits ba7438ae and 57dd8a07, being substituted by
> copy_from_iter and copy_to_iter.
>
> This pa
> Due to API changes in function pointer ndo_bridge_setlink
> (commit ad41faa8) and the rename of functions vlan_tx_*
> (commit df8a39de) in kernel 4.0, DPDK would not build.
>
> This patch adds the properly checks to fix the compilation.
>
> Reported-by: Stephen Hemminger
> Signed-off-by: Pablo
Hi Paul,
On 11 May 2015 at 02:14, Paul Emmerich wrote:
> Another possible solution would be a more dynamic approach to mbufs:
Let me suggest a slightly more extreme idea for your consideration. This
method can easily do > 100 Mpps with one very lightly loaded core. I don't
know if it works for
2015-05-07 12:57, David Marchand:
> On Thu, May 7, 2015 at 11:23 AM, Bruce Richardson wrote:
> > On Thu, May 07, 2015 at 09:19:09AM +0530, Sujith Sankar wrote:
> > > This patch adds support for enic in the nic_uio driver so that enic
> > could be used on FreeBSD.
> > >
> > > Signed-off-by: Sujith S
Hi Sujith,
2015-02-27 08:09, Sujith Sankar:
> Hi Thomas,
>
> No update on it from my side :-(
> It would take some more time for me to start working on it (and flow
> director api) as a few other things are keeping me busy.
[...]
Documentation was split to better welcome new NICs:
http:
2015-05-07 16:35, Bruce Richardson:
> The "lib" directory is getting very crowded, with both general libs and
> poll mode drivers in it. This patch set proposes to move the PMDs out of the
> lib folder and to put them in a separate "pmds" folder. This should help
> with code browse-ability as the
Hi Ravi,
> -Original Message-
> From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Ravi Kerur
> Sent: Friday, May 08, 2015 11:55 PM
> To: Matt Laswell
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v2] Implement memcmp using AVX/SSE
> instructions.
>
> On Fri, May 8, 2015 at
Hi Dong,
> -Original Message-
> From: Wang Dong [mailto:dong.wang.pro at hotmail.com]
> Sent: Saturday, May 09, 2015 11:24 AM
> To: Ananyev, Konstantin; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH] librte_eal:Using compiler memory barrier for
> IA processor's rte_wmb/rte_rmb.
>
> Hi
On Sat, May 09, 2015 at 04:27:12PM +, Clark, Gilbert wrote:
>
> Hi folks:
>
> I'm brand new to DPDK.? Read about it off and on occasionally, but never had
> the chance to sit down and play with things until now. ?It's been fun so far:
> just been working on a few toy applications to get mys
Hi Luke,
thanks for your suggestion, I actually looked at how your packet
generator in SnabbSwitch works before and it's quite clever. But
unfortunately that's not what I'm looking for.
I'm looking for a generic solution that works with whatever NIC is
supported by DPDK and I don't want to wri
> -Original Message-
> From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Pravin Shelar
> Sent: Friday, May 8, 2015 2:20 AM
> To: Oleg Strikov
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] Issues met while running openvswitch/dpdk/virtio
> inside the VM
>
> On Thu, May 7, 2015 at 9
2015-04-29 10:04, Stephen Hemminger:
> --- a/lib/librte_mbuf/rte_mbuf.h
> +++ b/lib/librte_mbuf/rte_mbuf.h
> @@ -285,7 +285,10 @@ struct rte_mbuf {
> /**< First 4 flexible bytes or FD ID, dependent on
>PKT_RX_FDIR_* flag in ol_flags. */
>
2015-04-29 10:04, Stephen Hemminger:
> The rte_sched statistics API should allow reading statistics without
> clearing. Make auto-clear optional.
>
> Signed-off-by: Stephen Hemminger
> ---
> app/test/test_sched.c| 4 ++--
> examples/qos_sched/stats.c | 16 +++-
> lib/librt
On Thu, May 07, 2015 at 04:25:32PM -0700, Stephen Hemminger wrote:
> From: Stephen Hemminger
>
> Some drivers need ability to access PCI config (for example for power
> management). This adds an abstraction to do this; only implemented
> on Linux, but should be possible on BSD.
>
> Signed-off-by
> > A large number of our header files and libraries are dependent on one
> > another,
> > which can lead to problems with circular dependencies if trying to tie some
> > of
> > those libraries together, e.g. when prototyping with pktdev, or other
> > schemes
> > to get a common API for ethdev/
> Fixes: 6065355a "pci: make device id tables const"
>
> Following the above commit, compilation on FreeBSD with clang was broken,
> giving the error message:
>
> .../lib/librte_eal/bsdapp/eal/eal_pci.c:438:16: fatal error: assigning to
> 'struct rte_pci_id *' from 'const struct rte_pci_id
Remove extra parenthesis from return statements.
Signed-off-by: Ferruh Yigit
---
lib/librte_cmdline/cmdline_parse_etheraddr.c | 10 ++---
lib/librte_cmdline/cmdline_parse_ipaddr.c | 38 -
lib/librte_cmdline/cmdline_parse_num.c | 24 +--
lib/libr
On Mon, 11 May 2015 13:31:04 +0800
"Liang, Cunming" wrote:
> > Since MSI-X vectors are limited on many hardware platforms, this whole API
> > should be changed so that max_intr is based on number of rx_queues actually
> > used by the application. That means the setup needs to move from init to
> > v2 changes:
> > - add a new macro into rte_mbuf.h
> > - make samples to use that new macro
> >
> >
> > Fixes: dfb03bbe2b ("app/testpmd: use standard functions to initialize
> > mbufs and mbuf pool").
> > Latest mbuf changes (priv_size addition and related fixes)
> > exposed small problem with t
> > Set internal event file descriptor to be non-block and not inherited across
> > exec. This prevents accidental hangs and passing in anothr thread.
> >
> > Signed-off-by: Stephen Hemminger
>
> Acked-by: Anatoly Burakov
Applied, thanks
Ok will stub out the pci_config stuff for BSD.
But I don't have time or resources to do real BSD support.
Also, the whole bnx2x driver loads firmware and that probably has dependencies
that are different on BSD
This is just a reminder that this call is on tomorrow, at the following times,
which is just under 24 hours from now.
Dublin (Ireland) - Tuesday, May 12, 2015 at 4:00:00 PM IST UTC+1 hour
San Francisco (U.S.A. - California) - Tuesday, May 12, 2015 at 8:00:00 AM PDT
UTC-7 hours
Phoenix (U.S.A. -
On Mon, May 11, 2015 at 08:23:59AM -0700, Stephen Hemminger wrote:
> Ok will stub out the pci_config stuff for BSD.
> But I don't have time or resources to do real BSD support.
>
> Also, the whole bnx2x driver loads firmware and that probably has dependencies
> that are different on BSD
>
Thats a
Hi all,
after a small amount of offline discussion with Marc Sune, here is an
alternative proposal for a higher-level interface - aka pktdev - to allow a
common Rx/Tx API across device types handling mbufs [for now, ethdev, ring
and KNI]. The key code is in the first patch fo the set - the second
This is a trivial example showing code which is using ethdevs and rings
in a neutral manner, with the same piece of pipeline code passing mbufs
along a chain without ever having to query its source or destination
type.
Signed-off-by: Bruce Richardson
---
examples/pktdev/Makefile | 57
This commit demonstrates what a minimal API for all packet handling
might look like. It provides common APIs for RX and TX, by wrapping
the types as appropriate. Implementations provided for ring, ethdev and
kni.
Signed-off-by: Bruce Richardson
---
config/common_bsdapp | 5 ++
config
This is 3rd rev of DPDK changes to QoS scheduler.
The change from last revision was to fix the example and fix whitespace.
Stephen Hemminger (6):
rte_sched: make RED optional at runtime
rte_sched: expand scheduler hierarchy for more VLAN's
rte_sched: keep track of RED drops
rte_sched: allo
From: Stephen Hemminger
Want to be able to build with RTE_SCHED_RED enabled but
allow disabling RED on a per-queue basis at runtime.
RED is disabled unless min/max thresholds set.
Signed-off-by: Stephen Hemmminger
---
lib/librte_sched/rte_sched.c | 9 +
1 file changed, 9 insertions(+)
From: Stephen Hemminger
The QoS subport is limited to 8 bits in original code.
But customers demanded ability to support full number of VLAN's (4096)
therefore use the full part of the tag field of mbuf.
Resize the pipe as well to allow for more pipes in future and
avoid expensive bitfield acces
From: Stephen Hemminger
Add new statistic to keep track of drops due to RED.
Signed-off-by: Stephen Hemminger
---
lib/librte_sched/rte_sched.c | 31 ++-
lib/librte_sched/rte_sched.h | 6 ++
2 files changed, 32 insertions(+), 5 deletions(-)
diff --git a/lib/lib
The rte_sched statistics API should allow reading statistics without
clearing. Make auto-clear optional.
Signed-off-by: Stephen Hemminger
---
app/test/test_sched.c| 4 ++--
examples/qos_sched/stats.c | 22 +++---
lib/librte_sched/rte_sched.c | 44 ++
From: Stephen Hemminger
syslog does not like tabs in log messages; tab gets translated to #011
Signed-off-by: Stephen Hemminger
---
lib/librte_sched/rte_sched.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/lib/librte_sched/rte_sched.c b/lib/librte_sched/rt
The setup messages should be at DEBUG level since they are not
important for normal operation of system. The messages about
problems should be at NOTICE or ERR level.
Signed-off-by: Stephen Hemminger
---
lib/librte_sched/rte_sched.c | 15 +--
1 file changed, 9 insertions(+), 6 deleti
On Mon, May 11, 2015 at 10:07:47AM -0700, Stephen Hemminger wrote:
> From: Stephen Hemminger
>
> The QoS subport is limited to 8 bits in original code.
> But customers demanded ability to support full number of VLAN's (4096)
> therefore use the full part of the tag field of mbuf.
>
> Resize the
On Mon, 11 May 2015 11:37:08 -0400
Neil Horman wrote:
> On Mon, May 11, 2015 at 08:23:59AM -0700, Stephen Hemminger wrote:
> > Ok will stub out the pci_config stuff for BSD.
> > But I don't have time or resources to do real BSD support.
> >
> > Also, the whole bnx2x driver loads firmware and tha
On Mon, 11 May 2015 12:54:54 +
Neil Horman wrote:
> On Thu, May 07, 2015 at 04:25:32PM -0700, Stephen Hemminger wrote:
> > From: Stephen Hemminger
> >
> > Some drivers need ability to access PCI config (for example for power
> > management). This adds an abstraction to do this; only impleme
On Mon, 11 May 2015 17:20:07 +
Neil Horman wrote:
> Have you run this through the ABI checker? Seems like this would alter lots
> of
> pointer offsets.
> Neil
No, I have not run it through ABI checker.
It would change the ABI for applications using qos_sched but will not
change layout of m
Hi Konstantin,
On Mon, May 11, 2015 at 2:51 AM, Ananyev, Konstantin <
konstantin.ananyev at intel.com> wrote:
> Hi Ravi,
>
> > -Original Message-
> > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Ravi Kerur
> > Sent: Friday, May 08, 2015 11:55 PM
> > To: Matt Laswell
> > Cc: de
On Mon, May 11, 2015 at 10:32:59AM -0700, Stephen Hemminger wrote:
> On Mon, 11 May 2015 17:20:07 +
> Neil Horman wrote:
>
> > Have you run this through the ABI checker? Seems like this would alter
> > lots of
> > pointer offsets.
> > Neil
>
> No, I have not run it through ABI checker.
> I
Hi Ravi,
>
> From: Ravi Kerur [mailto:rkerur at gmail.com]
> Sent: Monday, May 11, 2015 6:43 PM
> To: Ananyev, Konstantin
> Cc: Matt Laswell; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v2] Implement memcmp using AVX/SSE
> instructions.
>
> Hi Konstantin,
>
>
> On Mon, May 11, 2015 at 2
Hi Konstantin,
On Mon, May 11, 2015 at 12:35 PM, Ananyev, Konstantin <
konstantin.ananyev at intel.com> wrote:
>
> Hi Ravi,
>
> >
> > From: Ravi Kerur [mailto:rkerur at gmail.com]
> > Sent: Monday, May 11, 2015 6:43 PM
> > To: Ananyev, Konstantin
> > Cc: Matt Laswell; dev at dpdk.org
> > Subject
I probably shouldn't stick my nose into this, but I can't help myself.
An experienced programmer will tend to ignore the documentation for
a routine named "blahblah_memcmp" and just assume it functions like
memcmp. Whether or not there's currently a use case in DPDK is
completely irrelevant becaus
Trying to simplify the ifdefs in rte.app.mk to make the code
more readable and maintainable by moving LDLIBS variable to use
the same style as LDLIBS-y being used in the rest of the code.
Added a new variable called EXTRA_LDLIBS to be used by example apps
instead of using LDLIB
Signed-off-by: Keith Wiles
---
doc/build-sdk-quick.txt | 1 +
doc/guides/prog_guide/dev_kit_build_system.rst | 2 ++
doc/guides/prog_guide/dev_kit_root_make_help.rst | 2 +-
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/doc/build-sdk-quick.txt b/doc/buil
59 matches
Mail list logo