[dpdk-dev] [PATCH v2] Fix rte_is_power_of_2

2014-12-27 Thread Ravi Kerur
Changes in v2 Make this a separate patch. rte_is_power_of_2 returns true for 0, fix by checking for n. Ravi Kerur (1): Fix rte_is_power_of_2 lib/librte_eal/common/include/rte_common.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) -- 1.9.1

[dpdk-dev] [PATCH v2] Fix rte_is_power_of_2

2014-12-27 Thread Ravi Kerur
rte_is_power_of_2 returns true for 0 and 0 is not power_of_2. Fix by checking for n. Signed-off-by: Ravi Kerur --- lib/librte_eal/common/include/rte_common.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/librte_eal/common/include/rte_common.h b/lib/librte_eal/common/in

[dpdk-dev] [PATCH v2 0/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Fix Neil's patch review comments. Common functions in linuxapp and bsdapp are moved into librte_eal/common directory. New files added follow _common_ naming conventions. Following checkpatch warnings are treated as false-positive. 1. WARNING: quoted string split across lines Tested against ubunt

[dpdk-dev] [PATCH v2 1/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Changes in v2 1. Remove rte_dump_registers() function since it is not implemented. 2. Fix comment for _rte_exit() eal_debug.c has no difference between Linux and BSD, move into common directory. Rename eal_debug.c to eal_common_debug.c Makefile changes to reflect file move and name change. Fix che

[dpdk-dev] [PATCH v2 2/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Changes in v2 None eal_thread.c has minor difference between Linux and BSD, move into common directory. Use RTE_EXEC_ENV_BSDAPP to differentiate minor difference. Rename eal_thread.c to eal_common_thread.c Makefile changes to reflect file move and name change. Fix checkpatch warnings. Signed-off-

[dpdk-dev] [PATCH v2 3/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Changes in v2 1. In function rte_eal_config_create remove #ifdef _BSDAPP_ and initialize mem_cfg_addr unconditionally. Move common functions in eal.c to librte_eal/common directory. Makefile changes to reflect new file added. Fix checkpatch warnings and errors. Signed-off-by: Ravi Kerur ---

[dpdk-dev] [PATCH v2 4/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Changes in v2 None Move common functions in eal_lcore.c to librte_eal/common directory. Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in common functions. Makefile changes to reflect new file added. Fix checkpatch warnings and errors. Signed-off-by: Ravi Kerur --- lib/librte_eal/bs

[dpdk-dev] [PATCH v2 5/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Changes in v2 1. Use common function name set_tsc_freq_from_sysctl for BSD and Linux. Update comments about its actuality in function declaration. Move common functions in eal_timer.c to librte_eal/common directory. Makefile changes to reflect new file added. Fix checkpatch warnings and errors.

[dpdk-dev] [PATCH v2 6/6] Move EAL common functions

2014-12-27 Thread Ravi Kerur
Changes in v2 1. Use common function names rte_eal_hugepage_init and rte_eal_hugepage_attach for BSD and Linux. Update comments about its actuality in function declaration. Move common functions in eal_memory.c to librte_eal/common directory. Fix checkpatch warnings and errors. Signed-off-b

[dpdk-dev] [PATCH] ixgbe: initialize link status on initialization

2014-12-27 Thread Stephen Hemminger
The link_status variable is not set when device is initialized. This can lead to problems with link never being reported as up if using some SFP modules where the link is instantly on. Signed-off-by: Stephen Hemminger --- a/lib/librte_pmd_ixgbe/ixgbe_ethdev.c +++ b/lib/librte_pmd_ixgbe/ixgbe_eth

[dpdk-dev] [PATCH v2] Fix rte_is_power_of_2

2014-12-27 Thread Neil Horman
On Sat, Dec 27, 2014 at 10:30:44AM -0500, Ravi Kerur wrote: > rte_is_power_of_2 returns true for 0 and 0 is not power_of_2. Fix > by checking for n. > > Signed-off-by: Ravi Kerur > --- > lib/librte_eal/common/include/rte_common.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff

[dpdk-dev] [RFC] resolve conflict between net/ethernet.h and rte_ethdev.h

2014-12-27 Thread Stephen Hemminger
This is a patch to address the conflict between and the definitions in . It has two side effects worth discussion: 1. It forces inclusion of net/ethernet.h 2. It has definition to deal with the differing structure elements in the two versions of struct ether_addr. By doing this ether_nto

[dpdk-dev] [RFC] resolve conflict between net/ethernet.h and rte_ethdev.h

2014-12-27 Thread Neil Horman
On Sat, Dec 27, 2014 at 03:13:00PM -0800, Stephen Hemminger wrote: > This is a patch to address the conflict between > and the definitions in . It has two side effects > worth discussion: > 1. It forces inclusion of net/ethernet.h > 2. It has definition to deal with the differing structure ele