[dpdk-dev] [PATCHv2] librte_acl make it build/work for 'default' target

2014-08-12 Thread Thomas Monjalon
Hi all, 2014-08-08 10:30, Neil Horman: > On Fri, Aug 08, 2014 at 01:09:34PM +, Ananyev, Konstantin wrote: > > > > Also I think user should have an ability to change default classify > > > > code path without modifying/rebuilding acl library. > > > I agree, but both the methods we are advocat

[dpdk-dev] [PATCH] pcap: Fixed bug in eth_pcap_rx function

2014-08-12 Thread Jiajia, SunX
Tested-by: Jiajia SunX This patch fixed a bug by changing eth_pcap_rx function, and is ready to integrate into DPDK.org. > -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Pablo de Lara > Sent: Tuesday, August 05, 2014 6:18 PM > To: dev at dpdk.org > Subjec

[dpdk-dev] [PATCH 0/6]Support VxLAN on fortville

2014-08-12 Thread Jijiang Liu
The patch set supports VxLAN on fortville,and based on current mbuf structure, when the new mbuf structure done, there will be minor changes later. It includes: - Support VxLAN packet filter by configuring UDP port, and add tunneling UDP APIs. - Support VxLAN cloud filters: It is used to use

[dpdk-dev] [PATCH 1/6]i40e:vxlan packet identification

2014-08-12 Thread Jijiang Liu
VxLAN UDP port configuration on i40e, it includes - VxLAN UDP port initialization - Add VxLAN UDP port API Signed-off-by: jijiangl Acked-by: Helin Zhang Acked-by: Jingjing Wu Acked-by: Jing Chen --- lib/librte_ether/rte_ethdev.c | 63 lib/librte_ether/rte_ethdev.h

[dpdk-dev] [PATCH 2/6]app/test-pmd:test vxlan packet identification

2014-08-12 Thread Jijiang Liu
Add commands to test receive vxlan packet identification, which include - use command to add/delete VxLAN UDP port. - use rxonly mode to receive VxLAN packet. Signed-off-by: jijiangl Acked-by: Helin Zhang Acked-by: Jingjing Wu Acked-by: Jing Chen --- app/test-pmd/cmdline.c| 78 +++

[dpdk-dev] [PATCH 4/6]app/testpmd:test VxLAN cloud filter API

2014-08-12 Thread Jijiang Liu
Add commands to test VxLAN cloud filter API. Signed-off-by: jijiangl Acked-by: Helin Zhang Acked-by: Jingjing Wu Acked-by: Jing Chen --- app/test-pmd/cmdline.c | 142 1 files changed, 142 insertions(+), 0 deletions(-) diff --git a/app/test-pm

[dpdk-dev] [PATCH 5/6]i40e:VxLAN Tx checksum offload

2014-08-12 Thread Jijiang Liu
Support VxLAN TX check offload, which include outer and inner L3(IP), inner L4(UDP,TCP and SCTP). Signed-off-by: jijiangl Acked-by: Helin Zhang Acked-by: Jingjing Wu Acked-by: Jing Chen --- lib/librte_mbuf/rte_mbuf.h |4 +++ lib/librte_pmd_i40e/i40e_rxtx.c | 58

[dpdk-dev] [PATCH 6/6]app/testpmd:test VxLAN Tx checksum offload

2014-08-12 Thread Jijiang Liu
Add test cases in testpmd to test VxLAN Tx Checksum offlad, which include IP4 and IPV6 case, and also include inner L3 and L4 test cases. Signed-off-by: jijiangl Acked-by: Helin Zhang Acked-by: Jingjing Wu Acked-by: Jing Chen --- app/test-pmd/config.c |6 +- app/test-pmd/csumon

[dpdk-dev] [PATCH 3/6]i40e:Add VxLAN Cloud filter API

2014-08-12 Thread Jijiang Liu
Support VxLAN cloud filters,which is used to use MAC, VLAN to point to a queue. The filter types supported include below: 1. Inner MAC and Inner VLAN ID 2. Inner MAC address and inner VLAN ID, tenned ID. 3. Inner MAC and tenant ID 4. Inner MAC address 5. Outer MAC address, tenant

[dpdk-dev] [RFC PATCH 01/14] mbuf: rename RTE_MBUF_SCATTER_GATHER into RTE_MBUF_REFCNT

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 11:45 PM, Stephen Hemminger wrote: > On Mon, 11 Aug 2014 21:44:37 +0100 > Bruce Richardson wrote: > >> From: Olivier Matz >> >> It seems that RTE_MBUF_SCATTER_GATHER is not the proper name for the >> feature it provides. "Scatter gather" means that data is stored using >>

[dpdk-dev] [RFC PATCH 02/14] mbuf: remove rte_ctrlmbuf

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > From: Olivier Matz > > The initial role of rte_ctrlmbuf is to carry generic messages (data > pointer + data length) but it's not used by the DPDK or it applications. > Keeping it implies: >- loosing 1 byte in the rte_mbuf structure >

[dpdk-dev] [RFC PATCH 03/14] mbuf: remove the rte_pktmbuf structure

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > From: Olivier Matz > > The rte_pktmbuf structure was initially included in the rte_mbuf > structure. This was needed when there was 2 types of mbuf (ctrl and > packet). As the control mbuf has been removed, we can merge the > rte_pktmbuf

[dpdk-dev] [RFC PATCH 04/14] mbuf: replace data pointer by an offset

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > From: Olivier Matz > > Original patch: > The mbuf structure already contains a pointer to the beginning of the > buffer (m->buf_addr). It is not needed to use 8 bytes again to store > another pointer to the beginning of the data. >

[dpdk-dev] [RFC PATCH 05/14] mbuf: rename in_port to just port

2014-08-12 Thread Olivier MATZ
On 08/11/2014 10:44 PM, Bruce Richardson wrote: > In some cases we may want to tag a packet for a particular destination > or output port, so rename the "in_port" field in the mbuf to just "port" > so that it can be re-used for this purpose if an application needs it. > > Signed-off-by: Bruce Richa

[dpdk-dev] [RFC PATCH 06/14] mbuf: reorder fields by time-of-use

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > * Reorder the fields in the mbuf so that we have fields that are used > together side-by-side in the structure. This means that we have a > contiguous block of 8-bytes in the mbuf which are used to reset an mbuf > of descriptor rearm. >

[dpdk-dev] [PATCH 3/6]i40e:Add VxLAN Cloud filter API

2014-08-12 Thread Thomas Monjalon
Hi Jijiang, 2014-08-12 11:12, Jijiang Liu: > Support VxLAN cloud filters,which is used to use MAC, VLAN to point >to a queue. The filter types supported include below: >1. Inner MAC and Inner VLAN ID >2. Inner MAC address and inner VLAN ID, tenned ID. >3. Inner MAC and tenant ID >

[dpdk-dev] [RFC PATCH 09/14] Fix performance regression due to moved pool ptr

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > Adjust the fast-path code to fix the regression caused by the pool > pointer moving to the second cache line. This change adjusts the > prefetching and also the way in which the mbufs are freed back to the > mempool. > > Signed-off-by: Br

[dpdk-dev] [RFC PATCH 13/14] mbuf: cleanup + added in additional mbuf fields.

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > Cleanups: > * use typedefs for markers within mbuf struct > * split up vlan_macip field as the l2/l3 lengths are for TX so go on the >second cache line. > * created a tx_ol field in second cache line for data used for tx >offloads

[dpdk-dev] [RFC PATCH 00/14] Extend the mbuf structure

2014-08-12 Thread Olivier MATZ
Hi Bruce, On 08/11/2014 10:44 PM, Bruce Richardson wrote: > This patch set expands and enhances the mbuf data structure. This set > includes patches previously > submitted by Olivier to rework the mbuf, but takes the rework further than > proposed there. > > NOTE: This is still a work in progres

[dpdk-dev] [RFC PATCH 01/14] mbuf: rename RTE_MBUF_SCATTER_GATHER into RTE_MBUF_REFCNT

2014-08-12 Thread Richardson, Bruce
Ok, thanks, I'll see about fixing those. I see a number of comments about the format and structure of the patch set itself. I'll take those all on board, but I'll admit that I didn't rework the patchset much before submitting it as an RFC. I'm leaving that until I've finished on this and ready t

[dpdk-dev] [PATCH] hash: added rte_hash_keys to extract all keys

2014-08-12 Thread Tomas Vestelind
I added a function which extracts all the configured keys in a hash map. This is good to have when debugging and printing data store in hash maps. Signed-off-by: Tomas Vestelind --- lib/librte_hash/rte_hash.c | 26 ++ lib/librte_hash/rte_hash.h | 15 +++ 2

[dpdk-dev] [PATCH] hash: added rte_hash_clear that clears all keys

2014-08-12 Thread Tomas Vestelind
I added rte_hash_clear which clear the map from all previously added keys. Signed-off-by: Tomas Vestelind --- lib/librte_hash/rte_hash.c | 14 ++ lib/librte_hash/rte_hash.h | 10 ++ 2 files changed, 24 insertions(+) diff --git a/lib/librte_hash/rte_hash.c b/lib/librte_ha