[dpdk-dev] Rx-errors with testpmd (only 75% line rate)

2014-01-24 Thread François-Frédéric Ozog
> -Message d'origine- > De?: dev [mailto:dev-bounces at dpdk.org] De la part de Michael Quicquaro > Envoy??: vendredi 24 janvier 2014 00:23 > ??: Robert Sanford > Cc?: dev at dpdk.org; mayhan at mayhan.org > Objet?: Re: [dpdk-dev] Rx-errors with testpmd (only 75% line rate) > > Thank you,

[dpdk-dev] [PATCH] timer: add lfence before TSC read

2014-01-24 Thread Didier Pallard
According to Intel Developer's Manual: "The RDTSC instruction is not a serializing instruction. It does not necessarily wait until all previous instructions have been executed before reading the counter. Simi- larly, subsequent instructions may begin execution before the read operation is per

[dpdk-dev] [PATCH] timer: add lfence before TSC read

2014-01-24 Thread François-Frédéric Ozog
Hi, Most of the time rdtsc is used for timestamping and a few cycles incorrect are most of the time not an issue (a precision of 0.1us for session start is usually enough). Sometimes you need to serialize because the time you want to measure is very short, in the order of few nanoseconds. If the

[dpdk-dev] [PATCH] timer: add lfence before TSC read

2014-01-24 Thread Ananyev, Konstantin
Hi, Totally agree with Fran?ois-Fr?d?ric. Actually was going to suggest exactly the same thing. BTW, there is rte_rmb() defined inside rte_atomic.h, that should produce an lfence instruction. Probably better to use it to keep code consistent. Konstantin -Original Message- From: dev [mail

[dpdk-dev] [PATCH v4 0/2] introduce if_index in device info

2014-01-24 Thread liljegren.ma...@gmail.com
Changes since v1: - Split into two patches: Generic and pcap specific. - Changed interface name to interface index Changes since v2: - Interface index is now unsigned - Value 0 used as error rather than 0 - Added missing include of net/if.h in rte_eth_pcap.c - Declared struct args_dict in rte_eth_

[dpdk-dev] [PATCH v4 1/2] ethdev: introduce if_index in device info

2014-01-24 Thread liljegren.ma...@gmail.com
From: Mats Liljegren This field is intended for pcap to describe the name of the interface as known to Linux. It is an interface index, but can be translated into an interface name using if_indextoname() function. When using pcap, interrupt affinity becomes important, and this field gives the ap

[dpdk-dev] [PATCH v4 2/2] pcap: save if_index of the bound device

2014-01-24 Thread liljegren.ma...@gmail.com
From: Mats Liljegren Use command line parameters to get the name of the interface. This name is converted into if_index, which is provided as device info. Signed-off-by: Mats Liljegren --- lib/librte_pmd_pcap/rte_eth_pcap.c | 36 lib/librte_pmd_pcap/rte_e

[dpdk-dev] [PATCH] spinlock: fix build with clang

2014-01-24 Thread Olivier Matz
LLVM clang requires an explicitly sized "cmp" assembly instruction. Signed-off-by: Olivier Matz --- lib/librte_eal/common/include/rte_spinlock.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/librte_eal/common/include/rte_spinlock.h b/lib/librte_eal/common/include/rte_s

[dpdk-dev] [PATCH 0/2] pci: allow to run without hotplug

2014-01-24 Thread Olivier Matz
The default behavior of DPDK is to wait the creation of /dev/uioX devices. This work is usually done by hotplug thanks to the kernel notification. On some embedded systems, there is no hotplug program. These 2 patches introduce a new EAL option "--create-uio-dev" that tells the DPDK to create the

[dpdk-dev] [PATCH 1/2] pci: split the function providing uio device and mappings

2014-01-24 Thread Olivier Matz
Add a new function pci_get_uio_dev() that parses /sys/bus/pci/devices to get the uio device associated with a PCI device. This patch just moves some code that was in pci_uio_map_resource() in the new function without any functional change. Thanks to this change, the next commit will be easier to u

[dpdk-dev] [PATCH 2/2] pci: add option --create-uio-dev to run without hotplug

2014-01-24 Thread Olivier Matz
When the user specifies --create-uio-dev in dpdk eal start options, the DPDK will create the /dev/uioX instead of waiting that a program does it (which is usually hotplug). This option is useful in embedded environments where there is no hotplug to do the work. Signed-off-by: Olivier Matz --- l

[dpdk-dev] [memnic PATCH] pmd: fix attributes

2014-01-24 Thread Olivier Matz
Add missing "const" and remove useless "rte_unused" attributes. Signed-off-by: Olivier Matz --- pmd/pmd_memnic.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/pmd/pmd_memnic.c b/pmd/pmd_memnic.c index d16eb0d..bc01746 100644 --- a/pmd/pmd_memnic.c +++ b/pmd/pmd_memnic

[dpdk-dev] [memnic PATCH] pmd: use memory barrier function instead of asm volatile

2014-01-24 Thread Olivier Matz
Use the DPDK specific function rte_mb() instead of the GCC statement asm volatile ("" ::: "memory"). Signed-off-by: Olivier Matz --- common/memnic.h | 2 -- pmd/pmd_memnic.c | 6 +++--- 2 files changed, 3 insertions(+), 5 deletions(-) diff --git a/common/memnic.h b/common/memnic.h index 6ff38a

[dpdk-dev] [memnic PATCH] linux: fix build with kernel >= 3.3

2014-01-24 Thread Olivier Matz
Signed-off-by: Olivier Matz --- linux/memnic_net.c | 28 ++-- 1 file changed, 26 insertions(+), 2 deletions(-) diff --git a/linux/memnic_net.c b/linux/memnic_net.c index 747ae51..b6018fb 100644 --- a/linux/memnic_net.c +++ b/linux/memnic_net.c @@ -2,6 +2,7 @@ * BSD LI

[dpdk-dev] [memnic PATCH 0/3] cosmetic improvements

2014-01-24 Thread Thomas Monjalon
These patches are some minor improvements for the new memnic PMD. --- Thomas Monjalon (3): pmd: remove symlink pmd: remove useless includes common: remove double underscores common/memnic.h | 10 +++--- pmd/Makefile |2 +- pmd/memnic.h |1 - pmd/pmd_memnic.c |4

[dpdk-dev] [memnic PATCH 1/3] pmd: remove symlink

2014-01-24 Thread Thomas Monjalon
No need to have a symbolic link to a common file when it can be simply included. Signed-off-by: Thomas Monjalon --- pmd/Makefile |2 +- pmd/memnic.h |1 - 2 files changed, 1 insertion(+), 2 deletions(-) delete mode 12 pmd/memnic.h diff --git a/pmd/Makefile b/pmd/Makefile index a96e

[dpdk-dev] [memnic PATCH 2/3] pmd: remove useless includes

2014-01-24 Thread Thomas Monjalon
Signed-off-by: Thomas Monjalon --- common/memnic.h |4 pmd/pmd_memnic.c |4 2 files changed, 8 deletions(-) diff --git a/common/memnic.h b/common/memnic.h index 6ff38a0..58dd019 100644 --- a/common/memnic.h +++ b/common/memnic.h @@ -31,10 +31,6 @@ #ifndef __MEMNIC_H__ #defin

[dpdk-dev] [memnic PATCH 3/3] common: remove double underscores

2014-01-24 Thread Thomas Monjalon
The usage of double underscores is reserved. Signed-off-by: Thomas Monjalon --- common/memnic.h |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/common/memnic.h b/common/memnic.h index 58dd019..e5b3c6f 100644 --- a/common/memnic.h +++ b/common/memnic.h @@ -28,8 +28,8

[dpdk-dev] DPDK L2fwd benchmark with 64byte packets

2014-01-24 Thread Chris Pappas
Hi, we are benchmarking DPDK l2fwd performance by using DPDK Pktgen (both up to date). We have connected two server machines back-to-back, and each machine is a dual-socket server with 6 dual-port 10G NICs (12 ports in total with 120 Gbps). Four of the NICs (8 ports in total) are connected to sock

[dpdk-dev] pktgen offload checksum flag not able to make it work with pacp packets.

2014-01-24 Thread Banashankar KV
I was modifying a packet in pktgen_pcap_mbuf_ctor() and after modifying I wanted to offload the checksum calculation to h/w so I am setting these flags in pktgen_pcap_mbuf_ctor function. m->pkt.vlan_macip.f.l2_len = sizeof(struct ether_hdr); m->pkt.vlan_macip.f.l3_len = sizeof(struct ipv4_hdr); m

[dpdk-dev] pktgen offload checksum flag not able to make it work with pacp packets.

2014-01-24 Thread Wiles, Roger Keith
I have not enabled that feature myself, but I would expect it to work as long as the hardware does. What does the docs say about enabling hardware offload support? Did you look at the following files: ip_reassembly/ipv4_rsmbl.h: m->ol_flags |= PKT_TX_IP_CKSUM; ipv4_frag/rte_ipv4_frag.h: