On 7/7/2023 2:08 PM, Lingyu Liu wrote:
Add iavf live migration steps based on KVM VFIO migration.
Signed-off-by: Lingyu Liu
---
v2: Fixed CI.
Added brief introduction about live migration.
Clarified this is iavf feature.
v3: Added intro and link about vfio live migration.
Adde
Hi Lingyu,
On 7/4/2023 10:27 AM, Lingyu Liu wrote:
Describe iavf live migration steps.
Signed-off-by: Lingyu Liu
---
v2: Fixed CI.
Added brief introduction about live migration.
Clarified this is iavf feature.
---
doc/guides/nics/intel_vf.rst | 101
On 5/26/2023 12:31 AM, Miao Li wrote:
This patch adds sparse mmap support in PCI bus. Sparse mmap is a
capability defined in VFIO which allows multiple mmap areas in one
VFIO region.
In this patch, the sparse mmap regions are mapped to one continuous
virtual address region that follows device-
On 5/26/2023 12:31 AM, Miao Li wrote:
From: Chenbo Xia
The MMIO regions may not be mmap-able for VFIO-PCI devices.
In this case, the driver should explicitly do read and write
to access these regions.
Signed-off-by: Chenbo Xia
---
drivers/bus/pci/bsd/pci.c| 22 +++
dr
On 5/26/2023 12:31 AM, Miao Li wrote:
From: Chenbo Xia
The value 40 used in VFIO_GET_REGION_ADDR() is a private value
(VFIO_PCI_OFFSET_SHIFT) defined in Linux kernel source [1]. It
is not part of VFIO API, and we should not depend on it.
[1] https://github.com/torvalds/linux/blob/v6.2/includ
On 5/26/2023 12:31 AM, Miao Li wrote:
From: Chenbo Xia
This patch introduces an internal representation of the PCI device
which will be used to store the internal information that don't have
to be exposed to drivers, e.g., the VFIO region sizes/offsets.
In this patch, the internal structure
I suggest that you can merge this commit into the Patch 3/5, since they are
all about input set mask changes.
> -Original Message-
> From: Yan, Zhirun
> Sent: Monday, December 21, 2020 2:52 PM
> To: dev@dpdk.org; Zhang, Qi Z ; Cao, Yahui
> ; Wang, Xiao W ;
> Guo,
> -Original Message-
> From: Yan, Zhirun
> Sent: Monday, December 21, 2020 2:52 PM
> To: dev@dpdk.org; Zhang, Qi Z ; Cao, Yahui
> ; Wang, Xiao W ;
> Guo, Junfeng
> Cc: Su, Simei ; Xu, Ting ; Zhang,
> Yuying ; Yan, Zhirun
>
> Subject: [PATCH v1 3/5] net
> -Original Message-
> From: Yan, Zhirun
> Sent: Monday, December 21, 2020 2:52 PM
> To: dev@dpdk.org; Zhang, Qi Z ; Cao, Yahui
> ; Wang, Xiao W ;
> Guo, Junfeng
> Cc: Su, Simei ; Xu, Ting ; Zhang,
> Yuying ; Yan, Zhirun
>
> Subject: [PATCH v1 2/5]
> -Original Message-
> From: Yan, Zhirun
> Sent: Wednesday, November 18, 2020 11:15 AM
> To: Cao, Yahui
> Cc: dev@dpdk.org; Zhang, Qi Z ; Wang, Xiao W
> ; Su, Simei
> Subject: [PATCH v1] net/ice: refactor flow pattern parser
>
> * Cao, Yahui [2020-11-17
: Tuesday, November 17, 2020 4:45 PM
> To: dev@dpdk.org; Zhang, Qi Z ; Cao, Yahui
> ; Wang, Xiao W ;
> Su, Simei
> Cc: Yan, Zhirun
> Subject: [PATCH v1] net/ice: refactor flow pattern parser
>
> Distinguish inner/outer fields. And avoid too many nested conditionals
> in each t
> -Original Message-
> From: Yan, Zhirun
> Sent: Monday, September 28, 2020 2:32 PM
> To: Zhang, Qi Z ; dev@dpdk.org
> Cc: Cao, Yahui ; Wang, Xiao W
> ; Su, Simei ; Guo, Junfeng
> ; Yan, Zhirun
> Subject: [PATCH v1 2/2] net/ice: support inner/ou
> -Original Message-
> From: Yan, Zhirun
> Sent: Tuesday, September 15, 2020 1:27 PM
> To: Zhang, Qi Z ; dev@dpdk.org
> Cc: Cao, Yahui ; Wang, Xiao W
> ; Su, Simei ; Guo, Junfeng
> ; Yan, Zhirun
> Subject: [PATCH v3 2/2] net/ice: merge inner/outer flow se
> -Original Message-
> From: Yan, Zhirun
> Sent: Tuesday, September 15, 2020 1:27 PM
> To: Zhang, Qi Z ; dev@dpdk.org
> Cc: Cao, Yahui ; Wang, Xiao W
> ; Su, Simei ; Guo, Junfeng
> ; Yan, Zhirun
> Subject: [PATCH v3 1/2] net/ice: refactor FDIR set conf functi
> -Original Message-
> From: Su, Simei
> Sent: Thursday, April 2, 2020 9:33 PM
> To: Zhang, Qi Z ; Ye, Xiaolong ;
> Wu, Jingjing
> Cc: dev@dpdk.org; Cao, Yahui ; Su, Simei
>
> Subject: [PATCH v2 1/5] net/iavf: add support for FDIR basic rule
>
> This
> -Original Message-
> From: Su, Simei
> Sent: Wednesday, March 18, 2020 1:42 PM
> To: Ye, Xiaolong ; Zhang, Qi Z
> Cc: dev@dpdk.org; Cao, Yahui ; Wu, Jingjing
> ; Su, Simei
> Subject: [PATCH 1/5] net/iavf: add support for FDIR basic rule
>
> This pat
> -Original Message-
> From: Su, Simei
> Sent: Wednesday, March 18, 2020 1:42 PM
> To: Ye, Xiaolong ; Zhang, Qi Z
> Cc: dev@dpdk.org; Cao, Yahui ; Wu, Jingjing
> ; Su, Simei
> Subject: [PATCH 5/5] net/iavf: add support for FDIR mark action
>
> This patch
Suggest to rename ICE_FDIR_INSET_GTPU_IPV4 to ICE_FDIR_INSET_GTPU, and rename
ICE_FDIR_INSET_GTPU_EH_IPV4 to ICE_FDIR_INSET_GTPU_EH
Thanks.
Yahui.
-Original Message-
From: Zhang, Qi Z
Sent: Monday, January 20, 2020 1:08 PM
To: Cao, Yahui ; Xing, Beilei
Cc: Sun, Chenmin ; dev
Thanks for the comments. Old version patches' states are changed.
-Original Message-
From: Gavin Hu (Arm Technology China) [mailto:gavin...@arm.com]
Sent: Wednesday, September 25, 2019 11:20 AM
To: Cao, Yahui ; Yang, Qiming ; Lu,
Wenzhuo
Cc: dev@dpdk.org; Zhang, Qi Z ; Ye, Xia
19 matches
Mail list logo