On Fri, Feb 04, 2022 at 07:21:10PM +, Ananyev, Konstantin wrote:
> > Implement thread attributes for:
> > * thread affinity
> > * thread priority
> > Implement functions for managing thread attributes.
> >
> > Priority is represented through an enum that allows for two levels:
> > - RTE_TH
On Arm platforms, reading of descriptors may be re-ordered causing the
status of DD bits to be discontinuous. Add logic to only process
continuous descriptors by checking DD bits.
Fixes: b8b4c54ef9b0 ("net/iavf: support flexible Rx descriptor in normal path")
Cc: sta...@dpdk.org
Signed-off-by: Ka
On Arm platforms, reading of descriptors may be re-ordered causing the
status of DD bits to be discontinuous. Add logic to only process
continuous descriptors by checking DD bits.
Fixes: 1060591eada5 ("net/avf: enable bulk allocate Rx")
Cc: sta...@dpdk.org
Signed-off-by: Kathleen Capella
Reviewe
This patchset introduces a fix for Arm platforms to the IAVF driver that was
added to the i40e driver in a previous patchset [1].
The driver determines which descriptors in the HW ring reference packets
that are ready to be received by counting those descriptors whose DD bit is set
to 1. On Arm,
On Fri, 4 Feb 2022 19:59:03 +
Sean Morrissey wrote:
> This patchset introduces config file support for l3fwd
> and its lookup methods LPM, FIB, and EM, similar to
> that of l3fwd-acl. This allows for route rules to be
> defined in configuration files and edited there instead
> of in each of
> Subject: [PATCH v4 1/3] ethdev: introduce IP reassembly offload
>
> IP Reassembly is a costly operation if it is done in software.
> The operation becomes even more costlier if IP fragments are encrypted.
> However, if it is offloaded to HW, it can considerably save application
> cycles.
>
> He
A new option is added in IPsec to enable and attempt reassembly
of inbound packets.
Signed-off-by: Akhil Goyal
Change-Id: I6f66f0b5a659550976a32629130594070cb16cb1
---
devtools/libabigail.abignore | 14 ++
lib/security/rte_security.h | 12 +++-
2 files changed, 25 insertions
Hardware IP reassembly may be incomplete for multiple reasons like
reassembly timeout reached, duplicate fragments, etc.
To save application cycles to process these packets again, a new
mbuf dynflag is added to show that the mbuf received is not
reassembled properly.
Now if this dynflag is set, ap
IP Reassembly is a costly operation if it is done in software.
The operation becomes even more costlier if IP fragments are encrypted.
However, if it is offloaded to HW, it can considerably save application
cycles.
Hence, a new offload feature is exposed in eth_dev ops for devices which can
attemp
As discussed in the RFC[1] sent in 21.11, a new offload is
introduced in ethdev for IP reassembly.
This patchset add the IP reassembly RX offload.
Currently, the offload is tested along with inline IPsec processing.
It can also be updated as a standalone offload without IPsec, if there
are some ha
Add support to define ipv4 and ipv6 forwarding tables
from reading from a config file for EM with a format
similar to l3fwd-acl one.
Users can now use the default hardcoded route tables
or optionally config files for 'l3fwd_em'. Default
config files have been provided for use with EM.
Related l3f
Add support to define ipv4 and ipv6 forwarding tables
from reading from a config file for LPM and FIB,
with format similar to l3fwd-acl one.
Users can now use the default hardcoded route tables
or optionally config files. Default config files have
been provided for use with LPM and FIB.
Signed-of
This patchset introduces config file support for l3fwd
and its lookup methods LPM, FIB, and EM, similar to
that of l3fwd-acl. This allows for route rules to be
defined in configuration files and edited there instead
of in each of the lookup methods hardcoded route tables.
V4:
* Fix nondeterministi
2022-01-18 05:33 (UTC-0800), Srikanth Yalavarthi:
> Added an internal helper to get OS-specific EAL mapping base address
>
> This helper can be used by the drivers to program offload / accelerator
> devices, where the base address can be used as a reference address by
> the accelerator to access t
> Implement thread attributes for:
> * thread affinity
> * thread priority
> Implement functions for managing thread attributes.
>
> Priority is represented through an enum that allows for two levels:
> - RTE_THREAD_PRIORITY_NORMAL
> - RTE_THREAD_PRIORITY_REALTIME_CRITICAL
>
> Affinit
> Use a portable, type-safe representation for the thread identifier.
> Add functions for comparing thread ids and obtaining the thread id
> for the current thread.
>
> Signed-off-by: Narcisa Vasile
> ---
> lib/eal/common/meson.build| 1 +
> lib/eal/{unix => common}/rte_thread.c | 5
This patch adds the SGL out of place support to QAT PMD
Signed-off-by: Kai Ji
---
drivers/crypto/qat/dev/qat_crypto_pmd_gen3.c | 28 --
drivers/crypto/qat/dev/qat_crypto_pmd_gen4.c | 14 -
drivers/crypto/qat/dev/qat_sym_pmd_gen1.c| 55 +---
3 files changed, 83 ins
This patch "unifies" QAT's raw dp api implementations
to share the same enqueue/dequeue methods as the crypto
operation enqueue/dequeue methods. In addition, different QAT
generation specific implementations are done respectively.
The qat_sym_hw_dp.c is removed as no longer required.
Signed-off-by
This patch enable op_build_request function in qat_enqueue_op_burst,
and qat_dequeue_process_response function in qat_dequeue_op_burst.
The op_build_request invoked in crypto build request op is based
on crypto operations setup during session init.
Signed-off-by: Kai Ji
---
drivers/common/qat/qa
This patch removes qat_asym_pmd.c and integrates all the
functions into qat_asym.c. The unified/integrated asym crypto
pmd apis should make them easier to maintain.
Signed-off-by: Kai Ji
---
drivers/common/qat/meson.build| 2 +-
drivers/crypto/qat/qat_asym.c | 180 +
This patch removes qat_sym_pmd.c and integrates all the apis into
qat_sym.c. The unified/integrated qat sym crypto pmd apis should
make them easier to maintain.
Signed-off-by: Kai Ji
---
drivers/common/qat/meson.build | 4 +-
drivers/common/qat/qat_device.c | 4 +-
drivers/common/
This patch reworks the asymmetric crypto data path
implementation to QAT driver. The change includes separation
of different QAT generations' asymmetric crypto data path
implementations and shrink the device capabilities declaration
code size.
Signed-off-by: Kai Ji
---
drivers/common/qat/qat_qp.
This patch introduces the set_session methods for different
generations of QAT. In addition, the patch replaces
'min_qat_dev_gen_id' with 'qat_dev_gen'. Thus, the session
no longer allow to be created by one generation of QAT used by another
generation.
Signed-off-by: Kai Ji
---
drivers/crypto/q
This patch add in specific aead & auth build op enqueue functions
for QAT Gen3 & Gen4
Signed-off-by: Kai Ji
---
drivers/crypto/qat/dev/qat_crypto_pmd_gen3.c | 117 ++-
drivers/crypto/qat/dev/qat_crypto_pmd_gen4.c | 34 +-
2 files changed, 149 insertions(+), 2 deletions(-)
d
This patch adds common inline functions for QAT symmetric
crypto driver to process crypto op and the build op
request function pointer implementation for QAT generation 1.
Signed-off-by: Kai Ji
---
drivers/crypto/qat/dev/qat_crypto_pmd_gens.h | 832 ++-
drivers/crypto/qat/dev/qat
This patch introduce build request op and dequeue op function
pointers to qat queue pair implementation. Those two functions
are used to be assigned during qat session generation based on
crypto operation
Signed-off-by: Kai Ji
---
drivers/common/qat/qat_qp.c | 10 --
drivers/common/
This patch reworks QAT symmetric crypto datapatch implementation where each
generation request building separated and the crypto operation under the
raw datapath api implementation are unified.
In addtion this patchset also enables QAT OOP support in raw datapath api
implementation.
v6:
- fix of
On Fri, Feb 04, 2022 at 05:42:08PM +, Bruce Richardson wrote:
> Some of the linux header includes are explicitly noted as being
> incompatible with C++. However, these headers can included by C files
> directly, or by internal headers, to avoid polluting the public DPDK
> headers with non-C++ s
On Fri, 4 Feb 2022 17:42:05 +
Bruce Richardson wrote:
> C++ does not have automatic casting to/from void pointers, so need
> explicit cast if header is to be included in C++ code
>
> Signed-off-by: Bruce Richardson
> ---
> lib/graph/rte_graph_worker.h | 2 +-
> 1 file changed, 1 insertion
This patch update the EVP MAC routine in crypto openssl pmd
to adopt openssl 3.0 library.
Signed-off-by: Kai Ji
---
drivers/crypto/openssl/compat.h | 12 ++
drivers/crypto/openssl/openssl_pmd_private.h | 4 +
drivers/crypto/openssl/rte_openssl_pmd.c | 129 ++-
Add support for checking each of our headers for issues when included in
a C++ file.
Signed-off-by: Bruce Richardson
---
buildtools/chkincs/main.cpp| 4
buildtools/chkincs/meson.build | 20
2 files changed, 24 insertions(+)
create mode 100644 buildtools/chkincs/ma
Some of the linux header includes are explicitly noted as being
incompatible with C++. However, these headers can included by C files
directly, or by internal headers, to avoid polluting the public DPDK
headers with non-C++ safe includes.
Signed-off-by: Bruce Richardson
---
drivers/net/vhost/rte
Since C++ doesn't support automatic casting from void * to other types,
we need to explicitly add the casts to any header files in DPDK.
Signed-off-by: Bruce Richardson
---
lib/table/rte_table_hash_func.h | 32
1 file changed, 16 insertions(+), 16 deletions(-)
d
C++ does not have automatic casting to/from void pointers, so need
explicit cast if header is to be included in C++ code
Signed-off-by: Bruce Richardson
---
lib/ipsec/rte_ipsec_group.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/ipsec/rte_ipsec_group.h b/lib/ipsec
C++ does not have automatic casting to/from void pointers, so need
explicit cast if header is to be included in C++ code
Signed-off-by: Bruce Richardson
---
lib/graph/rte_graph_worker.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/graph/rte_graph_worker.h b/lib/graph/r
The eventdev headers had issues when used from C++
* Missing closing "}" for the extern "C" block
* No automatic casting to/from void *
Signed-off-by: Bruce Richardson
---
lib/eventdev/rte_event_timer_adapter.h | 3 +++
lib/eventdev/rte_eventdev.h| 2 +-
2 files changed, 4 insertion
C++ files could not include some headers because:
* "new" is a keyword in C++, so can't be a variable name
* there is no automatic casting to/from void *
Signed-off-by: Bruce Richardson
---
lib/eal/include/generic/rte_ticketlock.h | 14 +++---
lib/eal/include/rte_trace_point.h|
This patchset expands upon the exiting chkincs infrastructure to build a
C++ test application as well as the existing C test app, which helps
catch any build errors when the public DPDK headers are included in C++
code. The rest of this patchset fixes the errors caught by this
additional check - mo
> Calls to rte_memcpy_generic could result in unaligned loads/stores for
> 1 < n < 16. This is undefined behavior according to the C standard,
> and it gets flagged by the clang undefined behavior sanitizer.
>
> rte_memcpy_generic is called with unaligned src and dst addresses.
> When 1 < n < 16
Hi,
It's been several days and I haven't received any additional feedback
on this patch (and the other patch related to this one:
http://mails.dpdk.org/archives/dev/2022-January/232491.html). I would
welcome any kind of feedback. Ideally, I'm hoping an authoritative
voice would indicate if there's
On 2/1/2022 12:57 PM, Ori Kam wrote:
Hi Sean,
Please add this feature to the release note.
Hi Sean,
Reminder of this change request, waiting for new version.
Also please remember to add the missing doc in mlx patch (4/4) in next version.
Thanks,
ferruh
-Original Message-
From: S
On 12/21/2021 7:57 PM, Robert Sanford wrote:
This patchset makes the following changes to net/bonding:
- Clean up minor errors in spelling, whitespace, C++ wrappers, and
comments.
- Replace directly overwriting of slave port's rte_eth_conf by copying
it, but only updating it via rte_eth_dev
On 12/21/2021 7:57 PM, Robert Sanford wrote:
- Clean up minor typos in comments, strings, and private names.
- Fix whitespace in log messages and function formatting
(new line before open brace).
- Move closing C++ wrapper to the end of rte_eth_bond_8023ad.h.
Signed-off-by: Robert Sanford
--
On 12/21/2021 7:57 PM, Robert Sanford wrote:
- Add "set bonding lacp timeout_ctrl on|off" to testpmd.
- Add "test_mode4_lacp_timeout_control" to dpdk-test.
- Remove call to rte_eth_dev_mac_addr_remove from add_slave,
as it always fails and prints an error.
Signed-off-by: Robert Sanford
---
On Fri, Feb 04, 2022 at 02:36:47PM +, Ferruh Yigit wrote:
> On 12/21/2021 7:57 PM, Robert Sanford wrote:
> > Add promiscuous_enable, promiscuous_disable, allmulticast_enable,
> > and allmulticast_disable API stubs.
> > This helps clean up errors in dpdk-test link_bonding_mode4_autotest.
> >
>
On 12/21/2021 7:57 PM, Robert Sanford wrote:
- Add bond_8023ad and bond_alb to API documentation.
Signed-off-by: Robert Sanford
---
doc/api/doxy-api-index.md | 2 ++
1 file changed, 2 insertions(+)
diff --git a/doc/api/doxy-api-index.md b/doc/api/doxy-api-index.md
index 4245b96..830235c 100
On 12/21/2021 7:57 PM, Robert Sanford wrote:
- Add support for enabling LACP short timeout, i.e., link partner can
use fast periodic time interval between transmits.
Signed-off-by: Robert Sanford
---
drivers/net/bonding/eth_bond_8023ad_private.h | 3 ++-
drivers/net/bonding/rte_eth_bond_
On 12/21/2021 7:57 PM, Robert Sanford wrote:
Add promiscuous_enable, promiscuous_disable, allmulticast_enable,
and allmulticast_disable API stubs.
This helps clean up errors in dpdk-test link_bonding_mode4_autotest.
Signed-off-by: Robert Sanford
---
drivers/net/ring/rte_eth_ring.c | 28 ++
On 2/4/2022 12:54 PM, Ciara Loftus wrote:
Secondary process support had been disabled for the AF_XDP PMD
because there was no logic in place to share the AF_XDP socket
file descriptors between the processes. This commit introduces
this logic using the IPC APIs.
Since AF_XDP rings are single-prod
On 2/3/2022 12:31 PM, Ferruh Yigit wrote:
On 2/3/2022 8:24 AM, Kumara Parameshwaran wrote:
From: Kumara Parameshwaran
Make changes in PMDs to use the new function where
rte_eth_dev_get_port_by_name is used to get port_id
to access rte_eth_devices
Signed-off-by: Kumara Parameshwaran
---
v1
*
On 1/24/2022 12:28 PM, Xiaoyun Li wrote:
Added functions to calculate UDP/TCP checksum for packets which may be
over multi-segments and called the functions in testpmd csum forwarding
mode to support UDP/TCP sotfware checksum over multi-segments.
Xiaoyun Li (2):
net: add functions to calculat
On 1/24/2022 12:28 PM, Xiaoyun Li wrote:
Csum forwarding mode only supports software UDP/TCP csum calculation
for single segment packets when hardware offload is not enabled.
This patch enables software UDP/TCP csum calculation over multiple
segments.
Signed-off-by: Xiaoyun Li
Tested-by: Sunil
Secondary process support had been disabled for the AF_XDP PMD
because there was no logic in place to share the AF_XDP socket
file descriptors between the processes. This commit introduces
this logic using the IPC APIs.
Since AF_XDP rings are single-producer single-consumer, rx/tx
in the secondary
Hi Christophe,
On 1/23/22 12:59, Christophe Fontaine wrote:
FDs at the end of the VhostUserMessage structure limits the size
of the payload. Move them to an other englobing structure, before
the header & payload of a VhostUserMessage.
Also removes a reference to fds in the VHUMsg structure defin
On 10/25/2021 7:39 AM, Min Hu (Connor) wrote:
From: Huisong Li
Currently, some eth devices are added to bond device, these devices are not
released when the quit command is executed in testpmd. This patch adds the
release operation for all active slaves under a bond device.
'close_port()' fu
On 10/25/2021 7:39 AM, Min Hu (Connor) wrote:
From: Huisong Li
Stopping a bond device also stops all active slaves under the bond device.
If this port is bond device, we need to modify the port status of all
slaves from RTE_PORT_STARTED to RTE_PORT_STOPPED.
Fixes: 0e545d3047fe ("app/testpmd: c
The macro sfc_vdpa_info(sva, ...) will invoke sva->logtype_main,
It'll trigger a NULL dereference when sva is NULL.
This patch fix it.
BTW this patch is not superseded by another one:
[v2] vdpa/sfc: fix null dereference
(http://dpdk.org/patch/106720)
They looks alike in title, but deal with d
On 1/19/22 16:10, xuan.d...@intel.com wrote:
From: Xuan Ding
This patchset fixes the issue of incorrect DMA mapping in PA mode.
Due to the ambiguity of host_phys_addr naming in the guest page
struct, rename it to host_iova.
v2:
* Change the order of patch.
Xuan Ding (2):
vhost: rename f
On 1/19/22 16:10, xuan.d...@intel.com wrote:
From: Xuan Ding
When choosing IOVA as PA mode, IOVA is likely to be discontinuous,
which requires page by page mapping for DMA devices. To be consistent,
this patch implements page by page mapping instead of mapping at the
region granularity for b
On 2/1/22 12:29, Kevin Traynor wrote:
On 01/02/2022 08:28, Maxime Coquelin wrote:
On 1/19/22 16:10, xuan.d...@intel.com wrote:
From: Xuan Ding
This patchset fixes the issue of incorrect DMA mapping in PA mode.
Due to the ambiguity of host_phys_addr naming in the guest page
struct, rename
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Wednesday, February 2, 2022 6:51 AM
> To: dev@dpdk.org
> Cc: gak...@marvell.com; Zhang, Roy Fan ;
> rb...@marvell.com; Kusztal, ArkadiuszX
> Subject: [PATCH 4/4] crypto: reorganize endianness comments, add crypto
> uint
>
> This pa
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Wednesday, February 2, 2022 6:50 AM
> To: dev@dpdk.org
> Cc: gak...@marvell.com; Zhang, Roy Fan ;
> rb...@marvell.com; Kusztal, ArkadiuszX
> Subject: [PATCH 3/4] crypto: use rte macro instead of direct attribute
>
> This commit rep
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Wednesday, February 2, 2022 6:50 AM
> To: dev@dpdk.org
> Cc: gak...@marvell.com; Zhang, Roy Fan ;
> rb...@marvell.com; Kusztal, ArkadiuszX
> Subject: [PATCH 0/4] Clarify asymmetric random, add 'k', uint
>
> This patchset introduces
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Wednesday, February 2, 2022 6:50 AM
> To: dev@dpdk.org
> Cc: gak...@marvell.com; Zhang, Roy Fan ;
> rb...@marvell.com; Kusztal, ArkadiuszX
> Subject: [PATCH 2/4] crypto: clarify usage of random numbers in asym
>
> This commit clari
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Wednesday, February 2, 2022 6:50 AM
> To: dev@dpdk.org
> Cc: gak...@marvell.com; Zhang, Roy Fan ;
> rb...@marvell.com; Kusztal, ArkadiuszX
> Subject: [PATCH 1/4] crypto: add dsa random number k
>
> This commit adds random number 'k
> -Original Message-
> From: Yigit, Ferruh
> Sent: Thursday, February 3, 2022 12:36 PM
> To: Singh, Jasvinder ; Dumitrescu, Cristian
>
> Cc: Kumara Parameshwaran ; Kumara
> Parameshwaran ; dev@dpdk.org
> Subject: Re: [PATCH v1] drivers/net: use internal API to get eth dev from
> name
>
Looks good. Thanks Weiguo for posting this patch and addressing all the
comments!
Acked-by: Jay Jayatheerthan < jay.jayatheert...@intel.com>
-Jay
> -Original Message-
> From: Weiguo Li
> Sent: Friday, February 4, 2022 1:51 PM
> To: Jayatheerthan, Jay
> Cc: Kundapura, Ganapati ; Naga
The memory get from strdup should be freed when parameter parsing
finished, and also should be freed when error occurs.
Fixes: 814d01709328 ("eventdev/eth_rx: support telemetry")
Fixes: 9e583185318f ("eventdev/eth_rx: support telemetry")
Signed-off-by: Weiguo Li
Acked-by: Ganapati Kundapura
--
68 matches
Mail list logo