Re: [dpdk-dev] [PATCH] net/mlx5: fix flow creation on port start

2017-11-05 Thread NĂ©lio Laranjeiro
Hi Shahaf, On Sun, Nov 05, 2017 at 05:44:49PM +0200, Shahaf Shuler wrote: > While the PMD avoids from creating hash RXQ with no hash fields and > array of queues after the port was allready started, it lacks such > protection when re-creating the flows after the port restarts. > > This may lead t

Re: [dpdk-dev] [PATCH v2] ring: guarantee ordering of cons/prod loading when doing

2017-11-05 Thread Jia He
Hi Jerin On 11/3/2017 8:56 PM, Jerin Jacob Wrote: -Original Message- [...] g like that. Ok, but how to distinguish following 2 options? No clearly understood this question. For arm64 case, you can add CONFIG_RTE_RING_USE_C11_MEM_MODEL=y in config/defconfig_arm64-armv8a-* Sorry for

Re: [dpdk-dev] [PATCH v4 15/15] doc: add IOVA aware API changes in release notes

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The wording changes have been done in the API without breaking > the ABI. The deprecated fields and symbols can be removed later > when an another ABI change will be required. > The deprecation notice can be removed. > > The release not

Re: [dpdk-dev] [PATCH v4 09/15] mempool: rename address mapping function to IOVA

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The function rte_mempool_virt2phy() is renamed to rte_mempool_virt2iova(). > The new function has one less parameter because it is unused. > The deprecated function is kept as an alias to avoid breaking the API. > > Signed-off-by: Thoma

Re: [dpdk-dev] [PATCH v4 08/15] mempool: rename addresses from physical to IOVA

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The struct fields phys_addr_t rte_mempool_objhdr.physaddr and > rte_mempool_memhdr.phys_addr are renamed to rte_iova_t iova. > The deprecated names are kept in an anonymous union to avoid breaking > the API. > > Signed-off-by: Thomas M

Re: [dpdk-dev] [PATCH v4 07/15] memzone: rename address from physical to IOVA

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The struct rte_memzone field .phys_addr is renamed to .iova. > The deprecated name is kept in an anonymous union to avoid breaking > the API. > > Signed-off-by: Thomas Monjalon > --- Acked-by: Santosh Shukla

Re: [dpdk-dev] [PATCH v4 05/15] malloc: rename address mapping function to IOVA

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The function rte_malloc_virt2phy() is renamed to rte_malloc_virt2iova(). > The deprecated name is kept as an alias to avoid breaking the API. > > Signed-off-by: Thomas Monjalon > --- Acked-by: Santosh Shukla

Re: [dpdk-dev] [PATCH v4 04/15] mem: rename address mapping function to IOVA

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The function rte_mem_virt2phy() is kept and used in functions which > works only with physical addresses. > For all other calls this function is replaced by rte_mem_virt2iova() > which does a direct mapping (no conversion) in the VA cas

Re: [dpdk-dev] [PATCH v4 01/15] mem: hide physical address error in VA mode

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > If the IOVA mode is not using physical addresses, > no need to log an error about physical address issue. > > Signed-off-by: Thomas Monjalon > --- Acked-by: Santosh Shukla

Re: [dpdk-dev] [PATCH v4 02/15] mem: introduce IOVA type

2017-11-05 Thread santosh
On Monday 06 November 2017 07:11 AM, Thomas Monjalon wrote: > The IO virtual addresses may be used instead of physical addresses. > As IOVA is more generic, it should be used in most places instead > of physical address wording. > > Signed-off-by: Thomas Monjalon > --- > lib/librte_eal/common/in

Re: [dpdk-dev] [PATCH v2] net/e1000: fix cannot getting Rx interrupts issue

2017-11-05 Thread Lu, Wenzhuo
Hi, > -Original Message- > From: Li, Xiaoyun > Sent: Monday, November 6, 2017 10:42 AM > To: Lu, Wenzhuo > Cc: dev@dpdk.org; Li, Xiaoyun ; sta...@dpdk.org > Subject: [PATCH v2] net/e1000: fix cannot getting Rx interrupts issue > > When using VFIO and MSIX interrupt mode, cannot get Rx in

Re: [dpdk-dev] [PATCH v2] examples/l3fwd: fix aliasing in port grouping

2017-11-05 Thread Jerin Jacob
-Original Message- > Date: Fri, 3 Nov 2017 16:13:51 +0530 > From: Guduri Prathyusha > To: tomasz.kante...@intel.com > CC: jianbo@arm.com, guduriprathyu...@gmail.com, > konstantin.anan...@intel.com, dev@dpdk.org, Guduri Prathyusha > > Subject: [dpdk-dev] [PATCH v2] examples/l3fwd: f

Re: [dpdk-dev] [PATCH] vhost: postpone ring addresses translations at kick time only

2017-11-05 Thread Yao, Lei A
Hi, Maxime > -Original Message- > From: Maxime Coquelin [mailto:maxime.coque...@redhat.com] > Sent: Friday, November 3, 2017 11:57 PM > To: dev@dpdk.org; y...@fridaylinux.org; Yao, Lei A > Cc: m...@redhat.com > Subject: Re: [PATCH] vhost: postpone ring addresses translations at kick time

[dpdk-dev] [PATCH v2] net/e1000: fix cannot getting Rx interrupts issue

2017-11-05 Thread Xiaoyun Li
When using VFIO and MSIX interrupt mode, cannot get Rx interrupts. Because when enabling the interrupt vectors, the offset is computed in a way which only supports IGB_UIO. But the offset should be different when using VFIO. This patch fixes this issue. Fixes: c3cd3de0ab50 ("igb: enable Rx queue i

[dpdk-dev] [PATCH] bus/pci: fix namespace of sysfs path function

2017-11-05 Thread Thomas Monjalon
The function pci_get_sysfs_path was moved from EAL to the PCI driver. The namespace is now fixed by adding "rte_" prefix. The map files are fixed by removing the symbol from EAL and adding it to the PCI driver. It is an API break but it is probably not used by applications. Anyway this API is alr

[dpdk-dev] [PATCH v4 14/15] drivers/net: rename physical address type to IOVA

2017-11-05 Thread Thomas Monjalon
From: Santosh Shukla Renamed data type from phys_addr_t to rte_iova_t. Signed-off-by: Santosh Shukla Reviewed-by: Anatoly Burakov Signed-off-by: Thomas Monjalon --- drivers/net/ark/ark_ddm.c | 2 +- drivers/net/ark/ark_ddm.h | 4 +-- drivers/net/ark/ark_et

[dpdk-dev] [PATCH v4 15/15] doc: add IOVA aware API changes in release notes

2017-11-05 Thread Thomas Monjalon
The wording changes have been done in the API without breaking the ABI. The deprecated fields and symbols can be removed later when an another ABI change will be required. The deprecation notice can be removed. The release notes describe the new available API with IOVA wording. Signed-off-by: Tho

[dpdk-dev] [PATCH v4 13/15] cryptodev: rename physical address type to IOVA

2017-11-05 Thread Thomas Monjalon
From: Santosh Shukla Renamed data type from phys_addr_t to rte_iova_t. Signed-off-by: Santosh Shukla Reviewed-by: Anatoly Burakov Signed-off-by: Thomas Monjalon --- app/test-crypto-perf/cperf_test_common.c | 2 +- app/test-crypto-perf/cperf_test_vectors.h | 4 ++-- doc/guides/prog_guide/c

[dpdk-dev] [PATCH v4 12/15] mbuf: rename data address helpers to IOVA

2017-11-05 Thread Thomas Monjalon
The following inline functions and macros have been renamed to be consistent with the IOVA wording: rte_mbuf_data_dma_addr -> rte_mbuf_data_iova rte_mbuf_data_dma_addr_default -> rte_mbuf_data_iova_default rte_pktmbuf_mtophys-> rte_pktmbuf_iova rte_pktmbuf_mtophys_offset ->

[dpdk-dev] [PATCH v4 11/15] mbuf: rename physical address to IOVA

2017-11-05 Thread Thomas Monjalon
From: Santosh Shukla Rename buf_physaddr to buf_iova. Keep the deprecated name in an anonymous union to avoid breaking the API. Signed-off-by: Santosh Shukla Reviewed-by: Anatoly Burakov Signed-off-by: Thomas Monjalon --- app/test-crypto-perf/cperf_test_common.c | 4 ++-- doc/guides/prog_gu

[dpdk-dev] [PATCH v4 08/15] mempool: rename addresses from physical to IOVA

2017-11-05 Thread Thomas Monjalon
The struct fields phys_addr_t rte_mempool_objhdr.physaddr and rte_mempool_memhdr.phys_addr are renamed to rte_iova_t iova. The deprecated names are kept in an anonymous union to avoid breaking the API. Signed-off-by: Thomas Monjalon --- drivers/mempool/dpaa2/dpaa2_hw_mempool.h| 2 +- dr

[dpdk-dev] [PATCH v4 10/15] mempool: rename populate functions to IOVA

2017-11-05 Thread Thomas Monjalon
The functions rte_mempool_populate_phys() and rte_mempool_populate_phys_tab() are renamed to rte_mempool_populate_iova() and rte_mempool_populate_iova_tab(). The deprecated functions are kept as aliases to avoid breaking the API. Signed-off-by: Thomas Monjalon --- lib/librte_mempool/rte_mempool.

[dpdk-dev] [PATCH v4 09/15] mempool: rename address mapping function to IOVA

2017-11-05 Thread Thomas Monjalon
The function rte_mempool_virt2phy() is renamed to rte_mempool_virt2iova(). The new function has one less parameter because it is unused. The deprecated function is kept as an alias to avoid breaking the API. Signed-off-by: Thomas Monjalon --- app/test-crypto-perf/cperf_test_common.c | 4 ++-- d

[dpdk-dev] [PATCH v4 07/15] memzone: rename address from physical to IOVA

2017-11-05 Thread Thomas Monjalon
The struct rte_memzone field .phys_addr is renamed to .iova. The deprecated name is kept in an anonymous union to avoid breaking the API. Signed-off-by: Thomas Monjalon --- drivers/crypto/qat/qat_qp.c | 2 +- drivers/net/bnx2x/bnx2x.c | 2 +- drivers/net/bnx2x

[dpdk-dev] [PATCH v4 06/15] malloc: use pointer diff macro in IOVA mapping

2017-11-05 Thread Thomas Monjalon
From: Santosh Shukla Use RTE_PTR_DIFF macro in rte_mem_virt2iova api. Suggested-by: Anatoly Burakov Signed-off-by: Santosh Shukla --- lib/librte_eal/common/rte_malloc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/librte_eal/common/rte_malloc.c b/lib/librte_eal/com

[dpdk-dev] [PATCH v4 03/15] mem: rename segment address from physical to IOVA

2017-11-05 Thread Thomas Monjalon
From: Santosh Shukla Renaming rte_memseg {.phys_addr} to {.iova} Keep the deprecated name in an anonymous union to avoid breaking the API. Use rte_iova_t and RTE_BAD_IOVA where appropriate in memory segment handling. Signed-off-by: Santosh Shukla Reviewed-by: Anatoly Burakov Signed-off-by: Th

[dpdk-dev] [PATCH v4 05/15] malloc: rename address mapping function to IOVA

2017-11-05 Thread Thomas Monjalon
The function rte_malloc_virt2phy() is renamed to rte_malloc_virt2iova(). The deprecated name is kept as an alias to avoid breaking the API. Signed-off-by: Thomas Monjalon --- app/test-crypto-perf/cperf_test_vector_parsing.c | 4 ++-- app/test-crypto-perf/cperf_test_vectors.c| 6 +++---

[dpdk-dev] [PATCH v4 04/15] mem: rename address mapping function to IOVA

2017-11-05 Thread Thomas Monjalon
The function rte_mem_virt2phy() is kept and used in functions which works only with physical addresses. For all other calls this function is replaced by rte_mem_virt2iova() which does a direct mapping (no conversion) in the VA case. Note: the new function rte_mem_virt2iova() function matches the b

[dpdk-dev] [PATCH v4 02/15] mem: introduce IOVA type

2017-11-05 Thread Thomas Monjalon
The IO virtual addresses may be used instead of physical addresses. As IOVA is more generic, it should be used in most places instead of physical address wording. Signed-off-by: Thomas Monjalon --- lib/librte_eal/common/include/rte_memory.h | 10 +- 1 file changed, 9 insertions(+), 1 del

[dpdk-dev] [PATCH v4 01/15] mem: hide physical address error in VA mode

2017-11-05 Thread Thomas Monjalon
If the IOVA mode is not using physical addresses, no need to log an error about physical address issue. Signed-off-by: Thomas Monjalon --- lib/librte_eal/linuxapp/eal/eal_memory.c | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/lib/librte_eal/linuxapp/eal/eal_memory.

[dpdk-dev] [PATCH v4 00/15] make DPDK IOVA aware

2017-11-05 Thread Thomas Monjalon
This v4 is a big rework to complete the patches sent by Santosh. The core components for memory handling (memseg, malloc, memzone, mempool, mbuf) are almost fully updated for IOVA awareness. It will ease maintenance and upcoming reworks; that's why we should push it in 17.11 LTS. The most importan

Re: [dpdk-dev] DPDK support for 82579

2017-11-05 Thread Thomas Monjalon
Hi, 05/11/2017 13:05, James Bensley: > Hi all, > > Please see attached and below a patch which allowed Pktgen to run on > my laptop which has a built in Intel 82579LM 1G NIC: Thank you for your contribution. If you have a bit of time, you can try to send a well formatted patch which will be bett

[dpdk-dev] build error in ixgbe_crypto_capabilities_get on SLES

2017-11-05 Thread Thomas Monjalon
Hi, I think we have a compilation error in ixgbe IPsec for more than one week. Someone to fix it please? 05/11/2017 21:11, sys_...@intel.com: > Failure #1 > SUSE11SP2_64 / Linux 3.0.13-0 / GCC 4.5.1 > Config: x86_64-native-linuxapp-gcc > CONFIG_RTE_LIBRTE_PMD_PCAP=y, > CONFIG_RTE_

[dpdk-dev] [PATCH v4] net/mlx4: enhance Rx packet type offloads

2017-11-05 Thread Moti Haimovsky
This patch enhances the Rx packet type offload to also report the L4 protocol information in the hw ptype filled by the PMD for each received packet. Signed-off-by: Moti Haimovsky --- V4: * Removed extra blank line from the end of mlx4_ethdev.c V3: * Modifications according to review by Adrien Ma

[dpdk-dev] [PATCH] net/pcap: fix memory leak from missing pcap_close

2017-11-05 Thread Stefan Baranoff
In open_single_tx_pcap there is a call to pcap_open_dead which calls malloc to create and return a pcap_t. That object is never freed in this case. Other places it is freed by passing it back similar to the way the pcap_dumper_t is in this case. The pcap_t is only used to create the pcap_dumper_t

[dpdk-dev] [PATCH] net/mlx5: fix flow creation on port start

2017-11-05 Thread Shahaf Shuler
While the PMD avoids from creating hash RXQ with no hash fields and array of queues after the port was allready started, it lacks such protection when re-creating the flows after the port restarts. This may lead to inconsist behaviour for flows depending if they were created before or after the po

[dpdk-dev] [PATCH v3] net/mlx4: enhance Rx packet type offloads

2017-11-05 Thread Moti Haimovsky
This patch enhances the Rx packet type offload to also report the L4 protocol information in the hw ptype filled by the PMD for each received packet. Signed-off-by: Moti Haimovsky --- V3: * Modifications according to review by Adrien Mazarguil Re: [PATCH v2] net/mlx4: enhance Rx packet type

Re: [dpdk-dev] [PATCH v2] net/mlx4: enhance Rx packet type offloads

2017-11-05 Thread Mordechay Haimovsky
See inline > -Original Message- > From: Adrien Mazarguil [mailto:adrien.mazarg...@6wind.com] > Sent: Friday, November 3, 2017 4:23 PM > To: Mordechay Haimovsky > Cc: dev@dpdk.org > Subject: Re: [PATCH v2] net/mlx4: enhance Rx packet type offloads > > On Thu, Nov 02, 2017 at 02:14:34PM +0

[dpdk-dev] DPDK support for 82579

2017-11-05 Thread James Bensley
Hi all, Please see attached and below a patch which allowed Pktgen to run on my laptop which has a built in Intel 82579LM 1G NIC: bensley@ubuntu-laptop:~$ lspci -nn | grep Ether 00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04) bensley@

[dpdk-dev] net/pcap: remove single interface constraint (v2)

2017-11-05 Thread Ilya Matveychikov
Hello folks, This patch removes single interface constraint from the libpcap-based PMD. The problem it solves is to allow PCAP device consists of more than single device: # testpmd --vdev net_pcap0,iface=vethA,iface=vethB,iface=vethC and so.. I found the issue when performed RSS emulation based

[dpdk-dev] net/pcap: remove single interface constraint

2017-11-05 Thread Ilya Matveychikov
Hello folks, This patch removes single interface constraint from the libpcap-based PMD. The problem it solves is to allow PCAP device consists of more than single device: # testpmd --vdev net_pcap0,iface=vethA,iface=vethB,iface=vethC and so.. I found the issue when performed RSS emulation base