[dpdk-dev] [RFC PATCH 0/4]: Implement module information export

2016-05-04 Thread Thomas Monjalon
This discussion requires more opinions. Please everybody, READ and COMMENT. Thanks If it is not enough visible, a new thread could be started later. 2016-05-04 07:43, Neil Horman: > On Wed, May 04, 2016 at 10:24:18AM +0200, David Marchand wrote: > > On Tue, May 3, 2016 at 1:57 PM, Neil Horman >

[dpdk-dev] [PATCH] virtio: split virtio rx/tx queue

2016-05-04 Thread Yuanhan Liu
On Thu, May 05, 2016 at 03:29:44AM +, Xie, Huawei wrote: > On 5/5/2016 11:03 AM, Yuanhan Liu wrote: > > On Thu, May 05, 2016 at 01:54:25AM +, Xie, Huawei wrote: > >> On 5/5/2016 7:59 AM, Yuanhan Liu wrote: > >>> On Wed, May 04, 2016 at 08:50:27AM +0800, Huawei Xie wrote: > -int virtio_

[dpdk-dev] [PATCH v2] ethdev: make struct rte_eth_dev cache aligned

2016-05-04 Thread Jerin Jacob
On Wed, May 04, 2016 at 01:53:39PM +, Richardson, Bruce wrote: > > > > -Original Message- > > From: Jerin Jacob [mailto:jerin.jacob at caviumnetworks.com] > > Sent: Wednesday, May 4, 2016 2:43 PM > > To: Richardson, Bruce > > Cc: dev at dpdk.org; thomas.monjalon at 6wind.com > > Subj

[dpdk-dev] [PATCH v3 2/2] virtio: fix memory leak of virtqueue memzones

2016-05-04 Thread Yuanhan Liu
ping... On Thu, Apr 28, 2016 at 10:33:08PM -0700, Yuanhan Liu wrote: > On Fri, Apr 29, 2016 at 12:48:46AM +, Jianfeng Tan wrote: > > @@ -447,6 +453,7 @@ int virtio_dev_queue_setup(struct rte_eth_dev *dev, > > > > hw->vtpci_ops->setup_queue(hw, vq); > > > > + vq->started = 1; > > Jud

[dpdk-dev] [PATCH v3 1/2] virtio: cleanup virtio_dev_queue_setup()

2016-05-04 Thread Yuanhan Liu
On Fri, Apr 29, 2016 at 12:48:45AM +, Jianfeng Tan wrote: > + if (queue_type < VTNET_RQ || queue_type > VTNET_CQ) { > + PMD_INIT_LOG(ERR, "invalid queue type: %d", queue_type); > + return -EINVAL; > } I'm thinking this check is not necessary. We can make sure

[dpdk-dev] [PATCH] virtio: split virtio rx/tx queue

2016-05-04 Thread Yuanhan Liu
On Thu, May 05, 2016 at 01:54:25AM +, Xie, Huawei wrote: > On 5/5/2016 7:59 AM, Yuanhan Liu wrote: > > On Wed, May 04, 2016 at 08:50:27AM +0800, Huawei Xie wrote: > >> -int virtio_dev_queue_setup(struct rte_eth_dev *dev, > >> - int queue_type, > >> - uint16_t q

[dpdk-dev] [PATCH] app/test: shorten execution time

2016-05-04 Thread Thomas Monjalon
The autotests are too long to be run often. This patch reduces the needed time of some tests in fast_test. The others will be analyzed when they will be able to run in a VM with a reasonnable amount of memory. The current status in a small VM is below: > make fast_test /root/dpdk/build/app/test -

[dpdk-dev] [PATCH v2] eal: make hugetlb initialization more robust

2016-05-04 Thread Tan, Jianfeng
Hi Sergio, On 5/4/2016 7:07 PM, Sergio Gonzalez Monroy wrote: > On 08/03/2016 01:42, Jianfeng Tan wrote: >> This patch adds an option, --huge-trybest, to use a recover mechanism to >> the case that there are not so many hugepages (declared in sysfs), which >> can be used. It relys on a mem access

[dpdk-dev] [PATCH v2] ethdev: make struct rte_eth_dev cache aligned

2016-05-04 Thread Jerin Jacob
On Wed, May 04, 2016 at 12:09:50PM +0100, Bruce Richardson wrote: > On Tue, May 03, 2016 at 06:12:07PM +0530, Jerin Jacob wrote: > > Elements of struct rte_eth_dev used in the fast path. > > Make struct rte_eth_dev cache aligned to avoid the cases where > > rte_eth_dev elements share the same cache

[dpdk-dev] [PATCH v2 12/17] pci: add a helper for device name

2016-05-04 Thread Thomas Monjalon
2016-05-04 16:25, Bruce Richardson: > On Wed, Apr 20, 2016 at 01:44:12PM +0200, David Marchand wrote: > > eal is a better place than crypto / ethdev for naming resources. > > Add a helper in eal and make use of it in crypto / ethdev. > > > > Signed-off-by: David Marchand > > --- > > lib/librte_c

[dpdk-dev] [PATCH] eal: add missing include to debug header

2016-05-04 Thread Bruce Richardson
The header file rte_debug.h makes use of the "unlikely" macro which means it should include the rte_branch_prediction.h header file. Fixes: 50705e8e3cdd ("eal: add assert macro for debug") Signed-off-by: Bruce Richardson --- lib/librte_eal/common/include/rte_debug.h | 1 + 1 file changed, 1 ins

[dpdk-dev] [PATCH v2 12/17] pci: add a helper for device name

2016-05-04 Thread Bruce Richardson
On Wed, May 04, 2016 at 06:26:18PM +0200, Thomas Monjalon wrote: > 2016-05-04 16:25, Bruce Richardson: > > On Wed, Apr 20, 2016 at 01:44:12PM +0200, David Marchand wrote: > > > eal is a better place than crypto / ethdev for naming resources. > > > Add a helper in eal and make use of it in crypto /

[dpdk-dev] [PATCH] virtio: split virtio rx/tx queue

2016-05-04 Thread Yuanhan Liu
On Wed, May 04, 2016 at 08:50:27AM +0800, Huawei Xie wrote: > -int virtio_dev_queue_setup(struct rte_eth_dev *dev, > - int queue_type, > - uint16_t queue_idx, > +static int > +virtio_dev_cq_queue_setup(struct rte_eth_dev *dev, While it's good to split Rx/Tx

[dpdk-dev] virtio still blindly take over virtio device managed by kernel

2016-05-04 Thread Xie, Huawei
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Vincent Li > Sent: Thursday, May 05, 2016 12:21 AM > To: dev at dpdk.org > Subject: [dpdk-dev] virtio still blindly take over virtio device managed > by kernel > > Hi, > > I am running the dpdk git repo which

[dpdk-dev] [PATCH v2] ethdev: make struct rte_eth_dev cache aligned

2016-05-04 Thread Bruce Richardson
On Wed, May 04, 2016 at 08:49:38PM +0530, Jerin Jacob wrote: > On Wed, May 04, 2016 at 01:53:39PM +, Richardson, Bruce wrote: > > > > > > > -Original Message- > > > From: Jerin Jacob [mailto:jerin.jacob at caviumnetworks.com] > > > Sent: Wednesday, May 4, 2016 2:43 PM > > > To: Richar

[dpdk-dev] [PATCH v2 12/17] pci: add a helper for device name

2016-05-04 Thread Bruce Richardson
On Wed, Apr 20, 2016 at 01:44:12PM +0200, David Marchand wrote: > eal is a better place than crypto / ethdev for naming resources. > Add a helper in eal and make use of it in crypto / ethdev. > > Signed-off-by: David Marchand > --- > lib/librte_cryptodev/rte_cryptodev.c| 27 -

[dpdk-dev] [PATCH v2] virtio: fix modify drv_flags for specific device

2016-05-04 Thread Yuanhan Liu
On Tue, May 03, 2016 at 10:05:01AM +0200, David Marchand wrote: > Hello Tan, > > On Thu, Apr 28, 2016 at 8:08 PM, Jianfeng Tan > wrote: > > Issue: virtio's drv_flags are decided by devices types (modern vs legacy), > > and which kernel driver is used, and the negotiated features (especially > >

[dpdk-dev] [PATCH] app/test: fix log check when default level is high

2016-05-04 Thread Thomas Monjalon
The log unit test was checking display of low priority messages. It was not working if RTE_LOG_LEVEL is not RTE_LOG_DEBUG. It is even easier to see since the default level is INFO (9b9d7ca). Now the test use ERR and CRIT levels which should be always enabled while not trigerring syslog output on t

[dpdk-dev] Old oversubscription related checkin

2016-05-04 Thread Sridhar.V.Iyer
Hi Cristian, I stumbled into an old from 2013 (http://dpdk.org/browse/dpdk/patch/lib/librte_sched/rte_sched.c?id=835c5409a7bac3055b82bebee65d8ada7f20d332 ) I couldn?t find any context f

[dpdk-dev] [PATCH v2] ethdev: make struct rte_eth_dev cache aligned

2016-05-04 Thread Richardson, Bruce
> -Original Message- > From: Jerin Jacob [mailto:jerin.jacob at caviumnetworks.com] > Sent: Wednesday, May 4, 2016 2:43 PM > To: Richardson, Bruce > Cc: dev at dpdk.org; thomas.monjalon at 6wind.com > Subject: Re: [dpdk-dev] [PATCH v2] ethdev: make struct rte_eth_dev cache > aligned > >

[dpdk-dev] [PATCH] i40e: fix vlan stripping from inner header

2016-05-04 Thread Jingjing Wu
Previously, for tunnel packets, such as VXLAN/NVGRE, the vlan tags of the inner header will be stripped without putting vlan info to descriptor, what is not expected behaviour. This patch fixes it by changing hardware configuration to leave the inner packet alone. Fixes: 4861cde46116 ("i40e: new p

[dpdk-dev] [PATCH v2] eal: make hugetlb initialization more robust

2016-05-04 Thread Sergio Gonzalez Monroy
On 08/03/2016 01:42, Jianfeng Tan wrote: > This patch adds an option, --huge-trybest, to use a recover mechanism to > the case that there are not so many hugepages (declared in sysfs), which > can be used. It relys on a mem access to fault-in hugepages, and if fails > with SIGBUS, recover to previo

[dpdk-dev] [PATCH v2] ethdev: make struct rte_eth_dev cache aligned

2016-05-04 Thread Bruce Richardson
On Tue, May 03, 2016 at 06:12:07PM +0530, Jerin Jacob wrote: > Elements of struct rte_eth_dev used in the fast path. > Make struct rte_eth_dev cache aligned to avoid the cases where > rte_eth_dev elements share the same cache line with other structures. > > Signed-off-by: Jerin Jacob > --- > v2:

[dpdk-dev] [PATCH v2] eal: make hugetlb initialization more robust

2016-05-04 Thread Sergio Gonzalez Monroy
On 08/03/2016 01:42, Jianfeng Tan wrote: > This patch adds an option, --huge-trybest, to use a recover mechanism to > the case that there are not so many hugepages (declared in sysfs), which > can be used. It relys on a mem access to fault-in hugepages, and if fails > with SIGBUS, recover to previo

[dpdk-dev] [PATCH V2] i40evf: add ops for rx queue and tx queue

2016-05-04 Thread Bruce Richardson
On Thu, Apr 28, 2016 at 04:57:51AM +, Wu, Jingjing wrote: > > > > -Original Message- > > From: Xing, Beilei > > Sent: Thursday, April 28, 2016 11:18 AM > > To: Wu, Jingjing > > Cc: dev at dpdk.org; Xing, Beilei > > Subject: [PATCH V2] i40evf: add ops for rx queue and tx queue > > > >

[dpdk-dev] [PATCH] enic: fix misalignment of Rx mbuf data

2016-05-04 Thread Bruce Richardson
On Tue, Apr 26, 2016 at 07:51:56PM -0700, John Daley wrote: > Data DMA used m->data_off of uninitialized mbufs instead of > RTE_PKTMBUF_HEADROOM, potentially causing Rx data to be > placed at the wrong alignment in the mbuf. > > Fixes: 947d860c821f ("enic: improve Rx performance") > Signed-off-by:

[dpdk-dev] [PATCH v3 02/13] ixgbe: move pci device ids to driver

2016-05-04 Thread David Marchand
On Fri, Apr 29, 2016 at 3:34 AM, Wu, Jingjing wrote: > Hi, David > > For the changes on igb, ixgbe, I saw you create a new header file called > **__pci_dev_ids.h to replace the rte_pci_dev_ids.h for each driver. > But for the changes on i40e, you didn't do that way. > If you look into the base co

[dpdk-dev] [RFC PATCH 0/4]: Implement module information export

2016-05-04 Thread David Marchand
On Tue, May 3, 2016 at 1:57 PM, Neil Horman wrote: > On Tue, Apr 26, 2016 at 01:39:47PM -0400, Neil Horman wrote: >> Hey- >> So a few days ago we were reviewing Davids patch series to introduce >> the >> abiilty to dump hardware support from pmd DSO's in a human readable format. >> That eff

[dpdk-dev] [PATCH] app/test: fix +/-1 error in allocation

2016-05-04 Thread David Marchand
On Tue, May 3, 2016 at 9:15 PM, Jan Viktorin wrote: > A bug has been detected by valgrind: > > ==14406== Invalid write of size 1 > ==14406==by 0x86ECC76: sprintf (in /usr/lib/libc-2.23.so) > ==14406==by 0x430B0A: commands_init (in > /home/jviki/Projects/dpdk/dpdk-soc/build/app/test) > ==1

[dpdk-dev] virtio still blindly take over virtio device managed by kernel

2016-05-04 Thread Vincent Li
Hi, I am running the dpdk git repo which already had commit ac5e1d838dc (virtio: skip error when probing kernel managed device), but in my test, it seems still taking control of the kernel managed virtio device and segmentation fault, here is the example: # ./tools/dpdk_nic_bind.py --status Netw

[dpdk-dev] [PATCH v2] examples: remove useless checking

2016-05-04 Thread Ferruh Yigit
On 5/3/2016 10:16 PM, Mauricio Vasquez B wrote: > The rte_eth_dev_count() function will never return a value greater > than RTE_MAX_ETHPORTS, so that checking is useless. > > Signed-off-by: Mauricio Vasquez B studenti.polito.it> > --- > v2: > Add missed case in examples/kni/main.c Acked-by: Fer

[dpdk-dev] [PATCH] virtio: split virtio rx/tx queue

2016-05-04 Thread Huawei Xie
Currently virtio RX/TX paths use common vq structure. The initial idea is to split virtio RX and TX queues completely as they have different memory requirement and we could arrange data friendly for optimization for different paths in future. With this patch, we keep a common vq structure, as we h

[dpdk-dev] [RFC PATCH 0/4]: Implement module information export

2016-05-04 Thread Neil Horman
On Wed, May 04, 2016 at 10:24:18AM +0200, David Marchand wrote: > On Tue, May 3, 2016 at 1:57 PM, Neil Horman wrote: > > On Tue, Apr 26, 2016 at 01:39:47PM -0400, Neil Horman wrote: > >> Hey- > >> So a few days ago we were reviewing Davids patch series to introduce > >> the > >> abiilty to

[dpdk-dev] [PATCH v3 3/4] bnx2x: Enhance stats get

2016-05-04 Thread Rasesh Mody
> From: Van Haaren, Harry [mailto:harry.van.haaren at intel.com] > Sent: Wednesday, April 06, 2016 7:33 AM > > > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Rasesh Mody > > Subject: [dpdk-dev] [PATCH v3 3/4] bnx2x: Enhance stats get > > Hi Rasesh, > > > + snprintf(xstats[num].name,