2015-04-30 13:34, Mcnamara, John:
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> > It produces this error:
> > ERROR: Unknown interpreted text role "numref".
> >
> > Do you think it's possible to implement a fallback in our conf.py in order
> > to ignore this new role if not s
Some great input Dave. We discussed a number of issues yesterday which, while
related, should probably be treated separately for clarity. For each of these,
I think we need to start with a clear problem statement and a concrete proposal
for change.
I've added some further comments on the specif
Otherwise cache_flushthresh can be bigger than n, and
a consumer can starve others by keeping every element
either in use or in the cache.
Signed-off-by: Zoltan Kiss
---
lib/librte_mempool/rte_mempool.c | 3 ++-
lib/librte_mempool/rte_mempool.h | 2 +-
2 files changed, 3 insertions(+), 2 deletio
Try --socket-mem or -m 2048 to limit the vhost switch's memory consumption,
note that vswitch requires several GB memory due to some issue in the example,
so try allocating more huges pages.
> -Original Message-
> From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Maciej Grochowski
Hello, I trying to create vm2vm benchmark on my ubuntu(14.04) based
platform.
I had compiled DPDK to run a vhost example app with followed flags
CONFIG_RTE_LIBRTE_VHOST=y
CONFIG_RTE_LIBRTE_VHOST_USER=y
CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
then I run vhost app based on documentation:
./build/app/vho
On Wed, May 13, 2015 at 02:40:48PM +0100, Bruce Richardson wrote:
> On Wed, May 13, 2015 at 03:33:27PM +0200, Thomas Monjalon wrote:
> > 2015-05-13 11:01, Bruce Richardson:
> > > On Tue, May 12, 2015 at 09:30:45PM +0200, Thomas Monjalon wrote:
> > >> 2015-05-12 19:04, Bruce Richardson:
> > >>> dri
Hello, I trying to create vm2vm benchmark on my ubuntu (14.04) based
platform.
I had compiled DPDK to run a vhost example app with followed flags
CONFIG_RTE_LIBRTE_VHOST=y
CONFIG_RTE_LIBRTE_VHOST_USER=y
CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
then I run vhost app based on documentation:
./build/app/vh
enable mirror functionality in i40e driver
.mirror_rule_set
.mirror_rule_reset
Signed-off-by: Jingjing Wu
---
lib/librte_pmd_i40e/i40e_ethdev.c | 334 ++
lib/librte_pmd_i40e/i40e_ethdev.h | 23 +++
2 files changed, 357 insertions(+)
diff --git a/lib/librte_p
This path renames the mirror type in rte_eth_mirror_conf and macros,
and reworks the mirror set in ixgbe dirvers by using new definition.
It also fixes some coding style.
Signed-off-by: Jingjing Wu
---
app/test-pmd/cmdline.c | 42 ++---
lib/librte_ether/rte_ethde
This patch renames rte_eth_vmdq_mirror_conf to rte_eth_mirror_conf
and move the maximum number check from ethdev level to driver
Signed-off-by: Jingjing Wu
---
app/test-pmd/cmdline.c | 18 +-
lib/librte_ether/rte_ethdev.c | 18 ++
lib/librte_eth
This patch set enables mirror functionality in i40e driver, and
redefines structure and macros used to configure mirror.
Jingjing Wu (3):
ethdev: rename rte_eth_vmdq_mirror_conf
ethdev: redefine the mirror type
i40e: enable mirror functionality in i40e driver
app/test-pmd/cmdline.c
enable mirror functionality in i40e driver
.mirror_rule_set
.mirror_rule_reset
Signed-off-by: Jingjing Wu
---
lib/librte_pmd_i40e/i40e_ethdev.c | 334 ++
lib/librte_pmd_i40e/i40e_ethdev.h | 23 +++
2 files changed, 357 insertions(+)
diff --git a/lib/librte_p
This path renames the mirror type in rte_eth_mirror_conf and macros,
and reworks the mirror set in ixgbe dirvers by using new definition.
It also fixes some coding style.
Signed-off-by: Jingjing Wu
---
app/test-pmd/cmdline.c | 42 ++---
lib/librte_ether/rte_ethde
This patch renames rte_eth_vmdq_mirror_conf to rte_eth_mirror_conf
and move the maximum number check from ethdev level to driver
Signed-off-by: Jingjing Wu
---
app/test-pmd/cmdline.c | 18 +-
lib/librte_ether/rte_ethdev.c | 18 ++
lib/librte_eth
This patch set enables mirror functionality in i40e driver, and
redefine structure and macros used to configure mirror.
Jingjing Wu (3):
ethdev: rename rte_eth_vmdq_mirror_conf
ethdev: redefine the mirror type
i40e: enable mirror functionality in i40e driver
app/test-pmd/cmdline.c
Add coding standards document to guides directory. This document
codifies the current DPDK C coding conventions, to make it easier for
contributors to see the format their code should be in.
Signed-off-by: Bruce Richardson
Signed-off-by: Siobhan Butler
---
doc/guides/coding_standards/index.rst
This patch adds a coding standards doc to DPDK, and is based off the original
version Siobhan posted earlier in the tools discussion. It's been cleaned up
a bit, and converted to the rst format to match the rest of the docs.
I've pulled in a lot of the feedback that people gave on the original ver
On 05/13/2015 04:04 PM, Wiles, Keith wrote:
>
>
> On 5/13/15, 8:56 AM, "Olivier MATZ" wrote:
>
>> Hi Keith,
>>
>> On 05/13/2015 03:17 PM, Wiles, Keith wrote:
>
> endif # ifeq ($(NO_AUTOLIBS),)
>
> -LDLIBS += $(CPU_LDLIBS)
> +LDLIBS += $(_LDLIBS-y) $(EXTRA_LDLIBS)
>
>>>
Hi Keith,
On 05/13/2015 03:17 PM, Wiles, Keith wrote:
>>>
>>>endif # ifeq ($(NO_AUTOLIBS),)
>>>
>>> -LDLIBS += $(CPU_LDLIBS)
>>> +LDLIBS += $(_LDLIBS-y) $(EXTRA_LDLIBS)
>>>
>>
>> As discussed in the previous mail, all things that are about
>> EXTRA_LDLIBS should be moved in the second patch. T
2015-05-13 14:08, John McNamara:
> Signed-off-by: John McNamara
Acked-by: Thomas Monjalon
Applied, thanks
2015-05-13 11:01, Bruce Richardson:
> On Tue, May 12, 2015 at 09:30:45PM +0200, Thomas Monjalon wrote:
>> 2015-05-12 19:04, Bruce Richardson:
>>> drivers/e1000/e1000/e1000_hw.h | 1026
>>
>> As explained in a previous comment,
>> http://dpdk.org/ml/archives/dev/2015-May/017
On 2015/5/13 9:18, Ravi Kerur wrote:
> If you can wait until Thursday I will probably send v3 patch which will
> have full memcmp support.
Ok, I'd like to test it:)
>
> In your program try with volatile pointer and see if it helps.
like "volatile uint8_t *src, *dst" ?
Hi Pawel,
On 05/13/2015 01:59 PM, Pawel Wodkowski wrote:
> This patchset adds the ability to process console input in the same thread
> as packet processing by using poll() function and fixes some minor issues.
>
> v2 changes:
> - add doxygen documentation for cmdline_poll()
> - map file issue
On 5/13/15, 9:28 AM, "Olivier MATZ" wrote:
>
>On 05/13/2015 04:04 PM, Wiles, Keith wrote:
>>
>>
>> On 5/13/15, 8:56 AM, "Olivier MATZ" wrote:
>>
>>> Hi Keith,
>>>
>>> On 05/13/2015 03:17 PM, Wiles, Keith wrote:
>>
>> endif # ifeq ($(NO_AUTOLIBS),)
>>
>> -LDLIBS += $(CPU_LDL
On Wed, May 13, 2015 at 03:33:27PM +0200, Thomas Monjalon wrote:
> 2015-05-13 11:01, Bruce Richardson:
> > On Tue, May 12, 2015 at 09:30:45PM +0200, Thomas Monjalon wrote:
> >> 2015-05-12 19:04, Bruce Richardson:
> >>> drivers/e1000/e1000/e1000_hw.h | 1026
> >>
> >> As exp
On 5/13/15, 9:28 AM, "Olivier MATZ" wrote:
>
>On 05/13/2015 04:04 PM, Wiles, Keith wrote:
>>
>>
>> On 5/13/15, 8:56 AM, "Olivier MATZ" wrote:
>>
>>> Hi Keith,
>>>
>>> On 05/13/2015 03:17 PM, Wiles, Keith wrote:
>>
>> endif # ifeq ($(NO_AUTOLIBS),)
>>
>> -LDLIBS += $(CPU_LDL
Signed-off-by: John McNamara
---
MAINTAINERS | 1 +
1 file changed, 1 insertion(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index f53b87e..0477e7d 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -35,6 +35,7 @@ M: maintainers at dpdk.org
Documentation (with overlaps)
-
M: Siobhan Butle
On 5/13/15, 8:56 AM, "Olivier MATZ" wrote:
>Hi Keith,
>
>On 05/13/2015 03:17 PM, Wiles, Keith wrote:
endif # ifeq ($(NO_AUTOLIBS),)
-LDLIBS += $(CPU_LDLIBS)
+LDLIBS += $(_LDLIBS-y) $(EXTRA_LDLIBS)
>>>
>>> As discussed in the previous mail, all things that are ab
This patch adds the ability to process console input in the same thread
as packet processing by using poll() function.
Signed-off-by: Pawel Wodkowski
---
doc/api/doxy-api.conf | 1 +
lib/librte_cmdline/cmdline.c | 35 ++
lib/librte_
When including only some of library headers some definitions
are missing and build fails.
Signed-off-by: Pawel Wodkowski
---
lib/librte_cmdline/cmdline.h | 3 +++
lib/librte_cmdline/cmdline_parse_ipaddr.h | 2 ++
lib/librte_cmdline/cmdline_rdline.h | 1 +
lib/librte_cmdline/cm
This patchset adds the ability to process console input in the same thread
as packet processing by using poll() function and fixes some minor issues.
v2 changes:
- add doxygen documentation for cmdline_poll()
- map file issue fixed
- use proper email address.
- add addtional missing include in
Hi Neil,
> -Original Message-
> From: Neil Horman [mailto:nhorman at tuxdriver.com]
> Sent: Tuesday, May 12, 2015 4:33 PM
> To: De Lara Guarch, Pablo
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v4 0/6] update jhash function
>
> On Tue, May 12, 2015 at 12:02:32PM +0100, Pablo de
On 5/13/15, 2:41 AM, "Olivier MATZ" wrote:
>Hi,
>
>On 05/12/2015 09:11 PM, Keith Wiles wrote:
>> Simplify the ifdefs in rte.app.mk to make the code more
>> readable and maintainable by moving LDLIBS variable to
>> use the same style as LDLIBS-y being used in the rest
>> of the code. The new int
On 05/13/2015 12:14 PM, Gonzalez Monroy, Sergio wrote:
> On 12/05/2015 15:48, Olivier MATZ wrote:
>> Hi Sergio,
>>
>> On 05/06/2015 06:10 PM, Gonzalez Monroy, Sergio wrote:
>>> Hi,
>>>
>>> I was wondering about the use case of rte_memzone_reserve_ APIs with
>>> len=0.
>>>
>>> From the docs (ht
On Wed, May 13, 2015 at 2:03 AM, Bruce Richardson <
bruce.richardson at intel.com> wrote:
> On Tue, May 12, 2015 at 06:16:20PM -0700, Ravi Kerur wrote:
> > On Mon, May 11, 2015 at 3:29 PM, Don Provan wrote:
> >
> > > I probably shouldn't stick my nose into this, but I can't help myself.
> > >
> >
On Wed, May 13, 2015 at 5:21 AM, Jay Rolette wrote:
> On Tue, May 12, 2015 at 8:16 PM, Ravi Kerur wrote:
>
>> On Mon, May 11, 2015 at 3:29 PM, Don Provan wrote:
>>
>> > I probably shouldn't stick my nose into this, but I can't help myself.
>> >
>> > An experienced programmer will tend to ignore
Hi Konstanin,
On Wed, May 13, 2015 at 3:12 AM, Ananyev, Konstantin <
konstantin.ananyev at intel.com> wrote:
> Hi Ravi,
>
> > -Original Message-
> > From: Ananyev, Konstantin
> > Sent: Wednesday, May 13, 2015 11:02 AM
> > To: Ananyev, Konstantin
> > Subject: FW: [dpdk-dev] [PATCH v2] Imp
On Wed, May 13, 2015 at 12:22 AM, Linhaifeng wrote:
>
>
> On 2015/5/13 9:18, Ravi Kerur wrote:
> > If you can wait until Thursday I will probably send v3 patch which will
> > have full memcmp support.
>
> Ok, I'd like to test it:)
>
> >
> > In your program try with volatile pointer and see if it
2015-04-29 19:11, Huawei Xie:
> update of used->idx and read of avail->flags could be reordered.
> memory fence should be used to ensure the order, otherwise guest could see a
> stale used->idx value after it toggles the interrupt suppression flag.
> After guest sets the interrupt suppression flag
> -Original Message-
> From: Wodkowski, PawelX
> Sent: Wednesday, May 13, 2015 1:00 PM
> To: dev at dpdk.org
> Cc: Dumitrescu, Cristian
> Subject: [PATCH v2 0/2] cmdline: add polling mode for command line
>
> This patchset adds the ability to process console input in the same thread
> as
Thanks for quick reply.
I have been using the v2.0.0 release branch, and switching to the master
eliminates the issue.
- Joongi
On Wed, May 13, 2015 at 6:14 PM Thomas Monjalon
wrote:
> Hi,
>
> 2015-05-13 08:47, Joongi Kim:
> > Hello,
> > I found that the following commit and post are conflictin
Signed-off-by: Keith Wiles
---
doc/build-sdk-quick.txt | 1 +
doc/guides/prog_guide/dev_kit_build_system.rst | 2 ++
doc/guides/prog_guide/dev_kit_root_make_help.rst | 2 +-
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/doc/build-sdk-quick.txt b/doc/buil
Simplify the ifdefs in rte.app.mk to make the code more
readable and maintainable by introducing a internal
_LDLIBS-y variable to build up the LDLIBS variable.
The new internal variable _LDLIBS-y should not be
used outside of the rte.app.mk file.
Signed-off-by: Keith Wiles
---
mk/rte.app.mk | 2
2015-05-13 09:57, Bruce Richardson:
> On Tue, May 12, 2015 at 10:02:20PM +0200, Thomas Monjalon wrote:
> > 2015-04-28 09:36, Stephen Hemminger:
> > > This set of patches starts out with fixing a regression where
> > > uio_pci_generic broke link state interrupt, then adds better
> > > management of
2015-04-30 17:27, Bruce Richardson:
> On Tue, Apr 28, 2015 at 09:36:38AM -0700, Stephen Hemminger wrote:
> > The introduction of uio_pci_generic broke interrupt handling with
> > igb_uio. The igb_uio device uses the kernel read/write method to
> > enable disable IRQ's; the uio_pci_generic has to us
Thanks to all who attended and contributed to yesterday's discussion. For the
benefit of those who couldn't attend, here's a brief summary of what was
covered. Please feel free to point out any errors or omissions.
Decision Making
- There was a discussion on whether we need a Technical Steering
On 12/05/2015 15:48, Olivier MATZ wrote:
> Hi Sergio,
>
> On 05/06/2015 06:10 PM, Gonzalez Monroy, Sergio wrote:
>> Hi,
>>
>> I was wondering about the use case of rte_memzone_reserve_ APIs with
>> len=0.
>>
>> From the docs (http://dpdk.org/doc/api/rte__memzone_8h.html):
>> len The s
Hi,
2015-05-13 08:47, Joongi Kim:
> Hello,
> I found that the following commit and post are conflicting with each other:
> 1)
> http://dpdk.org/browse/dpdk/commit/?id=23f91f32f2b119f1376488d87be2b80b078a945e
> 2) http://dpdk.org/ml/archives/dev/2015-April/016361.html
> Is there a consensus on how
On Wed, May 13, 2015 at 01:52:33PM +, De Lara Guarch, Pablo wrote:
> Hi Neil,
>
> > -Original Message-
> > From: Neil Horman [mailto:nhorman at tuxdriver.com]
> > Sent: Tuesday, May 12, 2015 4:33 PM
> > To: De Lara Guarch, Pablo
> > Cc: dev at dpdk.org
> > Subject: Re: [dpdk-dev] [PATC
Hi Ravi,
> -Original Message-
> From: Ananyev, Konstantin
> Sent: Wednesday, May 13, 2015 11:02 AM
> To: Ananyev, Konstantin
> Subject: FW: [dpdk-dev] [PATCH v2] Implement memcmp using AVX/SSE
> instructions.
>
>
>
> From: Ravi Kerur [mailto:rkerur at gmail.com]
> Sent: Monday, May 11,
On Tue, May 12, 2015 at 06:16:20PM -0700, Ravi Kerur wrote:
> On Mon, May 11, 2015 at 3:29 PM, Don Provan wrote:
>
> > I probably shouldn't stick my nose into this, but I can't help myself.
> >
> > An experienced programmer will tend to ignore the documentation for
> > a routine named "blahblah_m
On Tue, May 12, 2015 at 09:30:45PM +0200, Thomas Monjalon wrote:
> 2015-05-12 19:04, Bruce Richardson:
> > drivers/e1000/e1000/e1000_hw.h | 1026
>
> As explained in a previous comment,
> http://dpdk.org/ml/archives/dev/2015-May/017509.html
> I think this path would be bet
On Tue, May 12, 2015 at 10:02:20PM +0200, Thomas Monjalon wrote:
> 2015-04-28 09:36, Stephen Hemminger:
> > This set of patches starts out with fixing a regression where
> > uio_pci_generic broke link state interrupt, then adds better
> > management of PCI config space.
> >
> > Will leave up to do
Thanks for the notes Tim!
I had intended to participate, but didn't realise that there was a
conflict with an OPNFV call at the same time, and a calendaring snafu.
In the interests of having some more focussed discussion, I have some
questions on the notes to get beyond passive voice. I think it
Hi,
On 05/12/2015 09:11 PM, Keith Wiles wrote:
> Simplify the ifdefs in rte.app.mk to make the code more
> readable and maintainable by moving LDLIBS variable to
> use the same style as LDLIBS-y being used in the rest
> of the code. The new internal variable _LDLIBS should
> not be used outside of
Hi Paul,
> -Original Message-
> From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Paul Emmerich
> Sent: Tuesday, May 12, 2015 12:19 AM
> To: dev at dpdk.org
> Subject: Re: [dpdk-dev] TX performance regression caused by the mbuf cachline
> split
>
> Found a really simple solution t
Hello,
I found that the following commit and post are conflicting with each other:
1)
http://dpdk.org/browse/dpdk/commit/?id=23f91f32f2b119f1376488d87be2b80b078a945e
2) http://dpdk.org/ml/archives/dev/2015-April/016361.html
Is there a consensus on how verbose PMD init processes should be?
(i.e., Is
Due to the PATCH prefix is missed in the cover-letter, I will resend the patch
set. Please just ignore this one.
> -Original Message-
> From: Wu, Jingjing
> Sent: Wednesday, May 13, 2015 4:38 PM
> To: dev at dpdk.org
> Cc: Wu, Jingjing; Jiajia, SunX; Zhang, Helin; Liu, Jijiang
> Subject:
On Tue, May 12, 2015 at 8:16 PM, Ravi Kerur wrote:
> On Mon, May 11, 2015 at 3:29 PM, Don Provan wrote:
>
> > I probably shouldn't stick my nose into this, but I can't help myself.
> >
> > An experienced programmer will tend to ignore the documentation for
> > a routine named "blahblah_memcmp" a
59 matches
Mail list logo