Hello all,
Does the TSO offload option works for chained mbufs?
What i mean is, if i have a chain representing a big TCP buffer, and i only
set the first mbuf with
TSO flags and tso_segsz (mss) and L4 size, will that work ? (or only
applied on the first mbuf)
I think that ideally this should work
On 12/25/14 04:43, Ouyang, Changchun wrote:
> Hi,
> Sorry miss some comments, so continue my response below,
>
>> -Original Message-
>> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
>> Sent: Wednesday, December 24, 2014 6:40 PM
>> To: Ouyang, Changchun; dev at dpdk.org
>> Sub
On 12/25/14 04:43, Ouyang, Changchun wrote:
> Hi,
> Sorry miss some comments, so continue my response below,
>
>> -Original Message-
>> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
>> Sent: Wednesday, December 24, 2014 6:40 PM
>> To: Ouyang, Changchun; dev at dpdk.org
>> Sub
On 12/25/14 04:14, Ouyang, Changchun wrote:
> Hi,
>
>> -Original Message-
>> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
>> Sent: Wednesday, December 24, 2014 6:40 PM
>> To: Ouyang, Changchun; dev at dpdk.org
>> Subject: Re: [dpdk-dev] [PATCH v3 5/6] ixgbe: Config VF RSS
>>
Hi,
I can see that in the recent releases of DPDK the rte_mbuf structure has
undergone some changes.
Would like to know which field in the rte_mbuf data structure holds the
exact payload of the received packet in the modified structure.
Regards
Shankari
On 12/25/14 04:26, Ouyang, Changchun wrote:
> Hi,
>
>> -Original Message-
>> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
>> Sent: Wednesday, December 24, 2014 6:49 PM
>> To: Ouyang, Changchun;dev at dpdk.org
>> Subject: Re: [dpdk-dev] [PATCH v3 0/6] Enable VF RSS for Nianti
On Thu, Dec 25, 2014 at 10:33:17AM -0500, Ravi Kerur wrote:
> Move common functions in eal_memory.c to librte_eal/common
> directory.
> Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
> common functions.
> Fix checkpatch warnings and errors.
>
> Signed-off-by: Ravi Kerur
> ---
> li
On Thu, Dec 25, 2014 at 10:33:14AM -0500, Ravi Kerur wrote:
> Move common functions in eal.c to librte_eal/common directory.
> Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
> common functions.
> Makefile changes to reflect new file.
> Fix checkpatch warnings and errors.
>
> Signed-
On Thu, Dec 25, 2014 at 10:33:13AM -0500, Ravi Kerur wrote:
> eal_thread.c has minor difference between Linux and BSD, move
> into common directory.
> Use RTE_EXEC_ENV_BSDAPP to differentiate minor difference.
> Rename eal_thread.c to eal_common_thread.c
> Makefile changes to reflect file move and
On Thu, Dec 25, 2014 at 10:33:12AM -0500, Ravi Kerur wrote:
> eal_debug.c has no difference between Linux and BSD, move
> into common directory.
> Rename eal_debug.c to eal_common_debug.c
> Makefile changes to reflect file move and name change.
> Fix checkpatch warnings.
>
> Signed-off-by: Ravi Ke
On Thu, Dec 25, 2014 at 10:33:11AM -0500, Ravi Kerur wrote:
> rte_is_power_of_2 returns true for 0 and 0 is not power_of_2. Fix
> by checking for n.
>
> Signed-off-by: Ravi Kerur
> ---
> lib/librte_eal/common/include/rte_common.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff
On Thu, Dec 25, 2014 at 10:11:51AM +0100, sothy shan wrote:
> On Wed, Dec 24, 2014 at 4:04 PM, Neil Horman wrote:
>
> > On Wed, Dec 24, 2014 at 02:26:21PM +0100, sothy shan wrote:
> > > Hello!
> > >
> > > I am playing with DPDK 1.7.1 in Fedora.
> > >
> > > When I do like this:
> > >
> > > export
Thanks Neil for reviews. Inline
On Thu, Dec 25, 2014 at 9:30 AM, Neil Horman wrote:
> On Thu, Dec 25, 2014 at 10:33:12AM -0500, Ravi Kerur wrote:
> > eal_debug.c has no difference between Linux and BSD, move
> > into common directory.
> > Rename eal_debug.c to eal_common_debug.c
> > Makefile ch
Inline
On Thu, Dec 25, 2014 at 9:46 AM, Neil Horman wrote:
> On Thu, Dec 25, 2014 at 10:33:17AM -0500, Ravi Kerur wrote:
> > Move common functions in eal_memory.c to librte_eal/common
> > directory.
> > Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
> > common functions.
> > Fix
Inline
On Thu, Dec 25, 2014 at 9:44 AM, Neil Horman wrote:
> On Thu, Dec 25, 2014 at 10:33:14AM -0500, Ravi Kerur wrote:
> > Move common functions in eal.c to librte_eal/common directory.
> > Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
> > common functions.
> > Makefile change
Struct rte_ethertype_filter is removed.
Following APIs are removed:
- rte_eth_dev_add_ethertype_filter
- rte_eth_dev_remove_ethertype_filter
- rte_eth_dev_get_ethertype_filter
Signed-off-by: Jingjing Wu
---
lib/librte_ether/rte_ethdev.c | 57
lib/librte_ether/r
Following commands of ethertype filter are removed:
- add_ethertype_filter (port_id) ethertype (eth_value)
- remove_ethertype_filter (port_id) index (idx)
- get_ethertype_filter (port_id) index (idx)
New command is added for ethertype filter by using filter_ctrl API and new
ethertype filter s
This patch removes old functions which deal with ethertype filters in ixgbe
driver.
It also defines eth_igb_filter_ctrl which is binding to filter_ctrl API,
and ethertype filter can be dealt with through this new entrance.
Signed-off-by: Jingjing Wu
---
lib/librte_pmd_e1000/e1000_ethdev.h | 1
This patch removes old functions which deal with ethertype filter in ixgbe
driver.
It also defines ixgbe_dev_filter_ctrl which is binding to filter_ctrl API,
and ethertype filter can be dealt with through this new entrance.
Signed-off-by: Jingjing Wu
---
lib/librte_pmd_ixgbe/ixgbe_ethdev.c | 35
The patch set uses new filter_ctrl API to replace old ethertype filter APIs.
It uses new functions and structure to replace old ones in igb/ixgbe driver,
new commands to replace old ones in testpmd, and removes the old APIs.
Jingjing Wu (4):
ixgbe: new functions replaces old ones for ethertype
Inline
On Thu, Dec 25, 2014 at 9:41 AM, Neil Horman wrote:
> On Thu, Dec 25, 2014 at 10:33:13AM -0500, Ravi Kerur wrote:
> > eal_thread.c has minor difference between Linux and BSD, move
> > into common directory.
> > Use RTE_EXEC_ENV_BSDAPP to differentiate minor difference.
> > Rename eal_thr
Sure, will post it separately.
Thanks.
On Thu, Dec 25, 2014 at 9:21 AM, Neil Horman wrote:
> On Thu, Dec 25, 2014 at 10:33:11AM -0500, Ravi Kerur wrote:
> > rte_is_power_of_2 returns true for 0 and 0 is not power_of_2. Fix
> > by checking for n.
> >
> > Signed-off-by: Ravi Kerur
> > ---
> > l
Move common functions in eal_memory.c to librte_eal/common
directory.
Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
common functions.
Fix checkpatch warnings and errors.
Signed-off-by: Ravi Kerur
---
lib/librte_eal/bsdapp/eal/eal_memory.c| 36 ++
lib/l
Move common functions in eal_timer.c to librte_eal/common
directory.
Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
common functions.
Makefile changes to reflect new file.
Fix checkpatch warnings and errors.
Signed-off-by: Ravi Kerur
---
lib/librte_eal/bsdapp/eal/Makefile |
Move common functions in eal_lcore.c to librte_eal/common
directory.
Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
common functions.
Makefile changes to reflect new file.
Fix checkpatch warnings and errors.
Signed-off-by: Ravi Kerur
---
lib/librte_eal/bsdapp/eal/Makefile |
Move common functions in eal.c to librte_eal/common directory.
Use RTE_EXEC_ENV_BSDAPP to differentiate minor differences in
common functions.
Makefile changes to reflect new file.
Fix checkpatch warnings and errors.
Signed-off-by: Ravi Kerur
---
lib/librte_eal/bsdapp/eal/Makefile| 1 +
li
eal_thread.c has minor difference between Linux and BSD, move
into common directory.
Use RTE_EXEC_ENV_BSDAPP to differentiate minor difference.
Rename eal_thread.c to eal_common_thread.c
Makefile changes to reflect file move and name change.
Fix checkpatch warnings.
Signed-off-by: Ravi Kerur
---
eal_debug.c has no difference between Linux and BSD, move
into common directory.
Rename eal_debug.c to eal_common_debug.c
Makefile changes to reflect file move and name change.
Fix checkpatch warnings.
Signed-off-by: Ravi Kerur
---
lib/librte_eal/bsdapp/eal/Makefile | 2 +-
lib/librte_ea
rte_is_power_of_2 returns true for 0 and 0 is not power_of_2. Fix
by checking for n.
Signed-off-by: Ravi Kerur
---
lib/librte_eal/common/include/rte_common.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/librte_eal/common/include/rte_common.h
b/lib/librte_eal/common/in
Common functions in linuxapp and bsdapp are moved into
librte_eal/common directory.
New files added follow _common_ naming conventions.
Tested against ubuntu and FreeBSD.
*** BLURB HERE ***
Ravi Kerur (7):
Fix rte_is_power_of_2
Move EAL common functions
Move EAL common functions
Move EAL
Fix checkpatch warnings and errors in lib/librte_mempool. checkpatch
is run as follows
scripts/checkpatch.pl --no-tree --file
Following warning is treated as false-positive
1. WARNING: quoted string split across lines
Signed-off-by: Ravi Kerur
---
lib/librte_mempool/rte_dom0_mempool.c | 41 +
Fix checkpatch warnings and errors in lib/librte_acl. checkpatch
is run as follows
scripts/checkpatch.pl --no-tree --file
Following warnings are treated as false-positive
1. WARNING: quoted string split across lines
2. WARNING: do not add new typedefs
3. WARNING: __aligned(size) is preferred ov
checkpatch script is run against files in librte_acl and
librte_mempool files. No functionality change.
Changes are tested in Ubuntu and FreeBSD.
Ravi Kerur (2):
Fix checkpatch errors in librte_acl
Fix checkpatch errors in librte_mempool
lib/librte_acl/acl_bld.c | 192 +
On Wed, Dec 24, 2014 at 4:04 PM, Neil Horman wrote:
> On Wed, Dec 24, 2014 at 02:26:21PM +0100, sothy shan wrote:
> > Hello!
> >
> > I am playing with DPDK 1.7.1 in Fedora.
> >
> > When I do like this:
> >
> > export RTE_SDK=$(pwd)export RTE_TARGET="x86_64-ivshmem-linuxapp-gcc"
> > make install T
On 12/25/2014 11:39 AM, Wu, Jingjing wrote:
> Hi, Michael
>
> It's a long discuss in community.
>
> Due to in the development in i40e driver, we defined a new common API used
> for kinds of filters. In R1.8, because of time limit and compatibility, we
> just used the new API for i40e driver. Whil
Hi, Michael
It's a long discuss in community.
Due to in the development in i40e driver, we defined a new common API used for
kinds of filters. In R1.8, because of time limit and compatibility, we just
used the new API for i40e driver. While other driver still use old ones.
We have planned to in
Hi Jingjing,
Would you mind to tell me why need new APIs? Any functional or
performance increase?
Better to state in commit log.
You know it should be careful to change APIs, especially for user
interface.
Thanks,
Michael
On 12/25/2014 11:14 AM, Jingjing Wu wrote:
> The patch set uses new filte
Hi,
Sorry miss some comments, so continue my response below,
> -Original Message-
> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
> Sent: Wednesday, December 24, 2014 6:40 PM
> To: Ouyang, Changchun; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v3 5/6] ixgbe: Config VF RS
Hi,
> -Original Message-
> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
> Sent: Wednesday, December 24, 2014 6:49 PM
> To: Ouyang, Changchun; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v3 0/6] Enable VF RSS for Niantic
>
>
> On 12/24/14 07:22, Ouyang Changchun wrote:
Hi,
> -Original Message-
> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
> Sent: Wednesday, December 24, 2014 6:40 PM
> To: Ouyang, Changchun; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v3 5/6] ixgbe: Config VF RSS
>
>
> On 12/24/14 07:23, Ouyang Changchun wrote:
> >
Hi,
> -Original Message-
> From: Vlad Zolotarov [mailto:vladz at cloudius-systems.com]
> Sent: Wednesday, December 24, 2014 5:59 PM
> To: Ouyang, Changchun; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v3 0/6] Enable VF RSS for Niantic
>
>
> On 12/24/14 07:22, Ouyang Changchun wrote:
Hi Neil
> -Original Message-
> From: Neil Horman [mailto:nhorman at tuxdriver.com]
> Sent: Wednesday, December 24, 2014 10:55 PM
> To: Zhang, Helin
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH] i40e: workaround for XL710 performance
>
> On Wed, Dec 24, 2014 at 03:14:08PM +0800,
Hi,
> EAL: Searching for IVSHMEM devices...
> EAL: No IVSHMEM configuration found!
ivshmem is used with QEMU virtual machine.
see http://dpdk.org/doc/guides/prog_guide/ivshmem_lib.html
Try RTE_TARGET="x86_64-native-linuxapp-gcc".
2014-12-24 22:26 GMT+09:00 sothy shan :
> Hello!
>
> I am playin
43 matches
Mail list logo