Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes [v2]

2023-05-29 Thread Daniel Fuchs
On Fri, 26 May 2023 16:54:42 GMT, Roger Riggs wrote: >> Decouple the jdk.internal.util OperatingSystem and Version classes to >> simplify class loading and avoid an indirect cyclic initialization. >> >> Move the method to get the current OS version from OperatingSystem to the >> Version class

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes [v2]

2023-05-26 Thread Roger Riggs
> Decouple the jdk.internal.util OperatingSystem and Version classes to > simplify class loading and avoid an indirect cyclic initialization. > > Move the method to get the current OS version from OperatingSystem to the > Version class and its initialization. > Revert to using String.toUpperCase

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Daniel Fuchs
On Fri, 26 May 2023 16:16:58 GMT, Mandy Chung wrote: > Alternatively, move `Version` record as a nested class in `OperatingSystem`. That would work WRT naming, but I thought the point was to not have to load OperatingSystem in order to load Version? Unless loading a static inner class doesn't f

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Roger Riggs
On Fri, 26 May 2023 14:57:21 GMT, Roger Riggs wrote: > Decouple the jdk.internal.util OperatingSystem and Version classes to > simplify class loading and avoid an indirect cyclic initialization. > > Move the method to get the current OS version from OperatingSystem to the > Version class and i

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Mandy Chung
On Fri, 26 May 2023 14:57:21 GMT, Roger Riggs wrote: > Decouple the jdk.internal.util OperatingSystem and Version classes to > simplify class loading and avoid an indirect cyclic initialization. > > Move the method to get the current OS version from OperatingSystem to the > Version class and i

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Mandy Chung
On Fri, 26 May 2023 15:32:20 GMT, Roger Riggs wrote: > Should we take this opportunity to rename `jdk.internal.util.Version` into > something like `OsVersion` to make it more clear what its `current()` method > actually returns? Alternatively, move `Version` record as a nested class in `Operat

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Mandy Chung
On Fri, 26 May 2023 14:57:21 GMT, Roger Riggs wrote: > Decouple the jdk.internal.util OperatingSystem and Version classes to > simplify class loading and avoid an indirect cyclic initialization. > > Move the method to get the current OS version from OperatingSystem to the > Version class and i

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Daniel Fuchs
On Fri, 26 May 2023 14:57:21 GMT, Roger Riggs wrote: > Decouple the jdk.internal.util OperatingSystem and Version classes to > simplify class loading and avoid an indirect cyclic initialization. > > Move the method to get the current OS version from OperatingSystem to the > Version class and i

Re: RFR: 8308960: Decouple internal Version and OperatingSystem classes

2023-05-26 Thread Roger Riggs
On Fri, 26 May 2023 15:21:42 GMT, Daniel Fuchs wrote: > Should we take this opportunity to rename `jdk.internal.util.Version` into > something like `OsVersion` to make it more clear what its `current()` method > actually returns? ok, it will give a bit more flavor; there are already multiple v