Re: RFR: 8336043: Add quality of implementation discussion to Object.{equals, toString, hashCode} [v4]

2024-07-30 Thread Joe Darcy
> First pass at adding some quality of implementation discussions around the > overridable methods of Object. Joe Darcy has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull

Re: RFR: 8322256: Define and document GZIPInputStream concatenated stream semantics [v8]

2024-07-30 Thread Archie Cobbs
On Sat, 27 Jul 2024 15:00:51 GMT, Archie Cobbs wrote: >> `GZIPInputStream` supports reading data from multiple concatenated GZIP data >> streams since [JDK-4691425](https://bugs.openjdk.org/browse/JDK-4691425). In >> order to do this, after a GZIP trailer frame is read, it attempts to read a >

Re: RFR: 8322256: Define and document GZIPInputStream concatenated stream semantics [v8]

2024-07-30 Thread Archie Cobbs
On Tue, 30 Jul 2024 17:35:33 GMT, Lance Andersen wrote: > Based on the above, I am reluctant to change the current behavior given it > appears to have been modeled after gzip/gunzip as well as WinZip. That's a reasonable conclusion... and I have no problem with preserving the existing behavior

Integrated: 8337219: AccessFlags factories do not require necessary arguments

2024-07-30 Thread Chen Liang
On Thu, 25 Jul 2024 23:11:15 GMT, Chen Liang wrote: > Removes 6 `AccessFlags` factories that do not take class-file versions as its > arguments. > > `AccessFlags` is a wrapper around a bit mask to support modifier streaming in > ClassFile API. It additionally supports advanced validation based

Integrated: 8336032: Enforce immutability of Lists used by ClassFile API

2024-07-30 Thread Chen Liang
On Mon, 29 Jul 2024 19:36:31 GMT, Chen Liang wrote: > In #20241, it's noted that `ClassFile.verify` can return a mix-and-match of > mutable and immutable lists. > > Though the mutability of the list returned by `verify` has no particular > importance, as the mutable list is constructed on ever

Re: RFR: 8322256: Define and document GZIPInputStream concatenated stream semantics [v8]

2024-07-30 Thread Lance Andersen
On Sat, 27 Jul 2024 15:00:51 GMT, Archie Cobbs wrote: >> `GZIPInputStream` supports reading data from multiple concatenated GZIP data >> streams since [JDK-4691425](https://bugs.openjdk.org/browse/JDK-4691425). In >> order to do this, after a GZIP trailer frame is read, it attempts to read a >

Re: Stream Gatherers (JEP 473) feedback

2024-07-30 Thread Anthony Vanelverdinghe
July 29, 2024 at 8:08 PM, "Viktor Klang" wrote: > > Hi Anthony, Hi Viktor > Thank you for your patience, and for providing feedback, it is always much > appreciated. > > >When writing factory methods for Gatherers, there's sometimes a > degenerate case that requires returning a no-op Gatherer

Integrated: 8336315: tools/jpackage/windows/WinChildProcessTest.java Failed: Check is calculator process is alive

2024-07-30 Thread Vanitha B P
On Wed, 24 Jul 2024 12:20:05 GMT, Vanitha B P wrote: > tools/jpackage/windows/WinChildProcessTest.java was failing intermittently, > fixed the issue and changes are tested. This pull request has now been integrated. Changeset: 2c9fd901 Author:Vanitha B P Committer: Alexey Semenyuk URL:

Re: RFR: 8336462: ConcurrentSkipListSet Javadoc incorrectly warns about size method complexity

2024-07-30 Thread Doug Lea
On Tue, 30 Jul 2024 09:24:12 GMT, Viktor Klang wrote: > Removes some of the old wording around the algorithmic complexity of > ConcurrentSkipListSet::size() while still retaining the warning around the > accuracy of the returned result. Yes, thanks for fixing wording that should have been upda

Re: RFR: 8336462: ConcurrentSkipListSet Javadoc incorrectly warns about size method complexity

2024-07-30 Thread Viktor Klang
On Tue, 30 Jul 2024 09:24:12 GMT, Viktor Klang wrote: > Removes some of the old wording around the algorithmic complexity of > ConcurrentSkipListSet::size() while still retaining the warning around the > accuracy of the returned result. @DougLea Please let me know what you think about this cha

RFR: 8336462: ConcurrentSkipListSet Javadoc incorrectly warns about size method complexity

2024-07-30 Thread Viktor Klang
Removes some of the old wording around the algorithmic complexity of ConcurrentSkipListSet::size() while still retaining the warning around the accuracy of the returned result. - Commit messages: - Improving the JavaDoc of ConcurrentSkipListSet::size() to reflect current reality

Re: RFR: 8337219: AccessFlags factories do not require necessary arguments [v2]

2024-07-30 Thread Adam Sotona
On Mon, 29 Jul 2024 23:30:48 GMT, Chen Liang wrote: >> Removes 6 `AccessFlags` factories that do not take class-file versions as >> its arguments. >> >> `AccessFlags` is a wrapper around a bit mask to support modifier streaming >> in ClassFile API. It additionally supports advanced validation

Re: RFR: 8336032: Enforce immutability of Lists used by ClassFile API

2024-07-30 Thread Adam Sotona
On Mon, 29 Jul 2024 19:36:31 GMT, Chen Liang wrote: > In #20241, it's noted that `ClassFile.verify` can return a mix-and-match of > mutable and immutable lists. > > Though the mutability of the list returned by `verify` has no particular > importance, as the mutable list is constructed on ever

Re: RFR: 8322420: [Linux] cgroup v2: Limits in parent nested control groups are not detected [v15]

2024-07-30 Thread Jan Kratochvil
On Mon, 29 Jul 2024 05:03:22 GMT, Jan Kratochvil wrote: >> src/hotspot/os/linux/cgroupUtil_linux.cpp line 64: >> >>> 62: return cpu->adjust_controller(cpu_total); >>> 63: } >>> 64: return cpu; >> >> I guess an alternative - and maybe more readable solution - would be to >> inline `cpu

Re: RFR: 8322420: [Linux] cgroup v2: Limits in parent nested control groups are not detected [v19]

2024-07-30 Thread Jan Kratochvil
> The testcase requires root permissions. > > Fix by Severin Gehwolf. > Testcase by Jan Kratochvil. Jan Kratochvil has updated the pull request incrementally with two additional commits since the last revision: - Inline adjust_controller() twice - Revert "Unify 4 copies of adjust_controller(