Re: RFR: 8261242: [Linux] OSContainer::is_containerized() returns true when run outside a container [v8]

2024-06-29 Thread Ioi Lam
On Fri, 28 Jun 2024 15:41:48 GMT, Severin Gehwolf wrote: >> Please review this enhancement to the container detection code which allows >> it to figure out whether the JVM is actually running inside a container >> (`podman`, `docker`, `crio`), or with some other means that enforces >> memory/c

Re: RFR: 8335366: Improve String.format performance with fastpath [v7]

2024-06-29 Thread Shaojin Wen
> We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter capabilities. The performance is > good enough that it is

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalFileAttributes [v5]

2024-06-29 Thread Jaikiran Pai
On Sat, 29 Jun 2024 18:24:46 GMT, Eirik Bjørsnøs wrote: >> Please consider this PR which suggests we rename `ZipEntry.extraAttributes` >> to `ZipEntry.externalFileAttributes`. >> >> This field was introduced in >> [JDK-8218021](https://bugs.openjdk.org/browse/JDK-8218021), originally under >>

Re: RFR: 8335366: Improve String.format performance with fastpath [v6]

2024-06-29 Thread Shaojin Wen
> We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter capabilities. The performance is > good enough that it is

Re: RFR: 8335366: Improve String.format performance with fastpath [v5]

2024-06-29 Thread Shaojin Wen
On Sat, 29 Jun 2024 19:05:18 GMT, David Schlosnagle wrote: >> Shaojin Wen has updated the pull request incrementally with one additional >> commit since the last revision: >> >> private method & field > > src/java.base/share/classes/java/lang/StringFormat.java line 48: > >> 46: static St

Re: RFR: 8335366: Improve String.format performance with fastpath [v5]

2024-06-29 Thread David Schlosnagle
On Sat, 29 Jun 2024 18:59:33 GMT, Shaojin Wen wrote: >> We need a String format solution with good performance. String Template was >> once expected, but it has been removed. j.u.Formatter is powerful, but its >> performance is not good enough. >> >> This PR implements a subset of j.u.Formatte

Re: RFR: 8335366: Improve String.format performance with fastpath [v5]

2024-06-29 Thread Shaojin Wen
> We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter capabilities. The performance is > good enough that it is

Re: RFR: 8335366: Improve String.format performance with fastpath [v4]

2024-06-29 Thread Shaojin Wen
On Sat, 29 Jun 2024 17:41:47 GMT, David Schlosnagle wrote: >> src/java.base/share/classes/java/lang/StringFormat.java line 82: >> >>> 80: conv = format.charAt(off + 2); >>> 81: } >>> 82: } >> >> is it worth handling `width > 9`? >> >> Suggestion: >> >>

Re: RFR: 8335366: Improve String.format performance with fastpath [v4]

2024-06-29 Thread Shaojin Wen
> We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter capabilities. The performance is > good enough that it is

Re: RFR: 8334755: Asymptotically faster implementation of square root algorithm [v19]

2024-06-29 Thread fabioromano1
> I have implemented the Zimmermann's square root algorithm, available in works > [here](https://inria.hal.science/inria-00072854/en/) and > [here](https://www.researchgate.net/publication/220532560_A_proof_of_GMP_square_root). > > The algorithm is proved to be asymptotically faster than the New

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalFileAttributes [v4]

2024-06-29 Thread Eirik Bjørsnøs
On Thu, 9 May 2024 12:00:13 GMT, Jaikiran Pai wrote: > Hello Eirik, it will be better to merge with the latest master branch and run > the tier tests before integrating. Life happened, but I have now merged with the latest master and GHA runs green. Did you want to run additional testing befor

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalFileAttributes [v4]

2024-06-29 Thread Eirik Bjørsnøs
On Sun, 12 May 2024 14:37:23 GMT, Chen Liang wrote: > I believe this field only captures the 2 bytes at higher indices of External > File Attribute; it's not the complete 4-byte external file attributes and > this value is not captured unless "Version made by" field's larger index byte > (byte

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalFileAttributes [v5]

2024-06-29 Thread Eirik Bjørsnøs
> Please consider this PR which suggests we rename `ZipEntry.extraAttributes` > to `ZipEntry.externalFileAttributes`. > > This field was introduced in > [JDK-8218021](https://bugs.openjdk.org/browse/JDK-8218021), originally under > the name `ZipEntry.posixPerms`. > [JDK-8250968](https://bugs.o

Re: RFR: 8335366: Improve String.format performance with fastpath [v3]

2024-06-29 Thread David Schlosnagle
On Sat, 29 Jun 2024 16:16:51 GMT, David Schlosnagle wrote: >> Shaojin Wen has updated the pull request incrementally with one additional >> commit since the last revision: >> >> rename `digit` to `width` > > src/java.base/share/classes/java/lang/StringFormat.java line 82: > >> 80:

Re: RFR: 8335366: Improve String.format performance with fastpath [v3]

2024-06-29 Thread Shaojin Wen
> We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter capabilities. The performance is > good enough that it is

Re: RFR: 8335366: Improve String.format performance with fastpath [v2]

2024-06-29 Thread Shaojin Wen
On Sat, 29 Jun 2024 16:17:32 GMT, David Schlosnagle wrote: >> Shaojin Wen has updated the pull request incrementally with four additional >> commits since the last revision: >> >> - Update src/java.base/share/classes/java/lang/StringFormat.java >> >>Co-authored-by: David Schlosnagle >

Re: RFR: 8335366: Improve String.format performance with fastpath [v2]

2024-06-29 Thread Shaojin Wen
> We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter capabilities. The performance is > good enough that it is

Re: RFR: 8335366: Improve String.format performance with fastpath

2024-06-29 Thread David Schlosnagle
On Sat, 29 Jun 2024 11:53:31 GMT, Shaojin Wen wrote: > We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter cap

Re: RFR: 8335366: Improve String.format performance with fastpath

2024-06-29 Thread Glavo
On Sat, 29 Jun 2024 11:53:31 GMT, Shaojin Wen wrote: > We need a String format solution with good performance. String Template was > once expected, but it has been removed. j.u.Formatter is powerful, but its > performance is not good enough. > > This PR implements a subset of j.u.Formatter cap

RFR: 8335366: Improve String.format performance with fastpath

2024-06-29 Thread Shaojin Wen
We need a String format solution with good performance. String Template was once expected, but it has been removed. j.u.Formatter is powerful, but its performance is not good enough. This PR implements a subset of j.u.Formatter capabilities. The performance is good enough that it is a fastpath

Re: RFR: 8335252: Reduce size of j.u.Formatter.Conversion#isValid [v4]

2024-06-29 Thread Claes Redestad
On Fri, 28 Jun 2024 12:46:49 GMT, Shaojin Wen wrote: >> Currently, the java.util.Formatter$Conversion::isValid method is implemented >> based on switch, which cannot be inlined because codeSize > 325. This >> problem can be avoided by implementing it with ImmutableBitSetPredicate. >> >> use `-