On Fri, 17 Nov 2023 21:51:06 GMT, Brian Burkhalter wrote:
> The method `windowsDriveRelative` of the test `java/io/File/GetAbsolutePath`
> was incorrectly translated from its previous version to the current JUnit 5
> version.
The test fix looks okay but the title on the issue is confusing, it
Hi Rob,
Delegating caller sensitive methods can be tricky.
Besides the obvious solutions with StackWalker and/or Lookup objects I've
sometimes used an abstract class that must be extended by users of my library.
This may be more trouble in your case than the other solutions though.
In your situa
On Wed, 15 Nov 2023 22:28:19 GMT, Stuart Marks wrote:
>> Classes in the `java.lang.ref` package would benefit from an update to bring
>> the spec in line with how the VM already behaves. The changes would focus on
>> _happens-before_ edges at some key points during reference processing.
>>
>>
On Wed, 15 Nov 2023 23:17:29 GMT, Brent Christian wrote:
>> src/java.base/share/classes/java/lang/ref/Reference.java line 393:
>>
>>> 391: * Clears this reference object. Invoking this method does not
>>> enqueue this
>>> 392: * object, and the garbage collector will no longer enqueue
On Mon, 13 Nov 2023 22:31:16 GMT, Brent Christian wrote:
> Classes in the `java.lang.ref` package would benefit from an update to bring
> the spec in line with how the VM already behaves. The changes would focus on
> _happens-before_ edges at some key points during reference processing.
>
> A
On Wed, 8 Nov 2023 17:29:28 GMT, Joe Darcy wrote:
> Add discussion of some of the common pitfalls related to decimal <-> binary
> conversion.
This pull request has now been integrated.
Changeset: 8ff7d6ea
Author:Joe Darcy
URL:
https://git.openjdk.org/jdk/commit/8ff7d6ea0a9615fa4c52
> Add discussion of some of the common pitfalls related to decimal <-> binary
> conversion.
Joe Darcy has updated the pull request incrementally with one additional commit
since the last revision:
Fix link.
-
Changes:
- all: https://git.openjdk.org/jdk/pull/16566/files
- new
> The goal is to develop faster sort routines for x86_64 CPUs by taking
> advantage of AVX2 instructions. This enhancement provides an order of
> magnitude speedup for Arrays.sort() using int, long, float and double arrays.
>
> For serial sort on random data, this PR shows upto ~7.5x improvement
> Add discussion of some of the common pitfalls related to decimal <-> binary
> conversion.
Joe Darcy has updated the pull request incrementally with one additional commit
since the last revision:
Minor tweaks.
-
Changes:
- all: https://git.openjdk.org/jdk/pull/16566/files
-
On Wed, 8 Nov 2023 18:41:53 GMT, Eirik Bjorsnos wrote:
>> Joe Darcy has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Small clean ups.
>
> src/java.base/share/classes/java/lang/Double.java line 209:
>
>> 207: * decimal conversion. While
> Add discussion of some of the common pitfalls related to decimal <-> binary
> conversion.
Joe Darcy has updated the pull request incrementally with one additional commit
since the last revision:
Small clean ups.
-
Changes:
- all: https://git.openjdk.org/jdk/pull/16566/files
> Add discussion of some of the common pitfalls related to decimal <-> binary
> conversion.
Joe Darcy has updated the pull request incrementally with one additional commit
since the last revision:
Minor rewordings.
-
Changes:
- all: https://git.openjdk.org/jdk/pull/16566/files
> Add discussion of some of the common pitfalls related to decimal <-> binary
> conversion.
Joe Darcy has updated the pull request with a new target base due to a merge or
a rebase. The incremental webrev excludes the unrelated changes brought in by
the merge/rebase. The pull request contains e
On Fri, 17 Nov 2023 22:58:00 GMT, Naoto Sato wrote:
>> src/java.base/share/classes/java/util/Formatter.java line 4507:
>>
>>> 4505: || t instanceof LocalDateTime
>>> 4506: || t instanceof LocalDate) {
>>> 4507: yearF
> This is the proposed patch for Primitive types in patterns, instanceof, and
> switch (Preview).
>
> Draft spec here: https://cr.openjdk.org/~abimpoudis/instanceof/latest/
Aggelos Biboudis has updated the pull request with a new target base due to a
merge or a rebase. The pull request now cont
On Fri, 17 Nov 2023 21:09:13 GMT, Vladimir Yaroslavskiy
wrote:
>> Comparision of Stock JDK ( with AVX512sort) vs. Radix sort for All
>> (https://github.com/iaroslavski/sorting/blob/master/radixsort/DualPivotQuicksort_RadixForAll.java)
>> > xmlns:o="urn:schemas-microsoft-com:office:office"
>> xm
On Fri, 17 Nov 2023 22:16:36 GMT, Roger Riggs wrote:
>> Shaojin Wen has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> fix format 'ja-JP-u-ca-japanese' ChronoLocalDate
>
> src/java.base/share/classes/java/util/Formatter.java line 4507:
>
>
> Please review this PR and [CSR](https://bugs.openjdk.org/browse/JDK-8319982)
> which overrides and provides an implementation of `toString()` in
> _java.util.zip.ZipFile_ (and by extension, _java.util.jar.JarFile_).
>
> This change is primarily to provide a more informative String representati
On Thu, 16 Nov 2023 11:22:36 GMT, Pavel Rappo wrote:
>> @justin-curtis-lu, for inspiration and consistency, you might want to have a
>> look at this implementation:
>> https://github.com/openjdk/jdk/blob/1d9688667e667dc710d64e52f1e918e047beaca3/src/java.base/share/classes/java/util/concurrent/C
On Fri, 10 Nov 2023 03:31:26 GMT, Shaojin Wen wrote:
>> j.u.Formatter now prints "%tF" (iso standard date) and the result is
>> incorrect when processing year < 0 or year >
>
> Shaojin Wen has updated the pull request incrementally with one additional
> commit since the last revision:
>
>
On Fri, 17 Nov 2023 21:51:06 GMT, Brian Burkhalter wrote:
> The method `windowsDriveRelative` of the test `java/io/File/GetAbsolutePath`
> was incorrectly translated from its previous version to the current JUnit 5
> version.
@MBaesken I would appreciate it if you would try out this proposed c
The method `windowsDriveRelative` of the test `java/io/File/GetAbsolutePath`
was incorrectly translated from its previous version to the current JUnit 5
version.
-
Commit messages:
- 8320348: java.io.File.getAbsolutePath fails if working directory is not on
drive C
Changes: https
On Fri, 10 Nov 2023 03:31:26 GMT, Shaojin Wen wrote:
>> j.u.Formatter now prints "%tF" (iso standard date) and the result is
>> incorrect when processing year < 0 or year >
>
> Shaojin Wen has updated the pull request incrementally with one additional
> commit since the last revision:
>
>
On Thu, 16 Nov 2023 22:08:41 GMT, Srinivas Vamsi Parasa
wrote:
>> Laurent Bourgès has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> add @SuppressWarnings (serial)
>
> Comparision of Stock JDK ( with AVX512sort) vs. Radix sort for All
> (
Implement the built-in Catalog.
-
Commit messages:
- fix whitespace error
- 8306055: Add a built-in Catalog to JDK XML module
Changes: https://git.openjdk.org/jdk/pull/16719/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=16719&range=00
Issue: https://bugs.openjdk.org/bro
On Thu, 16 Nov 2023 18:11:48 GMT, Andrey Turbanov wrote:
>> A few classes in `sun.util` package have non-final fields which could easily
>> be marked `final`.
>
> Andrey Turbanov has updated the pull request incrementally with one
> additional commit since the last revision:
>
> 8316557: Mak
On Fri, 17 Nov 2023 19:36:21 GMT, Naoto Sato wrote:
>> Justin Lu has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> reflect review comments
>
> test/jdk/java/util/Currency/PropertiesTest.sh line 30:
>
>> 28: # @summary tests the capability
> Please review this PR which allows these _j.util_ tests to launch new JVM
> processes with VM flags,
>
> This is primarily done using by switching to
> `ProcessTools::createTestJavaProcessBuilder`.
>
> _PropertiesTest.sh_ was updated with `@requires vm.flagless`.
Justin Lu has updated the pu
On Fri, 17 Nov 2023 09:25:40 GMT, Justin Lu wrote:
> Please review this PR which allows these _j.util_ tests to launch new JVM
> processes with VM flags,
>
> This is primarily done using by switching to
> `ProcessTools::createTestJavaProcessBuilder`.
>
> _PropertiesTest.sh_ was updated with `
On Fri, 17 Nov 2023 13:15:12 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Addressing trailing whitespace complaint
src/jav
On Fri, 17 Nov 2023 13:15:12 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Addressing trailing whitespace complaint
src/jav
On Fri, 17 Nov 2023 13:15:12 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Addressing trailing whitespace complaint
src/jav
On Fri, 17 Nov 2023 16:27:44 GMT, Tim Prinzing wrote:
> Marked as flagless.
This one is similar to JDK-8319568 that simplified `CallerAccessTest` to call
`ProcessTools::createNativeTestProcessBuilder` as the test can run with VM
flags. Is this same change applicable to NullCallerTest.java?
On Fri, 17 Nov 2023 08:38:37 GMT, Andrey Turbanov wrote:
>> The map contains several entries so I think the plural form is appropriate
>> here.
>
> Current naming highlights the difference in values in this maps:
> `FIRST_DAY_OF_WEEK` vs `MINIMAL_DAYS_IN_FIRST_WEEK`.
> I like this approach.
Ma
On Fri, 17 Nov 2023 13:15:12 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Addressing trailing whitespace complaint
src/jav
Marked as flagless.
-
Commit messages:
- 8319571: Update jni/nullCaller/NullCallerTest.java to accept flags or mark
as flagless
Changes: https://git.openjdk.org/jdk/pull/16711/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=16711&range=00
Issue: https://bugs.openjdk.org/b
On Mon, 30 Oct 2023 10:54:48 GMT, suchismith1993 wrote:
> The math library in AIX specifically, is a static archive. Doing a -lm wont
> suffice, because when the symbols are looked up using dlsym or accessing
> native code through Java, it will lead to failures.
> Hence we had to come up with a
On Fri, 17 Nov 2023 13:02:22 GMT, Martin Doerr wrote:
> > And I still don't understand if this is the list of symbols that are
> > required by our tests, or the complete list of symbols that FFI
> > `defaultLookup` returns to user applications. If it is the latter, then
> > this is sort-of oka
On Fri, 17 Nov 2023 13:02:22 GMT, Martin Doerr wrote:
> My understanding is that a lot of symbols can be found out of the box because
> they are in dynamically linked libraries. Only some libraries are special on
> AIX which don't support dynamic linking and we need this workaround for them.
T
> Address changes from JEP 445 to JEP 463.
>
> - Move from a SYNTHETIC unnamed class to a MANDATED implicit class.
>
> - Don't mark class on read.
>
> - Remove reflection and annotation processing related to unnamed classes.
>
> - Simplify main method search.
Jim Laskey has updated the pull re
On Thu, 16 Nov 2023 00:22:04 GMT, Paul Sandoz wrote:
>> Viktor Klang has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Improvements after feedback
>
> Elegantly and thoroughly done (I mostly focused on the API and
> implementation). I hav
On Fri, 17 Nov 2023 13:11:13 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Addressing trailing whitespace complaint
src/jav
> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
Viktor Klang has updated the pull request incrementally with one additional
commit since the last revision:
Addressing trailing whitespace complaint
-
Changes:
- all: https://git.openjdk.org/jdk/pull/16420/f
On Fri, 17 Nov 2023 12:45:32 GMT, suchismith1993 wrote:
> And I still don't understand if this is the list of symbols that are required
> by our tests, or the complete list of symbols that FFI `defaultLookup`
> returns to user applications. If it is the latter, then this is sort-of okay
> as a
On Mon, 16 Oct 2023 13:41:55 GMT, Jim Laskey wrote:
> Update String Templates for a second preview. With the addition of
>
> - Expression type and throws are determined from the `process` method of the
> processor type and not the processor type.
>
> - Qualified `STR` and `RAW` are treated the
On Fri, 17 Nov 2023 12:06:48 GMT, Martin Doerr wrote:
>>> > There is not generic way of generating this. It needs a manual
>>> > intervention and symbols are to be added on a need basis in future. Looks
>>> > like a list to be maintained. I had tried adding comments to explain the
>>> > list,
On Tue, 14 Nov 2023 16:41:31 GMT, Darragh Clarke wrote:
> Currently the `IsAlive` test occasionally times out.
>
> This PR changes the timeout from `10` to `25` which I think is an adequate
> increase based on the failures I've seen. Though I'd be happy to change it to
> another value if someo
On Fri, 17 Nov 2023 12:06:48 GMT, Martin Doerr wrote:
>>> > There is not generic way of generating this. It needs a manual
>>> > intervention and symbols are to be added on a need basis in future. Looks
>>> > like a list to be maintained. I had tried adding comments to explain the
>>> > list,
On Mon, 30 Oct 2023 10:54:48 GMT, suchismith1993 wrote:
> 1. Adding required compiler flags.
> 2. Adding required symbols.
>
> JBS-ISSUE : [JDK-8317799](https://bugs.openjdk.org/browse/JDK-8317799)
make/data/hotspot-symbols/symbols-aix-foreign line 1:
> 1:
Maybe delete the two leading empty
On Mon, 13 Nov 2023 11:47:52 GMT, suchismith1993 wrote:
>>> There is not generic way of generating this. It needs a manual intervention
>>> and symbols are to be added on a need basis in future. Looks like a list to
>>> be maintained. I had tried adding comments to explain the list, but that
>
On Fri, 17 Nov 2023 11:28:23 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Adding @implSpec for Gatherer.andThen, plus adds
On Fri, 17 Nov 2023 11:28:23 GMT, Viktor Klang wrote:
>> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
>
> Viktor Klang has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Adding @implSpec for Gatherer.andThen, plus adds
> This Pull-Request implements [JEP-461](https://openjdk.org/jeps/461)
Viktor Klang has updated the pull request incrementally with one additional
commit since the last revision:
Adding @implSpec for Gatherer.andThen, plus adds tests to verify the default
impls for Gatherer-related interfaces
Please review this PR which allows these _j.util_ tests to launch new JVM
processes with VM flags,
This is primarily done using by switching to
`ProcessTools::createTestJavaProcessBuilder`.
_PropertiesTest.sh_ was updated with `@requires vm.flagless`.
-
Commit messages:
- init
C
On Fri, 17 Nov 2023 08:13:05 GMT, Per Minborg wrote:
>> src/java.base/share/classes/sun/util/cldr/CLDRCalendarDataProviderImpl.java
>> line 48:
>>
>>> 46: public class CLDRCalendarDataProviderImpl extends
>>> CalendarDataProviderImpl {
>>> 47:
>>> 48: private static final Map firstDays =
On Thu, 16 Nov 2023 17:08:58 GMT, Naoto Sato wrote:
>> Andrey Turbanov has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> 8316557: Make fields final in 'sun.util' package
>>
>> rename 'firstDay' to 'firstDays' to match 'minDays' naming
56 matches
Mail list logo