[PATCH] D30268: Avoid copy of __atoms when char_type is char

2017-03-09 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. ping https://reviews.llvm.org/D30268 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D26991: Hoist redundant load

2016-11-28 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. @mclow.lists I can remove this and update this patch with the load hoisted, if this is okay. https://reviews.llvm.org/D26991 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/li

[PATCH] D26991: Hoist redundant load

2016-11-28 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 79463. hiraditya added a comment. Removed unused code. https://reviews.llvm.org/D26991 Files: libcxx/include/algorithm Index: libcxx/include/algorithm === --- libcxx/include/algorithm +++

[PATCH] D26991: Hoist redundant load

2016-11-29 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added inline comments. Comment at: libcxx/include/algorithm:1499 +// Load the first element from __first2 outside the loop because it is loop invariant +typename iterator_traits<_RandomAccessIterator1>::value_type __firstElement2 = *__first2; + ---

[PATCH] D26991: Remove unused code

2016-11-29 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya retitled this revision from "Hoist redundant load" to "Remove unused code". hiraditya updated this revision to Diff 79565. https://reviews.llvm.org/D26991 Files: include/algorithm Index: include/algorithm === --- includ

[PATCH] D26991: Remove unused code

2016-11-29 Thread Aditya Kumar via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL288143: [libcxx] remove unused code (authored by hiraditya). Changed prior to commit: https://reviews.llvm.org/D26991?vs=79565&id=79566#toc Repository: rL LLVM https://reviews.llvm.org/D26991 Files:

[PATCH] D26991: Remove unused code

2016-11-29 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added inline comments. Comment at: libcxx/include/algorithm:1499 +// Load the first element from __first2 outside the loop because it is loop invariant +typename iterator_traits<_RandomAccessIterator1>::value_type __firstElement2 = *__first2; + ---

[PATCH] D27068: Improve string::find

2016-12-01 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 79908. hiraditya added a comment. Updated the benchmark: Without patch: Run on (8 X 3400 MHz CPU s) 2016-12-01 09:20:38 ***WARNING*** CPU scaling is enabled, the benchmark real time measurements may be noisy and will incur extra overhead. Benchmark

[PATCH] D27068: Improve string::find

2016-12-02 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 80090. hiraditya added a comment. Addressed Tim's comments. https://reviews.llvm.org/D27068 Files: libcxx/benchmarks/string.bench.cpp libcxx/include/__string Index: libcxx/include/__string =

[PATCH] D27068: Improve string::find

2016-12-02 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added inline comments. Comment at: libcxx/include/__string:549 +// Stop short when source is smaller than pattern. +ptrdiff_t __len2 = __last2 - __first2; +if (__len2 == 0) mclow.lists wrote: > Is there a reason that you calculate the end po

[PATCH] D27068: Improve string::find

2016-12-02 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 80134. hiraditya added a comment. Addressed Marshall's comments. https://reviews.llvm.org/D27068 Files: libcxx/benchmarks/string.bench.cpp libcxx/include/__string Index: libcxx/include/__string

[PATCH] D27068: Improve string::find

2016-12-12 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. Ping https://reviews.llvm.org/D27068 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D30268: Avoid copy of __atoms when char_type is char

2017-04-21 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 96159. hiraditya added a comment. Minimized the diff by putting #ifdefs inside the function. https://reviews.llvm.org/D30268 Files: libcxx/include/__config libcxx/include/locale Index: libcxx/include/locale ===

[PATCH] D30268: Avoid copy of __atoms when char_type is char

2017-04-21 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added inline comments. Comment at: libcxx/include/locale:891 +#ifndef _LIBCPP_ABI_OPTIMIZED_LOCALE // signed EricWF wrote: > Would it be possible to reduce the amount of duplicate code between the two > implementations? Currently it seems like there

[PATCH] D30268: Avoid copy of __atoms when char_type is char

2017-05-01 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. This revision now requires changes to proceed. Ping https://reviews.llvm.org/D30268 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D30268: Avoid copy of __atoms when char_type is char

2017-05-08 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. Ping https://reviews.llvm.org/D30268 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D30268: Avoid copy of __atoms when char_type is char

2017-05-23 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. Ping https://reviews.llvm.org/D30268 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-06 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya created this revision. hiraditya added a reviewer: rjmccall. Herald added a reviewer: aaron.ballman. hiraditya requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. There are several methods where we do not want function instrumentation

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-06 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya added a comment. Still working on adding the testcase. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D111286/new/ https://reviews.llvm.org/D111286 ___ cfe-commits mailing list cfe-commits@lists.

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-06 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 377751. hiraditya added a comment. Testcase ready. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D111286/new/ https://reviews.llvm.org/D111286 Files: clang/include/clang/Basic/Attr.td clang/test/CodeGen/instrument-objc-method.m Index: clang/

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-06 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 377752. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D111286/new/ https://reviews.llvm.org/D111286 Files: clang/include/clang/Basic/Attr.td clang/test/CodeGen/instrument-objc-method.m Index: clang/test/CodeGen/instrument-objc-method.m ===

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-07 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 377895. hiraditya added a comment. Herald added a subscriber: jdoerfert. Added SemaObjc test case. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D111286/new/ https://reviews.llvm.org/D111286 Files: clang/include/clang/Basic/Attr.td clang/test/

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-07 Thread Aditya Kumar via Phabricator via cfe-commits
hiraditya updated this revision to Diff 377934. hiraditya added a comment. clang-format CHANGES SINCE LAST ACTION https://reviews.llvm.org/D111286/new/ https://reviews.llvm.org/D111286 Files: clang/include/clang/Basic/Attr.td clang/test/CodeGen/instrument-objc-method.m clang/test/Misc/

[PATCH] D111286: Add no_instrument_function attribute to Objective C methods as well

2021-10-08 Thread Aditya Kumar via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG0f00aa502d79: Add no_instrument_function attribute to Objective C methods as well (authored by hiraditya). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D1112

<    1   2